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1 Introduction

Installing and Configuring a Standalone
Java 6.40 SR1 System
1 Introduction
This documentation explains how to install and configure your Java 6.40 SR1 system on
Windows with Microsoft Cluster Service (MSCS) when your database is Oracle.
It is written for experienced database administrators and technical consultants who are
familiar with the Windows operating system and with Microsoft Cluster Service.
For this type of installation, you have to set up the system on two clustered hosts (called
“MSCS nodes”) and configure it so that it can take advantage of the MSCS software. The
MSCS software offers features that can improve the availability of the system and safeguard
it against unplanned downtime. Ideally it enables 24-hour operation, 365 days a year.
With MSCS you enable critical system components, so-called Single Points of Failure
(SPOFs) to be automatically switched from one machine to the other, if hardware or software
problems arise on one machine. With the help of this switchover – or failover – the system
can continue functioning normally so that unplanned system downtime is avoided.
Apart from enabling failover when hardware or software problems occur, you can also use
MSCS during system maintenance work. If you need to maintain one node, you can
deliberately switch the cluster resources to the other node and temporarily operate it there
while maintenance is in progress. When maintenance work is finished you can easily move
the resources back to their original node and continue operating them there.

1.1 Java System Landscape
In a Java standalone system you have the following components:
Component

Number of Components per
Java system

Single Point of Failure

SCS instance (message
services and enqueue
services)

1

yes

Database instance

1

yes

Application server

1–n

no

Java central instance,
Java dialog instance
•

To protect the SPOFs (SCS instance and database instance) you have to use MSCS.
If a hardware or software problem occurs the clustered SCS instance and the
clustered database automatically fail over to the other node.
If you need to maintain the node where the SCS instance and database are running
you can switch these instances on the other node. When maintenance work is finished
you move the SCS and database instance back to the original node.

•

To protect system components that are non-SPOFs, for example application servers,
you have to install them as multiple components. In this case you must install at least
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two application servers (one central and at least one dialog instance) on two different
hosts. You have the following options:
{

You install the central instance and the dialog instance on two MSCS nodes.
Any additional application servers (dialog instances) are installed outside of
MSCS. The J2EE Engine has to be installed on a local disk. If the J2EE Engine
is installed on an MSCS node to be maintained, you have to stop the J2EE
Engine. When you have finished maintenance, you restart the J2EE Engine.
MSCS Node A

MSCS Node B

Java Central
Instance

Java Dialog
Instance

MSCS
Central Services
Instance

failover

Central Services
Instance

failover
Database
Instance

Host 1

Java Dialog
Instance

{

6

Database
Instance

Host <n>

Java Dialog
Instance

You install the central instance and all dialog instances outside of MSCS on
different hosts. Only the SCS instance and the database instance are installed
on the cluster nodes.

November 2005

1 Introduction

MSCS
MSCS Node A

Central Services
Instance

MSCS Node B

failover

Central Services
Instance

failover
Database
Instance

Central
Java
Central
Instance
Instance
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2 Planning
You need to plan the cluster installation for your Java system.

In the following the two machines in the cluster are referred to as MSCS node A
and MSCS node B.

Process Flow
1. You have to read the installation documentation [Page 8].
2. You distribute components to disks for MSCS [Page 9].
3. You obtain IP addresses for MSCS [Page 12].
4. You check the hardware and software requirements for MSCS [Page 16].

The cluster hardware is equipped with two sets of disks:
•

Local disks that are attached directly to one of the nodes

•

Shared disks that can be accessed by both nodes via a shared
interconnect.
You need to work out which components have to be stored on local disks,
which on shared disks, and which have to be separated to different disks for
performance and security reasons.

2.1 Installation Documentation
Before you begin the installation, read:
•

The following SAP Notes as they contain the most recent information as well as
corrections to this documentation.
Note Number

•

Description

787451

MSCS-specific information about the Web AS 6.40 SR1 Java
system installation and corrections to the documentation.

786608

Windows-specific information about the Java system installation
and corrections to this documentation.

786673

Oracle-specific information about the Web AS 6.40 SR1 system
installation and corrections to this documentation

The current installation guide SAP Web Application Server 6.40 SR1 <Java> on
Windows: Oracle, which is available on SAP Service Marketplace at:
service.sap.com/instguidesNW04 → Installation → SAP Web AS → SAP Web
AS 6.40 SR 1 and Related Documentation
This guide contains important general information about the standard installation of an
SAP system.

8
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2.2 Distribution of Components to Disks for MSCS
Keep in mind that the cluster has the following different sets of disks:
•

Disk arrays connected locally to MSCS node A

•

Disk arrays connected locally to MSCS node B

•

Disk arrays connected to both MSCS nodes A and B with a shared bus, providing
shared storage for both MSCS nodes

You need to install system components in both the following ways:
•

Separately on both MSCS nodes A and B to use the local storage on each MSCS
node

•

Once on the shared storage that is used in common by MSCS nodes A and B

The following graphic illustrates how you distribute the software to different volumes of a
RAID system during the installation. You need to locate the database data files, the SAP
program files (executables), and the quorum resource on different RAID volumes. This
configuration is required so that the SAP system and database can be switched as separate
units during failover.

Software Distribution on a Cluster System with RAID for Oracle

Shared Storage
Node

Node

A

B
Database
directories, e.g
DB data
Redo logs

Quorum

¾ Windows

¾ MSCS Software
¾ Oracle Software
¾ Java central
instance files

¾ SCS instance

files
¾ SAP executables
¾ SAP global

¾ Windows
¾ MSCS Software
¾ Oracle Software
¾ Java dialog
instance files

directories

The Oracle server software in the ORACLE HOME directory must have the
same drive letter and path on both nodes.
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Quorum Disk
The MSCS quorum disk is unique to a cluster installation and is always owned by one of the
MSCS nodes. It has the following main functions in the cluster:
•

It logs changes to the cluster configuration that are entered in the Registry.

•

It arbitrates between competing MSCS nodes when the communication between
MSCS nodes breaks down. This means that cluster resources are forced to fail over to
the MSCS node that owns the quorum disk.

The default quorum log size is 64 MB. If you use a large number of shares,
the quorum disk size may be too small.
To increase the quorum log size, carry out the following steps:
a. Right-click the cluster group and choose Properties.
b. Select quorum log and increase the value to 4096 in the Size box.
For more information, see also the Microsoft Knowledge Base Article 225081.

Database Directories
As shown in the graphic above, you must distribute the database directories so that they:
•

Do not reside on the same RAID volumes as the SAP program files or the quorum
resource.

•

Reside on several different RAID volumes for security reasons

Depending on the disks available and the size of your system, various disk configurations are
possible, but you must always locate the database data and redo logs on separate volumes.
The following graphic shows a secure method to distribute the database directories to
volumes.
Database RAID Volumes

RAID 5
DB Data
Redo Logs Set A
Mirrored Redo Logs Set A
Redo Logs Set B
Mirrored Redo Logs Set B

RAID 1

Archived Redo Logs

Note that the BR*Tools directories \sapreorg, \saptrace, \sapbackup,\sapcheck
are not shown in the graphic. You can locate these directories on any of the database
volumes as they do not require special security measures.

10
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2.2.1 Directories in an MSCS Configuration
The following tables show the directories where the main software components for the SAP
cluster installation are stored:
Directories on Local RAID Volumes on both MSCS nodes A and B
Component

Default Directory

A supported operating system [Page 16]

%windir%

MSCS Software

%windir%\Cluster

SAP cluster files

%windir%\SAPCluster

Oracle server software

\oracle\<SAPSID>\920

Oracle Fail Safe Software

\oracle\OFS

Directories on shared volumes
Component

Default Directory

Cluster quorumresource

\MSCS

SAP global and SCS instance
directories

\usr\sap...

SAP data files

\ORACLE\<SAPSID>\<SAPSID>DATA1
... \<SAPSID>DATA<n>

Online redo logs, set A

\ORACLE\<SAPSID>\origlogA

Online redo logs, set B

\ORACLE\<SAPSID>\origlogB

Mirrored online redo logs, set A

\ORACLE\<SAPSID>\mirrlogA

Mirrored online redo logs, set B

\ORACLE\<SAPSID>\mirrlogB

Backup of online redo logs

\ORACLE\<SAPSID>\oraarch

BR*Tools directories

...\sapreorg, \saptrace,
...\sapbackup, \sapcheck,
...\saparch

In a live system with intense I/O activity, you must reserve at least 3 times the
minimum amount of space specified above for the redo logs and mirrored redo
logs.

SapCluster Directory
In an SAP cluster installation, an additional directory has to be created manually under the
system directory: %WINDIR%\SapCluster
This directory contains all the SAP files required by both cluster nodes, independently of the
MSCS node the SAP instance is running on. The files are database tools and program files
(executables) used by the operating system monitor (SAPOsCol).
The directory is added to the path variable of the user <sapsid>adm.
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2.3 IP Addresses in an MSCS Configuration
A part of the installation process that is unique to a cluster is the configuration of host names
and IP addresses in the network. This is a particularly important task because the addressing
plays a key role in the switchover procedure. Addressing must be set up correctly so that the
system can take advantage of the cluster functionality and switch between MSCS nodes
when hardware problems arise.
This section explains the different types of addresses and their function in the switchover
mechanism of the cluster.

Types of IP Addresses
In a correctly configured cluster, there are seven IP addresses and corresponding host
names. Some of the addresses are physical addresses that are assigned to the network
adapters (cards), others are virtual addresses that are assigned to the cluster groups.

Physical IP Addresses Assigned to Network Adapters
An MSCS configuration usually has two networks:
•

A public network that is used for the communication between the central instance,
application servers and the LAN.

•

A private network that is used internally for communication between the MSCS nodes
of the cluster.

To set up these two networks, each MSCS node needs an adapter for both the private and
public network. This means that each MSCS node must have an adapter for the private
network and an adapter for the public network and each of these adapters has its own
physical IP address and corresponding host name.

For more information on network configuration, see also the Microsoft
Knowledge Base Article 259267.
The graphic illustrates the adapters required for the public and private networks, and their
corresponding physical IP addresses. A physical address, as opposed to a virtual one, is
stationary and permanently mapped to the same adapter.

IP 1

IP 2

Private Network
Adapter
1

Adapter
2

Adapter
3

Adapter
4

IP 3

IP 4
Public Network
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Host Names Assigned to Network Adapters
Each of the physical IP addresses of the network adapters must have a corresponding host
name. For example, on the left-hand MSCS node above, you might assign the IP addresses
of the public and private network adapters as follows:
IP Addresses and Host Names
Network Adapter

IP Address

Host Name

Adapter 1 (private network)

10.1.1.1

clusA_priv

Adapter 3 ( public network)

129.20.5.1

clusA

Make sure that you are aware of the following:
•

The IP address and host name of the public network adapter is also the
IP address and name of the machine. In the above example, this means
that the machine that is the MSCS node on the left has the name clusA.

•

Do not confuse the host name with the computer name. Each MSCS
node also has a computer name, which is often the same as the host
name, but is written in uppercase.
The computer name is displayed in the MSCS node column of the
Cluster Administrator. However, it is not required for the TCP/IP
communication in the cluster. When you configure IP addresses and
corresponding names, keep in mind that it is the host names that are
important for the cluster, not the computer names.

Virtual IP Addresses Assigned to Cluster Groups
When you have installed the SAP system and fully configured the cluster, the critical system
resources are bound together in three different groups. Each of these groups requires a
virtual IP address and host name that is permanently mapped to the group and not to a
particular MSCS node. This has the advantage that, whenever a group is moved between
MSCS nodes, its IP address and host name move together with it.
A cluster configuration has the following groups:
•

SAP SCS cluster group

•

Database cluster group

•

Cluster group

Each group consists of a set of related resources that work together to offer a service to the
system. For example, the database cluster group comprises all the resources that enable the
database server to fulfill the requests of a client. When the group is moved from one MSCS
node to the other, due to MSCS node failure, the virtual IP address and host name move with
it. Therefore, there is a failover not only of resources, but also of the virtual IP address and
host name. As a result, all clients can still reach the database server with the same address
as before.
The following graphic illustrates how the virtual addresses of the database group and SAP
group can move from one MSCS node to the other when failover occurs.
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Virtual IP 1
Cluster Group

Node

Virtual IP 2
SAP SCS Groups

Node

A
B

Java
Central
Instance

Virtual IP 3
Database Group

Java
Dialog
Instance

2.3.1 Obtaining IP Addresses for MSCS
Use
You need to correctly configure IP addresses for a cluster system. During the installation
procedure you have to assign seven IP addresses and host names. You normally obtain
these names and addresses from the system administrator.

Prerequisites
•

If you are installing Windows for the first time on your system, follow the procedure
“Obtaining IP Addresses” below.

•

If Windows has already been installed on your system, the host names and IP
addresses of the network adapters (cards) have already been defined and exist in
your system.
This means that you can find out the IP addresses for the network adapters using the
procedure “Determining Existing IP Addresses” below.
However, you still need to also use the table “Virtual IP Addresses” in the procedure
“Obtaining IP Addresses.”

Procedure
Obtaining IP Addresses
Ask the system administrator to give you the addresses and host names listed in the tables
below. You will need to enter them later during the installation process.
The column Defined During indicates at which stage of the installation the addresses are
defined in the system.

Use the names exactly as specified by the system administrator, carefully
observing upper and lowercase letters.

14
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Physical IP Addresses
Component

Example for
Physical IP
Address

Example for
Physical
Host Name

Purpose

Defined
During

MSCS node A:
adapter for
private network

10.1.1.1

clusA_priv

Address for interMSCS node
communication
on the private
network

Windows
installation

MSCS node A:
adapter for
public network

129.20.5.1

clusA

Address of
MSCS node A
for
communication
with application
servers and LAN
(this is the same
as the address of
MSCS node A)

Windows
installation

MSCS node B:
adapter for
private network

10.1.1.2

clusB_priv

Address for interMSCS node
communication
on the private
network

Windows
installation

MSCS node B:
adapter for
public network

129.20.5.2

clusB

Address of
MSCS node B
for
communication
with application
servers and LAN
(this is the same
as the address of
MSCS node B)

Windows
installation

Virtual IP Addresses
Component

Example for
Virtual IP
Address

Example for
Name
(Host
Name)

Purpose

Defined
During or
Before

Cluster group

129.20.5.3

clusgrp

Virtual address
and name of the
cluster group. It
identifies the
cluster and is used
for administration
purposes.

MSCS
software
installation

SAP SCS
cluster group

129.20.5.4

sapgrp

Virtual address
and name for
accessing the
group of SAP
resources,

Installing the
SCS instance
on MSCS node
A

November 2005

15

2 Planning

Component

Example for
Virtual IP
Address

Example for
Name
(Host
Name)

Purpose

Defined
During or
Before

regardless of the
MSCS node it is
running on
Database
cluster group

129.20.5.5

dbgrp

Virtual address
and name for
accessing the
group of database
resources,
regardless of the
MSCS node it is
running on

Execution of
MSCS Wizard
or databasespecific cluster
scripts

Determining Existing IP Addresses
To find out the existing IP addresses and corresponding host names and addresses, proceed
as follows:
1. Choose Start → Settings → Network and dial-up Connections.
The Network and dial-up Connections window appears.
2. Select one of the network cards that are displayed and choose File → Properties.
A dialog box opens.
3. Choose TCP/IP Protocol → Properties.
The TCP/IP Properties dialog box appears and shows the IP address of the initially
selected network card.
4. To find out the host name that is mapped to the IP address, use the ping command:
ping -a <IP_Address>
The system returns the host name assigned to the IP address.
Do not forget to ping your local machine as well.
5. Repeat these steps for the other network cards.

2.4 Checking Hardware and Software Requirements
for MSCS
Use
When you install the SAP system on cluster hardware, you have to meet the hardware and
software requirements shown below. This makes sure that the system can take advantage of
the MSCS functionality and achieve an acceptable performance level.

Procedure
1. Check that your cluster hardware is certified.
AddOn Technology Center for SAP (AddOn TCS) certifies hardware platforms for SAP
on Microsoft Windows. The cluster must be included in the Microsoft list of certified
clusters and its components. You can access the lists at the following Internet
addresses:

16
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www.microsoft.com/hcl
www.saponwin.com
2. Make sure that both MSCS nodes of the cluster are connected by a private and public
network:
{

The public network enables communication from the MSCS nodes of the cluster
to other resources in the local area network (LAN).

{

The private network enables internal communication between the MSCS nodes.
In particular, it enables the Cluster Service running on both MSCS nodes to
regularly exchange messages on the state of the MSCS nodes so that the
failure of resources is quickly detected.

3. Check that sufficient storage space is available.
Each of the MSCS nodes in the cluster must have its own local disks and have access
to shared disks that can be reached by both MSCS nodes via a shared bus.
All software – except the Windows operating system, the Oracle home directory, the
MSCS software executables, and the Java application server instance – is stored on
the shared disks. One of the shared disks must be used exclusively by the Quorum
resource that stores the cluster registry and records information about the state of the
cluster.

Disks

Minimum Disk
Space

1 local disk on each MSCS node

4 GB
(plus 2 GB for
each installation
DVD)

How to Check
1. Choose Start → Programs
→ Administrative Tools
→ Computer Management
→ Disk Management.
2. Right-click the disk and
choose Properties.

At least 6 shared disks

6 GB

1. Choose Start → Programs
→ Administrative Tools
→ Computer Management
→ Disk Management.
2. Right-click the disk and
choose Properties.

4.

All disk controllers must be able to support hardware-based RAID.
Check the RAM and paging file size on each MSCS node:

Requirement

How to check

Minimum RAM: 1 GB

In the Windows Explorer choose Help → About
Windows.

Paging File Size:
•

32-bit: 1 GB plus 3 times
RAM. Maximum required is
10 GB.

November 2005

1. Right-click My Computer and choose Properties.
2. Choose Advanced → Performance Options.
3. If required, in section Virtual Memory, choose
Change.
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•

64-bit: At least 20 GB

5. Check that the software you install on the MSCS nodes meets the following
requirements:
Software Requirement
English international version
of one of the following:
•

Windows Server 2003
Enterprise Edition

•

Windows Server 2003
Datacenter Edition

•

Windows 2000 Advanced
Server with at least service
pack 4

•

Windows 2000 Datacenter
Server with at least service
pack 4

How to Check
To check the Windows version, open a command prompt
and enter the command winver

For any version of
Windows 2000,
you need at least
service pack 4.
For more
information on the
latest service
pack supported
by SAP, see SAP
Note 30478.
MSCS software
Oracle Enterprise Edition
9.2.0 with the current patch
and hot fix (if available).

–
For more information on the current patch set, see SAP
Note 578683.

You have to install the Oracle patch set and
hot fix (if available) on both nodes.
Oracle Fail Safe software
version 3.3.2

–

Suitable Windows Resource
Kit is strongly recommended

–

18
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Purpose
Before you install the Java system, you need to prepare the system for MSCS.

Prerequisites
•

Make sure that you have finished the installation planning [Page 8], especially the
hardware and software requirements [Page 16].

You cannot use a host with a domain controller as a cluster node.
•

On both nodes, youhave installed the operating system [Page 16] with the option
Cluster Service. For more information, see the Windows documentation.

When you install the Cluster Service, you specify a separate, shared disk for the
quorum resource.

Process Flow
1. On both nodes, you manually assign drive letters to the shared disks [Page 19] using
the Windows Disk Administrator. Both nodes must access the shared disks with the
same drive letters.
2. On both nodes, you adjust the size of paging file and the file cache. For more
information, see hardware and software requirements [Page 16] and „Reducing the
Size of File Cache” [Page 20].
3. You map the seven IP addresses to host names [Page 20] on the Domain Name
Server (DNS) or in the hosts file.
4. You check the mapping of host names for MSCS [Page 21].
5. In the Cluster Administrator, you move all disk groups and the cluster group to node A
[Page 43].
6. On both nodes, you install the Oracle 9.2.0 server software and the current patch set
and hotfix (if available) [Page 22].
7. On both nodes, you install the Oracle Fail Safe Software 3.3.2 [Page 24].
8. On Node A, you create an Oracle Fail Safe database group [Page 28].

3.1 Assigning Drive Letters for MSCS
Use
We recommend that you assign drive letters for MSCS.
In a cluster, the shared disks that can be accessed by both nodes via a common bus must be
addressed by both nodes with the same drive letters.

Procedure
1. Choose Start → Programs → Administrative Tools → Computer Management →
Storage → Disk Management.

November 2005

19

3 Preparation

2. Select a disk and choose Action → All tasks → Change drive.
3. Enter a new drive letter.

3.2 Reducing the Size of the File Cache
Use
The Windows file cache directly competes with SAP programs for working memory by
pushing them out of the memory. Therefore, you should minimize the file cache as described
below.

Procedure
...

4. Do one of the following:
{

Windows Server 2003:
Choose Start → Control Panel → Network Connections → Local Area
Connections.

{

Windows 2000:
Choose Start → Settings → Control Panel → Network and Dial-up Connections
and double-click Local Area Connections.

5. In the Local Area Connection Status dialog box, choose Properties.
6. In the Local Area Connection Properties dialog box, double-click File and Printer
Sharing for Microsoft Networks.

If you cannot select File and Printer Sharing for Microsoft Networks, this option
has not yet been installed. To install it, you need the Windows Server CDs.
7. Select Maximize data throughput for network applications.
8. To confirm your entries, choose OK.

3.3 Mapping Host Names to IP Addresses for MSCS
Use
To enable correct operation of the failover mechanism, you have to map all IP addresses in
the cluster to host names. The mapping enables the system to translate host names into IP
addresses. Host names are normally used for administrative tasks because they are easier to
use than the long, numeric IP addresses. The system can only respond to host names if they
are translated into IP addresses with the information stored on a DNS Server or in the hosts
file.

Prerequisites
•

You have the list of addresses [Page 14].

•

You have installed Windows.

•

You have entered all seven IP addresses required for the cluster configuration.

Missing or incorrect entries can cause problems later during the installation:
•
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•

You need to enter the names exactly as specified by the system
administrator.

Procedure
To map the host names to the IP addresses, do one of the following:
•

You map the host names to IP addresses on a Domain Name System (DNS) server.

•

You map the IP addresses in the Windows hosts file.
The hosts file is located in the default directory for Windows:
%SystemRoot%\system32\drivers\etc

We recommend that you perform the mapping on a DNS server, because it
only requires a single entry. If you perform the mapping in the Windows hosts
file, you have to maintain the hosts file on both nodes of the cluster and on all
application servers and front ends, as each host in the system has its own
hosts file.

3.4 Checking the Mapping of Host Names for MSCS
Use
You need to check the mapping of host names to IP addresses [Page 20] because this is
crucial for cluster operation.

Make sure that you perform this procedure. Otherwise you might have serious
problems later.

Prerequisites
•

You have mapped IP addresses to host names on the DNS Server or in the hosts
file.

•

Make sure that you check all IP addresses.

Procedure
1. For each IP address enter the following commands:
ping -a <IP_Address>
The system returns the host name that is assigned to the IP address.
ping hostname
The system returns the IP address that is assigned to the host name.

When you enter the ping command, you do not get a reply, if the host does
not yet exist.
If the address you are checking already exists in the system, you also receive
a reply from the host. For example, after the installation of Windows and the
configuration of the network, you get a reply when entering the IP addresses
of the network adapters.
2. Compare the output with your own record of addresses and host names and check for
the following possible errors:
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{

Incorrect output of uppercase and lowercase
Make sure that you correct the error before proceeding with the installation.

{

Error in the network bindings
If you enter the name of the public network adapter, which is usually also the
name of the local host, and the system returns the IP address of the private
network, there is an error in the network bindings. To correct the network
bindings, do the following on both nodes:
i.

Choose Start → Settings → Network and Dial-up Connections
The Network and Dial-up Connections window appears.

ii.

Choose Advanced → Advanced Settings → Adapters and Bindings
The network cards of the private and public networks are displayed for
the current node.

The card of the public network must be displayed before that of the private
network.
If necessary, change the order in which the cards are listed by using the Move
Up and Move down arrows.

3.5 Installing the Oracle Database Software
Use
You install the Oracle 9.2.0 database software, patch set and hot fix (if available) on a 32-bit
or 64-bit system.
•

There are different files to install the client and the server software.

•

For a 32-bit system there are three RDBMS CDs. They are located on the RDBMS
DVD for 32-bit in the directories ORA92_1 to ORA92_3.

•

For a 64-bit system there are two RDBMS CDs. They are located on the RDBMS DVD
for 64-bit in the directories ORA92_1 to ORA92_2.

During the installation, you are prompted to specify the correct path to CD2 and
CD3, if applicable. To avoid this, you can copy the CDs to disk as follows
before the installation:
a. Copy the contents of ORA92_1\NT\<OS> on the RDBMS DVD to \disk1
on your hard disk.
b. Repeat this for the second CD.
c.

For a 32-bit system, also repeat this for the third CD.

\disk1 to \disk3 can be on a network drive if required.

Procedure

You have to install the Oracle 9.2.0 software, patch set and hot fix (if available)
on both nodes.
...
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1. Start the Oracle Universal Installer as follows:
•

Place the Oracle RDBMS DVD for 32-bit or 64-bit in the DVD drive and start from
<DVD_DRIVE>:\ORA92_1\NT\<OS>.

•

If you have copied the CDs to disk, start from \disk1
On the database server, double-click the file sapserver.cmd.

To install the database client software, double-click the file sapclient.cmd.
You require the client software, if you want to install SAP instances outside the
MSCS cluster, for example, a Java dialog instance.
2. Enter the information as shown in the table below.

Window

Entry

File Locations

Under Source:
For Path:
Shows the path to the Oracle source software. Do not change
the path.
Under Destination:
For Name:
Enter the name of the new Oracle Home directory. We
recommend that you use the name
<SAPSID><ORACLE_VERSION>, for example, C11920
For Path
Enter the path of a new Oracle Home directory. We recommend
that you use the path:
<DRIVE>:\ORACLE\<DBSID>\<ORA_VERS>, for example,
C:\ORACLE\C11\920

Do not specify an already existing Oracle Home
directory. You must specify a new directory.
You need 2.2 GB disk space for the Oracle 9.2.0
server software and about 250 MB for the Oracle
9.2.0 client software
Choose Next.
32-bit and Oracle
Server Software only:

Choose No and then Next.

Create Database
Summary

Choose Install.

Oracle Server Software
only:

If this dialog appears, select Perform typical configuration.

Oracle Net
Configuration
Assistant: Welcome
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Window

Entry

File Locations / End of
Installation

Choose Exit.

3. Install the current patch set and hot fix (if available) as described in SAP Note 578683
and the patch_note.htm file for your platform on the patch DVD.

•

You have to install the Oracle patch set and hot fix (if available) on both
nodes.

•

Check SAP Note 306408, if you require an interim patch and the
relevant Perl version for the Oracle database installation.

3.6 Installing the Oracle Failsafe Software
To enable the database to take advantage of the cluster functionality, you have to install an
additional component, the Oracle Fail Safe software. The installation procedure differs
depending on whether you install the Oracle Fail Safe software in a 32-bit or a 64-bit system.

The Oracle Failsafe Service from previous Oracle releases is now called
OracleMSCSServices. You might still see the old name in certain SAP Notes.
Be sure that you always use the new name OracleMSCSServices.

Prerequisites
You have installed the Oracle database software locally on both nodes, using the same
Oracle home.

Procedure

You have to install the Oracle Fail Safe (OFS) software on both nodes.
Do not install the Fail Safe Software in parallel on both nodes.
Installing the Oracle Fail Safe Software in a 32-Bit System
1. In the Cluster Administrator make sure that:
{

The second cluster node is not set to Pause.

{

The SAP group is offline on the node where you are installing.

2. Make sure that the Cluster Server service is started on both nodes.
3. Insert the Oracle RDBMS DVD for 32-bit.
4. Start the Oracle Universal Installer. To do this, double-click the file sapofs.cmd in the
directory <DVD_DRIVE>:\ORAFS332I386
The Installer opens and guides you through the installation process in a series of
screens. Enter the required information as follows:
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Screen

Entry

Welcome

Choose Next.

File
Locations

Source...
For Path
The path to the Oracle software on the DVD is displayed. Do not
change the path.
Destination...
For Name
Enter the name of the Oracle Home for the Fail Safe software.
The Fail Safe software must be installed in a separate Oracle
home directory, for example OFS.
Use the same Oracle home for both nodes.
For Path
Enter the path of the Oracle Home directory for the Fail Safe
software. It must be on a local disk, for example:
F:\Oracle\OFS

Available
Products

Select Oracle Fail Safe <current_version> and choose Next.

Installation
types

Choose Typical.

Reboot
Needed After
Installation

Choose Next.

Summary

View the information and choose Install.

Install

Wait while the software is installed.

Configuration
Tools

On the dialog box Oracle Services for MSCS Account/Password
enter the account and password under which the Fail Safe
software is to run. This must be the same account as the one
under which the Cluster Server service is running.
To find out which account must be entered, choose Start →
Settings → Control Panel → Administrative Tools → Services.
Select the Cluster Service and click Startup…
The logon account for the service is displayed. Enter this account
for Oracle Fail Safe Account/Password.

End of
Installation

Click Exit to leave the Installer.

5. Reboot and log on again.

Do not reboot a node, if the installation of OFS 3.3.2 is in progress on the other
node.
Installing the Oracle Fail Safe Software in a 64-Bit System
If you use a 64-bit system you first have to install the 64-bit Fail Safe server software, and
then the 32-bit Fail Safe client software.
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...

1. In the Cluster Administrator make sure that:
{

The second cluster node is not set to Pause.

{

The SAP group is offline on the node where you are installing.

2. Make sure that the Cluster Server service is started on both nodes.
3. Insert the Oracle RDBMS DVD for 64 bit to install the Oracle Fail Safe Server
Software.
4. Start the Oracle Universal Installer by double-clicking the file sapofs.cmd in the
directory <DVD_DRIVE>:\ORAFS332.
5. Enter the required information as follows:

Screen

Entry

Welcome

Choose Next.

File
Locations

Source...
For Path
The path to the Oracle software on the DVD is displayed. Do not
change the path.
Destination...
For Name
Enter the name of the Oracle Home for the Fail Safe software.
The Fail Safe software must be installed in a separate Oracle
home directory, for example OFSSRV.
Use the same Oracle home for both nodes.
For Path
Enter the path of the Oracle Home directory for the Fail Safe
software. It must be on a local disk, for example:
F:\Oracle\OFS\SRV
Choose Next.

26

Installation
Types

Choose Typical.

Reboot
Needed After
Installation

Choose Next.

Summary

View the information and choose Install.

Install

Wait while the software is installed.
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Screen

Entry

Configuration
Tools

On the dialog box Oracle Services for MSCS Account/Password
enter the account and password under which the Fail Safe
software is to run. This must be the same account as the one
under which the Cluster Server service is running.
To find out which account must be entered, choose Start →
Settings → Control Panel → Administrative Tools → Services.
Select the Cluster Service and click Startup…
The log on account for the service is displayed. Enter this account
for Oracle Fail Safe Account/Password.

End of
Installation

Click Exit to leave the Installer.

6. Insert the Oracle RDBMS DVD for 32-bit to install the Oracle Fail Safe client software.
7. Start the Oracle Universal Installer by double-clicking the file sapofs.cmd in the
directory <DVD_DRIVE>:\ORAFS332I386
8. Enter the required information as follows:
Screen

Entry

Welcome

Choose Next.

File
Locations

Source...
For Path
The path to the Oracle software on the DVD is displayed. Do not
change the path.
Destination...
For Name
Enter the name of the Oracle Home for the Fail Safe software.
The Fail Safe software must be installed in a separate Oracle
home directory, for example OFSCLI.
Use the same Oracle home for both nodes.
For Path
Enter the path of the Oracle Home directory for the Fail Safe
software. It must be on a local disk, for example:
F:\Oracle\OFS\CLI

Available
Products

Select Oracle Fail Safe <current_version> and choose Next.

Installation
Types

Choose Client Only.

Summary

View the information and choose Install.

Install

Wait while the software is installed.

End of
Installation

Click Exit to leave the Installer.

9. Reboot and log on again.
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Do not reboot a node, if the installation of OFS 3.3.2 is in progress on the other
node.

3.7 Creating the Oracle Fail Safe Group
Use
You create the Oracle Fail Safe database group on Node A. With this step you enable the
database to be created with the virtual database host name.

Procedure
...

1. On node A, choose Start → Programs → Oracle - <OFSClient_Home> → Oracle Fail
Safe Manager.
The window Add Cluster To Tree appears.
2. Insert your virtual cluster name.
3. Right-click the cluster and choose Connect to cluster.
4. Depending on the user privileges you are asked to enter the information listed in the
table below and to confirm your entries with OK.

If you use a new OFS version, this information is not asked.
User name

<user> (user with the account under which the service
ClusterServer is running)

Password

<password>

Cluster Alias

<virtual_cluster_name> (name of the cluster you are
installing)

Domain

<domain_name>

5. In the Welcome dialog box, choose Verify Cluster.

Both cluster nodes must be up and running for this step.
The window Clusterwide Operation: Verifying Fail Safe Cluster shows the steps that
are executed to verify the cluster. When you are informed that the operation has
completed successfully, close the window.
6. In the Oracle Fail Safe Manager, create the Fail Safe group ORACLE<SAPSID>.
Choose Groups → Create.
The window Create Group:... appears.
7. Enter the Group Name ORACLE<SAPSID>.
In answer to the question Do you want to allow the group to failback to preferred
node?, select Prevent failback.
The window Finish Creating the Group appears and displays information about the
group. Choose OK.

28

November 2005

3 Preparation

8. In the window Add Virtual Address, select Yes to indicate that you want to add a virtual
address to the group.
The Add Resource to Group: - Virtual Address appears.
9. Select Show networks accessible by clients and enter the following information:
Under Network leave the entry public
Under Virtual Address for Host Name enter <database_group_name> (the virtual
name for the database group).
The IP Address is automatically recognized.
Choose Finish.
The window Add the Virtual Address to the Fail Group appears. Choose OK.

If the Fail Safe Manager cannot create the Fail Safe group, look at the Windows
Event Logs on both nodes to find out the reason for the failure.
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4 Installation
Purpose
You use the following procedure to install and cluster your Java system.

When you reboot during the installation process [Page 43], resources fail over
to the second node. Therefore, after each reboot, you have to return the
system to the state it had before the reboot.

Prerequisites
•

You have completed the preparations [Page 19].

To make sure that all preparation steps have been correctly performed, check
that you can move the disk resources from one node to the other so that they
are only accessible from a single node at any time.
•

You are logged on as domain administrator.
If for any reason, you are not granted domain administrators rights, you can perform
the installation as a domain user who is a member of the local administrators group.
However, the domain administrator has to prepare the system appropriately for you, as
described in the Web Application Server installation guide. Do not use the user
<sid>adm unless specified.

•

On node A, in the Cluster Administrator, you make sure that all existing cluster groups
are online.

•

On node A, log off and log on again when you are prompted.

Process Flow
1. On Node A, you install the SCS Instance [Page 30].
2. You cluster the Java SCS instance manually [Page 32].
3. On node A, you install the Java database [Page 37].
4. You configure the Java database for Fail Safe [Page 38].
5. You install the Java central instance [Page 40].
6. You install an additional dialog instance [Page 41].
7. You install the J2EE Engine license [Page 41].
8. You configure SAP MMC for MSCS [Page 42].

4.1 Installing the SCS Instance on MSCS Node A
1. Create the SCS cluster group and add one shared disk where the SCS instance is to
be located.
2. Add the virtual SCS IP and Network Name in the SAP cluster group and bring it online
on node A.
3. Install a released JDK version.
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For more information on the required JDK version, see SAP Service Marketplace at
service.sap.com/platforms → Product Availability Matrix → SAP NetWeaver
→ SAP NetWeaver 04 → SAP NETWEAVER 04 → JSE Platforms.
4. Add an environment variable JAVA_HOME=<JDK_DIR> and PATH=<JAVA_HOME>\bin
5. Start SAPinst with a virtual SCS host name variable as follows:
a. Open a command prompt and change to the relevant directory of the
Installation Master DVD:
<DVD>:\IM<xx>\SAPINST\NT\I386 (32-bit) or
<DVD>:\IM<xx>\SAPINST\NT\IA64 (64-bit)
b. Enter:
sapinst product_ha.catalog
SAPINST_USE_HOSTNAME=<SCS_virtual_host_name> to use the virtual
host name for the SCS installation.
6. Choose SAP NetWeaver ’04 Support Release 1 → Java System → Oracle → SCS
Installation.
7. If you install the SCS instance with SAPinst for the first time, you are asked to log off.
In this case, choose OK.
SAPinst logs off automatically.
8. Log on again.
SAPinst restarts automatically.
9. Choose Cancel and stop SAPinst.
To stop SAPinst, right-click the icon for the SAPinst output window located in the
Windows tray and choose Exit.
10. Restart SAPinst manually from the command prompt with the previous command:
sapinst product_ha.catalog
SAPINST_USE_HOSTNAME=<SCS_virtual_host_name>.
11. Choose again SAP NetWeaver ’04 Support Release 1 → Java System → Oracle →
SCS Installation.
12. Select Run a new installation and choose OK.

During the installation, the virtual host name will be used instead of the local
host name. Make sure that get a pop-up warning that you are using a virtual
host name.
13. Follow the instructions in the SAPinst dialogs and enter the required parameter values.
For the database host name, enter the virtual database host name.
The SCS installation drive must be a shared disk which belongs to the SCS cluster
group.
14. Check that the SCS instance is running.
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4.2 Clustering the Java SCS Instance Manually
Activities on MSCS Node A
1. Stop the SCS instance and services.
2. Add the following lines to both the start and SCS instance profiles:
DIR_INSTALL = <DISK>:\usr\sap\<SID>\SYS
DIR_INSTANCE = <DISK>:\usr\sap\<SID>\SCS<InstanceNumber>
SAPLOCALHOST = <SCSVirtualHostName>
SAPLOCALHOSTFULL = <SCSVirtualHostName>
In addition, change the content of the following lines of SCS instance start profile file
START_SCS<InstanceNumber>_<SCSVirtualHostName>:
Autostart = 0
3. Extract ntclust.sar archive from the directory
<drive>:\SAPINST\NT\<platform> with
sapcar.exe -xvgf <drive>:\SAPINST\NT\<platform>\ntclust.sar to
<UNPACKED_TEMP_DIR>
4. Copy the files SapClus.dll, Saprc.dll, Saprcex.dll, insaprct.exe from the
\NTCLUST\ directory to %windir%\system32
5. Run insaprct.exe in directory %windir%\system32\ to register sap cluster dll
6. Change the <SAPSID>adm user environment as follows:
a. Open a command prompt and enter runas /profile
/user:<domain>\<sid>adm regedit
b. Go to: HKEY_CURRENT_USER\Environment and change
PATH=%PATH%;%windir%\SapCluster
7. Under Services, stop the following SAP services saposcol,
SAP<SID>_<SCSInst.No>
8. Create the directory: %windir%\SapCluster
9. Copy the following files from \usr\sap\<SID>\SCS<Inst_no>\exe to
%windir%\SapCluster:
sapevents.dll
sapntchk.exe
saposcol.exe
sapstartsrv.exe
10. Change sapservice config by opening a command prompt and typing:
sc config saposcol binPath= "%windir%\SapCluster\
saposcol service"
11. Adapt the SCS SAP<SID>_< SCS_inst_no.> service:
a. Set it to Manual start
b. Register the type library as follows:
Start sapstartsrv.exe from the %windir%\SapCluster\ directory and
choose Register COM Typelibrary only.
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12. Delete the SCS IP address and network name cluster resources from the SCS cluster
group.
13. Start <UNPACKED_TEMP_DIR>\NTCLUSTER\crclgrp.exe
14. Enter the following parameters:
{

Cluster Name: <virtual cluster name – network name> (should be filled
automatically)

{

Global disk: <share disk where SCS instance is located>

{

Local Disk: <share disk where is SCS instance is located>

{

Network name: <virtual SCS host name>

{

IP address: <IP address of virtual SAP host name> (should be filled
automatically)

{

Subnet mask: <subnet address mask of the public network>
For the public network name, look in AdressMask located in the registry key:
HKEY_LOCAL_MACHINE\Cluster\Networks\
<public_netw_card_number>\

{

Network to use: <public network name>
For the public network name, look in Name located in
HKEY_LOCAL_MACHINE\Cluster\Networks\
<public_netw_card_number>\

15. Finish creating the SAP Cluster group as follows:
a. Run <UNPACKED_TEMP_DIR>\NTCLUSTER\ coclgrp.exe
b. In the GUI enter:



Cluster Name: <is filled automatically>



SID: <J2EE_SID>



Instance: <SCS_Instance_Number>

16. Create the following registry keys and entries, if they do not exist:
Registry keys:
{

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EventLog\Applic
ation\SAPOsCol

{

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EventLog\Applic
ation\SAP<SID>_<SCSInstanceNumber>

Registry entries for SAP<SAPSID>_<No.> and SAPOsCol:
ValueName

ValueType

ValueData

TypesSupported

REG_DWORD

7

EventMessageFile

REG_EXPAND_SZ

%windir%\SapCluster\
SAPEVENTS.DLL
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Activities on MSCS Node B
Prerequisites
Make sure that on Node A all resources of the SAP SCS cluster group are online, except the
SAP SCS cluster resource.

Procedure
1. Make the required dll files available
a. 32-bit only: Run R3DLLINS.exe in the directory <
<DVD>\SAPINST\NT\<platform>\NTPATCH\
The msvcr71.dll, msvcp71.dll, mfc71.dll, and mfc71u.dll are
extracted.
b. Open a command prompt in the local temp directory and enter
<DVD>:\IM<xx>\SAPINST\NT\<platform>\sapinst.exe –extract to
extract the archive.
c.

Copy all dlls from subdirectory SYSTEM to %windir%\system32.

d. Extract ntclust.sar archive from the directory <
<DVD>:\SAPINST\NT\<platform> with
sapcar.exe -xvgf <DVD>:\SAPINST\NT\<platform>\ntclust.sar to
<UNPACKED_TEMP_DIR>
e. Copy the files SapClus.dll, Saprc.dll, Saprcex.dll, insaprct.exe
from the \NTCLUST\ directory to system32
f.

Run insaprct.exe in directory %windir%\system32\ to register sap cluster
dll

2. Create local groups and add user accounts:
a. Create the local groups SAP_<SID>_LocalAdmin and SAP_LocalAdmin
b. Add the domain group SAP_<J2EE_SID>_GlobalAdmin into these local
groups.
c.

Add the domain group SAP_<J2EE_SID>_GlobalAdmin to the local
Administrators group.

For more information on creating groups and adding users, see Creating and Adding
New Groups and Users [Page 44].
3. Choose Administrative Tools → Local Security Policy → Local Policies → User Right
Assignment to add the following privileges:
{

{
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<J2EE_SID>adm privileges



SeTcbPrivilege (Act as a part of the Operating System)



SeAssignPrimaryTokenPrivilege (Replace a process-level token)



SeIncreaseQuotaPrivilege (Increase Quotas) (for Windows 2000)



SeIncreaseQuotaPrivilege (Adjust memory quotas for a process) (for
Windows Server 2003)

SAPService<J2EE_SID> privileges



SeServiceLogonRight (Log on as a Service)



SeNetworkLogonRight (Access this computer from the network)
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SeDenyInteractiveLogonRight (Deny Logon Locally and Deny log on
through Terminal Services)

4. Create the <SID>adm user environment as follows:
a. Open a command prompt and enter:
runas /profile /user:<domain>\<sid>adm regedit
b. Choose HKEY_CURRENT_USER\Environment and create the user
environment in the same environment as on MSCS Node A.
5. Copy the services file located in %windir%\system32\drivers\etc\ on Node A to
Node B into the same directory.
The services file includes the following SCS ports:
sapdp <SCSInstanceNumber>
Security Port

32<SCSInstanceNumber>/tcp # SAP System Dispatcher

sapdp<SCSInstanceNumber>s
Security Port

47<SCSInstanceNumber>/tcp # SAP System Dispatcher

sapgw<SCSInstanceNumber>

33<SCSInstanceNumber>/tcp # SAP System Gateway Port

sapgw<SCSInstanceNumber>s
Security Port

48<SCSInstanceNumber>/tcp # SAP System Gateway

sapms<SID>

36<SCSInstanceNumber>/tcp #SAP System Message Port

6. Move the SAP SCS cluster group to Node B.
7. Create the directory: %windir%\SapCluster
8. Copy the following files from \usr\sap\<SID>\SCS<Inst_no>\exe to
%windir%\SapCluster:
sapevents.dll
sapntchk.exe
saposcol.exe
sapstartsrv.exe
9. Create saposcol in a command prompt:
sc create saposcol binPath= “%windir%\SapCluster\saposcol”
service start= auto obj= <domain>\SAPService<SAPSID> password=
<password_of_SAPService<SAPSID>_user>

Make sure that there is a space after each equal sign.

If you use Windows 2000, sc.exe is part of the Windows Resource Kit.
10. Create SAP<SAPSID>_<No.> and reregister type library
a. Run sapstartsrv.exe in directory \usr\sap\<SID>\SCS<InstNo>\exe
b. In the GUI enter the following:



SID: <J2EE_SID>



NR: <SCSInstanceNumber>



Startprofile:
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<disk>\usr\sap\<SID>\SYS\profile\START_SCS<SCSInstanceNumber>_
<SCSVirtualHostName>

c.



User: <Domain>\SAPService<SID>



Password: <SAPService<SID> password>



Startup type: manual



Use Environment of user: <Domain>\<SID>adm

Choose OK.

11. Reregister type library:
a. Run sapstartsrv.exe located in the directory %windir%\SapCluster\
b. Choose Register COM Typelibrary only.
c.

Choose OK.

12. Register event log applications for SAP<SAPSID>_<No.> and saposcol as described
in Step 16 of “Clustering the Java SCS Instance Manually: Activities on MSCS Node
A”.
13. Registering SAP MMC
a. Extract the SAPMMCU.SAR (Unicode) archive from
<DVD>:\SAPINST\NT\<platform>\MMC\ with the command:
sapcar –xvf “<DVD>:\SAPINST\NT\<platform>\MMC\SAPMMCU.SAR”
b. Copy the files to %windir%\system32

If you cannot copy librfc32u.dll because the file is in use, stop the service
SAP<SID>_<No.>.
c.

Register all sapmmc*.dlls in a command prompt, for example:
%windir%\system32\regsvr32 sapmmc.dll

d. Create a desktop shortcut of %windir%\system32\sapmmc.msc
14. Start the SCS instance with the Cluster MMC and try failover from one node to another.
15. Remove the SAPLOC share from the SCS cluster group as follows:
a. Right-click the SAP SCS resource and choose Properties.
b. Select Dependencies and choose Modify.
c. Remove SAPLOC from the Dependencies list and choose OK.
16. Delete saploc in Cluster MMC.
17. Change the old name of the SAP cluster group and its cluster resources as shown in
the following table:
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Cluster group or
Resource Type

New Name

SAP Cluster group:

SAP <SAPSID>

IP Address:

SAP <SAPSID> IP
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Network Name:

SAP <SAPSID> NetName

SAP Resource:

SAP <SAPSID> <SCS_InstanceNumber> Instance

18. Create the generic service resource in the Cluster Administrator as follows:
a. Choose File → New → Resource
b. Under New Resource, enter or choose the following:
Name: SAP <SAPSID> <InstanceNumber> Service
Resource Type: Generic Service
Group: SAP <SAPSID>
c. Under Possible Owners, add both nodes.
d. Under Dependencies, add Resource dependencies to
SAP <SAPSID> SAPMNT
e. Under Generic Service Parameters, for Service Name enter:
SAP<SAPSID>_<InstanceNummber>
f. Choose Next and Finish.
19. In the Cluster Administrator check that the following dependencies are set:
SAP <SAPSID> NetName is dependent on SAP <SAPSID> IP
SAP <SAPSID> SAPMNT is dependent on SAP <SAPSID> NetName and <Disk>
SAP <SAPSID> <InstanceNumber> Service is dependent on
SAP <SAPSID> SAPMNT
SAP <SAPSID> <InstanceNumber> Instance is dependent on
SAP <SAPSID> <InstanceNumber> Service
To check the dependencies double-click the corresponding resource and choose
Dependencies.
20. If required, bring the resources offline and modify the dependencies.

4.3 Installing the Java Database
Prerequisites
•

The SAP cluster group is online on Node A.

•

The Oracle shared disk is online on Node A.

•

You have mapped the IP adress and its correcoponding network name on the DNS
server.

•

You have added the Oracle virtual IP network name to the Oracle cluster group and
brought it online on Node A.

Procedure
1. On node A, start SAPinst with a virtual database host name variable as follows:
a. Open a command prompt and change to the relevant directory of the Installation
Master DVD:
<DVD>:\IM<xx>\SAPINST\NT\I386 (32-bit) or
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<DVD>:\IM<xx>\SAPINST\NT\IA64 (64-bit)
b. Enter:
sapinst product_ha.catalog
SAPINST_USE_HOSTNAME=<database_virtual_host_name> to use the
virtual host name for the Java database installation.
2. Choose SAP NetWeaver ’04 Support Release 1 → Java System → Oracle → Java
Database Installation.
3. Follow the instructions in the SAPinst dialogs and enter the required parameter values.
For the SCS instance host name, enter the virtual SCS host name.
4. Delete the saploc share with the command:
net share saploc /delete
5. Change sapservice config by opening a command prompt and typing:
sc config saposcol binPath= "%windir%\SapCluster\
saposcol service"

4.4

Configuring the Database for Fail Safe

Use
The database must be cluster-enabled so that it can be switched between nodes as a group
of resources. To do this, you add the database of the SAP system to Oracle Fail Safe group
which you have created in a previous step.

Prerequisites
1. Create a new configuration file and name it for example init<DBSID>_OFS.ora, as
the original init<DBSID.ora file will be overwritten by the BR*Tools.
For more information see SAP Note 773173.
2. Enter the following line in the new configuration file:
SPFILE=<ORACLE_HOME>\database\SPFILE<DBSID>.ora
3. Copy all init*.* files and SPFILE<DBSID>.ora from %ORACLE_HOME%\database
on the first node to the second node.
4. Copy sqlnet.ora and tnsnames.ora from %ORACLE_HOME%\network\admin of
the first node to the second node.
5. On MSCS node B, create the local groups ORA_<DBSID>_DBA and
ORA_<DBSID>_OPER.
6. Add the <DOMAIN>\<SAPSID>adm and <DOMAIN>\SAPService<SAPSID> users to
these local groups.

Procedure
Perform the following steps in the Fail Safe Manager on the primary node A:
...

1. In the tree on the left, expand <Primary_Node> → Standalone Resources and then
select the database <SAPSID>.world.
2. Choose Resources → Add to Group.
3. On the dialog box Add Resource to Group – Resources:
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For Resource Type, select Oracle Database.
For Group name, select Oracle<SAPSID>
4. On the dialog box Add Resource to Group – Database Identity, enter the following:
Service Name

<DBSID>.world

Instance
Name

<DBSID>

Database
Name

<DBSID>

Parameter File

<DRIVE>:\<ORACLE_HOME>\database\init<DBSID>.ora

5. When you have made all entries, choose Finish.

If a warning appears about the location of init<sapsid>.ora, you can ignore
it.
6. On the dialog box Confirm Add Database to Group choose Yes to shutdown the
database.
7. For each node a Pop-Up appears: The Oracle Net Listener uses a host name in the
host address parameter. It must be converted to use an IP address.
Choose Yes to convert to an IP address.
The SAP database <DBSID> is now added to the Fail Safe group.
8. On MSCS node B, open a command prompt as user <DBSID>adm on the MSCS Node
where the database is online (active node), and enter the following command:
runas /profile /u:<domain>\<DBSID>adm cmd.exe
a. Run regedit, choose HKEY_CURRENT_USER\Environment and set the
following entries:
ValueName

ValueType

ValueData

ORACLE_HOME

REG_SZ

<ORACLE_HOME_DIR>

ORACLE_SID

REG_SZ

<DBSID>

b. Enter the following commands:
sqlplus /nolog
connect / as sysdba
create spfile from pfile
9. Copy PFILE from <ORACLE_HOME>\database\ to the other MSCS node (offline
node).
10. In the OFS Manager, choose Clusters → Groups → Oracle <DBSID> group.
a. Select <DBSID>.world and choose the Database tab.
b. In the Parameter File field, change init<DBSID>.ora into
init<DBSID>_OFS.ora
c. Choose Apply.
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4.5 Installing the Java Central Instance
You can install the Java central instance on MSCS node A or on a host outside
of MSCS.
•

If you install the central instance on a host outside of MSCS, you
have to install the database client software on this host.
• If you install the central instance on an MSCS node, make sure
that the central instance number is different from the SCS
instance number.
1. Open a command prompt and change to the relevant directory of the Installation
Master DVD:
<DVD>:\IM<xx>\SAPINST\NT\I386 (32-bit) or
<DVD>:\IM<xx>\SAPINST\NT\IA64 (64-bit)
2. Enter:
sapinst product_ha.catalog
3. Choose SAP NetWeaver ’04 Support Release 1 → Java System → Oracle → Java
Central Instance Installation.
4. If you are asked to log off, choose OK.
SAPinst logs off automatically.
5. Log on again.
SAPinst restarts automatically.
6. Choose Cancel and stop SAPinst.
To stop SAPinst, right-click the icon for the SAPinst output window located in the
Windows tray and choose Exit.
7. Restart SAPinst manually from the command prompt with the previous command:
sapinst product_ha.catalog
8. Choose again SAP NetWeaver ’04 Support Release 1 → Java System → Oracle →
Java Central Instance Installation.
9. Follow the instructions in the SAPinst dialogs and enter the required parameter values.

If you install the central instance on an MSCS node, make sure that on the
screen Java System > SCS Instance you enter the following:
•

For the SCS instance host name, enter the virtual SCS host name.

•

For the installation drive, you choose the local disk where you want to
install the Java central instance. Do not enter the shared disk for the
SCS instance.

10. Check that the Java central instance is running and you can log on to the Java system.
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4.6 Installing an Additional Dialog Instance
You can install the dialog instance on MSCS node B or on a host outside of
MSCS.
•

If you install the dialog instance on a host outside of MSCS, you
have to install the database client software on this host.
• If you install the dialog instance on an MSCS node, make sure
that:
o The dialog instance number is different from the SCS
instance number.
o For the dialog instance installation drive, you choose a
local disk. Do not choose the shared disk of the SCS
instance.
1. Open a command prompt and change to the relevant directory of the Installation
Master DVD:
<DVD>:\IM<xx>\SAPINST\NT\I386 (32-bit) or
<DVD>:\IM<xx>\SAPINST\NT\IA64 (64-bit)
2. Enter:
sapinst product_ha.catalog
3. Choose SAP NetWeaver’04 Support Release 1 → Java System → Oracle → Dialog
Instance Installation.
4. If you are asked to log off, choose OK.
SAPinst logs off automatically.
5. Log on again.
SAPinst restarts automatically.
6. Choose Cancel and stop SAPinst.
To stop SAPinst, right-click the icon for the SAPinst output window located in the
Windows tray and choose Exit.
7. Restart SAPinst manually from the command prompt with the previous command:
sapinst product_ha.catalog
8. Choose again SAP NetWeaver’04 Support Release 1 → Java System → Oracle →
Dialog Instance Installation.
9. Follow the instructions in the SAPinst dialogs and enter the required parameter values.
For the dialog instance installation drive, choose a local disk.
For the central instance host, enter the virtual SCS host name.

4.7 Installing the J2EE License
As in an MSCS environment the SCS instance can run on both nodes in case of hardware
failure (failover mechanism), the J2EE license has to be installed on both nodes, as follows:
1. Start the Java application server.
2. Log on to the Java central instance and install the license on the first MSCS node.
3. Start the Visual Administrator with go.bat from the directory
usr\sap\<sid>\<instance>\j2ee\admin\
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4. Choose Server → Services → Licensing Adapter
5. In the General tab you find all information about how to get a permanent license for the
J2EE Engine.
6. After you have installed the license on the first node, move the SAP SCS cluster group
to the second node.
7. Restart the Java application server and install the license on the second node as
described above.

4.8 Configuring SAP MMC for MSCS
You can use SAP Microsoft Management Console (MMC) to monitor the status of a clustered
SCS instance and any other remote system, view start profiles, development traces, and so
on.
You cannot use SAP MMC to start or stop a clustered SCS instance. For this purpose you
must use the cluster administrator tool. If you try to start or stop a clustered SCS instance
with SAP MCC, the cluster software regards this as an error.
You configure SAP MMC on both nodes to include the information from the clustered SCS
instance (or any remote instance) as follows:
1. Start SAP MMC by double clicking the shortcut on the desktop.
2. Choose Console Root → SAP Systems.
3. Right-click and choose Properties.
4. In the General tab, check the following settings:
o

Options → Use fix SAP instance list must be selected

o

Options → Always show local SAP instances must not be selected

5. In the Fixed tab, add required instances to the list.
6. Choose File → Save to save your changes.
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5 Additional Information
The following section provides information about:
•

Moving MSCS Groups [Page 43]

•

Rebooting during the installation for MSCS [Page 43]

•

Creating and adding new groups and users [Page 44]

•

Starting and stopping the SAP system in an MSCS configuration [Page 45]

5.1 Moving MSCS Groups
Use
During various stages of the cluster installation, you have to move the database, or the SAP
SCS cluster groups from one node to the other before you can continue.
You use the Cluster Administrator to move groups that do not belong to the Oracle database
groups.
You use the Fail Safe Manager to move the Oracle resources, for example, the Oracle
database group.
The following describes both procedures

Moving Groups with the Cluster Administrator
1. Start the Cluster Administrator with Start → Programs → Administrative Tools →
Cluster Administrator.
2. In the Cluster Administrator, select the group you want to move, and drag it to the
required node on the left-hand pane.
3. Repeat the previous step for each group that you want to move.

Moving Groups with the Fail Safe Manager
1. Start the Fail Safe Manager with Start → Programs → Oracle Fail Safe Manager.
2. On the left-hand pane, right-click the group you want to move, and choose Move to a
Different Node on the context menu.
The group is now moved to the other node.

5.2 Rebooting During the Installation for MSCS
Use
You only need to perform this procedure if you have to reboot during the installation for
MSCS. A reboot means that resources fail over to the second node. Therefore, after each
reboot, you have to return the system to the state it had before the reboot, as described
below.

Procedure
1. In the Cluster Administrator, move all resources back to the original node.
2. If you have not yet clustered the database, restart the database service.
3. If you have already clustered the database, bring the database group online.
4. Recreate the SAPMNT share for the directory usr\sap on the SCS instance drive
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If you use Windows Server 2003, you have to reset the permissions for the
SAPMNT shares from Read to Full Control, as follows:
a. Right-click on the directory usr\sap and choose Sharing and
Security.
b. Select Sharing and in the Share Name field, enter SAPMNT.
c.

Under Permissions, make sure that the permission for SAPMNT is
set to Full Control.

5.3 Creating and Adding New Groups and Users
Creating Local Groups
The following procedure describes how to create the local group named
SAP_SAP_<SID>_LocalAdmin.
1. Choose Start <→ Control Panel> → Administrative Tools → Computer Management.
2. Choose Local Users and Groups.
3. Right-click Groups and choose New Group.
4. For Group name, enter SAP_<SID>_LocalAdmin and choose Add.
The window Select Users, Computers, or Groups, opens.
5. In the Object names field enter:
<domain>\SAP_<SID>_GlobalAdmin
6. Choose OK.
In the Window New Group the group is added.
7. Choose OK.

Adding a domain group to a local group
With the following procedure you can add all users belonging to the domain group to a local
group. In the example, we add the domain group SAP_<SID>_GlobalAdmin to the local
Administrators group.
1. Choose Start <→ Control Panel> → Administrative Tools → Computer Management.
2. Choose Local Users and Groups.
3. Choose Groups.
4. In the right panel double-click the Administrators group and choose Add.
5. In the Object names field enter :<domain>\SAP_<SID>_GlobalAdmin
6. Choose OK.
7. Choose OK again.
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5.4 Starting and Stopping the Java System in an
MSCS Configuration
Use
You use this procedure to start or stop the Java system in an MSCS configuration.

Process Flow
1. You start or stop the SCS instance with the MSCS Management Console.
2. You start or stop the Java application server with the SAP Management Console.

Procedure
1. Start and stop the SCS instance with the MSCS Management Console as follows:
Starting the SCS Instance
...

a. Start the Cluster Administrator by choosing Start → Programs → Administrative
Tools → Cluster Administrator.
b. Right-click the SCS cluster group SAP-<SCS> <SAPSID> and choose Bring
online.
The SCS instance is started.
Stopping the SCS Instance
...

a. Start the Cluster Administrator by choosing Start → Programs → Administrative
Tools → Cluster Administrator.
b. Click the SCS cluster group SAP-<SCS> <SAPSID> to display the resources
belonging to the SCS cluster group.
c. Right-click the resource SAP-<SCS> <SAPSID> and choose Take offline.
The SCS instance is stopped
2. Start and stop the Java application server with the SAP Management Console.

Before you start the Java application server, make sure that the SCS instance is
running.
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