Customer Service Care
Reference Scenario
Copyright

© Copyright 2007 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.
IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, iSeries, pSeries, xSeries, zSeries, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, Informix, i5/OS, POWER, POWER5, OpenPower and PowerPC are trademarks or registered trademarks of IBM Corporation.

Adobe, the Adobe logo, Acrobat, PostScript, and Reader are either trademarks or registered trademarks of Adobe Systems Incorporated in the United States and/or other countries. Oracle is a registered trademark of Oracle Corporation.

UNIX, X/Open, OSF/1, and Motif are registered trademarks of the Open Group.
Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or registered trademarks of Citrix Systems, Inc.

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

Java is a registered trademark of Sun Microsystems, Inc.

JavaScript is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

MaxDB is a trademark of MySQL AB, Sweden.

SAP, R/3, mySAP, mySAP.com, xApps, xApp, SAP NetWeaver, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies. Data contained in this document serves informational purposes only. National product specifications may vary.

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies (“SAP Group”) for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.
Icons in Body Text

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📈</td>
<td>Example</td>
</tr>
<tr>
<td>⏰</td>
<td>Note</td>
</tr>
<tr>
<td>🛠</td>
<td>Recommendation</td>
</tr>
<tr>
<td>☑</td>
<td>Syntax</td>
</tr>
</tbody>
</table>

Additional icons are used in SAP Library documentation to help you identify different types of information at a glance. For more information, see Help on Help → General Information Classes and Information Classes for Business Information Warehouse on the first page of any version of SAP Library.

Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example text</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Cross-references to other documentation.</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>Emphasized words or phrases in body text, graphic titles, and table titles.</td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td>&lt;Example text&gt;</td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>
Exploring SAP NetWeaver CE Reference Scenario

This documentation provides information about the SAP NetWeaver CE reference scenario Customer Service Care. With the examples the user can gain benefit and see the actual representation of the Service Oriented Architecture (SOA).

Composite applications are defined as packaged applications that sit on top of other applications and reuse their functionality by service calls. The composites are developed following the paradigm of model-driven development and this is relevant for the examples described in this documentation. Model-driven development reduces the amount of handcrafted coding and increases the amount of configured or modeled parts of the composite. This approach improves the overall productivity and quality.

The scenario demonstrates the end-to-end development of a composite application from scratch. It reuses back-end services and data, at the same time adding its own business logic to flexibly implement a specific business process. The application shows how you can easily enhance the collaborative workflow by adding offline form-based steps and involving additional contributors.

Customer Service Care Application

Use

The following documentation provides a logical procedure describing the scenario in general, architecture hints, steps describing how to run the application, also the necessary steps when executing the scenario, and instructions how to review the source code of the application.

Procedure

1. Review general information about the scenario.
   More information: Scenario Overview [Page 5]
2. Review the application architecture.
3. Run the application.
   More information: Running the Application [Page 9]
4. Execute the scenario process.
   More information: Executing the Scenario Process [Page 13]
5. Review the source code of the application.
   More information: Reviewing the Application’s Source Code [Page 15]

Scenario Overview

This scenario represents a composite application named Customer Service Care that is built from scratch. It uses Composite Application Framework and Java Web Services to structure its business logic.

You can start this scenario in Guided Procedure (GP) runtime of the Portal by selecting Start a New Process → ReferenceApplication → CSC and choosing CSC_Process.

The implemented functionality allows a customer to enter a complaint for an existing order. The complaints are handled by an account executive. After the required evaluation, the account executive can deny, accept or choose an expert for additional assessment. As displayed below, the process flow can proceed in three directions:
• An order complaint is denied.
   The complaint is considered as insignificant and the account executive rejects it. The customer who entered the complaint form is notified by e-mail.

• An order complaint is accepted.
   The complaint is well-founded, therefore the account executive accepts it. The complaint data is saved and the customer is notified by e-mail.

• An order complaint is forwarded for additional expert investigation.
   The account executive appoints additional expert assessment. Once the assessment is done, the complaint needs to be sent for repeated account executive evaluation.
The application Customer Service Care has an architecture variant, which provides the flexibility of adding own business logic (services, created with Composite Application Framework) to address a specific scenario.

The application uses Guided Procedures (GP) to build the process. The user interface is implemented with Visual Composer and Composite Forms. The business case is realized with
services built with Composite Application Framework and others that are provided by SAP NetWeaver Demo Model.
The details of the application layer structure are described below.

**Process Logic Layer**
The process logic layer is implemented with GP. GP allows you to model lightweight collaborative processes in which you connect various back-end applications and services into a single workflow. Process modeling with GP does not require specific programming skills and is targeted at business experts who are familiar with business processes. You can review the process content (the actual step sequence with the corresponding callable objects, actions, sequential blocks, and so on) in the Portal by selecting **Guided Procedures → Design Time → CSC Process** and choosing **Open**.

Within each process step, exactly one action is executed. Each action is wrapped around a callable object, which either represents a user interface or a service.

**User Interface Layer**
Visual Composer and Composite Forms enable model-driven user interface creation and do not require specific programming skills. They describe the case where user interaction is needed. Visual Composer is applicable for straightforward online user interfaces. Composite Forms
provide the opportunity to add offline process steps in which user interaction is needed (for example, the user has to fill in a specific form or questionnaire) to continue the process workflow. The available functionality can cover the requirements of a more complicated process involving additional contributors.

**Business Logic Layer**

The Customer Service Care application includes invocations of Java Web services provided by the:

- Composite Application Framework (CAF) that includes the service modeling tools for creating and modeling business objects, application services, and for importing and exposing external services. With this toolset you can create a specific functionality (services) that meets your business case needs. For example, service `CreateComplaint` creates a complaint belonging to a specific order.

- CAF-composed services provided by SAP NetWeaver Demo Model, which is part of the SAP NetWeaver 7.1 Composition Environment installation. This model provides demo data for many of the SAP NetWeaver areas. It contains a variety of data (services, business objects, Portal content, non structured data, and so on). For example, `GetSalesOrderById`, which finds a specific sales order by order ID.

**Running the Application**

**Use**

This procedure shows the necessary configuration steps to run the Customer Service Care composite application.

**Procedure**

1. Set up the Customer Service Care application.
   More information: Setting Up Customer Service Care [Page 9]
2. Activate the Configuration Template.
   More information: Activating the Configuration Template [Page 10]
3. Add Guided Procedures Runtime portal roles.
4. Prepare the SAP NetWeaver Demo Model application for use in this scenario.
   More information: Preparing the SAP NetWeaver Demo Model Application [Page 11]
5. Configure the SMTP server.
   More information: Configuring SMTP server [Page 12]
6. Initiate the Guided Procedures process.

**Setting Up Customer Service Care**

This procedure shows you how to configure the AS Java in the SAP NetWeaver Developer Studio, and how to deploy the downloaded archive files on the AS Java. To actually run the application, you need to perform additional configuration steps.
Prerequisites

- You have SAP NetWeaver 7.1 Composition Environment (SP3 or newer) installed in your system landscape.
- You have started SAP NetWeaver Developer Studio.
- You have the necessary application archive files available on your system.

Procedure

1. Configure the AS Java in the SAP NetWeaver Developer Studio

   1. Navigate to Window → Preferences → SAP AS JAVA.
   2. In the SAP Instance identity field, enter the correct settings.
      For a local SAP NetWeaver Composition Environment installation the settings are:
      - Instance Number: the number you entered during installation. Usually 0 or 1.
      - Instance Host: localhost
      If you use a remote SAP NetWeaver 7.1 Composition Environment installation, enter the corresponding IP address or name.
   3. Select the Default SAP System indicator.
   4. Choose Register SAP Instance and then OK.

2. Deploy the Archive File to the AS Java

   1. In the SAP NetWeaver Developer Studio, open the Deploy perspective by selecting Window → Open Perspective → Other → Deploy and then choosing OK.
   2. In the Deploy view window, select the context menu of External Deployable Archives choose Add.
   3. Select the deployable CERACSC00_0 and choose Deploy.

Activating the Configuration Template

Use

This procedure describes how to activate the application configuration template, which performs configuration steps, not visible for the user, such as importing users (roles), creating Web service destinations, and so on.

Procedure

1. From your browser, start the SAP NetWeaver Administrator: http://<server>:<port>/nwa.
   If prompted for a log on, use the following credentials:
   - User ID: administrator
   - Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
2. Choose Configuration Management → Scenarios → Configuration Wizard.
3. Select All Configuration Tasks from the dropdown box in the Configuration Tasks window.

4. In the field next to the filter button, enter Configuration of Reference Application CSC and choose Enter.
5. Choose Expand tray in the Details field.
6. To activate the configuration template, choose Start.
7. Enter the administrative user name (the user name you entered during SAP NetWeaver 7.1 Composition Environment installation, usually administrator) and choose Next.

Adding Guided Procedures Runtime Portal Roles

Use
The following procedure describes how you assign GP Runtime WC portal roles to the default Administrator user and the users executing the application.

Procedure
1. From your browser, start the portal: http://<server>:<port>/irj.
   If you are prompted to log on, use the following credentials:
   ○ User ID: administrator
   ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
2. Choose System Administration → Permissions → Portal Content → Content Provided by SAP → platform_add_ons → Guided Procedures → GP Runtime WC.
3. From the GP Runtime WC context menu, choose Open → Permissions.
4. In the Search In field, located in the Assigned New Permissions window, choose Group and then Go.
5. Select the indicator in front of the group Everyone and choose Add.
   The group Everyone appears in the list in the Assigned Permissions window.
6. Select the group Everyone indicator that appoints to End User and choose Save then OK.

Result
After you assign the above roles, the Administrator user and the rest of the users are able to access the Guided Procedures Runtime.

Preparing the SAP NetWeaver Demo Model Application

Use
This procedure describes how to prepare the necessary test data needed for the application, provided from the predeployed SAP NetWeaver demo model application. To run the reference application, you need to call and run a predefined via the Web Service Navigator.

Procedure
1. Open the start page of the Application Server Java using the following URL:
   http://<host>:<port>
2. Choose Web Services Navigator.
3. Enter the following URL in the WSDL URL field:
   http://<host>:<port>/NWDemoAdminBeanService/NWDemoAdminBean?wsdl
4. Choose Go.
5. Select the **generateData** operation and select the **Endpoint in WSDL** option under Configuration.
6. Choose Execute.

### Configuring SMTP server

#### Use
This procedure helps you configure your mail server, thus you can execute the Customer Service Care process thoroughly including the steps where mail notifications are necessary.

#### Procedure
2. Log on using the user name (for example, Administrator) and the SAP NetWeaver CE master password defined at installation.
3. Under Guided Procedures, choose Administration → Administer BMF.
4. Choose Clients, then under BMF Clients choose Settings, and then choose Mail Sending.
5. Enter the data for **SMTP Server** and **Mail Transport Protocol**. For example:
   - SMTP Server: mail.sap.corp
   - Mail Transport Protocol: smtp
6. Choose Save.

### Initiating the Customer Service Care Process

#### Prerequisites
You have completed the preceding steps described in Running the Application [Page 9].
**Procedure**

1. Launch your portal using the following URL:
   \[http://<host>:<port>/irj\]
2. Log on as a user who belongs to the ITeloPartners UME group. For example, \textit{buyerb}. All users from ITeloPartners UME group can be used in the application role \textit{Customer}.
   The default password is \texttt{welcome123} but you are prompted to change it the first time you log on.
3. Go to \textit{Guided Procedures} \rightarrow \textit{Runtime}.
5. Browse to select \textit{ReferenceApplication} \rightarrow \textit{CSC} \rightarrow \textit{CSC Process} and choose \textit{Next}.
6. Choose \textit{Add User}, then enter the name of a user, who belongs to the ITeloEmployees UME group, in the \textit{Find} field, and finally choose \textit{Go}.
   All users from ITeloEmployees UME group can be used in the application role \textit{Account Executive}. For example, you can use \texttt{Springs}.
7. To add the user to the role, choose \textit{Add}, then \textit{Done}, and then \textit{Next}.
8. (Optional) You can change the name of the process in the \textit{Process Name} field.
9. To start the process, choose \textit{Initiate}.

**Result**

You are automatically redirected to the first process item that you need to execute.

![Executing the Scenario Process](image)

**Use**

This procedure shows the process flow of the Customer Service Care reference scenario.

**Prerequisites**

You have completed the steps in [Running the Application][Page 9].

**Procedure**

1. Select order from the \textit{Order Id} dropdown box.

```
<table>
<thead>
<tr>
<th>Business Partner</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name</td>
</tr>
<tr>
<td>Company</td>
</tr>
<tr>
<td>City</td>
</tr>
<tr>
<td>Country</td>
</tr>
<tr>
<td>Phone Number</td>
</tr>
<tr>
<td>Last Name</td>
</tr>
<tr>
<td>Street</td>
</tr>
<tr>
<td>Postal Code</td>
</tr>
<tr>
<td>Building</td>
</tr>
<tr>
<td>Order Id</td>
</tr>
</tbody>
</table>
```

For example, you can use order ID 5000000007.
2. Enter your comment or disagreement in the Complaint field and choose Create Claim.

3. Log off from the portal and log on again with the user assigned to the Account Executive role (in our case springs).

4. Go to Guided Procedures → Runtime and choose Tasks Where Action is Required to Continue Process Flow.

5. Select Display Order and Evaluate Complaint.

6. At this point, the process workflow can have three different variants:
   ○ You (as an account executive) agree with the claim, enter comments (if any), and choose Approve. Then you choose Save to complete this variant. A notification email is sent to the customer informing him/her for the complaint approval.
   ○ You disagree with the claim, enter comments, and choose Reject. This completes the second variant of the process workflow. A notification e-mail is sent to the customer informing him/her of the complaint rejection.
   ○ You decide that additional claim investigation is necessary. The following procedure describes this case:
     i. Choose Assign Expert.
        
        | Display Order And Evaluate Complaint | Account Executive: Fall, Franco | Attachments: 🔄 (0) |
        |-------------------------------------|-------------------------------|-------------------|
        | Account Executive - Customer Complaint Review |
        | Customer Complaint | Assign Expert |
        | Customer Complaint |
        
     ii. (Optional) You can add a new expert to the list by choosing Add Expert and entering details such as first name, last name, e-mail, and so on.
     iii. Select one of the available experts (users belonging to the CSC expert role) and add comments (if any).
     iv. Choose Assign.

Make sure you have configured Adobe Document Services for CE. More information:

After executing this step, the expert (either newly created or chosen from the existing list of experts) receives an e-mail notification with a PDF file attached. In the PDF file, the expert sees all the comments made by the customer (buyerb) and the account executive (springs) and is prompted to investigate the complaint.

v. You (now acting as the expert) can enter your final decision in the PDF file provided in the Verification Results field.

vi. In the PDF file provided, choose Submit.

Now the process workflow can proceed with the action required from the account executive: to approve or reject the complaint.
Reviewing the Application’s Source Code

Use
This procedure shows you how to review the source code of the Customer Service Care application, built with Guided Procedures, Visual Composer, and Composite Application Framework.

Prerequisites
- You have installed and started SAP NetWeaver Developer Studio.

1. Review the Application Part Built with Composite Application Framework

   If you have already imported the development configuration file CE-RA.export (if you were reviewing the source code of Project and Skill Management application) do not execute steps from 1 to 5. Alternatively, start from step 1.

1. Open the Development Infrastructure perspective by choosing Window → Open Perspective → Other → Development Infrastructure → OK.
2. From the main menu, choose File → New → Other → Development Infrastructure → Development Configuration → Next.
3. From the New/Import Development Configuration field select the from Development Configuration file indicator and choose Browse.
4. Browse to the correct location of the downloaded file from SDN CE-RA.export development configuration file and choose Open → Next.
5. In the Development Configuration Info window choose Finish.
6. If prompted for a log on, use the following credentials again:
   - User ID: administrator
   - Password: the password set during SAP NetWeaver 7.1 Composition Environment installation

The content of development configuration named CE-RA [0] appears in the Component Browser.

7. From the Development Infrastructure perspective, select the CE-RA-CSC[sap.com] context menu, then choose Import.
8. Browse to the correct location of the downloaded file from SDN CERACSC00_0 and choose Open.
10. Select simultaneously the following software components under CE-RA-CSC[sap.com] (using the Ctrl button):
   - xapps/ra.csc.caf/dictionary(sap.com)
   - xapps/ra.csc.caf/ear(sap.com)
   - xapps/ra.csc.caf/ejbmodule(sap.com)
   - xapps/ra.csc.caf/metadata(sap.com)
   - xapps/ra.csc.caf/permissions(sap.com)
11. From their context menu, choose Sync/Create Project → Create Project.
12. Deselect the Build DC after sync indicator and choose OK.
13. When prompted to switch to another perspective, choose the Composite Application perspective.
   The components are displayed in the Composite Application perspective and you can browse through their content.

2. Review the Application Part with Visual Composer
   1. From your browser, start the Visual Composer
      http://<host>:<port>/VC/freestyle.jsp
   2. When prompted for a log on, use the following credentials:
      ○ User ID: administrator
      ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
   3. Choose Model → New.
   4. Make sure you set in the Repository field Local Repository.
   5. In the Create New Model window, choose New (located to the Development component field).
   6. Enter racscvcdc in the Development component field and choose OK.
   7. On the Create New Model screen, choose Cancel.
   8. From the main menu, choose Model → Import → Browse.
   9. Browse to the location of the AccountExecutiveForm.zip, choose Open and then Import.
   10. Repeat step 9 for the following files:
       ○ AssignComplaint.zip
       ○ CreateCustomerClaim.zip

You may receive a message saying that some of the models already exist and if you continue, you will override them. You can agree by choosing Yes.
You can now explore the VC models locally.

3. Review the Application Part Built with Guided Procedures
   More information: Reviewing the GP Design Time of the Application [Page 16]

Reviewing the GP Design Time of the Application

Procedure

1. Allow General Portal Permissions
   1. From your browser, start the portal: http://<server>:<port>/irj.
   2. When prompted for a logon, use the following credentials:
      ○ User ID: administrator
      ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
   3. Choose System Administration → Permissions → Portal Content → Content Provided by SAP → platform_add_ons → Guided Procedures → GP Superuser.
4. From the **GP Superuser** context menu, choose **Open → Permissions**.
5. In the **Search In** field, located in the **Assigned New Permissions** window, choose **Group** and then **Go**.
6. Select the indicator in front of the group **Everyone** and choose **Add**.
   The group **Everyone** appears in the list in the **Assigned Permissions** window.
7. Select the group **Everyone** indicator that points at **End User** and choose **Save then OK**.
8. Repeat steps from 3 to 7 (as described above for the role **GP Superuser**) also for the role **GP Business Expert**.

### 2. Allow the Administrator to View the GP Design Time

1. Open the start page of the Application Server Java using the following URL:
   ```
   http://<host>:<port>
   ```
2. Choose **User Management → Identity Management**.
3. From the **Search Criteria** dropdown box, select **Role**.
4. Enter
   ```
   ```
   then choose **Go**.
5. Select the role displayed and choose **Modify**.
6. Select **Assigned Users**, enter A* in the **Search Criteria** field, and choose **Go** to find the default **Administrator** user.
7. Select the **Administrator** user, choose **Add** and then **Save**.
8. Repeat steps 3 to 7 also for the role
   ```
   ```

### 3. Review the Design Time of the Application

2. If prompted for a logon, use the following credentials again:
   - User ID: administrator
   - Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
3. Choose **Guided Procedures → Design Time → Reference Application → CSC → CSC Process → Open**.
   In the application process you can browse through the process steps and review the details such as type of step (action, sequential block, parallel dynamic block), also details as roles, parameters, permissions, exceptions, and so on.