Installation & Configuration Guide

Preview version of the Mobile Application Modeler (MOAM)
Version 1.0.025

Document Version 2.00 – August 13, 2007
## Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Represents</th>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example Text</td>
<td>Words or characters that appear on the screen. These include field names, screen titles, pushbuttons as well as menu names, paths and options. Cross-references to other documentation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Example text</td>
<td>Emphasized words or phrases in body text, titles of graphics and tables</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Names of elements in the system. These include report names, program names, transaction codes, table names, and individual key words of a programming language, when surrounded by body text, for example, SELECT and INCLUDE.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Example text</td>
<td>Screen output. This includes file and directory names and their paths, messages, names of variables and parameters, source code as well as names of installation, upgrade and database tools.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Example text</td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>&lt;Example text&gt;</td>
<td>Variable user entry. Pointed brackets indicate that you replace these words and characters with appropriate entries.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Keys on the keyboard, for example, function keys (such as F2) or the ENTER key.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax" /></td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Installation Guide – Mobile Application Modeler (MOAM) 1.0.025

1 Introduction

The Mobile Application Modeler - MOAM enables the user to model and simulate/preview mobile applications. The MOAM Design Time is implemented as several Eclipse Plug Ins. In addition MOAM enables the user to instantly preview / simulate the model by providing a Preview View as an additional Plug.

The installation part acquires knowledge about setting up Java Development Kit 5 on operating system and a basic knowledge about Eclipse.

The MOAM Design Time Eclipse Plug-Ins were tested with Eclipse 2.2.0, Editing Modeling Framework (EMF version: 3.2.0), Graphical Editing Framework (GEF version: 3.2.0) and Graphical Modeling Framework (GMF 1.0.0). The Operating System was Windows XP.

Purpose

This guide will explain how to install the Mobile Application Modeler. You will learn about:

- Requirements about hardware and software requirements
- An installer based installation procedure of MOAM Design Time
- Configuration procedure of MOAM Design time for retrieving Web Service Operations

Integration

The following Eclipse components are used by MOAM Framework:

- Eclipse Modeling Framework (EMF) for managing the Meta Model of MOAM Design Team
- Graphical Editing Framework (GEF) for enabling graphical modeling of MOAM Design Time Meta Model
- Graphical Modeling Framework (GMF) allows generation of the mapping between the EMF Meta Model and the graphical representation (GEF) of the Meta Model.

Constraints

The only supported Operating Platform for MOAM Design Time and the installer is Windows XP.

Terminology

- Mobile Application Modeler (MOAM) is for designing mobile application which concentrates on the mobile scenario itself and does not require User Interface adjustments or implementation efforts.
2 Installation – Step by Step

Purpose

You use the tables in the following sections as checklists to navigate through the installation when you install the Mobile Application Modeler.

All necessary installation phases (planning, preparation, installation, and post-installation) are listed in these tables.

Use the links to the general descriptions of the actions and to any additional information to help you perform the actions. This prevents you missing important information.

Process Flow

1. You print out the relevant checklist:
   - The check list can be found here: 2.1 Installing

2. You follow the installation sequence exactly as shown in the tables.
   - If a step is required for your installation, you follow the link for that step to the corresponding section.
   - You perform the procedure described there.
   - After you have successfully completed the installation step, you mark the corresponding entry in the printed table with ✔ to log the progress of your installation.
   - You proceed with the next step listed in the table.
### 2.1 Installing

**Installation Planning**

<table>
<thead>
<tr>
<th>✓</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>3.1 Hardware and Software Requirements</td>
</tr>
</tbody>
</table>

**Installation Preparations**

<table>
<thead>
<tr>
<th>✓</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>4.1 Installing Java Runtime Environment (JRE 5)</td>
</tr>
<tr>
<td></td>
<td>4.2 Installing Eclipse Integrated Development Environment (IDE)</td>
</tr>
<tr>
<td></td>
<td>4.3 Installing Eclipse components: EMF, GEF and GMF (optional)</td>
</tr>
</tbody>
</table>

**Installation Process**

<table>
<thead>
<tr>
<th>✓</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>5.1 Installing MOAM Design Time Eclipse Plug-Ins</td>
</tr>
</tbody>
</table>

**Post-Installation Activities**

<table>
<thead>
<tr>
<th>✓</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3 Installation Planning

Make sure that you read Installation – Step by Step [page 6] before you start installation planning.

Installation is divided into four major parts:

- Installation
- Installation of Eclipse Environment
- Installation of MOAM Design Time Eclipse Plug Ins
- Configuration MOAM Design Time

The MOAM Design Time requires the installation of the Rich Client Platform application: “Eclipse” and the additional Plug Ins EMF, GEF and GMF. Those Plug Ins can be either installed manually via the Update functionality of Eclipse or automatically within the Installer.

3.1 Hardware and Software Requirements

The following table lists the hardware requirements for MOAM Design Time.

<table>
<thead>
<tr>
<th>Requirement Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware Requirement</td>
<td>Java Runtime Environment 1.5.x</td>
</tr>
<tr>
<td></td>
<td>Hard disk 16 MB</td>
</tr>
</tbody>
</table>
| Hardware Requirement   | Eclipse 3.2.x & Eclipse Project: “Callisto”:
|                        | Refer to the official web site of Eclipse Project: "Callisto". |
| Hardware Requirement   | MOAM Eclipse Plug Ins                      |
|                        | Hard disk 5 MB                             |

The following table lists the software requirements for MOAM Design Time.

<table>
<thead>
<tr>
<th>Requirement Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software Requirement</td>
<td>Operating System: Windows XP</td>
</tr>
<tr>
<td>Software Requirement</td>
<td>Java Runtime Environment 5</td>
</tr>
<tr>
<td>Software Requirement</td>
<td>Eclipse 3.2.x:</td>
</tr>
<tr>
<td>Software Requirement</td>
<td>Eclipse components:</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td></td>
<td>▪ Graphical Editing Framework (GEF version: 3.2.0),</td>
</tr>
<tr>
<td></td>
<td>▪ Eclipse Modeling Framework (EMF version: 2.2.0) and</td>
</tr>
<tr>
<td></td>
<td>▪ Graphical Modeling Framework (GMF 1.0.0)</td>
</tr>
<tr>
<td>Software Requirement</td>
<td>MOAM Eclipse Plug–Ins</td>
</tr>
</tbody>
</table>

3.2 Additional Planning Information
Not Relevant

4 Installation Preparations

4.1 Installing Java Runtime Environment (JRE 5)

Prerequisites
- Open the download capability for Java Runtime Environment (JRE) 5 from Sun Web Site. Download the JRE which is provided under topic: “Java Runtime Environment (JRE) 5.0 Update 12”.

Procedure
1. Install the JRE to your local hard disk drive
2. Update the variable: “JAVA_HOME” for the operating system: “Windows XP” as explained within the Sun JDK 5 Installation Guide (optional)

Validation of Output
- Open the File Explorer of the operating system: “Windows XP” and check if you find the JRE in your installation folder or check a Control Panel ‘Add or Remove Programs’ if the JRE has been installed

4.2 Installing Eclipse Integrated Development Environment (IDE)

Prerequisites
- Download Eclipse IDE from official Eclipse Download Site for Windows XP
- Press the link: “Eclipse 3.2.x” under the section “Latest Releases”

Procedure
1. Extract the ZIP file to your local hard disk drive
2. Open Eclipse
3. Set the installed JRE of point 4.1 Installing Java Runtime Environment (JRE 5) as the Java Environment for your Eclipse installation
4. Open the menu: “Window” -> “Preferences” -> “Java” -> “Installed JREs”
5. Select the root folder of your JDK installation which you set for the variable JAVA_HOME under 4.1 Installing Java Runtime Environment (JRE 5)

Validation of output
- Open Eclipse and check if you get any errors

4.3 Installing Eclipse components: EMF, GEF and GMF (optional)

Prerequisites
- Open the Eclipse Callisto Discovery Site (Only if it the site is not within Eclipse Update Manager by default)
- Set the proxy settings if you are inside a intranet:
  - Open menu bar item: “Window” -> “Preferences”
  - Open the tree item: ”Update/Install” an set your proxy like it is shown as a example here:

![Preferences](image)

Procedure
1. Actually the Eclipse Callisto Discovery Site should be included within the Eclipse Update Manager by default
2. You can open the Eclipse Update Manager using the menu bar item: “Help” -> “Software Updates” -> “Find and Install”
3. Choose the option: “Search for new features to install”
4. Mark the check box before the side: “Callisto Discovery Side” and press the button: “Finish”
5. Mark only the checkboxes as shown here:

![Search Results](image)

6. Press the button: “Next”
7. Accept the license agreements and press button: “Next”
8. Press the button: “Finish”
9. Ignore the warning and press the button: “Install All”
10. Press the button: “Yes” and confirm the restart of Eclipse
11. If the Callisto Discovery Site is not included within the Eclipse Update Manager please follow the next steps
12. Follow the instructions on the Eclipse Callisto Discovery Site on how to set up the Eclipse Update Manager for importing Eclipse components provided by Callisto
13. Select only the components under as shown at step 5

**Validation of output**

- Open Eclipse
- Open the menu item: “Help” -> “About Eclipse SDK”
Installation Guide: MOAM Framework

• Press the button: “Plugin Details”
• Look within the column: “Plugin Provider” for the EMF, GEF and GMF

5 Installation Process
5.1 Installing MOAM Design Time Eclipse Plug–Ins

Prerequisites
You downloaded the MOAM Design Time Installer exe file from SAP Software Developer Network ➔ page ‘Downloads’ ➔ section “MI”

Procedure
1. Click on the Exe File to run the Installer.
2. On the “Introduction” page, click on the button ‘Next’
3. On the “License Agreement” Page, Select the radio button “I accept the terms of the License Agreement” and click on the Button ‘Next’.

4. On the “Choose Java Virtual Machine” page choose a Java Virtual Machine of Version 1.5.x and click ‘Next’.
5. On the “Choose Eclipse Installation” page, choose the directory where you have installed Eclipse. Click on ‘Next’

6. On the “Check for Required Packages” page, select the missing packages and click “Next”
In case there are no missing features (e.g. you installed the features/Plug-Ins as described in 4.3), the following page is displayed. Click on “Next”.

7. On the “Proxy Settings” page select the check box “Use a proxy Server” and fill out the proxy settings (Host and Proxy) if you want to use a proxy for downloading the missing features. Click on “Next”. IMPORTANT: This page is only displayed when at least one feature was selected for download on the previous screen (Check for Required Packages).
8. On the “Choose Shortcut Folder” page select where you would like to create the product icon and if you want to create the icons for all users by checking the appropriate checkbox. Click “Next”.

9. On the “Review Installations Options” page check if the summary reflect what you intent to install. Click on “Next”.
10. On the “Installing” page check the progress of the downloading and installation. After the completion of the download and installation the installer automatically navigates to the page ‘Installation Complete’.

11. On the “Installation (Completed)” page select the checkbox ‘Run Mobile Application Modeler’ if you want to run the Mobile Application Modeler. Click on “Done”.
12. Determine Workspace

In the Popup select your workspace. If the workspace does not exist it will be created on the file system.

If you want the selected workspace as default workspace, do select the checkbox ‘Use this as the default and do not ask again’.

NOTE: If selected the check box and want to switch the Workspace at a later point of time, go within Eclipse to File → Switch Workspace…

If you want to be asked again to choose the workspace at the start up of Eclipse, go within Eclipse to Windows → Preferences → General → Startup and Shutdown and select the Checkbox ‘Prompt for workspace on startup’ and click on ‘OK’
5.2 Configuration MOAM Design Time

The following steps are necessary to use the export functionality of the simulator and run exported models in the Simulator without starting Eclipse.

- Navigate in the File Explorer to the location where your Eclipse is installed: This is the Folder which was entered in the Installer.
- Navigate to the Plug-Ins folder which is located at `<eclipse-installation>/plugins`.
- In the ‘plugins’ folder, look for a file with the name `org.eclipse.swt.win32.win32.x86_<version>.jar`.
- Extract the file to a temporary folder. Inside the extracted files, look for a file with the name ‘swt-win32-<version>.dll’.
- Copy the file ‘swt-win32-<version>.dll’ to the bin folder of your Java Runtime Environment (JRE). This folder was selected when selecting the Java Runtime Environment in the Installer.
- Delete the files which were extracted to the temporary folder.

6 Post Installation

Not relevant

7 Installation Check

7.1 MOAM Design Time

Eclipse Plug–Ins

To validate if the Mobile Application Modeler has been installed successfully first open MOAM by selecting one of the options which were selected on the page “Choose Shortcut Folder” of the Installation Wizard.

- Go to Help → About Eclipse SDK
- In the ‘About Eclipse SDK’ popup Dialog, click on ‘Plug-in Details’
- In the ‘About Eclipse SDK Plug-ins’ popup Dialog, ‘check if the PlugIns of the Version 1.0.25 were installed. Click on ‘OK’
Eclipse perspective: “MOAM Modeler”

Check if the Eclipse views: "Composition", “My Elements” and “My Models” are on the left hand side, the view “Preview” is on the right hand side and the views: “Problems” and “Properties” are below the Editor of a Mobile Application Modeler.

In case of a previously configured Workspace, it may happen that some views are not visible. In such case either reset your perspective by selecting ‘Window → Reset Perspective’, or read Chapter 8.3 additional Information for instructions on how to assign views after installation.
Eclipse perspective: “MOAM Service Enabler”

Check if the Eclipse views: “My Services” and “My Models” are on the left hand side, the view “Preview” is on the right hand side and the views: “Problems” and “Properties” are below the Editor of a Mobile Application Modeler.
8 Additional Information

8.1 Installation Troubleshooting

8.2 Interrupted Installation

To interrupt or abort the installation, click on ‘Cancel’ in the Installer.

8.3 Additional Information

Missing Views

In case of a missing view or if you would like to add an additional view to the Modeler or the Service Enabler Perspective, go in the Menu of Eclipse to: Window → Show View → Other…, select the View and click on OK.

For example, you find all the MOAM specific Views in the Folder MOAM.
Opening Models which were created with the previous SDN Version

When importing and opening a model which was created with the previous SDN Version of the Mobile Application Modeler, a popup Dialog appears and asks you if you want to create a copy. Enter a name for the Mode and click on “OK”. A Model in the format will be created which than can be modified in the Moam Application Modeler.

8.4 Uninstalling the Mobile Application Modeler

Uninstalling

Go to: Control Panel → Add or Remove Programs

1. In the popup Dialog ‘Add or Remove Programs’ select Mobile Application Modeler. Click on Change/Remove
2. The Uninstaller will appear. In the “Introduction Page” click on the Button ‘Uninstall’

2.1

![Uninstall Mobile Application Modeler](image)

2.2

3. On the “Uninstalling” page check the progress of the uninstalling. After the completion the uninstaller automatically navigates to the page ‘Installation Complete’.

3.1

![Uninstall Mobile Application Modeler](image)
4. On the “Uninstall Complete Page” click on Done

Validation of output
Go to: Control Panel → Add or Remove Programs and check if an entry for the Mobile Application Modeler still exists.