How to…
Enhance the Standard Web
Query Template
BUSINESS INFORMATION WAREHOUSE

ASAP “How to…” Paper

Applicable Releases: BW 3.0B SP 14
BW 3.0B Frontend Patch 8
June 2003

SAP (SAP America, Inc. and SAP AG) assumes no responsibility for errors or omissions in these materials.
These materials are provided “as is” without a warranty of any kind, either express or implied, including but not limited to,
the implied warranties of merchantability, fitness for a particular purpose, or non-infringement.
SAP shall not be liable for damages of any kind including without limitation direct, special, indirect, or consequential
damages that may result from the use of these materials.
SAP does not warrant the accuracy or completeness of the information, text, graphics, links or other items contained within
these materials. SAP has no control over the information that you may access through the use of hot links contained in
these materials and does not endorse your use of third party web pages nor provide any warranty whatsoever relating to
third party web pages.
mySAP BI “How-To” papers are intended to simplify the product implementation. While specific product features and
procedures typically are explained in a practical business context, it is not implied that those features and procedures are
the only approach in solving a specific business problem using mySAP BI. Should you wish to receive additional
information, clarification or support, please refer to SAP Professional Services (Consulting/Remote Consulting).

HOW TO... ENHANCE THE STANDARD WEB QUERY TEMPLATE

1 Business Scenario
When you display a query on the Web, the query is embedded automatically into a standard web
query template. The query is displayed on the web in a table with a navigation block. The name of
the query appears as the title. The most commonly used functions are accessed from a toolbar
that is embedded automatically. The navigation options are also available in the navigation block
and in the context menu.
Your reporting end users would like to have the toolbar included in their web templates as well.

They would like to modify the standard web query template to include customer-specific graphics
and toolbar functions, and then set this template as the new default web query template.
Additionally, you would like to customize the general template properties as well as the context
menu of a web template, and then use these settings as the default web template attributes.

2 The Result
In this "How to..." paper we will show how you can upload a new web template
(ZQUERY_TEMPLATE.htm) to the BEx Web Application Designer. This file contains the same
features delivered in the standard web template (0Query_Template) including the toolbar,
however the code has been modified to enable it to be opened and modified in the BEx Web
Application Designer.

Examples of enhancing the web template include adding pictures, changing chart types, and
modifying the toolbar. This new customized web template then can be set as the standard web
template in place of (0Query_Template), and we explain how this can be implemented.
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Next, we will explain how you can maintain the general template properties as well as the context
menu of a web template, and then use these settings as the default web template attributes. The
steps necessary to set this up are also provided including how to use Libraries. For example, the
context menu by default does not display the property Bookmark with Data, however you would
like that to be in the basic menu by default for all web templates.

Standard Context Menu

Context Menu based on the default standard template attributes setting

3 Background
When you display a query on the Web, this query is embedded automatically into a standard Web
template. In this case, the query is the Data Provider for the standard Web template and is
transferred as a parameter in the URL: myProtocol://myAppServer:myPort/sap/bw/BEx?saplanguage=myLanguage&bsplanguage= myLanguage&CMD=LDOC&INFOCUBE= <InfoProvider
Name>&QUERY=<Query Name>
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In the Standard Web template, the query is displayed in a table with a navigation block. The name
of the query appears as the title. You can access the most useful functions and other forms of
display (including various diagram types) from a symbol bar.
You set up the standard Web template in the SAP Reference IMG → Business Information
Warehouse → Reporting-relevant Settings → Web-based Settings → Determine Standard Web
Template. The 0Query_Template is the default standard Web template.
You can use this Web template as the template, change the HTML and then set your new Web
template as the standard Web template in the SAP Reference IMG.

The 0Query_Template is currently delivered as Technical Content and not Business
Content. This means that there is only an ‘A’ version of this object delivered, and no
‘D’ version. Even though there are no plans to deliver another version of this
template, any changes you make could be overwritten and there is no way to revert
back to the original version. Additionally, if there are problems with Web
Applications in your system and SAP Support needs to check your system, the
0Query_Template is used for debugging purposes. Therefore, customers should
never change 0Query_Template; instead you should make a copy of it and work
with the copied version.
Note: Since the standard Web template contains highly dynamic parts, technical
factors prevent you from being able to edit it in the Web Application Designer. You
can use any HTML Editor instead.
This How-To provides a new template containing the 0Query_Template properties
and features, which can be edited in the Web Application Designer.

4 Preliminary Steps
Before you can implement the solution described in section 5 you have to apply BW 3.0B
Frontend Patch 8 (or higher) to the Web Application developer’s pc. We recommend that you
have the corresponding Support Package (BW 3.0B SP14 / BW 3.1 Content SP8) or higher
applied to the BW system as well. Additionally, you have to export the file
(ZQUERY_TEMPLATE.htm) that is distributed with this "How To..." paper to the Web Application
developer’s pc, network directory, etc. in order for the BEx Web Application Designer to upload it
to the BW server. This is a one-time configuration step, and is valid system-wide if needed.
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5 The Step By Step Solution
5.1

Upload the new web template (ZQUERY_TEMPLATE.htm) to the BW
server using the Web Application Designer

1. Load the new template to the BW
server. Open the BEx Web
Application Designer.
Note: This is typically done by
choosing Start -> Programs ->
Business Explorer -> Web Application
Designer.

2. From the menu, select Web Template > Upload File to Server.

©2003 SAP AG

4

HOW TO... ENHANCE THE STANDARD WEB QUERY TEMPLATE

3. Find the location of the file
ZQUERY_TEMPLATE.htm.
See preliminary steps.
Select the file and then choose Open.

4. Save the Web Template. Choose
Favorites or Roles, and then select
the location where you would like to
save the web template. Give the
web template a Description and
Technical Name, for example
Customer Default Query Template
(Z_QUERY_TEMPLATE). Then
choose Save.
Note: In this example, we want to
have the web template accessible by
other Web Application developers,
so we will include this in a Role
rather than in Favorites.
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5. If the upload was successful, you
will receive a message at the bottom
of the screen in the Web Application
Designer.

5.2

Modifying the web template with the Web Application Designer

1. From the menu, select Web Template > Open. Then choose Roles in the
dialog box. Highlight the web
template you uploaded to the server
(Customer Default Query Template),
and then choose OK.
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2. The layout of the web template is
now displayed.

3. Enhance the web template. Insert a
picture at the top of the page. From
the menu, choose Insert -> Picture…
Note: For additional examples on
enhancing the web template see the
Appendix.

4. Select a picture from the list. Then
OK.
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5. The picture that you selected should
be visible on the Layout tab. Save
the web template.

5.3

Set the new web template (Z_QUERY_TEMPLATE) as the standard web
template

1. In the BW system, go to transaction
SPRO -> SAP Reference IMG ->
Business Information Warehouse ->
Reporting-relevant Settings -> WebBased Settings -> Determine Settings
for Web Templates. Maintain the
setting for Web Template. Enter the
technical name for the web template
that was created in the previous step
(Z_QUERY_TEMPLATE). Save the
change.
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2. Create a new query or execute an
existing query to verify that the
Z_QUERY_TEMPLATE is being
used.
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5.4

Create a web template based on the new standard web template
(Z_QUERY_TEMPLATE) in the Web Application Designer

1. From the menu, select Web Template > Open. Then choose Roles in the
dialog box. Highlight the web
template you uploaded to the server,
and then choose OK.

2. The layout of the updated web
template is now displayed. You will
need to assign a DataProvider, since
one has not been assigned yet.
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3. In the Properties section, choose a
web item, for example Text
Elements (TITLE). On the General
tab assign a DataProvider to the web
item by selecting the icon for a
Query or Query View.
Note: You only have to bind the
DataProvider to one web item since
all web items are binded to the
DataProvider ‘DP’ by default. Do
not change the name of the
DataProvider unless you are very
experienced with this tool.

4. Highlight the Query or Query View,
and then OK.

5. Save this as a new web template.
From the menu, select Web Template > Save as….
Note: The next section will discuss
how to use Libraries, which is an
option for inheriting web template
properties by default for other web
templates.
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6. Choose Favorites or Roles, and then
select the location where you would
like to save the web template. Give
the web template a Description and
Technical Name, for example My
New Web Query Template
(Z_BKQUERY_TEMPLATE). Then
choose Save.

7. Execute the web template in your
browser. From the menu, select Web
Template -> Execute in the Browser….
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5.5

Using web template properties as the default standard template
attributes

1. From the menu, select Web Template > Open. Then choose Roles in the
dialog box. Highlight the web
template you uploaded to the server
in section 5.1 step 4, Customer Default
Query Template
(Z_QUERY_TEMPLATE) and then
choose OK.

2. In the Properties section, select the
web template Customer Default Query
Template (Z_QUERY_TEMPLATE).
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3. Maintain the General Properties and
Context Menu entries that you
would like to use by default in your
web templates. Choose the tab Web
Item. Select the values for the
various properties. For example,
always display Bookmark with
Displayed Data.

Then choose Save in Library.

4. Choose an existing Library or create
a new one.
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5. Choose Favorites or Roles, and then
select the location where you would
like to save the Library. Give the
Library a Description and Technical
Name, for example My Library
(Z_MY_LIBRARY). Then choose
Save.

6. Enter a Description and Technical
Name for the Web Item, for example
Customer Default Template Properties
(Z_DEFAULT_TEMP_PROPERTIES)
. Then Save.
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7. The new Library (My Library) and
web item (Customer Default
Template Properties) should be
contained in the Library tab.

5.6

Set the standard template attributes

3. In the BW system, go to transaction
RSCUSTV11. Maintain the setting
for Template Attributes. Enter the
technical name for the web item that
was created for the template
properties in the previous step.
(Z_DEFAULT_TEMP_PROPERTIES)
. Save the change.
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4. Check the Context Menu to validate
that the changes have taken effect.
Create a new web template or
execute an existing web template
that has not had the template
properties maintained.

6 Appendix
6.1

Features

The standard Web template contains a record of Web items that you can display on a symbol
toolbar as and when required.
Clicking on a Web item symbol on the symbol bar (such as a Chart, Table, Ad-hoc Query
Designer and so on) sends a command via the URL that makes the Web Item visible and fills it
with the pre-specified Data Provider.
You can enhance or modify the Standard Web template in the following way:
You can enhance this symbol bar by


Inserting additional Web items (such as List of Documents) into the standard Web template
and by adding new symbols and tool tips for them.



Integrating additional functions (commands such as currency translation) into the symbol bar
and adding new symbols and tooltips for them.



Offering additional diagram types in the symbol toolbar, saving the corresponding Web items
for them in the Web Application Designer library, and then make a reference to them in the
Standard Web template.

6.2

Structure

The 0Query_Template is structured in the following way:


The basic structure of 0Query_Template is an HTML table with the name of the query as a
title. The Web item Text Elements is inserted to have the name of the query as a title. You
can use the setting ONLY_VALUES to make only the element containing the query name
(REPTXTLG) visible.
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<PARAM NAME="ONLY_VALUES" VALUE="X">
<PARAM NAME="ELEMENT_NAME" VALUE="REPTXTLG">
<PARAM NAME="ELEMENT_TYPE" VALUE="COMMON">




In addition, the following Web Items are contained in the HTML table:
•

Navigation Block and Table

•

4 Charts (various diagram types)

•

Text Elements

•

Filters

•

List of Exceptions

•

List of Conditions

•

Ad-hoc Query Designer

All Web items have the general property Hide Object activated (HIDDEN='X'). The two Web
items Navigation block and Table are set to HIDDEN=' '. In other words they are displayed
by default.
The Standard Web template does not contain an explicit Data Provider.The DataProvider is
not supplied with the URL and the Standard Web template filled with data until the query is
displayed in the Web.
The HTML table contains a symbol bar, which you can use to call up various functions.
For example, if you choose Chart on the standard Web template symbol bar, the Web item
Chart is set to HIDDEN=' '. The data is then displayed in the chart but not in the table.
You can display the data in the Standard Web template with various diagram types. Do so by
choosing Vertical Bar Chart, Pie Chart, Line Graph or 3D Bar Chart from the symbol bar.
These diagram types are saved as Web items in the library 0QUERY_TEMPLATE_LIB in the
Web Application Designer. In the Standard Web template, the system references these Web
items via their technical names.

For example: If you want to have Tachometer instead of Line Graph on the symbol
bar, you need to create a Web item Chart with the Chart type Tachometer in the
Web Application Designer. Adjust the layout settings (color, legend) before saving it
to your own library and then inserting it into the Standard Web template.
The symbol bar is comprised as follows in the Standard Web template:
a. Insert the required command into the Web template, for example, Switch Axes: <a
href="<SAP_BW_URL CMD='SWITCH_AXES' DATA_PROVIDER='DP'>">...</a>.

b. Save the required symbol for it in the Mime Repository and insert the link to it in the Web
template: <img src="sap/bw/Mime/BEx/Icons/S_B_RESH.gif" border="0" alt="...“>.
c. Insert the tooltip text after alt=. If you want the text to be translated into other languages
in BW, insert this text as SAP_BW_TEXT and specify the name of the program in which texts
are maintained and translated.

<!-- Display Switch Axes --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='SWITCH_AXES'
DATA_PROVIDER='DP'>"><img src="sap/bw/Mime/BEx/Icons/S_B_RESH.gif"
border="0" alt="<SAP_BW_TEXT program="SAPLRRSV"
key="312">"></a></td><td class="SAPBEXNavLine">&nbsp;|</td>
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6.3

Toolbar code

Please note that this code can be modified and enhanced, however it should not just be used alone as there
are other dynamic pieces contained in the file (ZQUERY_TEMPLATE.htm) that are missing, so this would
not work correctly by itself.
<!-- Toolbar --->
<tr><td style="padding:5px;">
<table cellspacing="0" cellpadding="1" border="0" class="SAPBEXNavLineBorder" width="450"><tr><td
width="100%">
<table border=0 cellspacing=0 cellpadding=5 width="100%"><tr>
<!-- Display table and nav block --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=*GR1*&MULTI=X&HIDDEN=''>"><img src="Mime/BEx/Icons/S_B_TVAR.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="622">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Display Bar Chart--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=GR1GR2NavBlock&HIDDEN='
CMD_2='CMD=RESET_ITEM&ITEM=GR2Chart&WIDTH=600&HEIGHT=400&HIDDEN=&ITEM_ID=0QUER
Y_TEMPLATE_COLUMNSTACKED&GENERATE_CAPTION='>"><img
src="Mime/BEx/Icons/S_GISBAR.gif" border="0" alt="<SAP_BW_TEXT program="SAPLRRSV"
key="657">"></a></td>
<!-- Display Pie Chart--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=GR1GR2NavBlock&HIDDEN='
CMD_2='CMD=RESET_ITEM&ITEM=GR2Chart&WIDTH=600&HEIGHT=400&HIDDEN=&ITEM_ID=0QUER
Y_TEMPLATE_PIES&GENERATE_CAPTION='>"><img src="Mime/BEx/Icons/S_GISPIE.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="658">"></a></td>
<!-- Display Line Chart--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=GR1GR2NavBlock&HIDDEN='
CMD_2='CMD=RESET_ITEM&ITEM=GR2Chart&WIDTH=600&HEIGHT=400&HIDDEN=&ITEM_ID=0QUER
Y_TEMPLATE_LINES&GENERATE_CAPTION='>"><img src="Mime/BEx/Icons/lines.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="659">"></a></td>
<!-- Display 3D Bar Chart--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=GR1GR2NavBlock&HIDDEN='
CMD_2='CMD=RESET_ITEM&ITEM=GR2Chart&WIDTH=600&HEIGHT=400&HIDDEN=&ITEM_ID=0QUER
Y_TEMPLATE_3DCOLUMNS&GENERATE_CAPTION='>"><img src="Mime/BEx/Icons/columns_3D.gif"
border="0" alt="<SAP_BW_TEXT program="SAPLRRSV" key="660">"></a></td>
<!-- Display Switch Axes --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='SWITCH_AXES'
DATA_PROVIDER='DP'>"><img src="Mime/BEx/Icons/S_B_RESH.gif" border="0" alt="<SAP_BW_TEXT
program="SAPLRRSV" key="312">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Display Infos --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=*GR3*&MULTI=X&HIDDEN='>"><img src="Mime/BEx/Icons/S_B_TXDP.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="T70">"></a></td>
<!-- Display Exceptions--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=*GR4*&MULTI=X&HIDDEN='>"><img src="Mime/BEx/Icons/S_BWEXMO.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="281">"></a></td>
<!-- Display Conditions--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='*GR*' MULTI='X' HIDDEN='X'
CMD_1='ITEM=*GR5*&MULTI=X&HIDDEN='>"><img src="Mime/BEx/Icons/S_SUMMAR.gif" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="282">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Display Variable Input --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='PROCESS_VARIABLES'
VARIABLE_SCREEN='X'>"><img src="Mime/BEx/Icons/S_B_VARB.gif" valign="middle" border="0"
alt="<SAP_BW_TEXT program="SAPLRRSV" key="T76">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Query Definition --->
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<td class="SAPBEXNavLine"><a href="<SAP_BW_URL ITEM='QueryDesigner' HIDDEN=' '>"><img
src="Mime/BEx/Icons/adhoc_querydesign.gif" border="0" alt="<SAP_BW_TEXT program="SAPLRRSV"
key="320">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Display Bookmark --->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='BOOKMARK'>"><img
src="Mime/BEx/Icons/bookmark.gif" border="0" alt="<SAP_BW_TEXT program="SAPLRRSV"
key="309">"></a></td>
<td class="SAPBEXNavLine">&nbsp;|</td>
<!-- Display Export Excel--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='EXPORT' FORMAT='XLS'
DATA_PROVIDER='DP'>"><img src="Mime/BEx/Icons/S_X_XLS.gif" border="0" alt="<SAP_BW_TEXT
program="SAPLRRSV" key="T77"> <SAP_BW_TEXT program="SAPLRRSV" key="T72">"></a></td>
<!-- Display Export CSV--->
<td class="SAPBEXNavLine"><a href="<SAP_BW_URL CMD='EXPORT' FORMAT='CSV'
DATA_PROVIDER='DP'>"><img src="Mime/BEx/Icons/csv.gif" border="0" alt="<SAP_BW_TEXT
program="SAPLRRSV" key="T77"> <SAP_BW_TEXT program="SAPLRRSV" key="T73">"></a></td>
<!-- Display Print Preview--->
<!-- <td class="SAPBEXNavLine"><a href=""><img src="Mime/BEx/Icons/S_B_LAYT.gif" border="0"
alt="Druckvorschau"></a></td> --->
</tr></table>
</td></tr></table></td></tr>

6.4

Accessing the Standard Web Template

You can call up queries on the Web using the following tools:
Query Designer: By clicking on the symbol for Display Query on the Web
BEx Analyzer: By choosing Tools → Launch in Web Browser: Query (Default View)
Ad-hoc Query Designer: If you do not specify the optional attributes
DISPLAY_DATA_PROVIDER, TARGET_FRAME and TARGET_TEMPLATE_ID, the query
results are displayed in a new browser window in the standard Web template.
6.4.1

Features

In addition to navigating in the context menu and in the navigation block, Web applications that
use the standard Web template also have a toolbar containing various functions.
Table
Once you have displayed your data using one of the functions described below, you can
use the Table function to display the data as a table again.
Bar chart
This function displays the query data in a bar chart. If you want to return to the table
display, click on the Table icon.
Pie Chart
This function displays the query data in a pie chart. If you want to return to the table
display, click on the Table icon.
Line chart
This function displays the query data in a line chart. If you want to return to the table
display, click on the Table icon.
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3D Bar Chart
This function displays the query data in a 3D bar chart. If you want to return to the table
display, click on the Table icon.
Swap Axes
You use this function to swap the axes of the query. For example, if you have
characteristics displayed in the rows and key figures in the columns and you choose the
Swap Axes function, the key figures are moved to the rows and the characteristics are
moved to the columns. If you want to undo this step and switch the axes back to how they
were originally, click on Swap Axes again.
Info
Information about the query key date, how up-to-date the query data is, who last changed
the query, when the query was last changed and the last time the query was refreshed is
displayed here. You can also see information about the values in the filter and the variable
values with which the query is filled.
If you want to return to the table display, click on the Table icon.
Exceptions
You can create new exceptions and change or delete existing exceptions. The existing
exceptions are displayed along with their status (active, inactive). In the context menu of an
exception, you can deactivate, change, or delete the exception. If you want to display the
exception in the table, click on the Table icon.
Conditions
You can create new conditions and change or delete existing conditions. The existing
conditions are displayed along with their status (active, inactive, not applicable, not used).
In the context menu of a condition, you can deactivate, change, or delete the condition. If
you want to display the condition in the table, click on the Table icon.
Display Variable Entries
If the query contains variables, you can use this function to display the screen for variables
so that you can select additional variable values as required.
Query Designer
You can call up the Ad-hoc Query Designer and define new queries or change an existing
query on the Web.
Bookmark
You can set a bookmark that enables you to call up a certain navigational state for the
query at a later date. The system creates a URL for the bookmark. This URL is displayed in
the address line of your Web browser.
To enable you to access the bookmark again later, you save the URL in your favorites or
copy and paste it into other files.
Export to MS Excel 2000
You can export query data to MS Excel 2000.
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The query data is displayed in the same way as queries are displayed in the BEx Analyzer.
You see the filter restrictions and the data in the table. Exceptions are highlighted in color in
the same way as they are on the Web.
The formatting is transferred, but it is no longer possible to navigate using the BW
functions. However, you can continue to edit the query using the MS Excel functions.
Export to CSV
You can export the query data into a CSV (comma separated value) file.
Unlike exporting to MS Excel 2000, you do not see the numbers in context and you cannot
see the filter data. The query formatting (such as how the exceptions are displayed) is also
not transferred to the CSV file.
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