Project and Skill Management
Reference Scenario
Copyright

© Copyright 2007 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.
IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, iSeries, pSeries, xSeries, zSeries, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, Informix, i5/OS, POWER, POWER5, OpenPower and PowerPC are trademarks or registered trademarks of IBM Corporation.

Adobe, the Adobe logo, Acrobat, PostScript, and Reader are either trademarks or registered trademarks of Adobe Systems Incorporated in the United States and/or other countries. Oracle is a registered trademark of Oracle Corporation.

UNIX, X/Open, OSF/1, and Motif are registered trademarks of the Open Group.
Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or registered trademarks of Citrix Systems, Inc.

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

Java is a registered trademark of Sun Microsystems, Inc.

JavaScript is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

MaxDB is a trademark of MySQL AB, Sweden.

SAP, R/3, mySAP, mySAP.com, xApps, xApp, SAP NetWeaver, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies. Data contained in this document serves informational purposes only. National product specifications may vary.

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.
Icons in Body Text

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>⚠️</td>
<td>Caution</td>
</tr>
<tr>
<td>示例</td>
<td>Example</td>
</tr>
<tr>
<td>&gt;Note&lt;</td>
<td>Note</td>
</tr>
<tr>
<td>推荐</td>
<td>Recommendation</td>
</tr>
<tr>
<td>语法</td>
<td>Syntax</td>
</tr>
</tbody>
</table>

Additional icons are used in SAP Library documentation to help you identify different types of information at a glance. For more information, see Help on Help → General Information Classes and Information Classes for Business Information Warehouse on the first page of any version of SAP Library.

Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example text</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Cross-references to other documentation.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Emphasized words or phrases in body text, graphic titles, and table titles.</td>
</tr>
<tr>
<td><strong>EXAMPLE TEXT</strong></td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><code>&lt;Example text&gt;</code></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td><strong>EXAMPLE TEXT</strong></td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>
Exploring SAP NetWeaver CE Reference Scenario ................................................................. 5
Project and Skill Management Application ........................................................................... 5
Scenario Overview ................................................................................................................ 5
Application Architecture .................................................................................................... 7
Running the Application ..................................................................................................... 8
  Setting Up Project and Skill Management ...................................................................... 9
  Activating the Configuration Template .......................................................................... 10
  Adding Guided Procedures Runtime Portal Roles ....................................................... 10
  Preparing the SAP NetWeaver Demo Model Application ........................................... 11
Initiating the Project and Skill Management Process ...................................................... 12
Executing the Scenario Process ......................................................................................... 13
Reviewing the Application’s Source Code ........................................................................ 14
  Reviewing the GP Design Time of the Application ..................................................... 15
Exploring SAP NetWeaver CE Reference Scenario

This documentation provides information about the SAP NetWeaver CE reference application named Project and Skill Management. With the example the user can gain benefit and see the actual representation of the Service Oriented Architecture (SOA).

Composite applications are defined as packaged applications that sit on top of other applications and reuse their functionality by service calls. The composites are developed following the paradigm of model-driven development and this is relevant for the example described in this documentation. Model-driven development reduces the amount of handcrafted coding and increases the amount of configured or modeled parts of the composite. This approach improves the overall productivity and quality.

The scenario shows how to design a composite process on top of Java EE application.

Project and Skill Management Application

Use

The following documentation provides a logical procedure describing the scenario in general, architecture hints, steps describing how to run the application, also the necessary steps when executing the scenario, and instructions how to review the source code of the application.

Procedure

1. Review general information about the scenario.
   More information: Scenario Overview [Page 5]
2. Review the application architecture.
3. Run the application.
   More information: Running the Application [Page 8]
4. Execute the scenario process.
   More information: Executing the Scenario Process [Page 13]
5. Review the application’s source code.
   More information: Reviewing the Application’s Source Code [Page 14]

Scenario Overview

In this scenario, the underlying data comes from the Project Management and Employee Services application and is accessed via Web Services calls. Although it relies on the data model of the Project Management and Employee Services application, it has own business logic and specific user interfaces.

More information about the data model of the Project Management and Employee Services application:
You can start this scenario in Guided Procedures (GP) runtime of the Portal by selecting Start a New Process → ReferenceApplication → xEDM and choosing xEDM_Process.

The Project and Skill Management scenario allows a manager to search for a project by various criteria, then the system defines the missing skills, the manager chooses an event from the available courses, and assigns an employee to join.

After logging on to the system, the employee books an event from the available courses. Finally the team manager approves/rejects the training, registers the training, and the employee is notified by e-mail.
Application Architecture

The applications Project and Skill Management have the same architecture goal that is typical for a general composite - to use data and functions provided as services by platforms and other applications (in our case, it uses services from the Project Management and Employee Services application and SAP NetWeaver Demo Model), and to combine these into user-centric processes and views. To build the process the application uses Guided Procedures (GP) and Web Dynpro to create user interfaces. The details of the application layer structure are described below.

Process Logic Layer

The process logic layer is implemented with GP. GP allows you to model lightweight collaborative processes in which you connect various back-end applications and services into a single workflow. Process modeling with GP does not require specific programming skills and is targeted at business experts who are familiar with business processes. You can review the process structure (the actual step sequence with the corresponding callable objects, actions, sequential blocks, parallel dynamic blocks, and so on) in the Portal by selecting Guided Procedures → Design Time → xEDM Process and choosing Open.

Within each process step, exactly one action is executed. Each action is wrapped around a callable object, which either represents a user interface or a service.
User Interface Layer

A process modeled with GP can integrate steps executed in the background and others that require certain user interaction. For steps that involve user interaction you can implement user interfaces using Web Dynpro, Visual Composer, or Composite Forms. Web Dynpro is used for developing more advanced online user interfaces and this is the technology used for the Project and Skill Management application. The Web Dynpro interfaces are integrated in GP as callable objects. For this purpose, they also implement a specific GP interface that allows the framework to automatically render the callable object parameters and result states.

Business Logic Layer

Most of the steps in the Project and Skill Management application include invocations of Java Web services provided by:

- Underlying Java EE 5-compliant Project Management and Employee Services application. For example, the Identify Missing Skills step involves a call to the ProjectDataServiceBean service.
- SAP NetWeaver Demo Model which is part of the SAP NetWeaver 7.1 Composition Environment installation. This model provides demo data for many of the SAP NetWeaver areas. It contains a variety of data (services, business objects, Portal content, non-structured data, and so on). For example, the Send Purchase Order step involves a call to a service provided by the SAP NetWeaver Demo Model.

Running the Application

Use

This procedure shows the necessary steps to configure and to run the Project and Skill Management application.

Procedure

1. Set up Project and Skill Management application.
   More information: Setting Up Project and Skill Management [Page 9]
2. Activate the Configuration Template.
   More information: Activating the Configuration Templates [Page 10]
3. Adding Guided Procedures Runtime portal roles.
4. Prepare the SAP NetWeaver Demo Model application for use in this scenario.
   More information: Preparing the SAP NetWeaver Demo Model Application [Page 11]
5. Initiate the Guided Procedures process.
Setting Up Project and Skill Management

Use
This procedure shows you how to configure the AS Java in the SAP NetWeaver Developer Studio, and how to deploy the downloaded archive files on the AS Java. To actually run the application, you need to perform additional configuration steps.

Prerequisites
- You have SAP NetWeaver 7.1 Composition Environment (SP3 or newer) installed in your system landscape.
- You have started SAP NetWeaver Developer Studio.
- You have the necessary application archive files available in your system.

Procedure

1. Configure the AS Java in the SAP NetWeaver Developer Studio
   1. Navigate to Window → Preferences → SAP AS JAVA.
   2. In the SAP Instance identity field, enter the correct settings.
      - Instance Number: the number you entered during installation. Usually 0 or 1.
      - Instance Host: localhost
         If you are using a remote SAP NetWeaver 7.1 Composition Environment installation, enter the corresponding IP address or name.
   3. Select the Default SAP System indicator.
   4. Choose Register SAP Instance and then OK.

2. Deploy the Archive File to the AS Java
   1. In the SAP NetWeaver Developer Studio, open the Deploy perspective by selecting Window → Open Perspective → Other → Deploy and then choosing OK.
   2. In the Deploy view window, select the context menu of External Deployable Archives, choose Add.
   3. From your file system, browse to the correct location of the file and choose Open.
      The file appears under External Deployable Archives in the Deploy View.
   4. Select the deployable CERAXEDM00_0.sca and choose Deploy.
Activating the Configuration Template

Use
This procedure describes how to activate the application configuration template, which performs configuration steps, not visible for the user, such as importing users (roles), creating Web service destinations, and so on.

Procedure
1. From your browser, start the SAP NetWeaver Administrator: http://<server>:<port>/nwa.
   If prompted for a log on, use the following credentials:
   ○ User ID: administrator
   ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
2. Choose Configuration Management → Scenarios → Configuration Wizard.
3. Select All Configuration Tasks from the dropdown box in the Configuration Tasks window.
4. In the field next to the filter button, enter Configuration of Reference Application xEDM and choose Enter.
5. Choose Expand tray in the Details field.
6. To activate the configuration template, choose Start.
7. Enter the administrative user name (the user name you entered during SAP NetWeaver 7.1 Composition Environment installation, usually administrator) and choose Next.

Adding Guided Procedures Runtime Portal Roles

Use
The following procedure describes how you assign GP Runtime WC portal roles to the default Administrator user and the users executing the application.

Procedure
1. From your browser, start the portal: http://<server>:<port>/irj.
   If you are prompted to log on, use the following credentials:
   ○ User ID: administrator
   ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
2. Choose System Administration → Permissions → Portal Content → Content Provided by SAP → platform_add_ons → Guided Procedures → GP Runtime WC.
3. From the GP Runtime WC context menu, choose Open → Permissions.
4. In the Search In field, located in the Assigned New Permissions window, choose Group and then Go.

5. Select the indicator in front of the group Everyone and choose Add. 
   The group Everyone appears in the list in the Assigned Permissions window.

6. Select the group Everyone indicator that appoints to End User and choose Save then OK.

**Result**

After you assign the above roles, the Administrator user and the rest of the users are able to access the Guided Procedures Runtime.

---

**Preparing the SAP NetWeaver Demo Model Application**

**Use**

This procedure describes how to prepare the necessary test data needed for the application, provided from the predeployed SAP NetWeaver demo model application. To run the reference application, you need to call and run a predefined via the Web Service Navigator.

**Procedure**

1. Open the start page of the Application Server Java using the following URL:
   
   ```
   http://<host>:<port>
   ```

2. Choose Web Services Navigator.

3. Enter the following URL in the WSDL URL field:

   ```
   http://<host>:<port>/NWDemoAdminBeanService/NWDemoAdminBean?wsdl
   ```

4. Choose Go.

5. Select the `generateData` operation and select the Endpoint in WSDL option under Configuration.

6. Choose Execute.
Configuring SMTP server

Use
This procedure helps you configure your mail server, thus you can execute the Project and Skill Management process thoroughly including the steps where mail notifications are necessary.

Procedure
2. Log on using the user name (for example, Administrator) and the SAP NetWeaver CE master password defined at installation.
3. Under Guided Procedures, choose Administration → Administer BMF.
4. Choose Clients, then under BMF Clients choose Settings, and then choose Mail Sending.
5. Enter the data for SMTP Server and Mail Transport Protocol. For example:
   - SMTP Server: mail.sap.corp
   - Mail Transport Protocol: smtp
6. Choose Save.

Initiating the Project and Skill Management Process

Prerequisites
You have completed the preceding steps described in Running the Application [Page 8]

Procedure
2. Log on using user name Administrator and the SAP NetWeaver CE master password defined at installation.
3. Go to Guided Procedures → Runtime.
5. Browse to select ReferenceApplication → xEDM → xEDM Process and choose Next.
6. Select Project Manager from the dropdown box and choose Add User.
7. In the Find field, enter a user who belongs to the EDMProjectManager UME group (for example, fallf) and choose Go.
   - All users from EDMProjectManager UME group can be used in the application role Project Manager.
8. To add the user to the role, select it in the result list, and choose Add.
9. Select Team Manager from the dropdown box and enter a user who belongs to the EDMTeamManager UME group (for example, platter).
   - All users from EDMTeamManager UME group can be used in the application role Team Manager.
10. To add the user to the role, select it in the result list, and choose Add.
11. Choose Done and then Next.
12. (Optional) You can change the name of the process in the Process Name field.
13. To start the process, choose Initiate.

**Executing the Scenario Process**

**Use**

This procedure shows the process flow of the Project and Skill Management reference scenario.

**Prerequisites**

You have completed the steps in Running the Application [Page 8]

**Procedure**

2. Log on with the user you have assigned to the project manager role (fallf).
3. Go to Guided Procedures → Runtime and choose Tasks Where Action is Required to Continue Process Flow under Tasks that require my action.
4. Choose Search and Select Project.
5. Enter Software Programming in the Enter search parameter field and choose Search.

<table>
<thead>
<tr>
<th>Enter search parameter</th>
<th>Software Programming</th>
<th>Search</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Project ID</th>
<th>Title</th>
<th>Start</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td>Software Programming</td>
<td>2007-05-20T00:00:00</td>
</tr>
</tbody>
</table>

The project is displayed in the Result List.
6. Choose Next and then Refresh.
7. Select the EN:Java Programming from the list of Missing Skills in Project.

The available courses are displayed in the List of Courses.
8. Select SW510/C++Start-Up Kit (EN) and choose Assign Employees.
9. Select an employee from the Employee List (for example Paul Burke, the user has user name burkep) and choose Select.
10. Choose Next and then Finish.
11. Log off from the portal and log on again with the user assigned to the employee role (in our case burkep).
13. Select Book Course Events, choose a course from the Event List, and choose Book Event.
14. Log off from the portal and log on with the user assigned to the Team Manager role (platter).
15. Go to Guided Procedures → Runtime and choose Tasks Where Action is Required to Continue Process Flow.
16. Choose Approve Booking, enter your comments (if any) under the Comment field, and then choose Accept or Reject.
17. Log on as the employee (burkep) to receive the notification.
19. Choose Receive Notification and then Complete.

### Reviewing the Application’s Source Code

#### Use
This procedure describes how to import and review source code of the application built with Web Dynpro and Guided Procedures.

#### Prerequisites
- You have installed and opened SAP NetWeaver Developer Studio.

#### Procedure

1. **Review the Application Part Built with Web Dynpro**
   - If you have already imported the development configuration file CE-RA.export (if you were reviewing the source code of Customer Service Care application) do not execute steps from 1 to 5. Alternatively, start from step 1.
   1. Open the Development Infrastructure perspective by selecting Window → Open Perspective → Other → Development Infrastructure and then choosing OK.
   2. From the main menu, choose File → New → Other → Development Infrastructure → Development Configuration → Next to open the next screen.
   3. From the Create/Import Development Configuration field select the from Development Configuration file indicator and choose Browse.
   4. Browse to the correct location of the downloaded from SDN development configuration file (CE-RA.export) and choose Open and then Next.
   6. If prompted for a log on, use the following credentials again:
      - User ID: administrator
○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation

The content of development configuration named CE-RA [0] appears in the Component Browser.

7. Select the CE-RA-XEDM[sap.com] context menu, then choose Import.
8. Browse to the correct location of the downloaded file from SDN CERAXEDM00_0 and choose Open.
9. Choose Next and then Finish.
10. Select simultaneously the following software components under CE-RA-XEDM[sap.com] (using the Ctrl button):
  ○ xapps/ra/xedm.aevtfrm.wd
  ○ xapps/ra/xedm.appvfrm.wd
  ○ xapps/ra/xedm.msklfrm.wd
  ○ xapps/ra/xedm.ntfform.wd
  ○ xapps/ra/xedm.psrhfrm.wd
11. From the context menu, choose Sync/Create Project → Create Project.
12. Deselect the Build DC after sync indicator and choose OK.
13. When prompted to switch to Web Dynpro perspective, choose Yes.

The components are displayed in the Web Dynpro Explorer and you can browse through their content.

2. Review the Application Part Built with Guided Procedures


Reviewing the GP Design Time of the Application

Procedure

1. Allow General Portal Permissions
   1. From your browser, start the portal: http://<server>:<port>/irj.
   2. When prompted for a logon, use the following credentials:
      ○ User ID: administrator
      ○ Password: the password set during SAP NetWeaver 7.1 Composition Environment installation
   3. Choose System Administration → Permissions → Portal Content → Content Provided by SAP → platform_add_ons → Guided Procedures → GP Superuser.
   4. From the GP Superuser context menu, choose Open → Permissions.
   5. In the Search In field, located in the Assigned New Permissions window, choose Group and then Go.
6. Select the indicator in front of the group *Everyone* and choose *Add*.
   The group *Everyone* appears in the list in the *Assigned Permissions* window.

7. Select the group *Everyone* indicator that points at *End User* and choose *Save then OK*.

8. Repeat steps from 3 to 7 (as described above for the role *GP Superuser*) also for the role *GP Business Expert*.

2. **Allow the Administrator to View the GP Design Time**

1. Open the start page of the Application Server Java using the following URL:
   ```
   http://<host>:<port>
   ```

2. Choose *User Management* → *Identity Management*.

3. From the *Search Criteria* dropdown box, select *Role*.

4. Enter
   ```
   ```
   then choose *Go*.

5. Select the role displayed and choose *Modify*.

6. Select *Assigned Users*, enter `A*` in the *Search Criteria* field, and choose Go to find the default *Administrator* user.

7. Select the *Administrator* user, choose *Add* and then *Save*.

8. Repeat steps 3 to 7 also for the role
   ```
   ```

3. **Review the Design Time of the Application**


2. If prompted for a logon, use the following credentials again:
   - User ID: administrator
   - Password: the password set during SAP NetWeaver 7.1 Composition Environment installation

3. Choose *Guided Procedures* → *Design Time* → *Reference Application* → *xEDM* → *xEDM Process* → *Open*.
   In the application process you can browse through the process steps and review the details such as type of step (action, sequential block, parallel dynamic block), also details as roles, parameters, permissions, exceptions, and so on.