How To Set Up and Use the CTS+ in a Portal Environment

Version 1.00 – June 2007

Applicable Releases:
SAP NetWeaver 7.0 SPS 12 (Transport System)
SAP NetWeaver 04 SPS 9 and higher (Portal)
© Copyright 2007 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.

IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, iSeries, pSeries, xSeries, zSeries, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, and Informix are trademarks or registered trademarks of IBM Corporation in the United States and/or other countries.

Oracle is a registered trademark of Oracle Corporation.

UNIX, X/Open, OSF/1, and Motif are registered trademarks of the Open Group.

Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or registered trademarks of Citrix Systems, Inc.

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C, World Wide Web Consortium, Massachusetts Institute of Technology.

Java is a registered trademark of Sun Microsystems, Inc.

JavaScript is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

MaxDB is a trademark of MySQL AB, Sweden.

SAP, R/3, mySAP, mySAP.com, xApps, xApp, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies. Data contained in this document serves informational purposes only. National product specifications may vary.

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

These materials are provided “as is” without a warranty of any kind, either express or implied, including but not limited to, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. SAP shall not be liable for damages of any kind including without limitation direct, special, indirect, or consequential damages that may result from the use of these materials.

SAP does not warrant the accuracy or completeness of the information, text, graphics, links or other items contained within these materials. SAP has no control over the information that you may access through the use of hot links contained in these materials and does not endorse your use of third party web pages nor provide any warranty whatsoever relating to third party web pages.

SAP NetWeaver “How-to” Guides are intended to simplify the product implementation. While specific product features and procedures typically are explained in a practical business context, it is not implied that those features and procedures are the only approach in solving a specific business problem using SAP NetWeaver. Should you wish to receive additional information, clarification or support, please refer to SAP Consulting.

Any software coding and/or code lines / strings (“Code”) included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, except if such damages were caused by SAP intentionally or grossly negligent.
1 Introduction

The functions of the Change and Transport System (CTS) have been enhanced to enable the transport of non-ABAP objects. This guide tells you how to use the additional functions of the SAP NetWeaver Change and Transport System (CTS+, enhanced CTS) in your portal landscape. Non-ABAP objects can be attached to transport orders. In the portal use case, deployment takes place using the SDM. The transport routes have to be defined in the transport system. The CTS+ also provides capabilities for transporting XI objects, J2EE developments, and for enriching transportation using the NWDI, for example. Refer to the appropriate guides if you use these systems.

The CTS+ enables the transportation of non-ABAP objects using the ABAP transport system. It does not provide all ABAP Workbench features. In particular, it does not provide an automated change record. There are no changes to how transport packages (epa files) are created in the portal.

This guide describes how you can transport epa files with CTS+. Documents and configurations of Knowledge Management and Collaboration (KMC) are not part of the CTS+ concept at the moment. Mechanisms for supporting KMC are planned for the future. Documentation will be provided.

The general documentation for the CTS+ can be found at help.sap.com (refer to the section entitled ‘Appendix’ for additional information and links).

2 Prerequisites

1. You need a system with a Java stack and an ABAP stack. We highly recommend that you use a dual stack system. The system Support Package state must be NetWeaver 7.0 (2004s) SPS12 or higher. This system acts as the CTS+ domain controller.
2. The portals that are to form part of the transport route(s) need to have NetWeaver 04 SPS 9 or higher installed.
3. To be able to perform the configuration steps below, you require full administration privileges both for the CTS+ system and for the portal assigned to your user.

3 Configuring the Transport System

3.1 Configuring the CTS+ system
You have to carry out the following configuration steps in every NetWeaver 7.0 SPS12 system that you want to use for creating transport routes.
3.1.1 Web Service Administration Settings

Log on to client 000.

Start transaction **WSADMIN**. From the menu, choose Go to ➔ Administration Settings.

Enter the URL (http://<cts+host>:<5< SAP System number>00>) for the Java stack of your CTS+ system).

You have to carry out this step for every client on which you want to configure transport routes.

**Note:**
Due to the long deployment time you should change the timeout of your ICM in the system profile to 

\[
\text{icm\_server\_port\_}<n> = \text{PROT=HTTP, PORT=80}<nn>, \text{PROCTIMEOUT=3600}
\]

and restart your server.

3.1.2 Checking the Web Service on the Java stack

Check the CTS Deploy Web service as follows:

Open a browser and enter the URL for the AS Java start page in the CTS+ system (http://<host>:<5< SAP System number >00>).

Navigate to the Web Service Navigator page.

Check that the **DeployProxy** Web service is listed in the list of deployed Web servers on the server in question.
3.1.3 Configuring the HTTP Connection

Log on to client 000.

Configure the HTTP connection as follows:
Start transaction SM59, select HTTP Connections to External Server, and then choose Create.

Create a new HTTP connection with the name CTSDEPLOY as an RFC destination of connection type G.

Go to the Technical Settings tab and enter the following values:

Target Host: hostname  
Service No.: port (5<SAP System number>00)  
Path Prefix: “/DeployProxy/default?style=document”

Note: If the system issues an error message, ignore it. Save twice and then leave the screen by clicking the green arrow pushbutton.
Go to the Logon & Security tab and select Basic Authentication as the logon procedure. As the logon user, enter the J2EE administrator user ID (usually 'j2ee_admin') of the Java stack on which the CTS deployment controller is deployed.

Save your changes.

Note: To check the user ID and password of the J2EE administrator, open a browser, call the address http://<host>:5<Instance Number>00/useradmin, and try to log on.

Click the Connection Test pushbutton to test the HTTP connection you just created.

Confirm the popup.
The value OK should appear for the status text, as shown in the graphic to the right.
3.1.4 Configuring a Logical Port for the Web Service

3.1.4.1 Checking the System Change Option

Log on to client 000.

Start transaction **SE03** and go to **Administration → Set System Change Option**. Double-click it to execute it.

Click the *Client Setting* pushbutton
Select the client 000 and switch to change mode (Ctrl + F1). Click the Details icon.

 Activate the Automatic recording of changes radio button and then save your changes.
3.1.4.2 Creating a Logical Port

Log on to client 000
Start transaction **IPCONFIG**.
In the **Proxy Class** field, select **CO_TFLDEPLOY_PROXY_VIDOCUMENT** from the list (F4).
In the **Logical Port** field, enter **CTSDEPLOY** and then choose **Create**.
Note: The client must be modifiable. For more information, see step 3.1.4.1 - **System Change Option**.

Enter a description (for example, **CTS deploy Web service**) for the logical port and select the **Default Port** checkbox.

If you do not specify a default port, the popup shown to the right appears. Confirm the prompt by choosing **Yes**.
Go to the Call Parameters tab and select ‘CTSDEPLOY’ as the value for the HTTP Destination field.

Save and activate (✓) your changes in a new transport request.

Note:
Reset the automatic recording of changes for client 000 (as described in section 3.1.4.1).

3.2 Configuring the ABAP Web Dynpro Application for the CTS+
SPS 12 provides a new ABAP Web Dynpro application that helps you to create transport orders and attach objects. You have to carry out certain configuration steps to run and use this application.

3.2.1 Checking Database Tables
The application type for the file objects must be available in the SI_RQ_APPL_NAME database table.

Call transaction SE11 and enter SI_RQ_APPL_NAME as the database table.
Choose Display.
Choose the Contents icon or choose Utilities → Table Contents → Display from the menu.

Enter the value 500 in the Width of Output List field and choose Execute.

For you to use the CTS+ in a portal environment, the entry ‘EP’ must be available.
The other entries in the screenshot also allow the use of the transport system with J2EE and XI.

Note: If you can only see the Application column, change the value for the screen width to 500:

If the required entries do not exist, choose Table Entry → Create from the menu and enter the required content.

Note: The table is language-dependent – log on in the language you are using in the application.
3.2.2 Activating the Service

You are logged on to client 000.

Call transaction SICF, enter SERVICE as the Hierarchy Type and Service Name: SODIS_CORE_WBO as the Service Name.

Choose Execute.

Select the service and activate it (using the context menu or by choosing Service/Host → Activate).
A popup appears. Choose the second pushbutton from the left (the pushbutton with the text Yes and a tree diagram).

Test the service by opening the context menu and choosing Test Service. If you still encounter problems, refer to SAP Note 517484.

Note:
If the test is running for the very first time, a timeout may occur as a result of the generation of the underlying objects in the ABAP stack. If this occurs, try again.
If you use the Web service for other clients than 000, you have to create the service in each client in which you want to use it. Call transaction **WSCONFIG**. Enter **SI_CORE_WBO_API** as the service definition and **SI_CORE_WBO_API** as the variant, and then choose **Create**. Save your changes and record them in a new transport request.

The **SI_CORE_WBO** service is visible in transaction **WSADMIN** for the client in question.

### 3.3 Configuring the Transport Domain Controller

Log on to your chosen AS ABAP System in client 000 and start transaction **STMS**.

The message **You are logged onto the domain controller** should appear.

If this message does not appear, make sure that you configured your system as the domain controller as described in **TMS Configuration** (http://help.sap.com/saphelp_nw2004s/helpdata/en/44/b4a09a7acc11d1899e0000e829fbbd/frameset.htm).
3.4 Transport Landscape Configuration

3.4.1 Defining and Configuring Systems

Log on to the client that you want to use for transportation.
Start transaction STMS and go to Overview → Systems.
Choose SAP System → Create → Non-ABAP System from the menu.

Define a new system.
Example:
System - JAD
Description - Java Development System.

The communication system is your CTS+ system by default (here: OTO).

Repeat the previous step twice to create for example a JAQ system as a quality system and a JAP system as a production system.

The system names mentioned here are only examples. You should usually use the SIDs of the physical systems to which deployment will take place as system names.

At the moment, no check takes place. However, following integration with the Solution Manager, a check will take place and the entries should be set accordingly.

Change the TMS configuration for the JAQ system as follows:
Double-click the JAQ system in the system overview. Go to the Transport Tool tab. Switch to change mode.

Check the following parameters. They were set automatically.

DEPLOY_DATA_SHARE should point to the data directory under DIR_TRANS. You can check the value of DIR_TRANS using transaction AL11 in the target system.
DEPLOY_WEB_SERVICE has to be CTSDEPLOY. This was configured in the CTS+ system as described above.
Add/select the following parameters:
**DEPLOY_URL**
SDM URL of the runtime system to which the changes are to be deployed

Note: Do not make this parameter a global parameter (do not select the Global checkbox). Place the cursor on a non-global parameter and choose Insert Row to add another row.

Save your changes.

Choose Change to switch to change mode.
From the menu, choose Goto → SDM Benutzer/PW.

Enter a user ID (not checked in the current version) and the SDM password of the portal that the import goes to (JAQ in this example).
Repeat these steps to configure the production system (for example, JAP):

The configuration is exactly the same as the configuration for JAQ. Double-click the JAP system in the system overview and then go to the Transport Tool tab.

Switch to change mode.

Add/select the following parameters: DEPLOY_URL → SDM URL of the runtime system to which the changes are to be deployed

Save your changes. Add a user and the SDM password as described previously.

3.4.1.1 Defining Transport Routes

In transaction STMS, choose (Transport Routes).

Switch to change mode.

Use Drag&Drop to move all the systems (here: OTO, JAD, JAQ and JAP) into the Single System Configuration area.

Create a transport layer as follows: From the menu, choose Edit → Transport Layer → Create.
Specify a name and a description for the new transport layer. Confirm the dialog by choosing the green check mark.

Example:
Transport layer: Z<SID of the development system>
Description: Java Development Landscape.

Add a transport route by choosing (or pressing F6 or choosing Edit → Transport Route → Add Transport Route from the menu).

Create the new transport route by dragging the cursor from the CTS+ system (OTO) to the consolidation system (JAQ). Choose Consolidation as the transport route type.

Make sure that the transport layer is the transport layer you just created (here: ZJAD).
Confirm the dialog by choosing the green check mark.
Repeat this step to create a new transport route from the consolidation system (JAQ) to the production system (JAP). This time, choose Delivery as the transport route type.

A screen like the one displayed in the graphic to the right should appear. In the current release, JAD is not part of the transport route since the CTS+ system (OTO) is used to start the transport.
Make sure that the standard transport layer is the transport layer you just created (here: ZJAD).

To check or change it, go to the Change Transport Routes view, select the CTS+ (OTO) system, and double-click it. A popup appears where you can change the system attributes. Go to the Standard Transport Layer tab.

Set the transport layer to ZJAD, for example. Confirm that dialog by choosing the green check mark.

If you use the CTS+ system for more than one use case and therefore require several transport routes, refer to SAP Note 1003674 - 'Enhancements for Non-ABAP-Systems in CTS' for more details.

You are now ready to use the CTS+ in your portal environment. The following sections contain an example of how to integrate the features provided by the CTS+ into your portal. This might help you to work with the CTS+ without needing to swap between different systems. The sections below also give an example of what the connection between the systems might look like. In particular, the section Creating a System gives an example of how to create a connection using a connection string. The use of this connection type is not mandatory - you can also use load balancing or a dedicated application server. Details on how the connection works for these types can be found at help.sap.com at the following address:

http://help.sap.com/saphelp_nw2004s/helpdata/en/1f/bddf3d48b05d5ae10000000a11405a/frameset.htm
4 Connecting the Transport System with the Portal

4.1 Creating a System

Log on to your portal.

Go to System Administration → System Configuration → System Landscape

Navigate through the Portal Content Catalog to the folder in which you want to create the system.

Use the secondary mouse button to click the folder in question and then choose New → System (from template)

The system creation wizard starts.

Choose SAP system using connection string or any other SAP system template that is applicable for you.

Click Next
Fill in the **System Name**, **System ID**, and **System ID Prefix** fields according to the naming conventions for your portal. Choose **Next**.

A summary of the data that you just entered appears. Choose **Finish**.

Select **Open the object for editing**. Click **Ok**.

Maintain the following values:

- **Authentication Ticket Type**: Select (if you are using user mapping)
- **Connection String**: <host> (if you are using a connection string for the connection)
- **ITS Host Name** <host>:<port> (=80+system number for your system)
- **ITS Path** /sap/bc/gui/sap/its/ (or the path to your system)
- **ITS Protocol** (protocol for your system)
- **Logon Method**: UIDPW (if you are using user mapping)
- **SAP Client** (client in the CTS+ system where you configured the transport routes)
- **SAP System ID** (system ID for your
CTS+ system

**SAP System Number** (system number for your CTS+ system)

**User Mapping Type**: Admin, User (if you are using user mapping)

**Web AS Host Name**: `<host>` (host name for your system)

**Web AS Path**: `/sap/bc/bsp/sap` (or path for your system)

**Web AS Protocol** (protocol for your system)

Choose Save.

Note: The parameters relating to the ITS are only required if you want to use the SAP GUI for HTML. If you decide to use the ITS, make sure that the `sap/public/bc/its/mimes` and `ap/bc/gui/sap/its/webgui` services are activated in your ABAP system in transaction SICF. If you still encounter problems, refer to SAP Note 964521.

Note: If you do not want to use user mapping as an authentication method, maintain the appropriate parameters accordingly.

Choose System Aliases from the Display dropdown box.

Enter CTS in the **Alias Name** field.

Choose Add.

Choose Save.

---

### 4.2 User Mapping

This example uses user mapping as the logon method. You now need to map your portal user to an existing back-end user. If you want to use another logon method, configure your systems accordingly.
Go to User Administration ➔ Identity Management.

Enter your portal user ID in the Search Criteria field.
Choose Go.

Select your user in the table.
A second table appears below your search results displaying the user details.
Go to the User Mapping for system access tab.

Choose Modify.
Select CTS (that is, the alias you created in the previous step).
Enter your credentials for the following fields:
  Mapped User ID
  Mapped Password
Choose Save.
You can also use the Personalize option in the portal header to maintain user mapping.

User mapping needs to be carried out for all users that are going to use the transport mechanisms. An administrator can do this for users or users can carry out their own user mapping by choosing Personalize in the portal header. User mapping is only necessary if logon tickets are not available.

5 Creating Portal Content

We suggest creating two new iViews. One iView is needed to create transport orders and to attach portal transport packages to this or to other existing transport orders. The second iView is needed to release transport orders and to import them into the target system. You can then decide whether or not you want to add these two iViews to an administration role that you already created or whether you want to use one or two new roles.

The first iView is needed by users that export content and the second one is for users that import content. You should use the way in which administration is organized in your company to decide where (as a part of which role) to provide these iViews. The second
iView might not be necessary if you want to use the CTS+ system (Transactions on the ABAP Stack) to start imports.

5.1  Web Dynpro iView for Attaching epa Files to Transport Orders (sodis_core_wbo)

Go to Content Administration → Portal Content.

Open the Portal Content Catalog and navigate to the folder in which you want to store the iView.

Use the secondary mouse button to click this folder.

Choose New → iView.

In step one of the iView wizard, choose iView template – create an iView from an existing iView template.

Choose Next.

Choose SAP Web Dynpro iView.

Choose Next.

Enter values for the following fields:
iView Name, iView ID and iView ID Prefix

Choose Next.
Select Web Dynpro for ABAP.
Choose Next.

Choose the system that you want to use (the back-end system that contains the Web Dynpro application and is used for transports).

Namespace: sap.
Application Name: sodis_core_wbo
Select the client that you want to use.
Choose Next.
Check the data you entered.
Select the Open for editing when wizard completes checkbox.
Choose Finish.

Enter DEFAULT_PURPOSE=ep for the Application Parameters parameter and choose Save.
5.2 iView for Transaction STMS_QUEUE

Go to Content Administration → Portal Content.

Open the Portal Content Catalog and navigate to the folder in which you want to store the iView.

Use the secondary mouse button to click this folder.

Choose New → iView.

In step one of the iView wizard, select iView template – create an iView from an existing iView template.

Choose Next.

Select SAP Transaction iView.

Choose Next.

Enter values for the following fields:
iView Name, iView ID and iView ID Prefix

Choose Next.
Select the SAP GUI type that you want to use.
Choose Next.
Note: SAP GUI for HTML requires an ITS

Select the system alias that you created.
Enter the following value in the Transaction Code field: STMS_QUEUES
Choose Next.

Check your data.
Choose Finish.

You have now created the content for using the CTS+ in the portal environment. You can either integrate this content into existing roles in your portal or create new roles and assign them to users.
For information on creating roles and assigning them to users, see http://help.sap.com.
Do not add the new iViews to roles delivered with the standard portal content.

6 Performing Transports

This section assumes that you have already integrated an iView displaying the Web Dynpro for the ABAP 'sodis_wbo_core' application into your portal and that you have enabled single sign-on. The example also assumes that the iView for sodis_wbo_core is called Transport Requests.

6.1.1 Creating a Workbench Transport Request
Open the *Transport Requests* iView.

Choose *Create Change Request*. A popup appears. Enter a short text and - if you are using this feature of CTS - a project. Choose *Create Change Request*

A message appears telling you that the transport order has been created. Choose *Refresh* to see it in the list.

Select your change request. The other pushbuttons are now active. Choose *Attach Object* to attach an epa file, for example, to your transport order. For more information on creating epa files, see help.sap.com at the following address:  
A popup appears. Choose *Browse* and locate your epa file. Make sure that *EP* is selected. Choose *Attach Object.*

Choose *Display Request* to see a list of the objects that are attached to the change request.

Choose *Release* as soon as you have attached all the objects that you want to transport. The icon in front of your change request changes to a lock to show that you cannot attach additional objects to this transport order.

Go to your STMS_QUEUES iView or call the transaction in your transport system. Double-click the system into which you want to import your transport order.

A list of requests appears.
Select your change request.

Choose Menu → Request → Import

A popup appears where you can change the import options.

Choose the green check mark if everything is correct.

A popup appears.

Choose Yes if the options are correct. This starts the import.

A lorry symbol is displayed to the side of your transport order. This indicates that the import is running.

Choose Refresh to find out when the import has finished.

You can double-click the return code for a transport order to get an import report.

The epa file has now been imported into the second system in your transport route. To import it into the third system, choose the next system in your system list (STMS_QUEUES) and repeat the import steps.

The import into the target system is performed in the order in which the files were attached to the transport request. This means that the changes in the last epa file are used, and not the ones from the epa file with the most recent creation date.
7 Appendix

Additional Information and Links
Non-ABAP Transports in the Change and Transport System
Configuring TMS:

SAP Solution Manager 4.0 offers change request management. For more information, go to the following address at http://help.sap.com:
http://help.sap.com/saphelp_sm40/helpdata/en/0c/5b2160f6fa4b83a3674a210bcde0/frameset.htm

For more information on the SAP Solution Manager in general, use the following link:

SAP Notes:
1003674 Central Note on enhanced CTS
517484 Inactive Services in the Internet Communication Framework