Update Guide

SAP NetWeaver Composition Environment 7.1 – Update to SP05

Target Audience

- System administrators
- Technology consultants

Document version: 1.0 – 03/03/2008
Document History

The following table provides an overview of the most important document changes.

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>3/3/2008</td>
<td>Initial Version</td>
</tr>
</tbody>
</table>
# Table of Contents

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Overview</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>Update Preparation</td>
<td>7</td>
</tr>
<tr>
<td>3</td>
<td>Updating the CE System From SP01 to SP05 or Higher</td>
<td>9</td>
</tr>
<tr>
<td>4</td>
<td>Updating the CE System from SP04 to SP05 or Higher (Manual Procedure)</td>
<td>11</td>
</tr>
<tr>
<td>5</td>
<td>Updating the CE System Using the Update Management Service (From SP03 or Higher)</td>
<td>13</td>
</tr>
<tr>
<td>6</td>
<td>Deploying Additional Components on an Updated System</td>
<td>15</td>
</tr>
<tr>
<td>7</td>
<td>Transporting Self-Developed Software Component Archives (SCA) into the System</td>
<td>17</td>
</tr>
<tr>
<td>8</td>
<td>SAP NetWeaver Developer Studio</td>
<td>19</td>
</tr>
<tr>
<td>8.1</td>
<td>Installing SAP NetWeaver Developer Studio</td>
<td>19</td>
</tr>
<tr>
<td>8.2</td>
<td>Updating SAP NetWeaver Developer Studio</td>
<td>24</td>
</tr>
<tr>
<td>9</td>
<td>Troubleshooting – Updating SAP NetWeaver Composition Environment</td>
<td>27</td>
</tr>
</tbody>
</table>
1 Overview

This guide describes the update process if you want to update your SAP NetWeaver Composition Environment 7.1 system to SP05.

Prerequisites
You have installed SAP NetWeaver Composition Environment 7.1 with at least one of the following support packages:

- SP01
- SP03
- SP04

⚠️ Caution
You cannot update your system from SP00 to any higher SP!

For more information about how to install SAP NetWeaver Composition Environment, see http://www.sdn.sap.com/irj/sdn/nw-ce.

More Information
For SAP NetWeaver Developer Studio to be on SP05, you can either reinstall it or update it. For more information, see SAP NetWeaver Developer Studio [page 19].
This page is intentionally left blank.
2 Update Preparation

Before you start the update of your SAP NetWeaver CE system, make sure that you have carried out all necessary preparation steps.

Procedure

1. Ensure that your SAP NetWeaver CE system is up and running.

   [Only valid for: Linux]

2. Linux only:
   Run the following command:
   
   ```
   sapcontrol -host <localhost> -nr <instance_number> -user <sidadm_user> <password>
   -function AccessCheck Stop
   ```

   If the command returns any other code than OK, apply section PAM configuration needed for "sapstartsrv" and "sapcontrol" of SAP Note 958253.

   After applying the SAP Note, re-execute the command.

   [Only valid for: AIX]

3. AIX only: Apply SAP Note 1140980.

   [End of: AIX]

4. Choose whether you want to update your system

   - from SP01 to SP05 or higher [page 9]
   - from SP04 to SP05 or higher [page 11]
   - using the update management service [page 13].

   Caution

   The update management service is not available for updates of SAP NetWeaver CE systems from SP01!
This page is intentionally left blank.
3 Updating the CE System From SP01 to SP05 or Higher

1. Make sure you have carried out all preparation steps [page 7].
2. Follow the instructions described in SAP Note 1118749.
3. Exchange the engine template.

Note
Before changing the current template, note down the name of the currently active template. You will need it at the end of the update procedure to reactivate the original template again.

a) Navigate to the configtool subdirectory of your installation directory, for example
   C:\usr\sap\CE1\J01\j2ee\configtool
b) Run the file configtool.bat.
c) Highlight the template and choose File Change System Template.
d) Switch from the current template to the instance développement template.
e) Save your settings and restart the server.
   To do this, open SAP Management Console, select the node and choose the restart option.

Caution
If you are running a cluster system, you need to check that all instances are running the correct template before proceeding to update the main instance.

5. Stop the SAP Management Console.
6. Windows: From the download folder from SAP Service Marketplace, run the update tool update<ID>.exe to apply patches and updates to your NetWeaver CE system.
   AIX/ Linux: Log on to your system as user root and, from the download folder from SAP Service Marketplace, run the update tool update<ID>.sh to apply patches and updates to your NetWeaver CE system.
   After running the update tool wait until the engine is fully started.
7. To complete the update process, change back the system template to the original one.
Caution
If you are running a cluster system, make sure that you change back to the original template on all dialog instances.

8. Restart the system.

Troubleshooting
If an error occurs, see section Troubleshooting — Updating SAP NetWeaver Composition Environment [page 27].
4 Updating the CE System from SP04 to SP05 or Higher (Manual Procedure)

If you want to apply the latest support packages and patches to your SAP NetWeaver CE system or update your applications automatically, use the update management service of SAP NetWeaver CE [page 13].

1. Make sure you have carried out all preparation [page 7] steps.
2. Stop all SAP Management Consoles connected to your SAP NetWeaver CE system.
4. **Windows**: From the download folder, run the update tool `update<ID>.exe` to apply patches and updates to your SAP NetWeaver CE system.
   **UNIX**: Log on to your system as user `root` and, in the download folder, unpack the `update<ID>.sar` file using `SAPCAR`. Then run the update tool `update<ID>.sh` to apply patches and updates to your SAP NetWeaver CE system.
   After running the update tool wait until the engine is fully started.
5. Restart the system.

**Troubleshooting**

If an error occurs, see section Troubleshooting – Updating SAP NetWeaver Composition Environment [page 27].
This page is intentionally left blank.
5 Updating the CE System Using the Update Management Service (From SP03 or Higher)

Update Management Service is intended to help automate the process of downloading and installing the latest Support Package Stack from SAP Service Marketplace. The Update Management tool connects to SAP Service Marketplace and looks for the latest support package stack available for your system. For example, if your system is on SP03 and the latest support package available is SP05, the Update Management Service will download and apply SP05 to your system. If, however, you want to go to an intermediate support package stack, you have to download the stack manually.

Procedure

1. Make sure you have carried out all preparation [page 7] steps.
2. Stop all SAP Management Consoles connected to your SAP NetWeaver CE system.
3. **Windows**: Start the Update Management tool `coupdatemanagement.exe` from the following path:
   ```
   <drive>\usr\sap\<SID>\SYS\exe\uc\<PLATFORM>
   ```
   **UNIX**: Start the Update Management tool as user root from the following path:
   ```
   /usr/sap/<SID>/SYS/exe/uc/<PLATFORM>/coupdatemanagement
   ```
4. Follow the on-screen instructions and enter the required logon information.
5. The Update Management tool checks the system for installed components and support package stack level.
6. The Update Management tool checks for updates and new support package stacks on SAP Service Marketplace and applies them automatically.

When the update has successfully completed, SAPinst shows the dialog *The system is up-to-date*. If an error occurs, create a customer support message in the application area BC-UPG-SLM.

⚠️ Caution

For systems with the component IDE Update Site installed, proceed as follows.

1. Check whether you have installed the component IDE Update Site by entering the following URL in a browser:
   ```
   http://<CE system host>:5<Java instance number>/00/utl/UsageTypesInfo.
   ```
2. Run the update management service as described above.
3. Follow the instructions as described in SAP Note 1118264.
4. Run the update management service again as described above.
5. The configuration wizard task *Configuration and Mirroring of local NWDS Update Site* has to be run after each patch or update of the IDE update site component on AS Java.

For more information about how to run the configuration wizard, see section *Post-Installation Activities* in the SAP NetWeaver installation documentation, available at [http://www.sdn.sap.com/irj/sdn/nw-ce](http://www.sdn.sap.com/irj/sdn/nw-ce).
6 Deploying Additional Components on an Updated System

Installing Additional Components
If you want to install additional components with SP05, proceed as follows:

1. On your CE system with SP03, install additional components as described in the installation guide for SAP NetWeaver Composition Environment 7.1 SP03, available at http://www.sdn.sap.com/irj/sdn/nw-ce.
2. Update the system to SP05 as described above.

OR

1. Update the system to SP05 as described above.

Note
For more information about updating the CE system, see Updating SAP NetWeaver Composition Environment [page 11] or Updating the CE System Using the Update Management Service [page 13].

Deploying Additional SCAs
If you want to deploy additional SCAs on your CE system, proceed as follows:

1. Download the SCAs as well as the update file from http://service.sap.com/swdc Download Support Packages and Patches » Entry by Application Group » SAP NetWeaver » SAP NETWEAVER CE 7.1 » Entry by Component ».
2. Copy or move the SCAs and the update file into one directory and start the update file.

OR
Start the update file from an empty directory.
During the dialog phase, specify the directory where the SCAs are located.
This page is intentionally left blank.
7 Transporting Self-Developed Software Component Archives (SCA) into the System

Prerequisites
You have developed your own Software Component Archives (SCA) and want to transport them into your SAP NetWeaver CE system.

Procedure
To transport your SCAs to the SAP NetWeaver CE system, proceed as follows:

2. From an empty directory, run the update tool update<ID>.exe.
3. In the dialog screens, specify the directory where your SCAs are located.
4. Follow the on-screen instructions.

Note
If the tool displays descriptions such as Applying Support Packages, you can ignore them.
8 SAP NetWeaver Developer Studio

As of SAP NetWeaver Developer Studio SP03 or higher you can update the Developer Studio with the Update Management Service. For more information, see Updating SAP NetWeaver Developer Studio [page 24]. If you have an older Developer Studio version, you have to install the Developer Studio from scratch. For more information, see Installing SAP NetWeaver Developer Studio [page 19].

8.1 Installing SAP NetWeaver Developer Studio

SAP NetWeaver Developer Studio is based on the open development platform Eclipse. It includes the standard Eclipse features and SAP features. The SAP NetWeaver development documentation assumes that you are familiar with Eclipse and how to develop Java applications with it.


SAP Features

SAP NetWeaver Developer Studio provides several features for composing and developing business applications. You can select the features according to the components you have installed on your AS Java of the Composition Environment. The Developer Studio has the following features:

- **SAP NetWeaver Developer Studio Java EE**
  - Provides the toolset for Java EE compliant development.
  - AS Java component required: Java Application Server.

- **SAP NetWeaver Developer Studio Development Infrastructure Client**
  - Provides the toolset necessary to work the SAP component model. It provides functionality to work locally or in a team.
  - Depending on feature: SAP NetWeaver Developer Studio Java EE.
  - AS Java component required: Java Application Server. Optionally: SAP NetWeaver Development Infrastructure (NWDI) as part of an SAP NetWeaver 7.0 system.

- **SAP NetWeaver Developer Studio Web Dynpro User Interfaces**
  - Provides the toolset to develop user interfaces with Web Dynpro for Java.
  - Depending on features: SAP NetWeaver Developer Studio Java EE, SAP NetWeaver Developer Studio Development Infrastructure Client.

- **SAP NetWeaver Developer Studio Composition Tools**
  - Provides the toolset to develop composite applications.
Depending on features: SAP NetWeaver Developer Studio Java EE, SAP NetWeaver Developer Studio Web Dynpro User Interfaces, SAP NetWeaver Developer Studio Development Infrastructure Client.


### Installation Recommendations

Depending on your system landscape we recommend that you install the SAP NetWeaver Developer Studio as follows:

- **Central AS Java with update site**
  When you have a central AS Java, we recommend that this server provides an update site. This makes sure that the SAP NetWeaver Developer Studio you install has the version that matches the application server.
  You can check the availability of a local update site by going to the following URL in your Web browser:
  
  ```
  http://[host]:<httpport>/updatesite
  ```

  **Example**
  
  ```
  http://dev_server_01:50000 updatesite
  ```

- **Note**
  Make sure that the update site is properly installed and that the post-installation activities for the update site have already been performed.
  For more information, see section » Post-Installation Activities » Configuring the IDE Update Site in the installation documentation, available at: [http://www.sdn.sap.com/irj/sdn/nw-ce](http://www.sdn.sap.com/irj/sdn/nw-ce).

- **Developer Workplace**
  If you want to install the AS Java and the Developer Studio on a single workstation you can use the following sources:

  - SAP NetWeaver Developer Studio Update Site (recommended)
    SAP provides a central update site. The update site can be found at:
    
    ```
    https://nwds.sap.com/swdc/downloads/updates/netweaver/nwds_ce
    ```
    To access the update site you need an SAP Service Marketplace user and password (S user).

  - DVD
    Use the DVD you installed the AS Java from to make sure the Developer Studio and the AS Java have the same version. Once the Developer Studio is installed from a DVD, the update manager is always looking on the DVD for updates. Therefore you can only update the Developer Studio when you have a DVD with a new release. The Developer Studio Update Guide contains the information how to instruct the Developer to look for updates on the Developer Studio Update Site rather than on the DVD.
In the following installation procedure we only use the term *Update Site*. The installation steps are the same, regardless if you decided to install the Developer Studio from the SAP update site or the update site on your AS Java.

⚠️ Caution

Do only use your Update Site on the AS Java or the SAP Update Site. Using other update sites, like the Eclipse update site, can lead to a version mismatch of features and undesired results.

**Prerequisites**

Check the hardware and software requirements necessary for the installation of SAP NetWeaver Developer Studio:

<table>
<thead>
<tr>
<th>Requirement Type</th>
<th>Requirement</th>
</tr>
</thead>
</table>
| **Hardware**     | ![Note](image) SAP NetWeaver Developer Studio can be installed on a 32-bit platform only.  
|                  | - 1 GB free disk space  
|                  | - 1 CPU with 3 GHz (minimum)  
|                  | - 2 GB RAM (minimum)  
|                  | - Paging file size: 2xRAM  
|                  |      To check paging file size:  
|                  | 1. Choose Windows *Start* button and choose *Control Panel* → *System*.  
|                  | 2. Choose tab *Advanced* and choose *Settings* in the *Performance* pane.  
|                  | 3. Choose tab *Advanced* in the *Performance Options* dialog window.  
|                  | The current page size is displayed in the *Virtual memory* pane. To change the page size value, choose *Change* enable the *Custom size* radio button and enter the new value in the input field *Initial size (MB)*. |
| **Software**     | **Supported Operating Systems:**  
|                  | Microsoft Windows XP Professional SP2 (or higher)(32-bit)  
|                  | **JDK version:**  
|                  | SUN JDK 1.5.0_11 (or higher).  
|                  | You can download this version from the SUN web site. |

The installation process begins with preparation steps that are dependent on the installation method, DVD or update site. The following installation steps are independent of the installation method.
Preparation – Installing the Developer Studio from a DVD

1. Start SAPinst from the SAP Installation Master DVD by double-clicking sapinst.exe from the following path: <DVD drive>:\DATA_UNITS\IM\WIN\I386\<data_base>
   SAPinst GUI starts automatically by displaying the Welcome screen.
2. In the Welcome screen, choose the installation option SAP NetWeaver Developer Studio.

Preparation – Installing the Developer Studio from an Update Site

1. Start your Web browser and connect to the update site.
2. Download NWDS_platform.zip.
   This zip file contains the SAP NetWeaver Developer Studio Platform Installer.
3. Unzip NWDS_platform.zip to a temporary folder on your local disk drive.
4. Navigate to the temporary folder.
5. Run the installer IDESetup.exe contained in the zip.

Installing the Developer Studio from DVD and Update Site

Follow the on-screen instructions of the installer.

During the installation dialog you are asked for the update site location. Always accept the preconfigured URL that points to the update site that is correct for the installation location (DVD or update site) you selected.

The Developer Studio is started automatically when the installation dialog is finished. During startup you are asked for the workspace folder for the Developer Studio.

⚠️ Caution
If you already had a Developer Studio installed on this client, you need to specify a different workspace than the one you used for the previously installed Developer Studio version. This is also true if you have uninstalled the previous version already. Uninstalling a Developer Studio does not remove the content you created in the workspace folder that includes the preferences of the Developer Studio and maybe projects you stored locally.

The next prompt during start up is to confirm the network connections. On the network connection preference page you can specify if you connect to the Internet directly or you can configure your proxy. The network connection settings must be configured so that the Developer Studio can connect to the update site. There can be misleading error messages if the proxy settings are not correct. The installer installs the kernel of the Developer Studio. The kernel contains Eclipse and a few SAP additions, but is not equipped with the SAP features necessary for the Composition Environment. To install the required SAP features, you have to install the SAP features with the following update procedure.

Selecting and Installing Features

1. The available features are displayed.
The **Updates** dialog window displays the main node of the features. Open the main node and you see the available main features.

2. Choose the main features you want to install.

![Note](note.png)

Make sure that the component required for the selected feature is installed on the AS Java.

3. Accept the license agreement

4. In the screen **Optional Features**, choose Next.

![Caution](caution.png)

Never deselect an optional feature. This can cause a malfunction of the Developer Studio.

5. In the **Install** screen, choose **Finish**.

   The features are being downloaded.

6. Choose **Install All** to verify the feature installation.

7. Restart the Developer Studio for the updates to take effect.

![Recommendation](recommendation.png)

We recommend that you start the Developer Studio with the shortcuts that were created on your desktop or in the **Start** menu.

To get to the SAP documentation in the Developer Studio, open the application and choose from the menu bar **Help** ▶ **Help Contents** ▶ **SAP NetWeaver CE Developer Studio Documentation**.

The installation of the Developer Studio is now completed.

**Additional Activities**

Once the Developer Studio is installed you can add, update and remove installed features at any time.

**Adding Features to an Installed Developer Studio**

You can add features any time.

1. Choose ▶ **Help** ▶ **Software Updates** ▶ **Find and Install...**.

2. Choose **Search for new features to install**.

3. Enable the displayed update site.

![Recommendation](recommendation.png)

We recommend that you do not change the update site to avoid version inconsistencies.

4. Continue with step **Selecting and Installing Main Features** as described above.
8.2 Updating SAP NetWeaver Developer Studio

Uninstalling Features

1. To uninstall features, choose Help ➤ Software Updates ➤ Manage Configuration ➤.
2. In the Product Configuration window, choose Show Disabled Features.
3. Open the node SAP NetWeaver Developer Studio and its subnode.
   The features are displayed with its status, enabled or disabled.
4. To change the status of feature, select the feature and choose Enable or Disable (depending on the current status).
   To uninstall a feature, it has to be set to status disabled.
5. Restart the SAP NetWeaver Developer Studio to apply the status change.

Note

To uninstall all old version features (after the update), choose Help ➤ Software Updates ➤ Uninstall Disabled Features ➤.

8.2 Updating SAP NetWeaver Developer Studio

Prerequisites

Make sure your SAP NetWeaver Developer Studio is stopped.
You can install the higher SP version of SAP NetWeaver Developer Studio version parallel to your existing installation. For more information, see Installing SAP NetWeaver Developer Studio [page 19].

If you want to replace the existing SAP NetWeaver Developer Studio, we recommend that you remove the old SP version with the standard Windows procedure, choosing Start \ Control Panel \ Add and Remove Programs \ SAP NetWeaver Developer Studio \, before you install the new Developer Studio.

⚠️ Caution
Make sure you create a new workspace for your new SAP NetWeaver Developer Studio.

To update the Developer Studio, proceed as follows:

1. If you have installed your current version of the Developer Studio from a DVD, you have to change the update site URL. To change the update site URL, proceed as follows:
   a) Exit the Developer Studio.
   b) Navigate to installation directory of the Developer Studio (default is \Program Files\SAP\IDE\CE\eclipse). Continue browsing to the directory configuration\settings.
   c) Open the file com.sap.ide.update.autostart.prefs with a text editor (for example, Notepad)
   d) Change the value of key updatePolicyURL to:


    ⚠️ Note
An SAP S-user is required to access the SAP update site.

When you have a central AS Java that has the IDE Update Site component installed you can also specify the URL of your AS Java. You can check the availability of a local update site by entering the following URL in your Web browser:

http://<host>:<httpport>/updatesite

⚠️ Example

http://dev_server_01:50000/updatesite

When the update site is available, you can specify it as update site URL.

⚠️ Example

updatePolicyURL=http://dev_server_01:50000/updatesite
26

8.2 Updating SAP NetWeaver Developer Studio

Note

Make sure that the update site is properly installed and that the post-installation activities for the update site have already been performed.

For more information, see the SAP NetWeaver Composition Environment 7.1 SP03 installation guide, section Post-Installation Activities > Configuring the IDE Update Site.

e) Save the changes and exit the text editor.

f) Start the Developer Studio.

2. Check the network configuration of the Developer Studio.

The network configuration can be set in the Developer Studio by selecting the command

Window > Preferences... > General > Network Connections.

If you need no proxy settings or you use the update site on your central AS Java you select option Direct connection to the Internet.

If you use the SAP update site and you need proxy settings to access the Internet, select option Manual proxy settings. The proxy settings must be the same as you use for your Web browser. In the Windows Internet Explorer, you can view the proxy settings with the command Tools > Internet Options.... Choose tab Connections and than choose LAN Settings.... If you are using a proxy the checkbox Use a proxy server in panel Proxy Server is enabled and the proxy settings are displayed in the input fields Address and Port.

3. Update the Developer Studio.

a) Choose Help > Software Updates > Find and Install...

b) Choose Search for updates of currently installed features.

c) Follow the on-screen instructions.

Updating Installed Features

As of SP03, SAP NetWeaver Developer Studio uses the IDE Update Site to keep itself up-to-date.

1. Choose Help > Software Updates > Find and Install...

2. Choose Search for updates of currently installed features.

3. Follow the on-screen instructions.

Note

You need to run the configuration wizard task Configuration and Mirroring of local NWDS Update Site after each patch or update of the IDE update site component on AS Java.

For more information about how to run the configuration wizard, see section Post-Installation Activities in the installation documentation, available at http://www.sdn.sap.com/irj/sdn/nw-ce.
9 Troubleshooting – Updating SAP NetWeaver Composition Environment

DB Logs
The update process uses DB logs and data space. If there is not enough space for DB logs or DB data and the update freezes in such case, contact your DB administrator to increase the DB volumes for logs and data. You can then resume the update.

Windows Only: sc.exe File Might Crash
In rare cases, the update is not able to exchange kernel binaries and, thus, crashes. The crash writes specific information to the log file and looks like this:

```
Syntax
Nov 22, 2007 6:08:04 PM [Info]: Process ID 39 has been started.
Nov 22, 2007 6:08:04 PM [Info]: Waiting for process ID 39, name sc.exe to finish.
Nov 22, 2007 6:08:05 PM [Info]: Process ID 39, name sc.exe has been finished, exit code 1.
```

The log file is located at <drive>\usr\sap\<SID>\<Java instance number>\j2ee\JSPM\log\log_<data stamp>\Engine_Operation_XX.LOG.

To overcome the issue, apply SAP Note 112058 and resume the update.
## Typographic Conventions

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt; &gt;</code></td>
<td>Angle brackets indicate that you replace these words or characters with appropriate entries to make entries in the system, for example, “Enter your <code>&lt;User Name&gt;</code>”.</td>
</tr>
<tr>
<td>▶ ▶ ◀ ◀</td>
<td>Arrows separating the parts of a navigation path, for example, menu options</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Emphasized words or expressions</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Words or characters that you enter in the system exactly as they appear in the documentation</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Textual cross-references to an internet address, for example, <a href="http://www.sap.com">http://www.sap.com</a></td>
</tr>
<tr>
<td><code>/example</code></td>
<td>Quicklinks added to the internet address of a homepage to enable quick access to specific content on the Web</td>
</tr>
<tr>
<td><code>123456</code></td>
<td>Hyperlink to an SAP Note, for example, SAP Note 123456</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Words or characters quoted from the screen. These include field labels, screen titles, pushbutton labels, menu names, and menu options.</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Cross-references to other documentation or published works</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Output on the screen following a user action, for example, messages</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>File and directory names and their paths, names of variables and parameters, and names of installation, upgrade, and database tools</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Technical names of system objects. These include report names, program names, transaction codes, database table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Keys on the keyboard</td>
</tr>
</tbody>
</table>
No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.

IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, iSeries, pSeries, xSeries, zSeries, System i, System i5, System p, System p5, System x, System z, System z9, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, Informix, i5/OS, POWER, POWER5, POWER5+, OpenPower and PowerPC are trademarks or registered trademarks of IBM Corporation.

Adobe, the Adobe logo, Acrobat, PostScript, and Reader are either trademarks or registered trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Oracle is a registered trademark of Oracle Corporation.

UNIX, X/Open, OSF/1, and Motif are registered trademarks of the Open Group.

Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or registered trademarks of Citrix Systems, Inc.

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

Java is a registered trademark of Sun Microsystems, Inc.

JavaScript is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

MaxDB is a trademark of MySQL AB, Sweden.

SAP, R/3, mySAP, mySAP.com, xApps, xApp, SAP NetWeaver, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies. Data contained in this document serves informational purposes only. National product specifications may vary.

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

This document was created using stylesheet 2006-12-3i (V5.1beta [= 6.0 for El]) and XSLT processor SAXON 6.5.2 from Michael Kay (http://saxon.sf.net/), XSLT version 1.

Disclaimer
Some components of this product are based on Java™. Any code change in these components may cause unpredictable and severe malfunctions and is therefore expressively prohibited, as is any decompilation of these components.

Any Java™ Source Code delivered with this product is only to be used by SAP’s Support Services and may not be modified or altered in any way.
Documentation in the SAP Service Marketplace
You can find this document at the following address: https://service.sap.com/instguides
This page is intentionally left blank.