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Icons in Body Text
Icon

Meaning
Caution
Example
Note
Recommendation
Syntax

Additional icons are used in SAP Library documentation to help you identify different types of
information at a glance. For more information, see Help on Help → General Information
Classes and Information Classes for Business Information Warehouse on the first page of any
version of SAP Library.

Typographic Conventions
Type Style

Description

Example text

Words or characters quoted from the screen. These include field
names, screen titles, pushbuttons labels, menu names, menu paths,
and menu options.
Cross-references to other documentation.

Example text

Emphasized words or phrases in body text, graphic titles, and table
titles.

EXAMPLE TEXT

Technical names of system objects. These include report names,
program names, transaction codes, table names, and key concepts of a
programming language when they are surrounded by body text, for
example, SELECT and INCLUDE.

Example text

Output on the screen. This includes file and directory names and their
paths, messages, names of variables and parameters, source text, and
names of installation, upgrade and database tools.

Example text

Exact user entry. These are words or characters that you enter in the
system exactly as they appear in the documentation.

<Example text>

Variable user entry. Angle brackets indicate that you replace these
words and characters with appropriate entries to make entries in the
system.

EXAMPLE TEXT

Keys on the keyboard, for example, F2 or ENTER.
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Deployment
Purpose
This section describes how you deploy, manage and undeploy an application on AS Java.
Refer to the Java EE specification about the specifics of the deployment phase.

Integration
Deployment is the final step before starting your application. When the application is
deployed, its components are allocated to the corresponding containers that can handle them
appropriately.
We recommend you use the SAP NetWeaver Developer Studio when you need to develop an
application from scratch and deploy it. For more information about developing an application
with the SAP NetWeaver Developer studio, see Developing Java EE 5 Applications from
Scratch.
If you have an already-developed application, you can deploy it with SAP NetWeaver
Developer Studio as described in this section.

Features
●

Building and Deploying Projects [Page 6]

●

Deploying Components with SAP NetWeaver Developer Studio [Page 9]

●

Deploying Applications with Third-Party Deployment Tools [Page 21]
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Building and Deploying Projects
Use
To streamline your development process, SAP NetWeaver Developer Studio allows you to
publish your Java EE applications when you want to combine the build and deploy phases.

If you have already built your application and you want to deploy it, you have to
use another deployment option.

If you want to deploy an SAP specific archive, use Deploying Components with
SAP NetWeaver Developer Studio [Page 9].

Integration
The publish function uses the build and deployment functionality of AS Java. It saves you time
from having to build and to deploy your Java EE applications separately.

Prerequisites
●

A running AS Java is specified in the SAP NetWeaver Developer Studio.

●

A Java EE application is created in the SAP NetWeaver Developer Studio.

Features
When you publish your application, it is first built and then deployed on the selected AS Java.
With the publish functionality you can:
●

Publish a Java EE application on an AS Java

●

Undeploy the published Java EE applications from an AS Java.

For more information, see Publishing Java EE Applications [Page 7].
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Publishing Java EE Applications
Prerequisites
●

There is a running AS Java

●

The Java EE application is created.

Publishing Java EE Applications
...

1. You have the following options to select an application for publishing:
If You Want To
Select the application from the Project
Explorer view.

Then
2. Click with the secondary mouse button
on the application in the Project
Explorer view.
3. From the pop-up menu, select Run As
→ Run on Server. The Define a New
Server view of the Run on Server
dialog box appears.
4. Define a server. You can:
○

Choose an existing server

○

Manually define a new server.

5. Click Next. The Add and Remove
Projects view of the Run on Server
dialog box appears with the application
already moved to the Configured
Projects list.
Specify the application from the Servers
view.

6. In the Servers view, click with the
secondary mouse button on the server
to which you want to publish your
application.
7. From the pop-up menu, select Add and
Remove Projects. The Add and
Remove Projects dialog box appears.
8. From the Available projects list select
the projects you want to publish.
9. Click Add or Add All.

10. Click Finish.

Removing Published Applications
To remove applications from the server where they reside:
11. Click with the secondary mouse button on the server from which you want to remove
the application.
12. From the pop-up menu, select Add and Remove Projects.
13. Select the project in the Configured Projects list.
14. Click Remove.
To remove a specific application from the server where it resides:
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15. Click with the secondary mouse button on the application you want to remove.
16. From the pop-up menu, select Remove.
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Deploying Components with SAP NetWeaver
Developer Studio
Purpose
After component development ends, you need to deploy the component on AS Java.
Deploy View is a visual interface that not only helps you deploy Java EE components, it also
guides you through all life cycle phases of these components. You can manage both Java EE
components developed within SAP NetWeaver Developer Studio and Java EE components
developed with other development environments.

We recommend you develop your components with SAP NetWeaver Developer
Studio to take advantage of its development accelerating features.

Integration
You can use the Deploy View only from within SAP NetWeaver Developer Studio.

Features
●

Deploying Archives [Page 10]

●

Deploy Templates [Page 13]

●

Managing Deployed Archives [Page 15]

●

Undeploying Archives [Page 16]

●

Managing Substitution Variables [Page 18]

●

Viewing Deployment Related Logs [Page 19]

●

Filtering and Sorting Archives [Page 20]
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Deploying Archives
Use
With the Deploy View, you can deploy:
●

SAP component archives

●

Java EE archives located either in your workspace or anywhere else in your file
system. Each of them is automatically transformed to an SAP specific component
archive file (an SDA) when added to the Deploy View list.

Prerequisites
The Deploy View is open in Window → Show View → Other → Deploy View → Deploy View.
The Deploy View settings are set in Window → Preferences → SAP AS Java → Deploy View.

Procedure
...

1. Open the Deploy View. On the left you see a tree with two main nodes: Workspace
Deployable Archives and External Deployable Archives. After selecting one of the
nodes, a pane with settings appears on the right.
2. Set the necessary settings and strategies:
○

○

○

Update strategy
■

Update deployed archives that have lower component versions than the
selected ones.

■

Update deployed archives that have the same or lower component
versions than the selected archives

■

Update deployed archives that have any version. This option is most
suitable when you deploy Java EE archives since they do not have
versions.

Error strategy
■

Stop when the first error occurs
The whole deployment process will fail when one of the deployments
fails. This is the default and recommended error behavior.

■

Skip deployment of archives depending on the erroneous deployment
If the deployment of one of the components fails, all depending
components are skipped and not deployed. The process continues with
the next component in the deployment queue that does not depend on
the failed component.

Life cycle strategy
■

Bulk
This is the recommended strategy for most of the scenarios. The Deploy
Controller first delivers the components to the containers, and once all
the components are delivered, they are started in the same order they
were delivered.

■

Sequential
The Deploy Controller sequentially delivers a component to the
containers and then starts it. This strategy should not be used under
normal circumstances. It is kept for backward compatibility only.
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■

Sequential state dependent
Applications are only deployed without any attempt to start them.

All applications that have already been deployed and started will be
started at the end.
3. Add/locate the archives for deployment. You have the following options:
○

Select archives from your workspace:

You can use this option only if you have projects that contain EARs.

○

i.

Select the node Workspace Deployable Archives.

ii.

with the quick info text Add element. The dialog box Add
Choose
Deployable Archives appears.

iii.

Select one or more archives from the list.

iv.

Choose OK. The selected archives are added to the Workspace
Deployable Archives as subnodes.

Select external archives
v.

Select the External Deployable Archives node.

vi.

To select (you can use multiple select):

vii.

●

A Java EE Archive, choose
with the quick info text Import Java
EE Archive and select one or more archives from the Choose
Java EE Deployable Archive dialog box.

●

An SAP Archive, choose
with the quick info text Add element
and select one or more archives that you want to deploy from the
Choose Deployable Archive dialog box. You can open different
archives as long as they contain the SAP-specific METAINF/SAP_MANIFEST.MF.

Choose Open. The names of the selected archives appear in the tree
under the External Deployable Archives root.

You can remove the archives from the list by selecting them and
choosing the
button with the quick info text Remove element.
4. You can save the set as a Deploy Template. For more information, see Deploy
Templates [Page 13].
5. In the tree, select one or more archives to be deployed.

If you select one of the root nodes, all archives beneath it will be deployed.

When you select a name of an archive, you can see additional information about
it. When you select several archives, the settings and strategies are displayed
on the right.
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6. Choose
with quick info text Deploy. The deployment process for this component
starts. When completed, a message appears to show the result. The message types
are:
○

Success – all applications have been deployed and started.

○

Warning – the application or some of the selected applications cannot be
started.

○

Error – one or more of the selected applications were not deployed.

Java EE applications will be started according to the chosen strategy. An error
message will notify you if an error occurred.

To make it easier for you, the message shows a summarized result of all
operations and lists separately the results of each one.

In the Deploy View tree you can see small icon masks in front of the names of
the archives that indicate the status of the last operation over them.
They are a:
○

Green tick in front of the component’s name (the deploy and start were
successful)

○

Red exclamation mark - warnings during deploy (most likely the unit was
successfully deployed, but could not be started)

○

Red cross (unsuccessful deploy)

For more detailed information about deployment operation, see the log
messages in the Deploy View Console.

Result
You can see the applications listed in the Deploy View and in the Repository View in the
respective software component branch.
See also:
Filtering and Sorting Archives [Page 20]
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Deploy Templates
Use
This function saves information about a set of deployment archives and deployment settings.
It helps you easily perform repeated deployments with similar characteristics.

Integration
You can use deploy templates during deploy operations in the SAP NetWeaver Developer
Studio.

Prerequisites
You must have started the SAP NetWeaver Developer Studio.
You must have prepared the set of archives for deployment and set the strategies.

Features
The deploy template contains information about the:
●

location of the selected deployment archives

●

set of strategies that are used when the archives are deployed.

See also:
Working with Deploy Templates [Page 14]
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Working with Deploy Templates
Prerequisites
The Deploy View of the SAP NetWeaver Developer Studio is open.

Saving Deploy Templates
...

1. Include the archives you want to deploy and set the strategies as described in
Deploying Archives [Page 10].
2. From the dropdown menu of the
Export template.

with the quick info text Export template choose

3. Navigate to the location where you want to save the deploy template and specify its
name.
4. Click Save.

Opening Deploy Templates
...

1. From the dropdown menu of the
with the quick info text Export template choose
Import template. The Load DeployView Template dialog box opens.
2. Navigate to the template you want to use.
3. Click Open. The deploy template is loaded in the Deploy View.

An exception message will tell you if the deploy template contains a link to a
non-existent archive.
See also:
Deploy Templates [Page 13]
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Managing Deployed Archives
Use
Once you have deployed the components, you can view some basic information about them
and also start and stop them.

Prerequisites
You must have opened the Repository View from Window → Show View → Other → Deploy
View → Repository View.
Do not forget to update the display using
may see outdated information.

with the quick info text Refresh, otherwise you

Viewing Application Information
To view the details of a software component, you have to select it from the list. The
information is shown on the right.

Starting and Stopping an Application
To start or stop an application:
...

1. Select the application.
2. To:
○

Start it, choose
with the quick info text Start Archive. A dialog box shows the
result. Upon successful start, a small green triangle appears in the components
tree before the name of the component.

○

with the quick info text Stop Archive. A dialog box shows the
Stop it, choose
result. Upon successful stop, a small red square appears before the name of
the component.

Result
The application has been started or stopped according to your need. You save time as you do
not need to undeploy the component that is not currently in use.
See also:
Filtering and Sorting Archives [Page 20]
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Undeploying Archives
Use
When you no longer need a component, you can undeploy it.

If you do not want to use it now, but plan to use it later, you can simply stop it as
described in Managing Deployed Archives [Page 15].

Prerequisites
Open the Undeploy View from Windows → Show View → Other → Deploy View → Undeploy
View.
with the quick info text Refresh to display an up-to-date list of the deployed

Choose
archives.

Procedure
...

1. Open the Undeploy View tab
2. Set:
○

An undeployment strategy
■

If depending stop
If there are components that depend on the software component that has
to be undeployed and these are not part of the list of components that
have to be undeployed, the undeployment process will stop. The
dependent components have to be undeployed for the undeployment to
be successful.

■

Undeploy depending
All deployed components that depend on the component that has to be
undeployed will be undeployed too.

Please use this strategy with caution. If there is a large dependency
chain, you may undeploy applications you did not intend to undeploy.
○

An error strategy
■

Stop when the first error occurs
The whole undeployment process will fail if one of the undeployments
fails. This is the default error behavior.

■

Skip undeployment of archives depending on the erroneous
undeployment
This option is most suitable when undeploying Java EE archives since all
your archives will be undeployed. If the undeployment of some of the
components fails, all depending components are skipped and not
undeployed. The process continues with the next component in the
undeployment queue that does not depend on the failed component.

3. Select the archives you want to undeploy from the tree. You can make multiple
selections.
4. Choose
with the quick info text Add Items to undeploy list. This will copy the names
to the table on the right.
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If you want to remove an archive from the list, select its name and click the
button with the quick info text Remove selected items from undeploy list.
5. Select the names of the archive you want to undeploy from the list on the right.
6. Choose
process.

with the quick info text Undeploy. A message is displayed at the end of the

You can check the undpeloyment status of the component, by clicking on the
button with the quick info text Show Undeployment status.

Result
You have undeployed the component. For more information, see the log messages in the
Deploy View Console.
See also:
Filtering and Sorting Archives [Page 20]
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Managing Substitution Variables
Use
Substitution variables let you set specific values for component properties for different
environments.

Prerequisites
You must be connected to an AS Java.
Open the Config View from Windows → Show View → Others → Deploy View → Config
View.

Getting Substitution Variables
To get an actual list of the substitution variables on the AS Java, choose
info text Refresh.

with the quick

To see the variable value, select the variable from the list.

Adding a Substitution variable
...

1. Select the Substitution Variable node. The
becomes active.

with the quick info text Add element

2. Enter the appropriate values in the Substitution Property Name and Config Property
Value fields.
3. Choose
with the quick info text Add element and confirm your decision. This adds
the variable as a node to the Substitution Variables list.

Removing a Substitution Variable
4. Select one or several substitution variables from the list. The
Remove element becomes active.
5. Choose

with the quick info text

with the quick info text Remove element and confirm your decision.

Result
The values of the substitution variables match your needs and the applications can behave
accordingly.

Example
The application X requires resource Y. Resource Y has different locations on the two server
nodes as follows:
●

On server node 1 it is located in directory server1/test1

●

On server node 2 it is located in directory server2/test1

To minimize efforts, application X can refer to the location of resource Y as {Y_location}/Y.
Using substitution variables you can give different values to the substitution variable
{Y_location} for the two different nodes. For:
●

Server node 1 it will be {Y_location} = server1/test1

●

Server node 2 it will be {Y_location} = server2/test1

As a result, you have more freedom to manage your resources and at the same time you do
not have to change the application before deploying it different on server nodes.
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Viewing Deployment Related Logs
Use
When you need more information about the deployment related operations, you can find it in
the Deploy View Console.

Integration
The Deploy View Console keeps track of all deployment related operations performed on the
cluster to which the SAP NetWeaver Developer Studio is connected. It even works when it is
not open, so you do not lose any information.

Prerequisites
Open the Deploy View Console from Window → Show View → Other → Deploy View →
Deploy View Console.
At least one deploy related operation must have been performed. Otherwise, the Deploy View
Console will be empty.

Activities
To read a log item, you have to double click it.
You can clean the Deploy View Console when the number of the logs increases too much. To
do so, choose
with quick info text Clear View.
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Filtering and Sorting Archives
Use
Use this function to filter which archives will be displayed in the Repository and Undeploy
view.

Prerequisites
Components are deployed on the AS Java.
The SAP NetWeaver Developer Studio is connected to a running AS Java.

Filtering Archives
...

1. Open the view (either Repository or Undeploy).
2. Open the dropdown menu of the
Filters.

button with quick info text Toolbar Menu and select

3. To specify which filter you want to use, click the checkbox in front of its name.
4. To modify the settings for the filter:
a. Click its name. The Config button becomes active.
b. Click the Config button.
c. Specify the filter value and the settings.
d. Choose OK to confirm this filter settings.
e. Choose OK to confirm the filter group settings. The components are filtered. The
ones that comply with the filter group are displayed.
5. To view all components again:
a. Open the dropdown menu of the
and select Filters.

button with the quick info text Toolbar Menu

b. Deselect all filters.
c. Click OK.

Sorting Archives
6. Open the view (Deploy, Repository or Undeploy).
7. Open the dropdown menu of the
button with the quick info text Toolbar Menu and
select Sorters. The Select Sorter dialog box appears.
8. Select a sorter and a sorting direction.
9. Choose OK.
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Deploying Applications with Third-Party
Deployment Tools
Purpose
If you want to use non-SAP Java EE compatible deployment tools to deploy your Java EE
components on AS Java, you have to use the Java EE Deployment plug-in provided with AS
Java. It conforms with the specific implementation of the Java EE Deployment specification in
AS Java.

When you use a non-SAP Java EE compatible deployment tool, you have to
consider its functional constraints. We recommend you use the SAP NetWeaver
Developer Studio for flawless development process.

Process Flow
The Java EE Deployment plug-in provides all deployment operations specified by the Java
EE specification. You can perform all deployment operations that are implemented by the
third-party deployment tool.
For more information about setting up the third party deployment tool, see Tuning the
Deployment Tool [Page 22].
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Tuning the Deployment Tool
Use
You can perform deployment operations from any Java EE compatible deployment tool. You
have to tune it so that it can work with AS Java.

Prerequisites
●

The As Java is installed on the host where you want to perform deployment
operations.

●

You have access to the Java EE Deployment plug-in file on the AS Java host.

Procedure
...

1. Save the Java EE Deployment plug-in JAR file
(<Installation_directory>/<SID>/<Instance_Number>/j2ee/deployment/lib/sap.com~tc~j
e~deployment14~impl.jar) in the appropriate directory of the deployment tool.

For more information about the location of this folder, see the documentation for
the deployment tool.
2. Open META-INF/MANIFEST.MF file in the Java EE Deployment plug-in JAR file.
3. Check whether the element J2EE-DeploymentFactory-Implementation-Class and its
value are written on one line without any line breaks.

If there are any line breaks, you should manually remove them. Otherwise the
external and internal tools that use the Java EE Deployment plug-in will not be
able to determine the SAP Deployment Manager entry point. This line break
appears due to specifics of the used Ant tasks that create the JAR file.
4. Put the following JAR files in the classpath of the deployment tool. You can find them in
directories <Installation_Directory>/<SID>/<Instance_Number>/j2ee/deployment/lib and
<Installation_Directory>/<SID>/<Instance_Number>/j2ee/j2eeclient.
○

sap.com~tc~je~clientlib~impl.jar

○

sap.com~tc~logging~java~impl.jar

○

sap.com~tc~exception~impl.jar

○

sap.com~tc~je~adminadapter~impl.jar

5. If you use an external access point you have to specify the value of Deployment
Manager URI, which has the following syntax:
<AS_Java_host>:<P4_port>:AS_Java_Deployer
6. You have to know the appropriate user and password for the specific AS Java you are
going to connect to so that you can enter them when requested. Otherwise, you will not
be allowed to perform deployment operations on the AS Java.

Result
Now you can use the deployment tool to manage your applications on AS Java.
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