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Caution

Cross-references to other
documentation

Syntax

Example text

Emphasized words or phrases in
body text, graphic titles, and
table titles

EXAMPLE TEXT

Technical names of system
objects. These include report
names, program names,
transaction codes, table names,
and key concepts of a
programming language when
they are surrounded by body
text, for example, SELECT and
INCLUDE.

Example text

Output on the screen. This
includes file and directory names
and their paths, messages,
names of variables and
parameters, source text, and
names of installation, upgrade
and database tools.

Example text

Exact user entry. These are
words or characters that you
enter in the system exactly as
they appear in the
documentation.

<Example text>

Variable user entry. Angle
brackets indicate that you
replace these words and
characters with appropriate
entries to make entries in the
system.

EXAMPLE TEXT

Keys on the keyboard, for
example, F2 or ENTER.
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History of Changes
The following table provides an overview of the most important changes that
were made in the latest versions.

Version

Important Changes

1.0

Initial revision
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1 Installation Overview
The SAP ME Software Development Kit (SDK) is a set of tools and documentation that can be
used to develop and build extensions for the SAP Manufacturing Execution (ME) application.
This guide provides information about installing and configuring the SDK development
environment, which includes an IDE, integrated build tool, source control client, and runtime
system for testing extensions.
It is worthy to note that the local development landscape also includes the installation of a standalone build tool instance known as the Central Build Instance (CBI). The CBI is used to create
ME releases that can be shipped to test and production systems. Each software vendor involved
in the project must install their own CBI. See the SAP ME Build Tool Installation Guide: Central
Build Instance for information about the CBI.

1.1 Platform Availability
The following table lists version requirements for external software products used by the SDK:
Component

Version

OS

Windows 7 (64bit)

JDK

Java 2 Standard Edition 1.6 update 21 or higher 1.6 release (32
bit)

Application Server (AS
Java)

SAP NetWeaver 7.30 Application Server Java SP8 or higher SP
with MaxDB
SAP NetWeaver 7.31 Application Server Java SP5 or higher SP
with MaxDB

ME Application

6.1.0.3 or higher 6.1.x release

ME Database

See the SAP ME 6.1 Product Availability Matrix for required
database versions

Source Control

Any

The following table defines the minimum hardware requirements depending on your database
configuration:
Configuration

Free Disk Space

Physical Memory

CPU

Locally hosted database

20G

8G

2 Ghz

Shared (remote) database

15G

8G

2 Ghz

1.2 Prerequisites
The following information and software should be available prior to creating a new installation of
the SDK:


Vendor ID assignment



ME core and legacy Software Component Archives



ME Configuration Wizard (CTC) Software Component Archive



Developer Workplace for NetWeaver 7.3 installation media



SAP NetWeaver 7.30 SP8 / 7.31 SP5 or higher SP with MaxDB installation media
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Installed Java Development Kit (JDK) 1.6 update 21 or higher 1.6 release (32 bit)

1.2.1 Vendor ID
A team ID, referred to as the vendor ID, must be assigned by the project manager to each
member of the local development team. If more than one development team is participating in
the project, then each team must have a unique ID assignment.
The same ID value must be used by all members of your local development team (i.e.
you should not create your own ID). In addition, the vendor ID is very difficult to
change after development has started, and so its value should be chosen with the
upmost care. The ID “sapdev” is reserved for SAP Custom Development.
On a technical level the vendor ID is a namespace qualifier that is used by the embedded SDK
build tool to package development artifacts and to create unique names for the resulting build
archives. This insures that artifacts such as Java classes and the archives in which they are
packaged are globally unique with respect to those created by other software vendors.
If you have not been assigned a vendor ID, contact your project manager so that one can be
created. Note that the installer will only allow a vendor ID value that conforms to the following
restrictions:


Globally unique for all software vendors participating in the project



Contains only lower case alphanumeric characters, including underscore



Does not begin with an underscore or number



Is between two and sixteen characters long

1.2.2 ME Software Component Archives
As of SAP ME 6.1 shipment using the Software Update Archive (SUA) has been replaced with
the standard Software Component Archive (SCA). The SAP MFG EXECUTION LEGACY 6.1
and SAP MFG EXECUTION CORE 6.1 software components are installation pre-requisites and
are made available for download from SAP Service Marketplace at the following location:
Software Downloads->Support Packages and Patches->A - Z Index->M->SAP MFG Execution>SAP MFG Execution 6.1->Comprised Software Component Versions
The SDK installer will prompt you to choose the legacy and core SCAs and automatically import
them into the SDK installation.
The SAP ME Build Tool User Guide is delivered by the installation and describes
SCA import as well as other build system operations and concepts.
The installer will make a copy of both archives and place them in the
<InstallDir>\import\sca directory. Once installation is completed you can remove the
downloaded copies from the download location.

1.2.3 ME Configuration Wizard (CTC)
SAP ME 6.1 is installed using the NetWeaver Configuration Wizard (CTC) for SAP ME. The
Configuration Wizard is shipped as a software component that must be deployed in order to
complete the SAP ME installation and configuration.
The configuration wizard is made available as a software component archive on SAP Service
Marketplace at the following location:
Software Downloads->Support Packages and Patches->A - Z Index->M->SAP MFG Execution>SAP MFG Execution 6.1->Comprised Software Component Versions
Download the SAP ME CTC software component SAPMECTC<XX>.sca to a temporary location
so that it is available during the SAP ME installation described later in this guide.

1.2.4 Installing NetWeaver Application Server
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NetWeaver application server can be installed in both development and productive modes. It is
important that you perform the development mode installation since it is tailored for efficiency to
run on a single developer machine. You install the application server in development mode by
performing the Developer Workplace installation for NetWeaver 7.3. Note that while the
Developer Workplace installer allows you to install the SAP NetWeaver Developer Studio IDE in
addition to the application server, you need only perform the application server installation.
You can find the Developer Workplace installation guide as well as other required documentation
on SAP Service Marketplace by going to http://service.sap.com/installnw73.

1.2.5 Installing the JDK
The embedded build tool and IDE require the Java 1.6 32 bit JDK. The SDK installer will prompt
you to specify the location of the JDK, and so this must be downloaded and installed prior to
installation. The latest 1.6 JDK is available for download at
http://www.oracle.com/technetwork/java/javase/downloads/index.html.
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2 Installation
Before continuing with the installation, make sure you have fulfilled all installation prerequisites and read any SAP Notes related to the SDK version you are installing.
SAP ME SDK notes can be accessed on Service Marketplace using the MFG-MESDK component.
To install the SDK, run the setup file and follow the on-screen instructions. Once completed
proceed to Post Installation Steps.
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3 Post Installation Steps
There are several steps that must be performed after the installer has finished, including:
1. Configure eclipse.exe compatibility mode
2. Configure the Eclipse Workspace
3. Install SAP ME

The SDK will be ready for developing extensions once these steps are completed.

3.1 Configure Compatibility Mode
Several NetWeaver specific Eclipse views will not be available if Eclipse is run directly on
Windows 7. You must set Windows XP compatibility mode on the Eclipse executable
(eclipse.exe) to correct this problem. To set compatibility mode, right click on
<InstallDir>\eclipse\eclipse.exe and select Properties. On the Compatibility tab,
enable Run this program in compatibility mode for and select Windows XP (Service Pack 3).

3.2 Configure the Eclipse Workspace
The SDK installation includes a preconfigured workspace and several default projects. Before
you can begin developing extensions you must complete the workspace configuration by
importing the default projects and configuring the Ant View so that build system targets can be
executed from within Eclipse.
If you are not familiar with Eclipse concepts, please refer to the online help by
selecting Help->Help Contents from the main menu.

3.2.1 Import Default Projects
There are several default projects provided with the installation that allow you to quickly work
with different types of ME extensions. Before these projects can be used they must be imported
into the workspace. Use the following steps to import the default projects into the workspace:
1.
2.
3.
4.

Run Eclipse and proceed to the Workbench.
Go to File->Import and select General->Existing Projects into Workspace and click Next.
Select Browse and choose the <InstallDir>\workspace directory.
Several projects will be listed in the projects list. Accept all projects and click Finish.
Do not select the option Copy projects into workspace.

3.2.2 Configure the Ant View
1. On the right side of the workbench you will see the Ant View displayed. Click the Add
Buildfiles button on the Ant View toolbar.
2. Select Build Resources/script/build.xml file and click OK. All Ant target defined
for the embedded build tool will be displayed.

3.2.3 Connect to SAP AS Java
The SDK includes two Eclipse plug-ins that allow you to interact with the NetWeaver cluster and
application server. Before they can be used you must add the SAP system to the SAP AS Java
configuration. Perform the following steps to add the SAP AS system.
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1.
2.
3.
4.
5.

Open SAP MMC and insure all processes in the NetWeaver cluster are started.
In Eclipse menu choose Window -> Preferences.
Select Item SAP AS Java.
Click Add new SAP System.
Enter the Instance Hostname and Instance Number.

If you have a local NW installed the default values are the following:
Instance Hostname: localhost
Instance Number: 00
6. The new SAP system should appear in the list. Click Ok.

3.2.4 Configure NetWeaver Deploy Views
NetWeaver Deploy views are used to deploy and undeploy software components into the
application server. Use the following steps to add deploy views to the Eclipse Java EE
perspective:
1. Open the Eclipse Java EE perspective
2. Open Window->Show View->Other->Deploy View and add each of the following views:
a. Deploy View
b. Deploy View Console
c.

Repository View

d. Undeploy View

3.3 Install SAP ME
You must install and configure SAP ME before you can deploy and test your extensions. Refer
to the SAP ME and SAP ME Scripts installation topics in the SAP ME 6.1 Installation Guide
located on SAP Service Marketplace at
Software Downloads->Support Packages and Patches->A - Z Index->M->SAP MFG Execution>SAP MFG Execution 6.1
Note: You may use the eclipse Deploy View to deploy SAP ME software components.
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3.5 Post-deployment Configuration
3.5.1 Configure SAP ME Application Data
Create an ME Test Site
Whether you are using a shared development ME database or are using a local database, it is a
good practice to create a new ME site in which you can test your extensions. This is especially
true when using a shared development database since each site encapsulates all ME
configuration and production data, cleanly separating your data from the data created by other
developers.
The ME global site should not be used for development testing. This site is a special
site that is typically only used to specify global configuration settings across all sites.
Use the following procedure to create and configure a development test site:
1. Access the SAP ME login page by navigating to
http://localhost:<AS_Java_HTTP_port>/manufacturing
2. Log in using your SAP ME user login ID and password.
3. Run the Site Maintenance activity under MAINTENANCE->SYSTEM CONFIGURATION
in the activity tree.
4. Enter a test site ID in the Site field and set the time zone according to your time zone.
5. Click Save. This will trigger the IDAT process for the new site, which can take several
minutes.
6. Navigate to NetWeaver Administrator:
http://localhost:<AS_Java_HTTP_port>/nwa
7. Choose Configuration -> Security -> Identity Management.
8. Click the Configuration button.
9. Select the User Admin UI tab and click the Modify Configuration button.
10. In the Administrator-Managed Custom Attributes field, enter the following value:
SAPME:DEFAULT SITE
11. Save the configuration.
12. Log out and log back into NetWeaver Administrator.
13. Choose Configuration -> Security -> Identity Management.
14. Retrieve and select the SITE_ADMIN user.
15. On the Details panel select the Customized Information tab.
16. Click the Modify button and enter your test site into the DEFAULT SITE field. The next
time you log into SAP ME you will be brought immediately to your test site.
17. Save the user details.
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4 Uninstall
The following options are available during the un-installation process:
1. Full Uninstall
2. Partial Uninstall
If you select the Full uninstall option then all files will be removed by the installer except
extension sources located under the \extension directory.
If you select the Partial uninstall option then several directories and files will not be removed so
that you may install the SDK into the same location and reuse many of the existing files (see
Upgrade for more information). Retained files include:


Build configuration file: Upon reinstallation you will be prompted to reuse build
configuration settings so that you do not have to enter them again



Third party libraries: Any third party libraries that your extension require



SCA/SEA: The core and legacy ME SCAs and external software vendor’s SEAs



Build export: Exported build results



Extension sources
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5 Upgrade
The SDK supports limited upgrade capability so that you can install a newer version into an
existing installation location.
The eclipse IDE, workspace, and SDK projects are removed and reinstalled during
the upgrade process. Any custom settings you have applied will be lost.
You perform the following steps to complete the upgrade:
1. Uninstall the current installation using the Partial uninstall option (see Uninstall for more
information).
2. Run the new installer choosing the existing installation location.
3. Complete all post installation steps as described previously in this guide.
4. If you are upgrading an SDK 5.2 installation you will need to perform additional steps as
described in the SDK Implementation Guide Appendix D: SDK 5.2 Migration.
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