How To... Create a Hello World Application Using JavaServer Faces

Applicable Releases:

SAP NetWeaver Composition Environment 7.1

Topic Area:

User Productivity
Development and Composition

Capability:

User Interface Technology
Java

Version 1.0
October 2008
These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

These materials are provided "as is" without a warranty of any kind, either express or implied, including but not limited to, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. SAP shall not be liable for damages of any kind including without limitation direct, special, indirect, or consequential damages that may result from the use of these materials. SAP does not warrant the accuracy or completeness of the information, text, graphics, links or other items contained within these materials. SAP has no control over the information that you may access through the use of hot links contained in these materials and does not endorse your use of third party web pages nor provide any warranty whatsoever relating to third party web pages.

SAP NetWeaver “How-to” Guides are intended to simplify the product implementation. While specific product features and procedures typically are explained in a practical business context, it is not implied that those features and procedures are the only approach in solving a specific business problem using SAP NetWeaver. Should you wish to receive additional information, clarification or support, please refer to SAP Consulting.

Any software coding and/or code lines / strings ("Code") included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, except if such damages were caused by SAP intentionally or grossly negligent.

Disclaimer

Some components of this product are based on Java™. Any code change in these components may cause unpredictable and severe malfunctions and is therefore expressively prohibited, as is any decompilation of these components. Any Java™ Source Code delivered with this product is only to be used by SAP’s Support Services and may not be modified or altered in any way.
## Document History

<table>
<thead>
<tr>
<th>Document Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>First official release of this guide</td>
</tr>
</tbody>
</table>
### Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Example Text</strong></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Cross-references to other documentation</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>Emphasized words or phrases in body text, graphic titles, and table titles</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>File and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>User entry texts. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><code>&lt;Example text&gt;</code></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td><strong>EXAMPLE TEXT</strong></td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>

### Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📚</td>
<td>Note or Important</td>
</tr>
<tr>
<td>📘</td>
<td>Example</td>
</tr>
<tr>
<td>🶚</td>
<td>Recommendation or Tip</td>
</tr>
</tbody>
</table>
Table of Contents

1. Business Scenario............................................................................................................... 1
2. Background Information..................................................................................................... 1
3. Prerequisites ........................................................................................................................ 1
4. Step-by-Step Procedure...................................................................................................... 2
   4.1 Create a Web Module Development Component......................................................... 2
   4.2 Create a Enterprise Application DC ........................................................................... 10
   4.3 Create a JSP Page ..................................................................................................... 14
   4.4 Build, Deploy and Run your application ..................................................................... 17
   4.5 Create a Web Context Root ....................................................................................... 21

Congrats! You have completed your first JSF application!..................................................... 22
1. Business Scenario

We will be creating a simple Hello World application with JavaServer Faces (JSF) to gain the basic knowledge needed to create more advanced JSF applications in the future.

2. Background Information

JavaServer Faces (JSF) is a relatively new user interface technology, having been added to the Java standard with Java EE 5. It is supported in the AS Java 7.1 since it supports Java EE 5. In addition the SAP NetWeaver Developer Studio (NWDS) is based on Eclipse 3.3 which in turn comes with development plug-ins for developing JSF applications. Like most other UI technologies JSF is based on the Model View Controller (MVC) architecture. To learn more about the JSF specification you can visit Sun's java website for JSF.

3. Prerequisites

The following is a list of all you need for developing JSF applications.

- AS Java 7.1 (CE 7.1 or NW 7.1)
- NWDS 7.1 (SP3 or higher with latest patch level).

Note

While this tutorial is geared towards to the SAP AS Java (the build/deploy steps of the guide), it wouldn’t be hard to replace the build/deploy portions with similar steps for any other Java EE 5 platform.
4. **Step-by-Step Procedure**

The following guide will step you thru the creating of a Java EE 5 Web Module for the development of a simple Hello World app. You will the create a Enterprise Application which is needed to deploy the web module.

4.1 **Create a Web Module Development Component**

1. If the NWDS is not already open, open it.
2. Open the Java EE perspective. To do this select the menu path: Window → Open Perspective → Other… - In the popup window select Java EE and click the “OK” button.

3. Select the menu path File → New → Project…

4. In the popup window select Development Component (under the Development Infrastructure node). Click the “Next” button.
5. Select the Web Module DC type (Under the J2EE node). Click the “Next” button.
6. Under LocalDevelopment select the MyComponents Software Component and click the “Next” button.
7. Give the DC the name hellojsf/web and click the “Next” button.

8. Make sure the Java EE version is set to 5.0. Then click the “Finish” button to create the DC.
Note

AS Java 7.1 and NWDS 7.1 support both Java EE 5 and J2EE 1.4. JSF is only supported in Java EE 5.

9. Right click on the newly created project node in the Project Explorer view and select “Properties” in the context menu.

10. In the popup window select “Project Facets” in the left hand pane. Click the “Modify Project…” button.
11. Check the checkbox for the JavaServer Faces facet, and make sure that the version is set to "1.2". Click the “Next” button.
12. You will see the configuration that will be added to the project in order to support JSF. Select the "Server Supplied JSF Implementation" radio button if it already isn’t. Then click the “Finish” button.
13. Click the “OK” button on the Project Facets window to close it. You have now created a Web Module DC that is configured for JSF development.

**Recommendation**

The following step actually generated a new deployment descriptor (faces-config.xml) and in addition updated the web.xml descriptor for JSF support. You should take a look at both of these descriptors which can be found in the “WebContext/WEB-INF” directory of the Web Module project you just created and configured.

**Important**

The faces-config.xml deployment descriptor is the glue that holds the JSF application together. While we will not be accessing it for this tutorial, you should know that to do
anything remotely real world you will be editing this descriptor quite a bit. You will see this in all the more advanced tutorials for JSF.

### 4.2 Create a Enterprise Application DC

1. Select the menu path *File → New → Project*…

![image](image1.png)

2. In the popup window select Development Component (under the Development Infrastructure node). Click the “Next” button.

![image](image2.png)

3. Select the Enterprise Application DC type (Under the J2EE node). Click the “Next” button.
4. Under LocalDevelopment select the MyComponents Software Component and click the “Next” button.
5. Give the DC the name hellojsf/ear and click the "Next" button.

6. Make sure the Java EE version is set to 5.0. Then click the "Next" button.
7. Reference the Web Module DC that we created in the last step by checking the checkbox next to it. This way the Web Module will get deployed with the Enterprise Application. Click the “Finish” button when you are done.

8. You have created the Enterprise Application DC! Next step is to create a JSP page!
4.3 Create a JSP Page

1. Drill into the Web Module project and right click on the WebContent folder and in the context menu select New → JSP.

2. Enter the file name “welcome.jsp” and click the “Finish” button. The JSP page will be created.

3. By default the NWDS will open up a JSP page with the JSP Editor. But with JSF we should use the Web Page editor to get easy access to the tag libraries associated with JSF. To do this right click on the JSP page you created and in the context menu select Open With… → Web Page Editor.

   Recommendation

   You can configure the NWDS to open JSP pages with the Web Page Editor by going to the Preferences → General → Editors → File Associations. Select the “*.jsp” from the list then select the “Web Page Editor” and click the “Default” button. Once done JSP pages will always open with the Web Page Editor.

4. The “welcome.jsp” page should open in the Web Page Editor as shown below.
Important

As you can see in the Palette you have reference to many different tag libraries. These tag libraries are by default available to JSF applications. It is also possible to make your own tag libraries that can then be inserted into the Palette. SAP is creating a set of JSF UI Components that will also show up here (Will be in the AS Java 7.1 EhP1 release).

5. Change the text between the title tags to “Welcome to JSF!”. 

Important

You can drag and drop the UI elements from the Palette onto the upper portion of the Web Page Editor where it says “Drag and drop Web page content here”.
6. Click the “JSF HTML” toolset in the Palette, this will show all the UI elements available within it.

![JSF HTML toolset](image)

7. Drag and drop an “Output Text” UI element (found in the JSF HTML elements) to the Web Page Editor.

![Web Page Editor with Output Text](image)

8. Take a look at the tags that were inserted into the JSP page. Put the cursor on the `<h:outputText>` tag and then select the Properties view in the bottom window pane. In the value property enter the text "Welcome to JSF!".
9. Click the “Edit” button next to the Style property. Change the settings as shown below or any other way you like, and then click the “OK” button.

10. Save the changes to the JSP page that you made.

4.4 **Build, Deploy and Run your application**

1. Right click on the Enterprise Application project node and in the context menu select *Development Component → Build*…
2. In the Build DCs popup window click the “OK” button to build the DCs.
3. Open the “Deploy View” by select in the NWDS menu Window → Show View → Other…

Note
There are many ways you can deploy from the NWDS to the AS Java 7.1. There is the Deploy view which we will be using here, there is the Servers view which allows you to deploy and undeploy, and then there is the Component Browser view (in the Development Infrastructure perspective) which allows you to deploy DCs. In addition there is also an Undeploy View which allows you to undeploy applications on the server.

4. Enter “Deploy” in the filter input field and then select the “Deploy View”. 
To deploy you must have configured your NWDS to point to a AS Java 7.1 in your landscape. If you haven’t done this go to the NWDS Preferences → SAP AS Java and register the server instance that you are using.

5. Select the project you want to deploy by click the icon in the deploy view. In the popup window select the EAR file you want to deploy, in this case the one generated by the Enterprise Application that you created and built. Click the “OK” button.
6. Click the deploy icon to start the deployment to the server. If this is your first deploy to the server since starting the NWDS you will have to enter your user name and password which has administrator rights.

![Deploy Successful]

7. By default Java EE 5 sets the context root of the web application to the same name as the WAR file generated by the Web Module. In this case “demo.sap.com~hellojsf~web” is the context root due to this. So to run your application use the following URL:

http://<servername>:<httpport>/demo.sap.com~hellojsf~web/faces/welcome.jsp

![Welcome to JSF!]

4.5 Create a Web Context Root

1. Open the Enterprise Application DC project and right click on the node directly under the project node. In the context menu select “Create Application.xml”. This will create and open the application.xml deployment descriptor.
2. In the Editor of the application.xml switch to the source view, and add the following XML between the <application ... > </application tags>. The follow XML assumes the WAR file is named “demo.sap.com~hello~web.war” and sets the context root to “hellojsf”.

```xml
<module>
  <web>
    <web-uri>demo.sap.com~hellojsf~web.war</web-uri>
    <context-root>hellojsf</context-root>
  </web>
</module>
```

3. Save the application.xml deployment descriptor.

4. Build and Redeploy the application.

5. Run the application using the following simplified URL:

   http://<servername>:<httpport>/hellojsf/faces/welcome.jsp

---

**Welcome to JSF!**

Congrats! You have completed your first JSF application!