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Introduction
Custom Help Mapping is an add-on to SAP Business One 2007 A that allows you to attach context-sensitive
help to the SAP Business One application. Users can then access the custom help in exactly the same way
that they access the context-sensitive help delivered by SAP with SAP Business One 2007 A.
You can attach custom help in any format supported by your operating system, such as .pdf, .chm, .ppt,
and .htm. For example, you can attach Web pages or e-learning as well as traditional documentation.
Unicode is supported, so you can attach custom help in any language. Note, however, that the interface
language of the Custom Help Mapping add-on is English only.
You can attach custom help to the following:
•

Windows, tabs, fields, radio buttons, checkboxes, and pushbuttons in SAP Business One

•

Windows, tabs, fields, radio buttons, checkboxes, and pushbuttons in any add-on that runs within SAP
Business One

•

User-defined fields (UDFs)
NOTE
In this document, fields, radio buttons, checkboxes, pushbuttons, and user-defined fields are
referred to collectively as fields.

It is not possible for you to change or delete SAP documentation using this add-on.

Reasons to Attach Custom Help
Here are some of the reasons why you might attach your own custom help:
•

To provide users with industry-specific and/or business-specific information about windows, tabs, and
fields

•

To attach context-sensitive documentation about an add-on that is used with SAP Business One

•

To explain a user-defined field that is unique to your business

•

To document SAP fields that you have renamed

Where to Download Custom Help Mapping
Custom Help Mapping is delivered to SAP Business One customers and partners free of charge through
SAP Community Network at http://www.sdn.sap.com. The source code is provided.

Help and Support
Custom Help Mapping comes with its own contextual help and how-to guide, both of which you can access
from the software itself.
Custom Help Mapping is delivered within the SAP Community Network license structure and therefore no
support is provided. If you have questions or feedback about using the add-on, you can enter them in the
SAP Business One SDK Forum in SAP Community Network.

Database Platform
Custom Help Mapping runs in SAP Business One installations with Microsoft SQL Server databases.
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Using SAP Templates to Write Custom Help
You can write and attach custom help that was written in any format supported by your operating system,
such as .pdf, .chm, .ppt, and .htm including Web pages.
SAP channel partners may use the Microsoft Word and XML templates provided in the industry solution
builder of SAP Channel Partner Portal for SAP Business One. The templates were designed originally for
use by software solution partners who develop industry solutions for SAP Business One, but they are generic
enough to be used in any solution package.
...

1. Go to http://service.sap.com/smb/sbo/isbuilder.
2. Click Package.
The templates are available under Documentation & Training.

The templates have their own documentation, which is also available at these links.
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Where to Store Custom Help
Before you map custom help to the SAP Business One application, you need to deploy the help to the
location from which the user will access it. You have the following options:
•

A Web server

•

A file server

•

In the SAP Business One directory under Help in the XX folder
The advantage of storing help in this location is that you only have to specify the relative path, and not
the full path, in the custom help mappings.
The XX folder may contain subfolders, each with custom help for a partner namespace or a specific
add-on.
You can store custom help files in the XX folder on the client or the server. To access help at this
location, the end user needs to have the correct setting on the General Tab of the Help Settings
window:
{

Local Installation (client)

{

Shared Folder (server)
NOTE

If you change this setting, you must choose the OK button to activate the change for Custom Help
Mapping.
CAUTION
If you intend to store .chm files on a shared server, check that your users can access them there.
There are known limitations on accessing .chm files on a server. For more information, go to
http://support.microsoft.com.
.
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Setting Up Custom Help Mapping
Custom Help Mapping is packaged as a standard add-on, which must be installed and registered. Only
superusers can perform this task:
1. Register and install the add-on as you would register and install any other add-on.
CAUTION
Do not try to change the default folder in which the add-on is installed: Program Files\SAP\SAP
Business One>\AddOns.
2. Answer the following system message with Yes.

3. In the Add-On Administration window, move Custom Help Mapping to the top of the list of companyassigned add-ons.
This ensures that all system events triggered in conjunction with F1 help or Shift + F1 help are
processed in the correct order.

4. Start Custom Help Mapping in the Add-On Manager window.
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Attaching Custom Help
To attach custom help to SAP Business One, you map the help to the window, tab, or field to which it refers.
There are two ways to attach custom help:
•

You can create or change a mapping manually.
Do this when you are testing or familiarizing yourself with the add-on.

•

You can import or update custom help mappings from a .csv file.
Do this to install or update custom help for an add-on or customized solution at a customer site.

If you want to use the custom help in several companies, you must attach the help separately to each
company.
Only superusers can attach custom help.

Preparing to Manually Create or Change Custom Help Mappings
To enable the superuser options that let you map custom help interactively, proceed as follows:
a. Choose Help → Documentation → Help Settings.
b. Select the Custom Help Mapping tab.
NOTE
Only superusers can access this tab.
c. Select the Enable Interactive Mapping checkbox.
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d. Choose the Update button.
The following menu entries are added to the context menu of windows, tabs, and fields:



Attach Help...



Remove Attached Help

Only a superuser can see these menu entries, as in the following example:

e. To close the Help Settings window, choose the OK button.
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Manually Creating a Custom Help Mapping
Prerequisite
•

You have placed the custom help at the location from which the user will access it.
For more information, see Where to Store Custom Help (page 5).

•

You have enabled the superuser options that let you map custom help interactively. For more
information, see Preparing to Manually Create or Change Custom Help Mappings (page 7).

Procedure
...

1. Right-click the window, tab, or field to which you want to attach the custom help, and choose Attach
Help... .
NOTE
If you cannot see the Attach Help... menu entry, the Interactive Help Mapping window is
already open for another object. Close it first and then repeat this step.
The Interactive Help Mapping window appears.

The title bar of this window shows the pane number of the tab or the item number of the field. This is
also the information you see at the bottom of the SAP Business One desktop if you choose View →
System Information from the menu bar and move your cursor over the window. If the window has no
tabs or if it has a general area that is always visible in addition to tabs, the pane number of the window
or general area is 0.
The item numbers of field labels are different from those of fields.
NOTE
The SAP documentation does not appear in the Interactive Help Mapping window.
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2. Specify the mapping properties:
a. In the Caption field, specify the name of the menu entry for the custom help. This field is
mandatory.
This is the menu entry that the user sees in the context menu of the window, tab, or field: For
windows or tabs, the name appears under the Context Help menu entry; for fields, the name
appears under the What’s This? menu entry.
b. In the File Path field, specify the path or URL to the help. This field is mandatory.
If the file is stored in the SAP Business One directory under Help in the XX folder, enter the
relative path. For more information, see Where to Store Custom Help (page 5).
c. If you want to attach a topic from a .chm file, make entries in the fields Application Path and
Parameters, as follows:
Field

Do this…

Application Path

Enter the path of the hh.exe file: C:\WINDOWS\hh.exe. This
file is needed to open a specific topic in a .chm file.
If you search for the file using the browse button
C:\WINDOWS folder is opened by default.

Parameters

, the

Enter the topic name in the following format:
::/ExchangeRatesConfiguration.htm
To find out the topic name, right-click in the topic in the .chm
file, choose Properties, and copy the topic name from the end
of the Address: (URL).

Here is an example:

d. For system forms, if you want the custom help to open instead of the SAP documentation when
the user chooses F1 (windows and tabs) or Shift + F1 (fields), select the Default checkbox.
If you want the SAP documentation to open when the user chooses F1 (windows and tabs) or
Shift + F1 (fields), leave the Default checkbox deselected. This applies only when you are
attaching custom help to system forms, which have existing SAP documentation.
If you are attaching help to a nonsystem form, then set an appropriate help file as the default. If
none of the help mappings are set as default, F1 and Shift + F1 do not work and the user
must open the help by using the Context Help menu or What’s This menu.
You can set only one entry as the default for a given window, tab, or field.
3. To check that the document opens at this location, choose Test.
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4. To save the mapping:
a. Insert the entry in the mapping table by choosing the Create button.
b. If a default mapping already exists for this object, confirm that you want to change the default
by choosing Yes in the system message.
c. To save your new entry, choose the Add button. If this is not the first mapping for this object,
choose the Update button.
5. To close the Interactive Help Mapping window, choose the OK button.
NOTE
When closing the Interactive Help Mapping window, choose either the OK or the Cancel button.
Do not use the
Close button on the top right or
and the
menu entry on
the top left. If you leave the window without having entered any changes but respond to the
system message about saving changes with Yes, an entry with blank values is created.

Manually Changing a Custom Help Mapping
Prerequisites
•

If necessary, you have placed new or updated custom help at the location from which the user will
access it.
For more information, see Where to Store Custom Help(page 5).

•

You have enabled the superuser options that let you map custom help interactively. For more
information, see Preparing to Manually Create or Change Custom Help Mappings (page 7).

Procedure
1. Right-click the window, tab, or field whose custom help mapping entry or entries you want to change.
The Interactive Help Mapping window appears.
2. To change the properties of an entry:
a. Select it in the table.
b. In the lower part of the window make the necessary changes.
c. Save the change(s) by choosing the Modify button and then the Update button.
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3. To change the sequence of the custom help in the user’s context menu:
a. Select the entry in the table.
b. Use the Move Up and Move Down buttons.

c. Save the change(s) by choosing the Modify button and then the Update button.
NOTE
You must save an entry before you can move it.
NOTE
If you have set a default for an object that already has a default, you must first confirm
that you want to change the default by choosing the Yes button.
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Importing Custom Help Mappings
The import of custom help mapping is based on a .csv file that defines the mapping of custom help to user
interface elements.
A mapping file is made up of the following lines:
•

Header (first) line: This line defines the fields (that is, the database table columns) included in the
import. The column names are delimited by semicolon.

•

Data lines: Each line after the header line specifies a single help file and the window, tab, or field to
which it should be attached. The values, delimited by semicolon, correspond to the column names
defined in the header line.

•

Comment lines (optional): Comment lines start with // (two forward slashes) and can be used to
document and/or group the data lines.
EXAMPLE
See the import file provided with Custom Help Mapping.

•

Delete lines (optional): #DEL#<partner key> or #DEL#<start of partner key>* indicate
which mappings are to be deleted.

Prerequisite
•

You have placed the custom help at the location from which the user will access it.
For more information, see Where to Store Custom Help (page 5).

Procedure
...

1. Prepare the mapping file:
a. Use a viewer that is capable of displaying the character set that you want to import.
b. Make the first line the header line, with the field names as shown in the table below. It is
important that you include all of the field names, even if you do not use some of the fields, and
that the order is the same as below. Use semicolons as the delimiter.
c. Define the field values as follows, using semicolons as the delimiter:
Field Name (first line)

Field Description

U_FormID

Specify the form ID. To find out the form ID for a window, choose View
→ System Information from the menu bar and move your cursor over
the window. The system information is displayed at the bottom of the
SAP Business One desktop.
U_FormID is a mandatory field. It may contain a maximum of 50
alphanumeric characters.
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Field Name (first line)

Field Description

U_PaneID

If the custom help refers to a tab, specify the pane ID. Otherwise,
leave this field blank.
To find out the pane ID for a tab, choose View → System Information
from the menu bar and move your cursor over the tab. The system
information is displayed at the bottom of the SAP Business One
desktop. Pane = 0 means that you are on the window level. Pane >
0 means that you are on the tab level.
U_PaneID may contain a maximum of 4 numeric characters.
NOTE
You do not need to specify a value for this field in order to
attach help to a field, because a field ID is unique across
the entire form.

U_FieldID

If the custom help refers to a field, specify the field ID. Otherwise,
leave this field blank.
To find out the field ID, choose View → System Information from the
menu bar and move your cursor over the field. The system information
for the field is displayed as the item at the bottom of the SAP Business
One desktop. The item numbers of field labels are different than the
item numbers of fields.
U_FieldID may contain a maximum of 50 alphanumeric characters.

U_Language

Specify XX for this field.
If you leave this field blank, its value will default to XX during the
import.

U_Caption

Specify the name of the menu entry for the custom help. This is the
menu entry that the user sees in the context menu of the window, tab,
or field.
The user sees the custom help name(s) for a window or tab under the
Context Help menu entry. The user sees the custom help name(s) for
a field under the What’s This? menu entry.
U_Caption is a mandatory field. It may contain a maximum of 128
alphanumeric characters.

U_ContHelp

Specify the path or URL that denotes the help file’s unique location.
If the file is stored in the SAP Business One directory under Help in the
XX folder, enter the relative path. For more information, see Where to
Store Custom Help (page 5).
U_ContHelp is a mandatory field. It may contain a maximum of 254
alphanumeric characters.

U_Params

If you want to attach a topic from a .chm file, enter the topic name in
the following format:
::/ExchangeRatesConfiguration.htm
To find out the topic name, right-click in the topic of the .chm file,
choose Properties, and copy the topic name from the end of the
Address: (URL).
U_Params may contain a maximum of 254 alphanumeric characters.
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Field Name (first line)

Field Description

U_Default

If you want the custom help to open instead of the SAP documentation
when the user chooses F1 (windows and tabs) or Shift + F1
(fields), specify Y. Otherwise, leave this field blank.
This applies only when you are attaching custom help to system forms,
which have existing SAP documentation.
If you are attaching help to a nonsystem form, then set an appropriate
help file as the default. If none of the help mappings are set as default,
F1 and Shift + F1 do not work and the user must open the help by
using the Context Help menu or What’s This menu.
You can set only one entry as the default for a given window, tab, or
field.
NOTE
The import does not overwrite existing defaults. For more
information, see the Result section below (page 16).

U_ApplPath

If you want to attach a topic from a .chm file, specify the path of the
hh.exe file: C:\WINDOWS\hh.exe. This file is needed to open a
specific topic in a .chm file.

U_PartnerKey

Use this field to uniquely identify each mapping. The field is the
mechanism by which you delete and update custom help mappings.
U_PartnerKey is a 50-character alphanumeric field.
EXAMPLE
You have custom help for the following:
{

Two add-ons from partner ABC

{

One add-on from partner XYZ

{

Your own business-specific help

For each add-on as well as for the business-specific help, a
.csv file is created. The keys are as follows:

© SAP AG 2008

{

ABC_AddOn1_001 to ABC_AddOn1_030 for the first
add-on of ABC

{

ABC_AddOn2_001 to ABC_AddOn2_040 for the second
add-on of ABC

{

XYZ_AddOn1_001 to XYZ_AddOn1_025 for the add-on
of XYZ

{

TopBiz_Cust_001 through TopBiz_Cust_099 for the
business-specific help
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d. If you want to update existing mappings, you do so by deleting the obsolete mappings and then
importing the up-to-date mappings, as follows:
i.

In one or more of the data lines, specify which mappings to delete by specifying the
U_PartnerKey of one or more mappings. You specify the key in one of two ways:
#DEL#<partner key>
This deletes all mappings with this key.
Example: #DEL#PTR_ADD1_012
#DEL#<start of partner key>*
This deletes all mapping(s) with a key that begins with the specified string.
Example: #DEL#PTR_ADD1*
Therefore, you can delete either a single mapping or all mappings for a specific add-on
or all mappings for a specific partner.

ii.

In subsequent rows of the same .csv file, specify the mappings you want to import, as
described in step c above.

e. Precede any comment lines with two forward slashes //.
These lines are ignored during the import.
2. In the menu bar, choose Help → Documentation → Help Settings.
3. Select the Custom Help Mapping tab and choose Import.
4. Browse to the .csv file you want to import, select it, and click Open.
5. Confirm the first system message by choosing the Continue button.
6. Wait for the second system message to appear, in which you can read how many mappings were
imported as well as the location of the import log.

Result
Note the following with regard to the results of the import:
•

The results of the import are recorded in an import log with a date and time stamp.

•

All entries are imported in the order listed in the import file.

•

If entries already exist in SAP Business One, the imported entries are appended to the bottom of the
existing list of entries. Any existing entries are not overwritten, even if they are duplicates.

•

Existing defaults are not overwritten. If a default already exists in the application, the default in the
.csv file is ignored and a warning is issued in the import log.

•

A warning is issued in the import log if a value in one of the alphanumeric fields exceeds the defined
character length, for example, if U_PartnerKey exceeds the 50-character field length.

•

The import skips blank lines with whitespaces or tabs, as long as they are not the first line.

•

Invalid lines are recorded in the import log. A line is invalid if any of the following applies:
{

A mandatory field value is missing.

{

A delimiter is missing.

{

The header line contains too few or incorrect field names.

•

The import does not check whether the help actually exists at the specified locations; that is, whether
the values in U_Caption and U_ContHelp are correct.

•

The import does not check whether the windows, tabs, and fields actually exist; that is, whether the
values in U_FormID, U_PaneID, and U_FieldID are correct.
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•

The import does not change, overwrite, or in any way affect the existing SAP documentation.

•

You can see an overview of all custom help that is attached to the company, including the mappings
you have just imported. For more information, see Viewing All Custom Help Mappings (page 19).

Exporting Custom Help Mappings
You export custom help mappings from SAP Business One for the following reasons:
•

To make a back-up before updating the existing mappings

•

To create a master file from which to feed multiple installations
For example, software solution partners may wish to keep a master file for each of their add-ons.

•

To create an example file to see how the file is formatted

Procedure
...

1. In the menu bar, choose Help → Documentation → Help Settings.
2. Select the Custom Help Mapping tab and choose Export.
3. Specify the location and file name, leave the extension as .csv, and click Open.
4. Confirm the first message by choosing the Continue button.
5. Wait until a second message appears, which informs you how many mappings were exported and
where the export log has been stored.

Result
For a description of the file format of the exported file, see the table in Importing Custom Help
Mappings(page 13).
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Removing Custom Help Mappings
You remove custom help mappings from SAP Business One in order to update them or to correct
inconsistencies or duplications. An import does not overwrite previous mappings.
NOTE
Removal deletes the custom help mapping(s) from the database. Removal does not delete the
custom help files themselves.
There are several ways to remove custom help mappings:
To...

Do this...

Remove the custom help mappings of a
specific partner or add-on

Include one or more deletion lines in the import file.
For more information, see step 1.d in Importing Custom Help
Mappings (page 16).
...

1. Choose Help → Documentation → Help Settings.

Remove all custom help mappings,
regardless of their type or origin

2. Select the Custom Help Mapping tab.
3. Choose Remove All and confirm the system message.
NOTE
This removes the SAP help mappings for the
Custom Help Mapping add-on as well. In case
these are accidentally removed, you can reimport them from the file
…\AddOns\sap\B1HM – Custom Help
Mapping\SAP B1HM AddOn
Help\B1HM_AddOn_Help_Import.csv.
...

Remove custom help for a window, tab, or
field

1. Right-click the window, tab, or field from which you
want to remove custom help and choose Attach
Help... .
2. In the Interactive Help Mapping window, select the
mapping you want to remove.
3. Choose the Remove button.
4. Choose the Update button.
4.

Remove custom help for a field

...

1. Right-click the field and choose Remove Attached
Help.
2. In the system message, check that the correct field is
indicated.
3. Choose the Field Only button.
A second message confirms successful removal.

Remove all custom help associated with
one window (the help for the window and all
its tabs and fields)

1. Right-click the window and choose Remove Attached
Help.
2. If you have right-clicked a window, choose the Yes
button. If you have right-clicked a field, choose the
Window button.
A system message confirms successful removal.
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Viewing All Custom Help Mappings
To see what custom help is mapped to your company, proceed as follows:
1. Choose Help → Documentation → Help Settings.
2. Select the Custom Help Mapping tab.
3. Choose Show All.
4. To group or filter the custom help entries, use the fields on the right.
NOTE
If a partner key identifies not only the partner but also an add-on as well as a unique custom
help mapping, you can filter by entering only part of the key, without an asterisk: for example,
you enter PTR1 to show all custom help mappings for partner PTR1; you enter PTR1_ADD001
to show all custom help mappings for add-on 001 from partner PTR1.
For more information about partner keys, see the description of field U_PartnerKey (page 15 of
Importing Custom Help Mappings).

Displaying Custom Help
So far, all the tasks discussed in this document are ones that a superuser performs. This section describes
how an end user displays the attached custom help.
There are two ways to display custom help:
•

Through the context menu, that is, by right-clicking the object
The user can access both SAP documentation and custom help through the context menu.

•

On windows or tabs by choosing F1 or on fields by choosing Shift + F1.
This option is possible if the custom help has been defined as the default.
If the custom help has not been defined as the default, the SAP documentation is displayed when the
user chooses F1 or Shift + F1 on a system form. If there is no SAP documentation, such as on
nonsystem forms, and no custom help has been set as the default, the message No SAP
documentation is available is displayed when the user chooses F1 or Shift + F1.

A menu entry that is checked indicates that this is the default help.

TECHNICAL NOTE
When the user chooses F1 or Shift + F1, the Custom Help Mapping add-on sets the
BubbleEvent to false only when custom help exists for a form/window, tab, or an item/field and
the custom help is set as the default. The BubbleEvent is set to false to suppress the display of
SAP standard help and to display the default custom help.
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Examples of Displaying Custom Help
Displaying Custom Help for a Window

Displaying Custom Help for a Tab

Displaying Custom Help for a Field
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Known Limitations
The following features are not supported in this version of Custom Help Mapping:
•

Attaching custom help for an add-on as part of the software installation or upgrade step

•

Attaching custom help to a matrix or grid, or to a column within a matrix or grid

•

If custom help has been defined for a nonselectable object (that is, an object that cannot be
highlighted or on which the cursor cannot be seen to be blinking), opening the SAP documentation of
this object
Right-clicking anywhere (also outside an object) opens the context menu of the active object, that is,
the object that is highlighted or where the cursor blink is blinking.
The pane is determined by the active object. Therefore, it is possible that if the active object belongs to
pane 0 and right-clicking is done on pane 6, the context menus correspond to pane 0.

•

If custom help has been defined as the default for a nonselectable object, opening the custom help of
this object by choosing F1 or Shift + F1

•

Opening custom help for a field with an open dropdown list
An exception is raised if you try to do this. To access the custom help, you must close the dropdown
list first while the field is still highlighted.

•

Opening the Interactive Help Mapping window for more than one object at a time
Once the Interactive Help Mapping window is open, you can no longer see Attach Help… in the
context menu for other objects.

•

Excluding the entry SAP Documentation from the user’s context menu for nonsystem forms
The user can choose SAP Documentation for a nonsystem form even though no SAP help exists.

•

Closing the Interactive Help Mapping window using the

Close button on the top right or

and the

menu entry on the top left
To close the Interactive Help Mapping window, choose either the OK or the Cancel button. If you leave
the window without having entered any changes but respond to the system message about saving
changes with Yes, a record with blank values is created.
•

The user interface of Custom Help Mapping in languages other than English

•

The Custom Help Mapping tab if the display language is Hebrew
To work with the functions on the tab, switch to English or another language.
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Copyrights and Trademarks
© Copyright 2008 SAP AG. All rights reserved.
The current version of the copyrights and trademarks at http://channel.sap.com/sbocustomer/documentation
is valid for this document.

Disclaimer
Some components of this product are based on Java™. Any code change in these components may cause
unpredictable and severe malfunctions and is therefore expressly prohibited, as is any decompilation of
these components.
Any Java™ Source Code delivered with this product is only to be used by SAP’s Support Services and may
not be modified or altered in any way.
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