SAP NetWeaver Composition Environment 7.1 SR5 – Developer Edition

Target Audience

- System administrators
- Technology consultants

Document version: 1.01 – 05/16/2008
## Document History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.01</td>
<td>5/16/2008</td>
<td>SR5</td>
</tr>
</tbody>
</table>
# Table of Contents

**Chapter 1**  
About This Document  

**Chapter 2**  
Installing SAP NetWeaver CE Developer Edition  

**Chapter 3**  
Installing SAP NetWeaver Developer Studio  

**Chapter 4**  
Installing Additional Components (Optional)  

**Chapter 5**  
Installing SAP Memory Analyzer (Optional)  

**Chapter 6**  
Post-Installation Activities  

**Chapter 7**  
Additional Information  
7.1 Transporting Self-Developed Software Component Archives (SCA) into the System  
7.2 Troubleshooting – Repairing an Inconsistent SAP MaxDB Installation  
7.3 Restarting the SAP MaxDB Server Manually  
7.4 Restarting the MS SQL Server Manually  
7.5 Configuration Templates  
7.6 Uninstalling SAP NetWeaver Composition Environment  

5  
7  
13  
19  
23  
27  
31  
31  
31  
32  
33  
33  
34
1 About This Document

This document explains how to install an SAP NetWeaver Composition Environment system as developer edition.

For more information about SAP NetWeaver Composition Environment in general, see http://sdn.sap.com/irj/sdn/nw-ce.

SAP Notes for the Installation

Make sure you have read the latest version of SAP Note 953763 before you start the installation. This SAP Note contains the most recent information on the installation, as well as corrections to the installation documentation. Make sure that you have the up-to-date version of each SAP Note, which you can find on SAP Service Marketplace at http://service.sap.com/notes.

Installation Process

1. Decide what you want to install.
   - SAP NetWeaver Composition Environment Developer Edition [page 7]
   - additional components [page 19] (optional), such as
     - Composition Tools
     - Adobe Document Services
     - Composite Voice
     - IDE Update Site
   - SAP NetWeaver Developer Studio [page 13]
   - SAP Memory Analyzer [page 23] (optional)
2. You start the installation.
3. You perform the post-installation steps [page 27].
4. Further documentation:
   - If you are a system administrator, refer to http://help.sap.com/nwce Administrators’ Guide. It contains information about how to configure and administer your system.
   - If you are a developer, refer to http://help.sap.com/nwce Developer’s Guide. It provides guidelines for developing applications using the SAP NetWeaver CE.
5. Additional information:
   - Transporting Self-developed Software Component Archives (SCA) into the System [page 31]
   - Troubleshooting — Repairing an Inconsistent SAP MaxDB Installation [page 31]
   - Restarting the SAP MaxDB Server Manually [page 32]
   - Restarting the MS SQL Server Manually [page 33]
   - Configuration Templates [page 33]
Uninstalling SAP NetWeaver Composition Environment [page 34]

More Information

Master Guide - SAP NetWeaver Composition Environment 7.1, available at:
2 Installing SAP NetWeaver CE Developer Edition

This section provides information about the steps that you have to perform to install SAP NetWeaver Composition Environment as a development system (Windows 32-bit only).

Hardware and Software Requirements for Development Systems

Before starting the installation, make sure you meet the hardware and software requirements for your operating system (OS) and the SAP NetWeaver CE system.

Consider the following information:

- For supported operating system releases, see the Product Availability Matrix on SAP Service Marketplace at [http://service.sap.com/pam](http://service.sap.com/pam).
- Contact your OS vendor for the latest OS patches.

If you want to install an SAP NetWeaver CE development system, the host must meet the following requirements:

<table>
<thead>
<tr>
<th>Requirement Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td><img src="https://%D1%86%D0%B8%D1%82%D0%B0%D1%82%D0%B0.com/caution.png" alt="Caution" /> Development systems can be installed on 32-bit Windows only.</td>
</tr>
<tr>
<td></td>
<td>- 10 GB free disk space</td>
</tr>
<tr>
<td></td>
<td>- Min. 1 CPU with 3 GHz</td>
</tr>
<tr>
<td></td>
<td>- 2 GB RAM (minimum)</td>
</tr>
<tr>
<td></td>
<td>- Paging file size: 2x RAM To check the paging file size:</td>
</tr>
<tr>
<td></td>
<td>1. Right-click <em>My Computer</em> and choose <em>Properties</em>.</td>
</tr>
<tr>
<td></td>
<td>2. Choose <em>Advanced Performance Settings</em>.</td>
</tr>
<tr>
<td></td>
<td>3. If required, in section <em>Virtual Memory</em>, choose <em>Change</em>.</td>
</tr>
<tr>
<td>Software</td>
<td><img src="https://%D1%86%D0%B8%D1%82%D0%B0%D1%82%D0%B0.com/support.png" alt="Supported Operating Systems" /> Microsoft Windows XP Professional SP2 (or higher) (32-bit)</td>
</tr>
<tr>
<td></td>
<td><img src="https://%D1%86%D0%B8%D1%82%D0%B0%D1%82%D0%B0.com/caution.png" alt="Caution" /> English version only!</td>
</tr>
<tr>
<td></td>
<td><strong>Supported Databases:</strong></td>
</tr>
</tbody>
</table>

05/16/2008
### Requirement Type

<table>
<thead>
<tr>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP MaxDB 7.6</td>
</tr>
<tr>
<td>MS SQL Server 2005 SP1 (or higher)</td>
</tr>
</tbody>
</table>

*Note*

The SAP MaxDB software is installed with the SAP NetWeaver CE system.

*Note*

If you want to use the MS SQL Server database, you have to install it **before** installing SAP NetWeaver CE.

**JDK version:**

SUN JDK 1.5.0_11 (or higher)

You can download this version from the SUN Web site.

---

**Note**

If you want to install additional components (optional) [page 19], you need the same hardware and software requirements as stated above plus an additional 2 GB RAM.

### Preparing the Installation DVD

Make sure you have the installation DVD for SAP NetWeaver Composition Environment 7.1 available. You can also download the installation DVD from SAP Service Marketplace at:


If you download the installation DVD, note that the DVD may be split into several archives. In this case, you have to unpack these archives to one folder after the download.

### Preparations for the MS SQL Server Database

Before installing your SAP NetWeaver CE development system on Windows and MS SQL Server, make sure that your MS SQL Server database meets the following requirements.

Before starting the installation check the following:

- The default collation of your database server is **SQL_Latin1_General_CP850_BIN2**
  1. Start the SQL Server Management Studio.
  2. Connect to your server.
  3. Right-click the server and in the context menu, choose **Properties**.
  4. Check the server collation on the general page.
  5. If the server collation differs from **SQL_Latin1_General_CP850_BIN2**, you have to reinstall it or use a different MS SQL Server Instance.
SQL Server logins are enabled.
1. Start the SQL Server Management Studio.
2. Connect to your server.
3. Right-click the server and in the context menu, choose Properties.
4. Switch to the security page.
   Under Server Authentication, make sure that the entry SQL Server and Windows Authentication mode is selected.

Note
If only Windows Authentication mode is selected, change it to SQL Server and Windows Authentication mode and restart the server for the changes to take effect.

TCP protocol is enabled and your server is able to communicate on the TCP port.
1. Start the SQL Server Configuration Manager under Start ➤ All Programs ➤ MS SQL Server 2005 ➤ Configuration Tools ➤.
2. Go to SQL Server 2005 Network Configuration in the left pane and select your instance.
3. In the right pane, make sure that Protocol TCP/IP is set to enabled.
   If this is not the case, refer to the MS SQL Server Books Online to configure the TCP/IP connection properly.

Installing a Development System
This procedure tells you how to install an SAP system with SAPinst. SAPinst includes a SAPinst GUI and a GUI server, which both use Java. This section describes an installation where SAPinst, SAPinst GUI, and the GUI server are running on the same host.

Note the following information about SAPinst:

- When you start SAPinst, SAPinst GUI and the GUI server also start. SAPinst GUI connects to the GUI server with a secure SSL connection, and the GUI server connects to SAPinst.
- SAPinst normally creates the installation directory sapinst_instdir, where it keeps its log files, and which is located directly in the Program Files directory. If SAPinst is not able to create sapinst_instdir there, it tries to create sapinst_instdir in the directory defined by the environment variable TEMP.

Recommendation
We recommend that you keep all installation directories until the system is completely and correctly installed.

- SAPinst creates a subdirectory for each installation option called <sapinst_instdir>\<installation_option_directory>, which is located in %ProgramFiles%.
- The SAPinst Self-Extractor extracts the executables to a temporary directory (TEMP, TMP, TMDIR, or SystemRoot). These executables are deleted after SAPinst has stopped running.
Directories called sapinst.exe.xxxxxx.xxxx sometimes remain in the temporary directory. You can safely delete them. The temporary directory also contains the SAPinst Self-Extractor log file dev_selfex.out, which might be useful if an error occurs.

Caution
If SAPInst cannot find a temporary directory, the installation terminates with the error FCO-00058.

If you want to terminate SAPInst and the SAPInst Self-Extractor, choose one of the following options:
- Right-click the icon for the SAPInst output window located in the Windows tray and choose Exit.
- Click the icon for the SAPInst output window located in the Windows tray and choose File ▶ Exit 4.

Prerequisites
You are logged on as a user with administration rights to install the SAPInst tool and the SAP system.

Note
When installing from a network share make sure that everyone has read access to this share. The installation routine creates users such as <sid>adm (for example, ce1adm). During the installation SAPInst does a user switch to this user. If the newly created user does not have permissions to the network share where the installation is running from, the installation will fail.

Procedure
1. Insert the SAP Installation Master DVD into your DVD drive or mount it locally.
2. Start SAPInst from the SAP Installation Master DVD by double-clicking sapinst.exe from the following path: <DVD drive>:\DATA_UNITS\IM_WIN.<platform>_<database>.
3. In the Welcome screen, choose the required SAPInst installation option from the tree structure.

Note
If SAPInst prompts you to log off from your system, log off and log on again.
SAPInst restarts automatically.
Choose Continue Old Installation.

4. Choose whether you want to run the installation in Typical mode or in Custom mode.
If you select Typical, the installation wizard provides automatic default settings and you only have to respond to a small selection of prompts. The rest is set by default. If you select Custom, you have to respond to all prompts.

Note
If you want to install the offline documentation for SAP NetWeaver CE, you need to choose Custom mode.
5. Follow the screens and enter the required parameters.

Note
For more information about the input parameters and information about restrictions for passwords, position the cursor on the required parameter and press [F1].

After you have entered all requested input parameters, SAPinst displays the Parameter Summary screen. This screen shows both the parameters that you entered and those that SAPinst set by default. If required, you can revise the parameters before starting the installation.

6. To start the installation, choose Start. SAPinst starts the installation and displays the progress of the installation. When the installation has successfully been completed, SAPinst shows the dialog Execution of<br>&lt;Option_Name&gt; has been completed successfully.

Note
You can install the update site (for SAP Developer Studio) on a development system only (single instance system).
This page is intentionally left blank.
3 Installing SAP NetWeaver Developer Studio

SAP NetWeaver Developer Studio is based on the open development platform Eclipse. It includes the standard Eclipse features and SAP features. The SAP NetWeaver development documentation assumes that you are familiar with Eclipse and how to develop Java applications with it.


SAP Features

SAP NetWeaver Developer Studio provides several features for composing and developing business applications. You can select the features according to the components you have installed on your AS Java of the Composition Environment. The Developer Studio has the following features:

- SAP NetWeaver Developer Studio Java EE
  Provides the toolset for Java EE-compliant development.
  AS Java component required: Java Application Server.

- SAP NetWeaver Developer Studio Development Infrastructure Client
  Provides the toolset necessary to work the SAP component model. It provides functionality to work locally or in a team.
  Depending on feature: SAP NetWeaver Developer Studio Java EE.
  AS Java component required: Java Application Server. Optionally: SAP NetWeaver Development Infrastructure (NWDI) as part of an SAP NetWeaver 7.0 system.

- SAP NetWeaver Developer Studio Web Dynpro User Interfaces
  Provides the toolset to develop user interfaces with Web Dynpro for Java.
  Depending on features: SAP NetWeaver Developer Studio Java EE, SAP NetWeaver Developer Studio Development Infrastructure Client.

- SAP NetWeaver Developer Studio Composition Tools
  Provides the toolset to develop composite applications.
  Depending on features: SAP NetWeaver Developer Studio Java EE, SAP NetWeaver Developer Studio Web Dynpro User Interfaces, SAP NetWeaver Developer Studio Development Infrastructure Client.
Installation Recommendations

Depending on your system landscape we recommend that you install the SAP NetWeaver Developer Studio as follows:

- **Central AS Java with update site**
  When you have a central AS Java, we recommend that this server provides an update site. This makes sure that the SAP NetWeaver Developer Studio you install has the version that matches the application server.
  You can check the availability of a local update site by going to the following URL in your Web browser:
  
  http://<host>:<httpport>/updatesite

  **Example**
  
  http://dev_server_01:50000/updatesite

- **Note**
  Make sure that the update site is properly installed and that the post-installation activities for the update site have already been performed.
  More information: Post-Installation Activities [page 27], section Configuring the IDE Update Site.

- **Developer Workplace**
  If you want to install the AS Java and the Developer Studio on a single workstation you can use the following sources:
  - SAP NetWeaver Developer Studio Update Site (recommended)
    SAP provides a central update site. The update site can be found at:
    
    https://nwds.sap.com/swdc/downloads/updates/netweaver/nwds/ce
    
    To access the update site you need an SAP Service Marketplace user and password (S user).
  - DVD
    Use the DVD you installed the AS Java from to make sure the Developer Studio and the AS Java have the same version. Once the Developer Studio is installed from a DVD, the update manager is always looking on the DVD for updates. Therefore you can only update the Developer Studio when you have a DVD with a new release. The Developer Studio Update Guide contains the information how to instruct the developer to look for updates on the Developer Studio Update Site rather than on the DVD.

In the following installation procedure we only use the term Update Site. The installation steps are the same, regardless if you decided to install the Developer Studio from the SAP update site or the update site on your AS Java.
Do only use your Update Site on the AS Java or the SAP Update Site. Using other update sites, like the Eclipse update site, can lead to a version mismatch of features and undesired results.

Prerequisites
Check the hardware and software requirements necessary for the installation of SAP NetWeaver Developer Studio:

<table>
<thead>
<tr>
<th>Requirement Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td>Note: SAP NetWeaver Developer Studio can be installed on a 32-bit platform only.</td>
</tr>
<tr>
<td></td>
<td>- 1 GB free disk space</td>
</tr>
<tr>
<td></td>
<td>- 1 CPU with 3 GHz (minimum)</td>
</tr>
<tr>
<td></td>
<td>- 2 GB RAM (minimum)</td>
</tr>
<tr>
<td></td>
<td>- Paging file size: 2x RAM</td>
</tr>
<tr>
<td></td>
<td>To check paging file size:</td>
</tr>
<tr>
<td></td>
<td>1. Choose Windows Start button and choose Control Panel → System.</td>
</tr>
<tr>
<td></td>
<td>2. Choose tab Advanced and choose Settings in the Performance pane.</td>
</tr>
<tr>
<td></td>
<td>3. Choose tab Advanced in the Performance Options dialog window.</td>
</tr>
<tr>
<td></td>
<td>The current page size is displayed in the Virtual memory pane. To change the page size value, choose Change enable the Custom size radio button and enter the new value in the input field Initial size (MB).</td>
</tr>
<tr>
<td>Software</td>
<td>Supported Operating Systems: Microsoft Windows XP Professional SP2 (or higher) (32-bit)</td>
</tr>
<tr>
<td></td>
<td>JDK version: SUN JDK 1.5.0_11 (or higher).</td>
</tr>
<tr>
<td></td>
<td>You can download this version from the SUN web site.</td>
</tr>
</tbody>
</table>

The installation process begins with preparation steps that are dependent on the installation method, DVD or update site. The following installation steps are independent of the installation method.

Preparation – Installing the Developer Studio from a DVD
1. Start SAPinst from the SAP Installation Master DVD by double-clicking <b>sapinst.exe</b> from the following path: <b>&lt;DVD drive&gt;\DATA_UNITS\IM_WIN_I386_&lt;data base&gt;</b>
   SAPinst GUI starts automatically by displaying the Welcome screen.
2. In the Welcome screen, choose the installation option SAP NetWeaver Developer Studio.
3. Choose Next and follow the on-screen instructions.

**Preparation – Installing the Developer Studio from an Update Site**

1. Start your Web browser and connect to the update site.
2. Download NWDS_platform.zip. This zip file contains the SAP NetWeaver Developer Studio Platform Installer.
3. Unzip NWDS_platform.zip to a temporary folder on your local disk drive.
4. Navigate to the temporary folder.
5. Run the installer IDESetup.exe contained in the zip.

**Installing the Developer Studio from DVD and Update Site**

Follow the on-screen instructions of the installation tool. During the installation dialog you are asked for the update site location. Always accept the preconfigured URL that points to the update site that is correct for the installation location (DVD or update site) you selected. The Developer Studio is started automatically when the installation dialog is finished. During startup you are asked for the workspace folder for the Developer Studio.

**Caution**

If you already had a Developer Studio installed on this client, you need to specify a different workspace than the one you used for the previously installed Developer Studio version. This is also true if you have uninstalled the previous version already. Uninstalling a Developer Studio does not remove the content you created in the workspace folder that includes the preferences of the Developer Studio and maybe projects you stored locally.

The next prompt during start up is to confirm the network connections. On the network connection preference page you can specify if you connect to the Internet directly or you can configure your proxy. The network connection settings must be configured so that the Developer Studio can connect to the update site. There can be misleading error messages if the proxy settings are not correct. The installer installs the kernel of the Developer Studio. The kernel contains Eclipse and a few SAP additions, but is not equipped with the SAP features necessary for the Composition Environment. To install the required SAP features, you have to install the SAP features with the following update procedure:

**Selecting and Installing Features**

1. The available features are displayed. The Updates dialog window displays the main node of the features. Open the main node and you see the available main features.
2. Choose the main features you want to install.
Note
Make sure that the component required for the selected feature is installed on the AS Java.

3. Accept the license agreement
4. In the screen Optional Features, choose Next.

Caution
Never deselect an optional feature. This can cause a malfunction of the Developer Studio.

5. In the Install screen, choose Finish.
   The features are being downloaded.
6. Choose Install All to verify the feature installation.
7. Restart the Developer Studio for the updates to take effect.

Recommendation
We recommend that you start the Developer Studio with the shortcuts that were created on your desktop or in the Start menu.
To get to the SAP documentation in the Developer Studio, open the application and choose from the menu bar Help Help Contents SAP NetWeaver CE Developer Studio Documentation.

The installation of the Developer Studio is now completed.

Additional Activities
Once the Developer Studio is installed you can add, update, and remove installed features at any time.

Adding Features to an Installed Developer Studio
You can add features any time.
1. Choose Help Software Updates Find and Install...
2. Choose Search for new features to install.
3. Enable the displayed update site.

Recommendation
We recommend that you do not change the update site to avoid version inconsistencies.

4. Continue with step Selecting and Installing Main Features as described above.

Updating Installed Features
1. Choose Help Software Updates Find and Install...
2. Choose Search for updates of currently installed features.
3. Follow the on-screen instructions.
As of SP03, SAP NetWeaver Developer Studio uses the IDE Update Site to keep itself up-to-date.

1. Choose Help > Software Updates > Find and Install...
2. Choose Search for updates of currently installed features.
3. Follow the on-screen instructions.

**Note**

The configuration wizard task Configuration and Mirroring of local NWDS Update Site has to be run after each patch or update of the IDE update site component on AS Java.

For more information about how to run the configuration wizard, see Post-Installation Activities [page 27].

**More Information**


**Uninstalling Features**

1. To uninstall features, choose Help > Software Updates > Manage Configuration.
2. In the *Product Configuration* window, choose Show Disabled Features.
3. Open the node *SAP NetWeaver Developer Studio* and its subnode.
   The features are displayed with its status, enabled or disabled.
4. To change the status of feature, select the feature and choose *Enable* or *Disable* (depending on the current status).
   To uninstall a feature, it has to be set to status *disabled*.
5. Restart the SAP NetWeaver Developer Studio to apply the status change.

**Note**

To uninstall all old version features (after the update), choose Help > Software Updates > Uninstall Disabled Features.
4 Installing Additional Components (Optional)

You can install the following additional components:

- Composition Tools
- Adobe Document Services
- Composite Voice
- IDE Update Site

Prerequisites
You need to meet the same hardware and software requirements as for your already installed development system plus an additional 2 GB RAM.

The Composition Tools and Composite Voice component make use of the Visual Composer. Visual Composer is a Web browser based tool to model user interfaces. To run Visual Composer, the following programs must be installed on the client computer from which you access Visual Composer:

- Microsoft Internet Explorer 6.0 SP1 or higher
- Adobe SVG Viewer 3.0
- Microsoft XML Parser 4.0 or higher

Note

- Before installing additional components, you need to stop all application servers manually.
- Before installing additional components and in the case that you made changes to the default template settings, see SAP Note 953763.

Prerequisites for SAP MaxDB

- Make sure that the Application Server Java and its corresponding database is running.
  You can stop and start the system using the shortcuts under Start ➤ All Programs ➤ SAP NetWeaver Composition Environment 7.1 ➤ Application Server Jax<sid> ➤ .
- During the installation of additional components, entries are written into the log area of the database. To avoid that the log is running full during the installation, make sure that your backup strategy is already active and an initial data backup was successful.
  When you want to establish your backup strategy after installing additional components, you can turn on the special log mode AutoOverwrite using the Database Manager GUI. This interrupts the existing backup history. You have to run a complete backup to start the history again.
Procedure
This procedure tells you how to install an SAP system with SAPinst. SAPinst includes a GUI and a
GUI server, both using Java. This section describes an installation where SAPinst, SAPinst GUI, and
the GUI server are running on the same host.
Note the following information about SAPinst:
- When you start SAPinst, SAPinst GUI and the GUI server also start. SAPinst GUI connects to the
GUI server with a secure SSL connection, and the GUI server connects to SAPinst.
- SAPinst creates the installation directory sapinst_instdir, where it keeps its log files. The
installation directory is located directly in the Program Files directory. If SAPinst is not able to
create sapinst_instdir there, it tries to create sapinst_instdir in the directory defined by the
environment variable TEMP.

Recommendation
We recommend that you keep all installation directories until the system is completely and
correctly installed.

- SAPinst creates a subdirectory for each installation option called
  <sapinst_instdir><installation_option_directory>, which is located in %ProgramFiles%\.
- The SAPinst Self-Extractor extracts the executables to a temporary directory (TEMP, TMP, TMPDIR, or
  SystemRoot). These executables are deleted after SAPinst has stopped running.
  Directories called sapinst_exe.xxx.xxx.xxx sometimes remain in the temporary directory. You
can safely delete them. The temporary directory also contains the SAPinst Self-Extractor log file
dev_selfex.out, which might be useful if an error occurs.

Caution
If SAPinst cannot find a temporary directory, the installation terminates with the error FCO-00058.

- If you want to terminate SAPinst and the SAPinst Self-Extractor, choose one of the following
  options:
  • Right-click the icon for the SAPinst output window located in the Windows tray and choose Exit.
  • Click the icon for the SAPinst output window located in the Windows tray and choose File ▶
    Exit ▼.

Prerequisites
You are logged on as a user with administration rights to install the SAPinst tool and the SAP system.

Note
When installing from a network share make sure that everyone has read access to this share. The
installation routine creates users such as <sid>adm (for example, ce1adm). During the installation
SAPinst does a user switch to this user. If the newly created user does not have permissions to the
network share where the installation is running from, the installation will fail.
Procedure

1. Insert the SAP Installation Master DVD into your DVD drive or mount it locally.
2. Start SAPinst from the SAP Installation Master DVD by double-clicking sapinst.exe from the following path: <DVD drive>:\DATA_UNITS\IM_WIN_<platform>_<database>
   SAPinst GUI starts automatically by displaying the Welcome screen.
3. In the Welcome screen, choose the required SAPinst installation option from the tree structure.
   
   ![Note]
   If SAPinst prompts you to log off from your system, log off and log on again.
   SAPinst restarts automatically.
   Choose Continue Old Installation.

4. Choose whether you want to run the installation in Typical mode or in Custom mode.
   If you select Typical, the installation wizard provides automatic default settings and you only have to respond to a small selection of prompts. The rest is set by default. If you select Custom, you have to respond to all prompts.
   
   ![Note]
   If you want to install the offline documentation for SAP NetWeaver CE, you need to choose Custom mode.
   After the installation, you can access the offline documentation by choosing Start All Programs SAP NetWeaver Composition Environment <SAPSID>.

5. Follow the screens and enter the required parameters.
   
   ![Note]
   For more information about the input parameters and information about restrictions for passwords, position the cursor on the required parameter and press F1.

   After you have entered all requested input parameters, SAPinst displays the Parameter Summary screen. This screen shows both the parameters that you entered and those that SAPinst set by default. If required, you can revise the parameters before starting the installation.

6. To start the installation, choose Start. SAPinst starts the installation and displays the progress of the installation. When the installation has successfully been completed, SAPinst shows the dialog Execution of <Service_Name> has been completed successfully.
   
   ![Note]
   After installing additional components, you need to perform some post-installation activities [page 27] to get the system up & running.
This page is intentionally left blank.
5 Installing SAP Memory Analyzer (Optional)

SAP Memory Analyzer helps you to analyze Java heap dumps, easily find big chunks of memory or complex memory aggregation patterns in your data structures and identify who is keeping this memory alive. New and innovative analysis techniques support the user with a fast and powerful feature set.

The tool (Eclipse RCP application) was developed to analyze real productive heap dumps, which tend to get enormous in size with hundreds of millions of objects. Performance, low resource consumption and especially the newly developed innovative analysis techniques make it a helpful tool, even to small application heap dumps.

You can install SAP Memory Analyzer as an additional tool.

This procedure tells you how to install an SAP system with SAPinst. SAPinst includes a GUI and a GUI server, both using Java. This section describes an installation where SAPinst, SAPinst GUI, and the GUI server are running on the same host.

Note the following information about SAPinst:

- When you start SAPinst, SAPinst GUI and the GUI server also start. SAPinst GUI connects to the GUI server with a secure SSL connection, and the GUI server connects to SAPinst.
- SAPinst creates the installation directory sapinst_instdir, where it keeps its log files. The installation directory is located directly in the Program Files directory. If SAPinst is not able to create sapinst_instdir there, it tries to create sapinst_instdir in the directory defined by the environment variable TEMP.

**Recommendation**

We recommend that you keep all installation directories until the system is completely and correctly installed.

- SAPinst creates a subdirectory for each installation service called <sapinst_instdir>\<installation_service_directory>, which is located in %ProgramFiles%\.
- The SAPinst Self-Extractor extracts the executables to a temporary directory (TEMP, TMP, TMPDIR, or SystemRoot). These executables are deleted after SAPinst has stopped running.
- Directories called sapinst_exe.xxxxx.xxxx sometimes remain in the temporary directory. You can safely delete them. The temporary directory also contains the SAPinst Self-Extractor log file dev_selfex.out, which might be useful if an error occurs.
Warning

If SAPInst cannot find a temporary directory, the installation terminates with the error FCO-00058.

- If you want to terminate SAPInst and the SAPInst Self-Extractor, choose one of the following options:
  - Right-click the icon for the SAPInst output window located in the Windows tray and choose Exit.
  - Click the icon for the SAPInst output window located in the Windows tray and choose File > Exit.

Prerequisites

You are logged on as a user with administration rights to install the SAPInst tool and the SAP system.

Note

When installing from a network share make sure that everyone has read access to this share. The installation routine creates users such as <sid>adm (for example, ce1adm). During the installation SAPInst performs a user switch to this user. If the newly created user does not have permissions to the network share where the installation is running from, the installation will fail.

Procedure

1. Insert the SAP Installation Master DVD into your DVD drive or mount it locally.
2. Start SAPInst from the SAP Installation Master DVD by double-clicking sapinst.exe from the following path: <DVD drive>:\DATA_UNITS\IM_WIN_<platform>_<database>.
   - SAPInst GUI starts automatically by displaying the Welcome screen.
3. In the Welcome screen, choose the required SAPInst installation option from the tree structure.
   - Note
     - If SAPInst prompts you to log off from your system, log off and log on again.
     - SAPInst restarts automatically.
     - Choose Continue Old Installation.
4. Choose whether you want to run the installation in Typical mode or in Custom mode.
   - If you select Typical, the installation wizard provides automatic default settings and you only have to respond to a small selection of prompts. The rest is set by default. If you select Custom, you have to respond to all prompts.
   - Note
     - If you want to install the offline documentation for SAP NetWeaver CE, you need to choose Custom mode.
     - After the installation, you can access the offline documentation by choosing Start > All Programs > SAP NetWeaver Composition Environment > <SAPSID>.
5. Follow the screens and enter the required parameters.

Note
For more information about the input parameters and information about restrictions for passwords, position the cursor on the required parameter and press [F1].

After you have entered all requested input parameters, SAPinst displays the Parameter Summary screen. This screen shows both the parameters that you entered and those that SAPinst set by default. If required, you can revise the parameters before starting the installation.

6. To start the installation, choose Start. SAPinst starts the installation and displays the progress of the installation. When the installation has successfully been completed, SAPinst shows the dialog Execution of <Option_Name> has been completed successfully.
This page is intentionally left blank.
6 Post-Installation Activities

This section describes the steps that you have to perform after the installation has finished successfully.

Running the Configuration Wizard (Optional)

Note
You can run the configuration wizard only once and only directly after installing and patching your SAP system.

For SAP NetWeaver CE, you need to run the following configuration tasks:

- Configuration of Services Registry Webservice Destinations
- When you have installed the IDE Update Site component: Configuration and Mirroring of local NWDS Update Site
- When you have installed the Adobe Document Services component: Initial setup ADS in CE

When you have an NWDI installation on another SAP NetWeaver 7.0 system you can perform the following configuration tasks:

- Change Management Service (CMS): Create an Application Skeleton
- Change Management Service (CMS): Modify a Software Component

To run the configuration wizard, proceed as follows:

1. After SAPInst has finished, open the SAP NetWeaver Administrator by entering the following URL in a browser: http://<host>:<http_port>/nwa.
2. Log on as user j2ee_admin.
3. In the SAP NetWeaver Administrator, choose Configuration Management > Scenarios > Configuration Wizard 4.
4. Select the appropriate configuration task in the list and choose Start.
5. Follow the on-screen instructions.
6. After the configuration wizard has finished successfully, restart your SAP system.

Configuring the IDE Update Site

1. In the Configuration Wizard, select the task Configuration and Mirroring of local NWDS Update Site in the list, and choose Start.
2. Follow the on-screen instructions.
Provide the credentials for the source update site location. The default URL is the central SAP update site. You can also use your installation DVD as source update site, which makes the mirror process much faster. To use the DVD as source update site, you have to specify the URL file:///<dvd_drive>:/IDE.

3. After the configuration wizard has finished successfully, restart your SAP system.

The data of the source update site location is now mirrored to your server.

**Enabling Adobe Document Services**

If you have installed SAP NetWeaver Composition Environment with the Adobe Document Services add-on in the developer edition on a Windows platform, you must complete the following post-installation steps to enable the add-on. In case you have installed an AS Java cluster, apply the procedure to the central host, as well as to all other hosts where additional application server instances are running.

1. Using the SAP Management Console, stop the AS Java system.
   
2. From the Start menu, open ▶ Control Panel ▶ Administrative Tools ▶ Computer Management ▶ Services and Applications ▶ Services ⇪.
3. Select SAP<SID>_<Instance_Number> (for example, SAPCEL_00) and open Properties from the context menu.
4. On the Log On tab page, enable the Local System account indicator.
5. Repeat the above steps for the second SAP<SID>_<Instance_Number> service that you see in the list.
6. Start the AS Java system.

Adobe LiveCycle Designer
For more information about how to install and configure the Adobe LiveCycle Designer see SAP Note 962763.

**Enabling Services Registry**

You must apply additional configuration steps to enable Services Registry after you have installed an SAP NetWeaver Composition Environment system containing the following components:

- Java Application Server and Composition Platform
- Java Application Server and Adobe Document Services

To enable Services Registry, you must apply the following configuration templates to your system:

CE_Complete_Stack_development_full
Note
For more information about what configuration templates are available, see Configuration Templates [page 33].

See also
| Developing and Composing Applications | Consuming Enterprise Services | Searching for Services | Services Registry |
| Tasks | Searching & Browsing Service Definitions | Configuring the Services Registry |

Configuring the Portal in SAP NetWeaver CE
After installing the portal in SAP NetWeaver CE, a number of deactivated or irrelevant tools are displayed in the UI. To display the correct portals tools for CE, proceed as follows:

1. Open a browser and log on to your portal as an administrator.
2. In the same browser session, enter the following URL:


   where <host> is the host name of your server and <httpport> is the port number of your server.
3. In the Portal Mode Configuration Tool, choose Activate Development Mode to restore the portal tools and content that are assigned to the development mode.
4. Restart or refresh your browser.
5. In the SAP Management Console, restart the server.

You may then continue with the mandatory and optional configuration steps as described in | [ http://help.sap.com/nwce ] SAP NetWeaver Composition Environment | Administrator’s Guide | Configuration of SAP NetWeaver Composition Environment | Configuration for CE Additional Components | Configuring the Portal |

Changing the Password for the Internet Communication Manager (ICM)
You can monitor and manage the Internet Communication Manager (ICM) from the command line program.

After the installation of your SAP NetWeaver CE system has successfully finished, you need to change the ICM password manually. To do so, proceed as follows:

1. Log on at operating system level to the computer where the ICM is running.
2. Start the program icmon with icmon -a profile=<instance_profile> to maintain the authentication file (default: authfile.txt).
3. Choose a to add a user.
4. Choose c to change the password of the existing user.
5. Choose **s** to save your settings.

**Further Configuration Steps**

After installing your SAP NetWeaver CE system and performing the post-installation steps to get the system up & running, you may need to perform further configuration steps. Refer to the following documentation to proceed with your tasks:


---

**Note**

The SAP NetWeaver CE documentation is also available offline as a part of your installation. To access it, choose **Start → All Programs → SAP NetWeaver → Composition Environment 1.0 → Documentation**.
7 Additional Information

The following section provides additional information about the installation of SAP NetWeaver Composition Environment.

7.1 Transporting Self-Developed Software Component Archives (SCA) into the System

Prerequisites
You have developed your own Software Component Archives (SCA) and want to transport them into your SAP NetWeaver CE system.

Procedure
To transport your SCAs to the SAP NetWeaver CE system, proceed as follows:

2. From an empty directory, run the update tool update<ID>.exe.
3. In the dialog screens, specify the directory where your SCAs are located.
4. Follow the on-screen instructions.

Note
If the tool displays descriptions such as Applying Support Packages, you can ignore them.

7.2 Troubleshooting – Repairing an Inconsistent SAP MaxDB Installation

Prerequisites
During the preinstallation phase, the installation tool checks the Microsoft Windows registry for already installed SAP MaxDB software.
If the registry key is found but there is no software on the hard drive, you receive the following message:
The existing MaxDB software is not consistent. Check the file system and registry. The most common reason for this inconsistency is the manual deletion of the software from the file system without using the specified tools.

Procedure
To repair this inconsistency, proceed as follows:

2. Make sure the services SAPDBWWW, SAPDB: *, and XServer are stopped.
3. Choose Start Run and run the command regedit.
4. Go to My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\SAP\SAP DBTech \ Key IndepPrograms. The key contains a path to a folder.
   a) Check if this folder exists on the file system.
   b) Note down the value of Key IndepPrograms for later usage (see step 7). If the path does not exist in the file system, delete the key SAP_DBTech.
5. Delete the following keys:
   - My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SAP DBTech-*
   - My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SAPDBWWW
   - My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\XServer
7. Delete the following paths from the variable:
   - <IndepPrograms>/bin
   - <IndepPrograms>/pgm
8. Reboot your computer.

7.3 Restarting the SAP MaxDB Server Manually

If, after a reboot, the database server is not running automatically, you need to restart the SAP MaxDB server manually.

Production Systems
To restart the SAP MaxDB server manually, proceed as follows:

1. Open a command prompt and enter the following command: net start sapdbwww
   OR
   Choose Start All Programs Administrative Tools Services. Double-click on SAP DB WWW and choose Start.
2. Open the SAP Management Console and choose SAP Systems <SAPSID> <machine name>.
3. Enter the master password and choose Logon.
4. Choose Online. When the database server is online, you can restart the engine.

**Development Systems**

To restart the SAP MaxDB server manually, choose Start > All Programs > SAP NetWeaver Composition Environment CE > Application Server <SAPSID> > Start Application Server.

**7.4 Restarting the MS SQL Server Manually**

If, after a reboot, the database server is not running automatically, you need to restart the MS SQL Server manually.

**Procedure**

1. Choose Start > All Programs > Administrative Tools > Services.
2. Look for the service named SQL Server <name>, where <name> is MSSQLSERVER for the default instance or <instance name> for a named instance.
3. If the service status is not started, right-click the service and choose Start in the context menu.
4. To insure the service is started automatically after each system restart, right-click it and choose Properties. Select Automatic as the startup type.

**7.5 Configuration Templates**

Configuration templates contain the predefined instance configuration for specific scenarios. They are automatically applied according to the installation option you have selected. The templates are designed to optimize system performance by applying certain configuration to the Java Virtual Machine and the application server, as well as by applying startup filters to AS Java services and applications to start only those relevant for the selected installation options.

The following table provides information about the available templates with SAP NetWeaver Composition Environment. In the template name, replace the <system_mode> parameter by development (for the templates relevant to systems installed in development mode) or production (for the templates relevant to systems installed in productive mode).
If your selection cannot be mapped to one of the combinations in the above table, the template **CE_Complete_Stack_<system_mode>_full** is applied. It starts all applications and services needed to run the complete stack.

You can manually apply a different configuration template if you want to switch to another installation option. For example, by changing from template **CE_Complete_Stack_<system_mode>_full** to **CE_Java_EE_<system_mode>_full**, you achieve shorter startup times and less memory consumption, but also less functionality since not all applications and services are running.


---

**7.6 Uninstalling SAP NetWeaver Composition Environment**

You have to uninstall all components of the SAP NetWeaver Composition Environment separately, that is SAP NetWeaver CE and SAP NetWeaver Developer Studio.

You can uninstall your SAP NetWeaver CE system in different ways.

**Uninstalling SAP NetWeaver CE**

**Windows:** Choose [Start] > Control Panel > Add / Remove programs > SAP System<SAPSID> 4.

**Uninstalling SAP NetWeaver CE Using SAPinst**

1. Insert the SAP Installation Master DVD into your DVD drive or mount it locally.
2. Start SAPinst from the SAP Installation Master DVD as described in the section *Installing SAP NetWeaver Composition Environment*.
3. In the Welcome screen, choose *Uninstall SAP System or Single Instances* from the tree structure.
4. Follow the on-screen instructions.

**Uninstalling SAP NetWeaver Developer Studio**

**Prerequisites**

Before uninstalling SAP NetWeaver Developer Studio, consider the following:
- All additionally installed features and plug-ins that were installed to the same folder as Developer Studio, for example, by using the Eclipse Update Manager, will also be removed.
- There may be other directories and files in the installation directory, notably `<install_dir>/eclipse/workspace/`, `<install_dir>/eclipse/links/`, and `<install_dir>/eclipse/configuration/` that contain important data. The files and folder as well as the existing workspaces are retained when the product is uninstalled.

**Procedure**

To uninstall SAP NetWeaver Developer Studio, proceed as described above. You can use either one of the options.

**Uninstalling the SAP Management Console**

Since all SAP systems use the SAP Management Console, there is no uninstallation option for the SAP Management Console within SAPinst. If you are sure that you do not need the SAP Management Console any more, you can remove it using `Start > Control Panel > Add / Remove programs`.
### Typographic Conventions

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt; &gt;</td>
<td>Angle brackets indicate that you replace these words or characters with appropriate entries to make entries in the system, for example, “Enter your &lt;User Name&gt;”.</td>
</tr>
<tr>
<td>▶ ⏯ ◄</td>
<td>Arrows separating the parts of a navigation path, for example, menu options</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Emphasized words or expressions</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Words or characters that you enter in the system exactly as they appear in the documentation</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Textual cross-references to an internet address, for example, <a href="http://www.sap.com">http://www.sap.com</a></td>
</tr>
<tr>
<td>/example</td>
<td>Quicklinks added to the internet address of a homepage to enable quick access to specific content on the Web</td>
</tr>
<tr>
<td>123456</td>
<td>Hyperlink to an SAP Note, for example, SAP Note 123456</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Words or characters quoted from the screen. These include field labels, screen titles, pushbutton labels, menu names, and menu options.</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Cross-references to other documentation or published works</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>Output on the screen following a user action, for example, messages</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>File and directory names and their paths, names of variables and parameters, and names of installation, upgrade, and database tools</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Technical names of system objects. These include report names, program names, transaction codes, database table names, and key concepts of a programming language when they are surrounded by body text, for example, <code>SELECT</code> and <code>INCLUDE</code></td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Keys on the keyboard</td>
</tr>
</tbody>
</table>
© Copyright 2008 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice. Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice. Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft, Windows, Excel, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation. IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, iSeries, pSeries, xSeries, zSeries, System i, System i5, System p, System p5, System x, System z, System z9, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, Informix, i5/OS, POWER, POWER5, POWER5+, OpenPower and PowerPC are trademarks or registered trademarks of IBM Corporation.

Adobe, the Adobe logo, Acrobat, PostScript, and Reader are either trademarks or registered trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Oracle is a registered trademark of Oracle Corporation.

UNIX, X/Open, OSF/1, and Motif are registered trademarks of the Open Group.

Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or registered trademarks of Citrix Systems, Inc.

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®c, World Wide Web Consortium, the Massachusetts Institute of Technology.

Java is a registered trademark of Sun Microsystems, Inc.

JavaScript is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, R/3, xApps, xApp, SAP NetWeaver, Duet, PartnerEdge, ByDesign, SAP Business ByDesign, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies. Data contained in this document serves informational purposes only. National product specifications may vary.

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

This document was created using stylesheet 2006-12-31 (V5.1beta [= 6.0 for E3]) and XSLT processor SAXON 6.5.2 from Michael Kay (http://saxon.sf.net/), XSLT version 1.
Disclaimer
Some components of this product are based on Java™. Any code change in these components may cause unpredictable and severe malfunctions and is therefore expressly prohibited, as is any decompilation of these components. Any Java™ Source Code delivered with this product is only to be used by SAP’s Support Services and may not be modified or altered in any way.

Documentation in the SAP Service Marketplace
You can find this document at the following address: https://service.sap.com/instguides
This page is intentionally left blank.