Crystal Reports 9
Report Designer Component 9 – Tutorial and Getting Started
Guide

Overview
This document describes how to create a Visual Basic application using the
Crystal Report Designer Component 9 (RDC). This document covers the basic
properties and methods that would be used to create an application that prints,
previews, or exports a report. This document is for use with Crystal Reports 9.
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Introduction
The RDC is based on Microsoft’s COM technology, and is supported in
Microsoft Visual Basic (VB) 5 or higher. For VB developers, creation of
reports and developing with them are simplified in one environment. VB
developers can now create reports at design time and use the RDC object models
to take advantage of Object Oriented programming techniques.
Report development is achieved by accessing properties and methods through an
object hierarchy similar to those found in other popular Automation Servers like
DAO and Excel.
The Report Designer Component (RDC) is composed of 4 primary DLLs:
Craxdrt9.dll – (Crystal Reports ActiveX Designer Run Time Library). This
runtime library formats and populates the report with data from the database.
This DLL needs to be included in the distribution of your compiled application.
Craxddt9.dll – (Crystal Reports ActiveX Designer Design and Runtime
Library). This design time library processes the design time formatting. This
DLL is only used when designing a report in the VB environment and should
not be distributed with your compiled application.
Craxdui.dll – (Crystal Reports ActiveX Designer User Interface Library). This
designer user interface library displays a user interface in VB that can be used to
create a report in the VB IDE. This DLL is only used in the application at
design time and should not be distributed with your compiled application.
Crviewer9.dll – (Crystal Reports Viewer Control 9 Library). This ActiveX
Viewer control previews the report objects and can export or print the report
from the viewer window. The crviewer.dll also has an object model hierarchy.

The Object Model
The following is a brief description of the Object Model that the RDC uses. The
RDC Automation Server is the file craxdrt.dll and at the top of the RDC
Automation Server is the Application object.
All RDC objects are children of the Application object. This means that the
Application object must first be created and instantiated before you can start
working with other objects in the Object Model hierarchy.
The RDC Application object is similar to the Application object from the
Crystal Reports (CR) Automation Server (cpeaut32.dll), as well as Excel’s
Automation Server and the DAO Engine object.
If you are designing reports inside of Visual Basic and are loading these reports
as DSR files in your application then you will not need to create this Application
object. It will automatically be created when you dimension your Report
Object.
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The diagram above shows a break down of the parent child relationship between
the objects in which this tutorial will be based. The full Object Model hierarchy
can be found in the Developer’s Help file (CrystalDevHelp.chm) by searching
the index for “Report Designer, Object Model.”
The naming of the objects is significant because the use of a plural denotes a
Collection. A Collection is an object that holds objects of a similar kind. For
example, the DatabaseTables collection is used to reference all the
DatabaseTable objects available in a report.

Creating an application that uses Designer (DSR) files
A DSR file is a designer file that can be used to design reports within the Visual
Basic IDE. When using DSR files it is important to remember that once your
application is compiled into an EXE file so are the DSR files. The reports will
remain the same and cannot be changed or updated outside of the VB IDE. This
is useful if you do not wish for your customers to access these reports outside of
your application.

Adding the RDC to a new application
The following steps describe how to add the RDC to a VB application and how
to create a report in the VB IDE.
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1.

Open a new project in Visual Basic (VB). Click the File menu and then
click New Project. Select Standard EXE and click OK.

2.

Click the Project menu, and click Add Crystal Reports 9. (If you do not
see Add Crystal Reports 9, click on Project | Components, and choose
the Designers tab. Select Crystal Reports 9. You should now see Add
Crystal Reports 9 in the Project menu).

3.

The Crystal Reports Gallery dialog box appears. Select Using the
Report Expert and then select Standard from the Expert list box. Click
OK.

4.

The Standard Report Creation Wizard dialog box appears. From the
Data screen expand the Create New Connection folder.
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In the Data Screen, there are five options you can select for your data source:
-Project Data
-Current Connections
-Favorites
-History
-Create New Connection

After expanding Create New Connection, now expand ODBC (RDO) then
select Xtreme Sample Database 9 (the default ODBC Data source that
Crystal Reports installs), and click Finish. Expand the Tables property and
select the Customer Table and click the Add (>) button.
5.

Click on the Next button to add fields from the Customer table to the
report.
Add the Customer ID and the Customer Name field to the report and then
click the Finish button.

6.

The Crystal Report Expert dialog appears with the following two options:
•

“Do you want the expert to add a form containing the Crystal Report
Viewer control.”

This option will create a form in the project with a viewer control on it and
write some basic code that will preview this report.
•

“Would you like the expert to modify the properties to set this form as
the startup object?”

This option will set this newly created form as the startup form in your
project.
Select Yes for both these options and click OK. This causes the RDC to
add the following references and component to your application:
References (Project | References menu):
•

Crystal Report 9 ActiveX Designer Run Time Library

•

Crystal Report 9 ActiveX Designer Design and Runtime Library

•

Crystal Report Viewer Control 9

Components (Project | Components menu):
•

Crystal Report Viewer Control 9

Code added by the RDC
The RDC inserts code in the General Declaration, Form_Load and
Form_Resize events of the Form that was added to your project.
General Declarations
4/29/2003 2:04 PM
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Dim Report As New CrystalReport1
‘Declare the report object as a new CrystalReport1
‘By declaring the Report Object in the General Declarations
‘section of the Form with the CRViewer on it, you can
‘assure that the Report Object will stay in scope as long
‘as this form is open.

Private Sub Form_Load()
Screen.MousePointer = vbHourglass
CRViewer91.ReportSource = Report
CRViewer91.ViewReport
Screen.MousePointer = vbDefault
End Sub

‘Passes the report object to the Crystal Reports Viewer
‘Control. The ReportSource property tells the viewer what
‘report object to load when the ViewReport method is
‘called.
‘The ViewReport method tells the viewer to load the report,
‘start processing the data and format the report.

Private Sub Form_Resize()
CRViewer91.Top = 0
CRViewer91.Left = 0
CRViewer91.Height = ScaleHeight
CRViewer91.Width = ScaleWidth
End Sub

‘Aligns the Crystal Report Viewer Control to the same size
‘as the form it is on.
NOTE

Any additional code for the Report object, like exporting or logging onto a database,
should be placed before CRViewer1.ReportSource = Report.

Setting the ConnectionProperties info for the
Report Object
NOTE

Use the ConnectionProperties method to log on to a secure database.
However, you do not need to use the ConnectionProperties method to run the sample
applications being created in this tutorial.

Earlier versions of the Report Designer component used the SetLogonInfo
method to log on to the database. In Crystal Reports 9, the recommended
method to log on to a database is the ConnectionProperties method.
4/29/2003 2:04 PM
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The ConnectionProperty method has different properties depending on what
type of connection you use in the report.
Use the ConnectionProperties method (of the DatabaseTables object) to
create a connection to the database that your report object uses.
The ConnectionProperties method can be used in two different cases:

NOTE

•

To create a connection to the database that the report was created from

•

To change the database that the report uses to retrieve its data
For information on how to make a database connection using the Report Designer
Component 9, refer to knowledge base article c2012058 found at:
http://support.crystaldecisions.com/library/kbase
For an in depth discussion of the new ConnectionProperties method of the RDC in Crystal
Reports 9 please see our Technical Brief – “Report Designer Component 9 – Connection
Properties.”
This document can be downloaded by searching for cr_rdc9_connectionproperties.pdf at:
http://support.crystaldecisions.com/docs

Previewing the Report
After setting the Report object to our CRViewer91 control, you are now ready to
run this project.
To run the project go to the Run menu and click on Start or press F5. This
should display the Report in the Crystal Report Viewer Control.

Printing the Report Directly to the Printer
To print a report directly to the printer without previewing, use the PrintOut
method of the Report object.
To send print the report directly to the printer:
1.

Comment out the following two lines of code that are in the Form_Load
event:

‘CRViewer91.ReportSource = Report
‘CRViewer91.ViewReport

2.

Replace those two lines of code with the following line of code:

Report.PrintOut False

NOTE

The syntax for the PrintOut method is:
object.PrintOut PromptUser, NumberOfCopies, Collated, StartPageNumber,
StopPageNumber
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PromptUser: Specifies whether or not you would like your application to prompt for the
printer options.
NumberOfCopies (Optional): Specifies how many copies you would like to print to the
printer.
Collated (Optional): Specifies if you would like the report to print collated or not.
StartPageNumber (Optional): Specifies the page you would like to start printing from.
StopPageNumber (Optional): Specifies the page you would like to stop printing from.

Exporting the Report directly to a Disk File.
To export a report directly to a disk file without prompting for customer input,
use the ExportOptions object off the Report object.
To export a report directly to a disk file:
1.

Comment out the following two lines of code that are in the Form_Load
event:

‘CRViewer1.ReportSource = Report
‘CRViewer1.ViewReport

2.

Replace those two lines of code with the following lines of code:

With Report.ExportOptions
.DestinationType = CrEDTDiskFile
.FormatType = crEFTRichText
.DiskFileName = App.Path & "\Report.rtf"
End With
Report.Export False

For further information on the properties and methods of the ExportOptions object, refer to
the Crystal Developer help file (CrystalDevHelp.chm).

NOTE

Using Report (RPT) files with the RDC in Visual Basic
When using RPT files in your application with the Report Designer Component
(RDC), there are advantages and disadvantages
Some advantages of using RPT files are:
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•

You can distribute the reports with your application and allow the
customers to update, maintain, and modify the reports themselves.

•

Your executable will not be as large as it would be if the reports where
compiled into it.

•

You can modify and distribute the same application with different reports to
provide flexible applications for multiple work environments.

Copyright  2003 Crystal Decisions, Inc. All Rights Reserved.

rdc9_tutorial.pdf

Page 7

Report Designer Component 9

Report Designer Component – Tutorial and Getting Started Guide

•

Separate designers are required for DSR files, but are not required for RPT
files. Not using separate designers will reduce the resources your
application uses.

Some disadvantages of using RPT files are:
•

Customers can modify these reports even if you do not want them to. (you
cannot write protect a report)

•

Distributing RPT files will increase the size of your application installation
package.

Creating a RPT file
When a report is created outside of Visual Basic in the stand-alone Crystal
Report Designer it is saved as a RPT file. These RPT files can be modified by
anyone who has the stand-alone Crystal Report Designer installed.
NOTE

The stand-alone Crystal Reports designer does not allow you to choose a Data
Environment as the database or use unbound fields.

To create a RPT file in the stand alone Crystal Reports Designer
1.

Open the Crystal Reports 9 Designer from your Start Menu.

2.

From the startup screen, select Using the Report Wizard from the Create
a New Crystal Report Document box. Click OK.

3.

The Crystal Reports Gallery dialog box appears. Select Using the
Report Expert and then select Standard from the Expert list box. Click
OK.

4.

The Standard Report Creation Wizard dialog box appears. Select the
Data screen and click the Create New Connection button.

5.

The Standard Report Expert dialog box appears. From the Data screen
expand the Create New Connection folder.
Expand the ODBC (RDO) folder and select Xtreme Sample Database 9.
Click Finish.
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6.

Under Xtreme Sample Database 9 expand the Tables property and select
the Customer table and click Add (>).

7.

Click the Next button to add database fields.

8.

Select the Customer ID and Customer Name field then click Add (>).
Click the Finish button to preview this report.

9.

A report with the Customer ID and Customer Name field will now
appear. To save this report, under the File menu select Save. Save this
report as C:\RDCTest.rpt.
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CAUTION

By default the report will be created with Saved Data.
Go to the File menu, and make sure Save Data with Report is unchecked, and then
resave your report. This will prevent sample data from being passed to your report when
you run your application.

Now that the report is saved as a disk file you can setup a new VB project
that will load this report into the Crystal Reports Viewer Control.

Creating the VB application to load the RPT file
To create a new VB project that loads a report into the Crystal Reports Viewer
Control:
1.

Open a new project in Visual Basic (VB). Click the File menu and then
click New Project. Select Standard EXE and click OK.

2.

Click the Project menu and then click on Components. Put a check beside
the Crystal Reports Viewer Control and then click OK.
Click the Project menu and then click References. Put a check mark
beside Crystal Report 9 ActiveX Designer Run Time Library and then
click OK.

3.

To add the Crystal Reports Viewer Control 9 to Form1, under the View
menu and click Toolbox. Double click the CRViewer Control from the
Toolbox to place it on Form1.

4.

Open the code window for Form1 and under the General Declarations
section, type the following lines of code:

‘General Declarations
Dim Appl as New CRAXDRT.Application
Dim Report as New CRAXDRT.Report
‘Declare the application and report object

5.

Open the code window for the Form_Resize event of Form1 and type the
following lines of code:

Sub Form_Resize()
With CRViewer91
.Top = 0
.Left = 0
.Width

= Me.ScaleWidth

.Height = Me.ScaleHeight
End With
‘This above code resizes the Viewer Control to the size of
‘the form
End Sub

4/29/2003 2:04 PM
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6.

To populate the report object and send it to the Viewer, open the code
window for the Form_Load event of Form1 and type the following lines
of code:

Sub Form_Load()
Set Report = Appl.OpenReport(“C:\RDCTest.Rpt”)
CRViewer91.ReportSource = Report
CRViewer91.ViewReport
End Sub
‘Pass that Report object to the CrViewer control using the
‘ReportSource property and View the report using the
‘ViewReport method

Setting the ConnectionProperties info for the
Report Object
Use the ConnectionProperties method to log on to a secure database.

NOTE

However, you do not need to use the ConnectionProperties method to run the sample
applications being created in this tutorial.

Earlier versions of the Report Designer component used the SetLogonInfo
method to log on to the database. In Crystal Reports 9, the recommended
method to log on to a database is the ConnectionProperties method.
The ConnectionProperty method has different properties depending on what
type of connection you use in the report.
Use the ConnectionProperties method (of the DatabaseTables object) to
create a connection to the database that your report object uses.
The ConnectionProperties method can be used in two different cases:

NOTE

•

To create a connection to the database that the report was created from

•

To change the database that the report uses to retrieve its data
For information on how to make a database connection using the Report Designer
Component 9, refer to knowledge base article c2012058 found at:
http://support.crystaldecisions.com/library/kbase
For an in depth discussion of the new ConnectionProperties method of the RDC in Crystal
Reports 9 please see our Technical Brief – “Report Designer Component 9 – Connection
Properties.”
This document can be downloaded by searching for cr_rdc9_connectionproperties.pdf at:
http://support.crystaldecisions.com/docs
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Previewing the Report
After setting the Report object to our CRViewer91 control, you are now ready to
run this project.
To run the project go to the Run menu and click on Start or press F5. This
should display the Report in the Crystal Report Viewer Control.

Printing the Report Directly to the Printer
To print a report directly to the printer without previewing, use the PrintOut
method of the Report object.
To send print the report directly to the printer:
1.

Comment out the following two lines of code that are in the Form_Load
event:

‘CRViewer91.ReportSource = Report
‘CRViewer91.ViewReport

2.

Replace those two lines of code with the following line of code:

Report.PrintOut False
NOTE

The syntax for the PrintOut method is:
object.PrintOut PromptUser, NumberOfCopies, Collated, StartPageNumber,
StopPageNumber
PromptUser: Specifies whether or not you would like your application to prompt for the
printer options.
NumberOfCopies (Optional): Specifies how many copies you would like to print to the
printer.
Collated (Optional): Specifies if you would like the report to print collated or not.
StartPageNumber (Optional): Specifies the page you would like to start printing from.
StopPageNumber (Optional): Specifies the page you would like to stop printing from.

Exporting the Report directly to a Disk File.
To export a report directly to a disk file without prompting for customer input,
use the ExportOptions object off the Report object.
To export a report directly to a disk file:
1.

Comment out the following two lines of code that are in the Form_Load
event:

‘CRViewer91.ReportSource = Report
‘CRViewer91.ViewReport

2.

Replace those two lines of code with the following lines of code:

With Report.ExportOptions
.DestinationType = CrEDTDiskFile
4/29/2003 2:04 PM
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.FormatType = crEFTRichText
.DiskFileName = App.Path & "\Report.rtf"
End With
Report.Export False

For further information on the properties and methods of the ExportOptions object, refer to
the Crystal Developer help file (CrystalDevHelp.chm).

NOTE

Finding More Information
The following documents can be downloaded from our website at
http://support.crystaldecisions.com/docs
•

apps_vb_rdc.pdf - This document provides a listing of all available Report
Designer Component (RDC) sample applications in Microsoft Visual Basic
available on the Crystal Decisions Support web site. Included is a
description of each application and a link to it’s download location.

•

apps_cpp_rdc.pdf - This document provides a listing of all available Report
Designer Component (RDC) sample applications in Microsoft Visual C++
available on the Crystal Decisions Support web site. Included is a
description of each application and a link to its download location.

•

rdc9_browser.exe - A Help file for developers using the Report Designer
Component (RDC). This utility allows you to navigate through the object
hierarchy of the RDC using an "Explorer tree" type interface. Included are
descriptions and/or syntax of objects, collections, methods, and properties.

•

rdc9_deployment.pdf – This document discusses creating an RDC
deployment package.

•

cr_rdc9_connectionproperties.pdf – This document provides an in depth
discussion of the new ConnectionProperties method for the RDC in Crystal
Reports 9.

•

rdc_tutorial.pdf - This document describes how to create a Visual Basic
application using the Crystal Report Designer Component 8 (RDC). This
document covers the basic properties and methods that would be used to
create an application that prints, previews, or exports a report.

The following knowledge base article can be downloaded from our website at
http://support.crystaldecisions.com/kbase
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•

Kbase c2012058 - How to make a database connection using the Report
Designer Component 9

•

Kbase c2012421 - Runtime File Requirements for the Report Designer
Component version 9
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Contacting Crystal Decisions for Technical Support
We recommend that you refer to the product documentation and that you visit
our Technical Support web site for more resources.
Self-serve Support:

http://support.crystaldecisions.com/
Email Support:

http://support.crystaldecisions.com/support/answers.asp
Telephone Support:

http://www.crystaldecisions.com/contact/support.asp
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