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Configure your SAP BusinessObjects Enterprise system  

 
Before we will start using the SAP BusinessObjects reporting tools we will need to configure our 
SAP BusinessObjects Enterprise system so that we are able to leverage Single Sign On with our 
SAP credentials. 
 
 

Configuring the SAP Authentication 

 

1. Logon to the Central Management Console (CMC) via the menu Start > Programs > 
BusinessObjects XI 3.1 > BusinessObjects Enterprise > BusinessObjects Enterprise Central 
Management Console 

 
2. As System enter the value Localhost:6400 
3. As User Name enter the value administrator (without a password) 
4. As Authentication select the entry Enterprise. 
5. Click Log On. 
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6. Select Authentication. 
7. Double-Click the entry SAP. 
8. Click New. 
9. Enter the details for the entitlement system. 
10. Click Update. 
11. Navigate to the tab Role Import. 
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12. Select the role from the list of available roles and Add the role to the list of Imported Roles. 
13. Click Update. 
14. Navigate to the tab Entitlement System. 
15. Click New. 
16. Enter the details for the entitlement system. 
17. Click Update. 
18. Navigate to the tab Role Import. 
19. Select the role from the list of available roles and Add the role to the list of Imported Roles. 
20. Click Update. 
21. Close the screen. 
22. Select the entry Users and Groups from the dropdown list 

 
 

23. Select the entry Group List on the left-hand side. 
 

 
 

24. Select the two newly added User Group: 
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25. Click the button Actions. 
26. Select the option Join Group. 
27. Select the entry Group List. 
28. Select the entry Administrators from the list and add it to the list of Destination Groups. 
29. Click OK. 
 
You are now able to leverage your SAP credentials in combination with SAP BusinessObjects 
Enterprise. 
 
 

Starting the SAP BusinessObjects Enterprise Services 

1. In the Central Management Console select the entry Servers from the dropdown list. 
2. Navigate to the entry Service Categories. 
 

 

3. Select the category Core Services. 
4. Select all server entries shown on the right hand side 
5. Right click and use the menu item Start Server. 
6. Select the category Crystal Reports. 
7. Select all server entries shown on the right hand side 
8. Right click and use the menu item Start Server. 
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9. Repeat these steps for the categories: 

a. Voyager 
b. Web Intelligence 
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Web Intelligence and SAP NetWeaver BW  

 
 

 

 

 
The available SAP data sources for Web Intelligence are: 

¶ SAP BW 

¶ BW queries and BW cubes. 

¶ Classic InfoSet via Transient Provider (NW 7.02) 

¶ ODS / DSO Objects via BW Query or Data Federator 
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SAP BW OLAP Universes 

The following table shows a list of SAP BW query elements and how these elements are used in an 
OLAP Universe. 
 

SAP BI element  Universe object  

Dimension  Class  

Characteristic  Subclass with dimension and detail objects  

Characteristic with hierarchy  BI Query: 
Subclass containing dimension and detail objects for each 
hierarchy level in the currently defined hierarchy 
BI InfoProvider: 
Subclasses containing dimension and detail objects for 
each hierarchy level for all hierarchies defined for the 
characteristic  

Structure based on Characteristics 
(BEx Queries only)  

Class with single dimension object for the structure  

Navigational attribute  Subclass with dimension and detail objects (identical to 
characteristic)  

Display Attribute  Detail object for the dimension  

Key Figure  Measure object in the class for the Key Figure structure 
with dimension objects for units/currency, numeric value 
and formatted value (based on User preferences)  

Calculated Key Figure (BEx Queries 
only)  

Measure and dimension objects (same as Key Figure)  

Restricted Key Figure (BEx Queries 
only)  

Measure and dimension objects (same as Key Figure)  

Variables (BEx Queries only)  Pre-defined Filter in the Universe 
In the class for the dimension to which the variable 
applies, two dimension objects supporting the list of 
values, one for caption, one for description.  

Key date variable (BEx Queries only)  Universe parameters defining key date variable in the 
universe  

Filter Filters will be applied to the underlying query but are not 
visible in the Crystal Reports designer. 

Conditions  Not supported > means Crystal Reports is receiving all 
rows  

Exceptions  Not transferred to Crystal Reports  

Display Settings  Not supported (example: number of decimals)  

 

Dimension and characteristics 

The screenshot below shows an SAP BI query in the BEx Query Designer. 
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The Rows area of this query includes several characteristics and the Columns area includes 
several keyfigures. On the left side, the actual cube structure is shown with the cube dimensions 
(not to be confused with characteristics). 

 
In the image you can identify one dimension and four characteristics. The dimension is Customer 
(technical name Z_BOBJ1) and the characteristics are City, Country, Customer, and Region. 
Building an OLAP Universe on top of such an SAP BW query results in the following elements: 
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¶ The cube dimension from SAP BW results in a class in the OLAP Universe (for example, 
dimension Customer). 

¶ Each characteristic in the query results in a class with dimension and detail objects. Level 00 
objects represent the aggregated view on this characteristic representing the ñAllò member from 
the underlying cube. 
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Display attributes and navigational attributes 

Display attributes are InfoObjects which are logically assigned or subordinated to a characteristic. 
For example: 
The characteristic customer has two attributes: 
¶ Phone number 
¶ Fax number 

 
Characteristics can be defined as navigational attributes in the BW cube, which then makes these 
attributes available for navigational purposes in the reporting tools. Navigational attributes are 
treated identically to a characteristic. 
 
The following screen shows an SAP BW query in the BEx Query Designer.  

 
 

The row structure includes a characteristic Customer with four display attributes (Geographical 
Height, Postal Code, Sector Code, and Area Code). 
 
In addition the BW query contains three navigational attributes in the rows: Regional Code, Postal 
Code, and Area Code. 
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Building an OLAP Universe on top of such an SAP BW query results in the following elements: 
 

 
 

¶ The cube dimension from SAP BW results in a class in the OLAP Universe (for example, 
dimension Customer ï not to confuse with the characteristic Customer). 

¶ Each characteristic in the query results in a class with dimension and detail objects. Level 00 
objects represent the aggregated view on this characteristic representing the ñAllò member from 
the underlying cube (characteristic Customer resulting in a class Customer2 with dimension L00 
Customer and L01 Customer). 

¶ Each navigational attribute in the query results in a class with dimension and details objects 
(Navigational attribute Postal Code resulting in a class Postal Code with dimension L00 Postal 
Code and L01 Postal Code). 

 

  



   

13 

The image shows the display attributes from characteristic Customer and how these display 
attributes are treated in an OLAP Universe. 

 

 

¶ Each display attribute for the characteristic results in a detail object for the corresponding 
dimension objects in the universe. 

¶ The OLAP Universe includes all available display attributes for the characteristic and not only uses the display 
attributes that are included in the SAP BW query. 
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Keyfigures, units and currencies 

Each keyfigure used in an SAP BW query can have up to three different sets of information: 

¶ Numeric value of the keyfigure. 

¶ Unit or Currency information. 

¶ Formatted value, representing the user-specific formatting. 
 
The image shows the result of two keyfigures in the OLAP Universe.  

 

 

¶ Each key figure is represented with a measure object in a class Key Figures. 

¶ In the case the keyfigure is configured in SAP BW with a unit, an additional dimension object 
will be added representing the unit information. 

¶ The formatted value represents the numeric value formatted as a string value, following the 
user-specific formatting settings. 
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Hierarchies 

The image shows an OLAP Universe class Sales with a subclass Sales Person. For the 
characteristic Sales Person a hierarchy has been activated and therefore the OLAP Universe has 
generated the number of levels required to leverage the complete hierarchy in the universe. 
 

 

 

¶ Each level of a hierarchy will result in a dimension object. 
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Creating a OLAP Universe on top of SAP NetWeaver BW 

 
For the next set of steps we create a BEx Query based on the SAP NetWeaver Demo model 
0D_NW_M01. 
 

 
 
In addition to the shown characteristics and Keyfigures above the BEx query also contains a 
variable for the characteristic Country and a variable for the characteristic Product. 
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1. Start the Universe Designer (Start > Programs > BusinessObjects XI Release 3 > BusinessObjects 
Enterprise > Universe Designer). 

 

 

2. Enter the User Name and Password. 
3. Click OK. 
 
Remember that you can configure the options for the generation of OLAP Universes in the menu  
Tools > Options on the tab OLAP. 
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4. Select the menu Tools > Options. 
5. Navigate to the tab OLAP. 

 
 

6. Make sure only the option Generate Level 00 is activated. 
7. Select the menu File > New. 

 

8. Click New to create a new connection. 
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9. Click Next. 

 

10. Select SAP Business Warehouse from the list. 
11. Enter SAP TechED 2010 as Connection Name. 
12. Click Next. 
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13. Enter the required details as shown in the beginning of this document. 
14. Select Use Single Sign On when refresh reports at viewtime for the Authentication mode. 
15. Click Next. 
16. Open the list of available cubes by clicking the plus sign next to OLAP Cubes. 
17. Navigate to the required cube. In our example the cube Actuals and Plan MultiProvider 

(0D_NW_M01) 
18. Open the list of available queries for the selected cube by clicking the plus sign next to the cube. 
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19. Select the BEx query called QUERY_PROMPTING. 
20. Click Next. 

 

21. Click Finish. 
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22. Enter SAP TechED 2010 as name for the Universe into the field Name. 
23. Navigate to the Controls tab. 

 

24. Uncheck all Query Limits. 
25. Click OK. 
26. Select the menu File > Export. 
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The Universe needs to be saved before it can be exported. 

27. Click Save. 

 

28. Select a Domain. In our example select the domain ñ/webi Universesò 
29. Select the Groups that should be assigned to the Universe. 

 

30. Click OK. 
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31. Click OK. 
 
 
We created our first Universe based on a BEx Query and can now move on to create our first report. 
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Creating your first Web Intelligence report 

After creating the OLAP Universe we can now leverage Web Intelligence to build a new report. 
 

1. Start InfoView by using Start > Programs > BusinessObjects XI 3.1 > BusinessObjects Enterprise >  
BusinessObjects Enterprise Java InfoView 

2. Logon to InfoView: 
3. Click Preferences 
4. Scroll down to the preferences for Web Intelligence. 

 
 

5. Set the View Format to Web. 
6. Set the default creation / editing tool to Advanced. 
7. Click Browse for the option to select a default Universe. 



   

26 

 
 

8. Select the option No default Universe. 
9. Click OK. 
10. Click OK. 
11. Click Document List. 
12. Click New. 
13. Select Web Intelligence. 

 
 

14. Select the Universe we created in the previous step. 
15. The Web Intelligence query panel is shown and you can no start to build your report. 
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16. Include the following objects into the panel for the Result Objects: 
o L01 Distribution Channel 
o L01 Product Group 
o L01 Product 
o L01 Country  
o L01 Region 
o L01 Calendar year / Month 
o Net Value 

17. Click Run Query 



   

28 

 

18. Enter all the Countries except Not Assigned from the list to the list of selected Countries. 
19. Enter all the Products except Not Assigned from the list to the list of selected Products. 
20. Click Run Query. 
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21. Double Click on the Report Title 
22. Enter ñMonthly Sales Reportò 
23. Click Return 
24. .Select the column Distribution Channel. 
25. Right-Click the column. 

 

26. Select the menu Sort > Descending. 
27. Right click the column Product Group. 
28. Select the menu Sort > Custom Sort. 
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29. Arrange the Product Groups into the following order as shown above. 
30. Click OK. 
31. Now move the column Country and move it to the beginning of the table. 
32. Move the column Region between the columns Country and Distribution Channel. 
33. Select the column Country. 

 
 

34. Select the option Insert / Remove Break. 
35. Select the column Region and repeat the step 
36. Select the column Distribution Channel and repeat the step. 


