Creating Formatted reports using BEx Report Designer

Applies to:
SAP NetWeaver BW 7.0  For more information, visit the Business Intelligence homepage.

Summary
This paper outlines the steps to create a formatted report using Report Designer. This report can be displayed on the web or can be converted into a PDF document to print or distribute.

Author: Gopalakrishnan Venkatachalam
Company: Global Softech Inc
Created on: 4 March 2010

Author Bio
Gopalakrishnan Venkatachalam is working as an SAP BW Consultant. He is a certified SAP BW Professional with experience in Data Warehousing and Reporting.
Table of Contents

Purpose........................................................................................................................................3
Prerequisites ....................................................................................................................................3
Report Designer ............................................................................................................................3
Creating a BEx Report....................................................................................................................3
  1. Inserting a Data Provider ........................................................................................................3
  2. Designing the Report ..............................................................................................................5
      a. Changing the Height and Width of Rows and Columns ....................................................7
      b. Inserting Custom Texts into the Report ..............................................................................7
      c. Arranging Fields (Query Fields, Text Elements, or Custom Texts) Differently or Deleting Them ..........................................................................................7
      d. Inserting Additional Report Sections ................................................................................7
  3. Conditional Formatting ...........................................................................................................10
     Prerequisite .............................................................................................................................10
     Procedure for Conditional Formatting ..................................................................................10
     Known Issues ..........................................................................................................................12
Related Content ...........................................................................................................................13
Disclaimer and Liability Notice .....................................................................................................14
Purpose
This article describes how to create Formatted Reports using BEx Report Designer.

Prerequisites
Need to install Latest SAP GUI.
A query or a query view that contain a Structure in the columns is required to create a report and access to BW Local Portal is required.

Report Designer
The Report Designer is a tool used to format and adapt the layout of the business data as a report (static or dynamic) and according to business needs. This report can be displayed on the Web. This report can also be converted into a PDF document to print or distribute to other users. The Report Designer is a component of BEx Web, which is the family of tools used to develop web based content.

Creating a BEx Report
1. Inserting a Data Provider
As mentioned in the prerequisite, a Query or Query View is required to create a Report. To insert a Data provider (either Query or Query View) you can use the Insert Data Provider Function. Menu Path Report → Insert Data Provider …

In the next screen, select the Query or Query view and Click on Open button.

The selected data provider is automatically embedded in a report section and is displayed together with the associated row patterns in the design area of the Report Designer. The following figure shows the Dynamic section of the report as the data provider query has only one structure.
Now let us take a look at the Static section of the query. For this, a query with 2 structures is required.

If the data provider query is changed then you can integrate those changes to report. For that select the report section and use the menu path Report → Check Data Provider.

The following screen will pop up and all the changes done to the query will be reflected to Field Catalog.
Note: Check Data Provider option is not available for the report with dynamic section.

2. Designing the Report

There are various options that are available to design the reports including Standard Formatting Functions. This includes selecting the color, font, and border for individual report elements (cells or fields). For instance, if you want to add color to a cell, select the cell and in the menu bar, choose Format → Background Color, or you can use the context menu of the cell. The color selection dialog appears.

Layout changes can be made, for example, adapting the height and width of rows and columns as required, inserting custom text, and rearranging query fields and text elements. The header and footer areas of the page and the report can be designed here. Images and custom texts can be inserted into these areas or the totals fields for the query can be integrated into the header area using drag and drop.

The formatting options can be accessed from a number of places. Many formatting options can be accessed directly from the context menu of the cells. The formatting options can also be accessed by highlighting the cells that needs to be changed and also by using the toolbar buttons or the Format menu.
Once the formatting changes to a Cell is done, then this formatting option will be available in the Format catalog as shown in figure below. Now if we want to apply the same formatting choices to multiple areas of the report, then we should make use of the Format Catalog. This feature allows us to collect a number of formatting changes and then apply using drag and drop on to the cells in the reports.

In addition to changing individual cells, an entire row, column or even the entire report can be changed at one time, by dragging the required format to the grey buttons around the edge of the report in the design area as shown in the following screenshot.
Note: Dragging a format from the format catalog overwrites any changes that has been made earlier to cells. For example, if we were to manually change the font size of a cell in the report from the context menu and then drag a format from the format catalog over this cell, the font size will immediately be adjusted to the setting in the format catalog and any earlier change will be overwritten.

a. Changing the Height and Width of Rows and Columns
To increase the width of a column, select the outer right border of the column header and drag it along the length of the ruler displayed in the design area until you reach the required width. The column width is adjusted accordingly.

b. Inserting Custom Texts into the Report
a. Select the cell or field into which you want to insert the text, and choose Insert Custom Text in the context menu for the cell, or Insert → Custom Text in the menu bar of the Report Designer.
b. Double-click the selected cell. The cell is now input-ready.
c. Insert the text and use the design functions as required

c. Arranging Fields (Query Fields, Text Elements, or Custom Texts) Differently or Deleting Them
1. To move a field displayed in the design area within the report, select it and drag it to the required cell using drag and drop.
2. To delete a field displayed in the design area, select the field and choose Delete Field in the context menu.
3. If you have deleted a field from the design area and want to insert it again later, or if you want to reuse a field in the page header or page footer for the report, choose the field from the field catalog and drag it to the required cell in the design area using drag and drop.

d. Inserting Additional Report Sections
You can insert additional report sections (to insert comments or footnotes, for example), as well as a page header or footer into your report. To do this, in the menu bar for the Report Designer, choose Insert → Page Header or Page Footer or Report Section.

The Page header is added to the top of the Data Provider.
You can add the Query text elements, Custom fields, Query Variables, Images from the Field Catalog to Header section.

The Page Footer is added to the End of the Page.

Report section is created automatically when you add a data provider to Report designer. But if you need to add space between two data providers you can do that using a section. For this section no data provider will be attached. You can also add a graph to the Report. For that insert a section to report design area and from context menu select Insert Chart. Increase the size of section to accommodate the graph area.

In the Report Structure pan select the Chart. Now you will find the Chart properties in the properties pan the bottom side. By default the system gives the Data provider name same as Query name.
On executing the report, the output looks like as shown in the figure:
3. Conditional Formatting

Using conditional formatting, selected characteristics can be formatted differently. In the executed report, these characteristic values have the formatting you specify and are set apart from the other characteristic values in the group level.

Prerequisite

You can apply conditional formatting only to characteristic values in dynamic sections of a data provider.

Procedure for Conditional Formatting

1. In the design area, select a row in the group level of the characteristic for which you want to apply conditional formatting to its characteristic value(s).

2. In the menu bar for the Report Designer, choose Format → Conditional Formatting. The BEx input Help dialog appears.

In the BEx input help dialog box, select a characteristic value for which you want to create the conditional formatting. In the design area, an additional row is displayed for the selected characteristic value beneath the selected characteristic row. This new row has its own row pattern.

Select the new row created for the characteristic value and format as required using the formatting functions. You can access these functions in the menu bar and in the toolbar of the Report Designer. You can, for example, color the row, left or right align the row, or add borders to the row.
Creating Formatted reports using BEx Report Designer

Upon execution, the report looks like this.
Once you complete the formatting of the report, save your Report. When you execute the report the output is displayed automatically to portal using standard Web Template 0REPORT_DEFAULT_TEMPLATE. This Web template is set as the default for displaying reports from the Report Designer in the SAP Customizing Implementation Guide under SAP NetWeaver → Business Intelligence → Reporting-Relevant Settings → BEx Web → Set Standard Web Templates → Enterprise Report.

**Known Issues**

- For the Dynamic section reports if you change the Data provider query or query view, the changes will not reflect to the report. To accommodate the new changes to report you need to create a new report.
- The RRI capability of the query is not supported in BEx report.
- The exceptions created in query are not seen in BEx Report.
- The cell length of the report will not get adjusted as per cell value, it has fixed length.
Related Content

http://help.sap.com/saphelp_nw70/helpdata/en/e3/e60138fede083de10000009b38f8cf/frameset.htm

For more information, visit the Business Intelligence homepage.
Disclaimer and Liability Notice

This document may discuss sample coding or other information that does not include SAP official interfaces and therefore is not supported by SAP. Changes made based on this information are not supported and can be overwritten during an upgrade.

SAP will not be held liable for any damages caused by using or misusing the information, code or methods suggested in this document, and anyone using these methods does so at his/her own risk.

SAP offers no guarantees and assumes no responsibility or liability of any type with respect to the content of this technical article or code sample, including any liability resulting from incompatibility between the content within this document and the materials and services offered by SAP. You agree that you will not hold, or seek to hold, SAP responsible or liable with respect to the content of this document.