Deploying J2EE Applications

Applies to:
SAP NetWeaver J2EE Preview

Summary
Learn more about deployment options available with the Deploy View in the Developer Studio. Find further information how to deploy standalone deployables (EARs, EJB JARs, WARs), how to manage undeployment, or start and stop deployed applications from within the Repository view.

Author(s): SAP NetWeaver Product Management

Company: SAP AG

Created on: April 2006
Table of Contents

Introduction ............................................................................................................................................. 3
Prerequisites ........................................................................................................................................... 3
Deploying Archives with the Deploy View ............................................................................................ 3
Displaying Deployed Applications in the Repository View ................................................................. 7
Undeploying Archives Using the Undeploy View ............................................................................... 8
References .......................................................................................................................................... 9
  Deploy View Messages .................................................................................................................. 9
    Errors ........................................................................................................................................ 9
    Status Messages ....................................................................................................................... 9
  SAP Component Archives .......................................................................................................... 10
Copyright ......................................................................................................................................... 12
Introduction

This tutorial will show you how to manage J2EE 1.4 archives with the toolset provided by the SAP NetWeaver Developer Studio. You can deploy, undeploy, start and stop them as well as subsequently observe the results of these processes.

The SAP NetWeaver Developer Studio automatically wraps all J2EE 1.4 archives in SDAs when importing them (and later uses these wrapped archives). For more information about SAP native component archives and how they differ to J2EE 1.4 archives, see SAP Component Archives.

The main focus is on the methods used to manage J2EE 1.4 archives that are not currently part of a project of the SAP NetWeaver Developer Studio.

For information on deploying archives that are part of the SAP NetWeaver Developer Studio, see SAP Server section in the Developing J2EE 1.4 Applications.

Prerequisites

You need to have knowledge of the J2EE 1.4 specification and the SAP NetWeaver Developer Studio.

You also need to do the following:

- Set up the SAP J2EE Engine. To do so, go to Window -> Preferences -> SAP J2EE Engine and enter the necessary details.
- Display the Deploy View related views. To do so, go to Window -> Show View -> Others -> Deploy View and choose Deploy View, Deploy View Console, Repository View and Undeploy View.
- Open Window -> Show View -> Other -> Server -> SAP J2EE Engine Cluster Overview and click the button with quick info text Refresh.
- Optionally, set up the Deploy View display options. To do so, go to Window -> Preferences -> SAP J2EE Engine -> Deploy View and provide the necessary details.

Deploying Archives with the Deploy View

Using the Deploy View, you can deploy J2EE archives located either in your workspace or anywhere else in your file system. Each of them is automatically transformed to an SAP native component archive file (an SDA) when added to the Deploy View list.

1. Open the Deploy View, as shown below:
On the left you see a tree with two main nodes – *Workspace Deployable Archives* and *External Deployable Archives*.

2. Set the necessary settings and strategies:

- **Settings for Updating SCAs/SDAs:**
  - Update deployed SCAs/SDAs that have lower component version than the selected SCAs/SDAs only
  - Update deployed SCAs/SDAs that have the same or lower component versions than the selected SCAs/SDAs
  - Update deployed SCAs/SDAs that have any version – this option is most suitable when deploying J2EE 1.4 archives since they do not have versions.

- **Error Strategy**
  - Stop when the first error occurs - the whole deployment process will fail when one of the deployments fails. This is the default error behavior.
  - Skip deployment of SCAs/SDAs depending on the erroneous deployment – this option is most suitable when deploying J2EE 1.4 archives since all your correct archives will be deployed. This option means that when the deployment of one of the components fails, all depending components are skipped and not deployed. The process continues with the next component in the deployment queue that does not depend on the failed component.

3. Add/locate the archives for deployment. You have the following options:

- **Deploy archives from your workspace:**
  **Note:** You can use this option only if you have projects that contain EARs.
  1. Select the node *Workspace Deployable Archives*.
  2. Click the button with quick info text *Add element*. The dialog box *Add Deployable Archives* appears.
  3. Select one or more archives from the list.
  4. Choose *OK*. The selected archives are added to the *Workspace Deployable Archives* as subnodes.

- **Deploy external archives**
  **Note:** You can not deploy stand alone WARs and JARs unless they have module deployment descriptors.
  1. Select the *External Deployable Archives* node.
  2. To select (you can use multiple select):
     - A J2EE Archive - click the button with quick info text *Import J2EE Archive* and select one or more archives from the dialog box *Choose J2EE Deployable Archive*.
     - An “SAP” Archive - click the button with quick info text *Add element* and select one or more archives that you want to deploy from the dialog box *Choose Deployable Archive*. You can open different archives, as long as they contain the SAP-specific META-INF/SAP_MANIFEST.MF.
  3. Choose *Open*. The names of the selected archives appear in the tree under the *External Deployable Archives* root.

  **Note:** You can remove the archives/ archives from the list by selecting them and clicking the button with quick info text *Remove Archive.*
4. In the tree, select one or more archives to be deployed. Note: If you select one of the root nodes, all archives beneath it will be deployed.

Note: When you select a name of an archive, you can see information for its location, its manifest headers and its SAP manifest source. When you select several archives, the settings and strategies are displayed on the right.

5. Click the button with quick info text Deploy. The deployment process for this component starts. When completed, a message appears to show the result. The message types are:
   - **Success** – all applications have been deployed and started.
   - **Warning** – most probably the application or some of the selected applications can not be started.
   - **Error** – one or more of the selected applications were not deployed.

Note: J2EE applications will be started automatically. If this automatic start fails, a warning will appear.
Note: To make it easier for you, the message shows a summarized result of all operations and lists separately the results of each one.

Note: In the Deploy View tree you can see small icon masks in front of the names of the archives that indicate the status of the last operation over them.
They are:

- green tick in front of the component's name - successful deploy and start
- red exclamation mark - warnings during deploy (most likely the unit was successfully deployed, but could not be started)
- red cross - unsuccessful deploy.

6. For more detailed information, view the log messages in Deploy View Console.

**Displaying Deployed Applications in the Repository View**

The **Repository View** lists the archives deployed on the J2EE Engine, as well as software or development component information.
In the Repository View you can start and stop the applications. To do so:

1. Select the application.
2. To:
   o Start it - click the button with quick info text *Start Archive*. A dialog box shows the result. Upon successful start, a small green triangle appears in the components tree before the name of the component.
   o Stop it – click the button with quick info text *Stop Archive*. A dialog box shows the result. Upon successful stop, a small red square appears before the name of the component.

To view the details of a software component you have to select it from the list. The information is shown on the right.

**Note:** Do not forget to update the display using the button with quick info text *Refresh*. Otherwise you might see outdated information.

**Undeploying Archives Using the Undeploy View**

1. Open the *Undeploy View* tab, as shown below.

2. Set:
   
   • An Undeployment Strategy
      
      o *If depending stop* - if there are components that depend on the software component that has to be undeployed and these are not part of the list of components that have to be undeployed, the undeployment process will stop. The dependent components have to be undeployed for the undeployment to be successful.
      
      o *Undeploy depending* – all deployed components that depend on the component that has to be undeployed will be undeployed too.

   • An Error Strategy
1. Select the archives you want to undeploy from the tree. You can use multiple select.
2. Click the button with quick info text *Add Items to undeploy list*. This will copy the names to the table on the right.
   **Note:** If you want to remove an archive from the list, select its name and click the button with quick info text *Remove selected items from undeploy list*.
3. Select the names of the archive you want to undeploy from the list on the right.
4. Click the button with quick info text *Undeploy*. A message is displayed at the end of the process.
5. For more information view the log messages in Deploy View Console.

**Note:** Use the button with quick info text *Refresh* to display an up-to-date list of the deployed archives.

**References**

**Deploy View Messages**

The *Deploy View Console* view shows general notes of the logs. You can double-click them to see their whole text in a separate window. There are several types of notes, such as Errors, Info messages and Status messages.

**Errors**

When an error occurs, you should first examine the logs in the *Deploy View Console* and look for the exceptions that caused the problems. If you click on the entries ending with [*more*], a dialog box with detailed information is displayed.

**Status Messages**

**Deployment statuses**

Deployment statuses show how the deployment process for a particular component has finished. They can be:

- **INITIAL** – the SDA has only been prepared for delivery to the J2EE Engine.
- **SKIPPED** – the SDA was not allowed to be deployed by at least one of the filters, set by the client.
- **SUCCESS** – the deployment of the SDA on the J2EE Engine was completed successfully.
- **WARNING** – the deployment of the SDA on the J2EE Engine was completed, but with some warnings.
- **ABORTED** – the deployment of the SDA on the J2EE Engine was aborted.
- **ADMITTED** – the SDA passed the validation check.
- **PREREQUISITE_VIOLATED** – the SDA did not pass the validation check.
- **ALREADY_DEPLOYED** – there is already an SDA with the same version.
- **DELIVERED** – the SDA was successfully delivered to the J2EE Engine, but was not registered in the Deploy controller repository.
- **FILTERED** – the SDA was rejected by the specified deployment filters.
Undeployment statuses

The undeployment statuses are shown in the Deploy View in a similar way to the deployment statuses. The undeployment statuses are:

- **INITIAL** – the SDA has only been prepared for undeployment.
- **SKIPPED** – the undeploy item was not allowed to be undeployed form the J2EE Engine.
- **SUCCESS** – the undeployment was completed successfully.
- **WARNING** – the undeployment was completed but with some minor exceptions.
- **ABORTED** – the undeployment was not finished due to major exceptions or the specified undeployment strategy.
- **NOT_DEPLOYED** – the SDA specified for undeployment was never deployed.
- **ADMITTED** – the SDA was admitted for undeployment.
- **NOT_SUPPORTED** – the SDA could not be undeployed because the Deploy Controller does not support its deletion. Possible reasons could be that the SDA has software type JDDISCHHEMA or DBSC, or that the SDA is one of the defined “core” components.

SAP Component Archives

How does SAP extend the deployable types?

The range of deployment module types has been continuously expanded and now includes types like webdynpro, webservices, portal, jmsconnector, and so on. Some of them support stand-alone deployment; all of them can be packaged in applications along with J2EE modules.

With regard to class libraries, SAP has divided them into the new deployable types library, service and interface. For each of these, a deployment descriptor was introduced; it is stored in the file `provider.xml`, which resides in the server and/or dispatcher directory of the archive.

In addition to defining the new deployable types, SAP has extended the J2EE standards by providing a common format for all types. SDA (Software Deployment Archive) is based on a JAR compatible archive, supplemented with self descriptive information, such as type, name, version, and so on. This data is added automatically when a unit is built inside SAP.

It is assumed that developers create their components and pack them in SDA files. A bundle of SDA files is then combined and delivered in an SCA (Software Component Archive), which is a software component. Files in SDA or SCA format usually have the corresponding file extension (.sda/.sca), but that is not always the case. So, why are some files in these formats, if it is not due to the extension? They contain a special entry with self-descriptive data. This entry is the META-INF/SAP_MANIFEST.MF file.

What type of content can be packed in an SDA file? SDA files are wrappers for J2EE applications and stand-alone modules, for file system and database components and for J2EE Engine specific components (services, libraries and interfaces).

One of the key attributes in the file META-INF/SAP_MANIFEST.MF is `softwaretype`. Its value shows the SDA deployment type, which is one of the following:

- **J2EE** - application as defined by J2EE standards
- **single-module** - stand-alone module as defined by J2EE standards
- **JAVA-LIB** - online library
- **library** - online library
- **primary-library** - offline library
- **primary-interface** - interface
- **primary-service** - service
- **DBSC** - database content
- **JDDSCHEMA** - database schema
- engine-bootstrap - bootstrap
- engine-kernel - kernel
- FS - file system package
SAP shall not be liable for damages of any kind including without limitation direct, special, indirect, or consequential damages that may result from the use of these materials.

SAP does not warrant the accuracy or completeness of the information, text, graphics, links or other items contained within these materials. SAP has no control over the information that you may access through the use of hot links contained in these materials and does not endorse your use of third party web pages nor provide any warranty whatsoever relating to third party web pages.

Any software coding and/or code lines/strings (“Code”) included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, except if such damages were caused by SAP intentionally or grossly negligent.