Configuring Master Data Management in Flexible Real Estate Management (RE FX)

Applies to:
Any SAP REFX consultant who wants to configure the master data management settings for user requirements in SAP flexible real estate management (RE FX) module. For more information, visit the Enterprise Resource Planning homepage.

Summary
This article aims to give an introduction to SAP flexible real estate management and also summarize the configurations required in the Master Data in flexible real estate module in SAP. It can be used as a ready reference for configuring the REFX module in SAP.

Author: Swapnoneel Mukherjee
Company: Infosys Technologies Ltd.
Created on: 31 May 2011

Author Bio
Swapnoneel Mukherjee has done his MBA(PGDM) in finance. He is currently working as a senior consultant in SAP FICO/REFX in Infosys Technologies Ltd. He has been associated with SAP FICO/REFX for around 5 years.
Table of Contents

Master Data Architecture in REFX ........................................................................................................... 4

Pre-Requisites to configuring Master Management .................................................................................. 7

Configurations in Master Data Management in RE-FX ........................................................................... 9
    Master Data Basic Settings .................................................................................................................... 10
    Define Measurement Types ................................................................................................................. 10
    Define Total Measurement Types ...................................................................................................... 11
    Define Derivable Measurements Types .............................................................................................. 11
    Define Tenancy Laws .......................................................................................................................... 12
    Create Architectural Object Types ...................................................................................................... 12
    Assign Icons to Architectural Object Types ......................................................................................... 13
    Define Allowed Object Type Hierarchy .............................................................................................. 13
    Specify Rule for Determining Object ID ............................................................................................. 13
    Functions per Architectural Object Type ............................................................................................. 14
    Measurement Types per Architectural Object Type ............................................................................ 14
    PM Integration ..................................................................................................................................... 14
    Settings per Architectural Object Type ............................................................................................... 14
    Define PM Notifications per Object Type ........................................................................................... 15
    Define Field Status Groups .................................................................................................................. 15
    Define Field Status ............................................................................................................................ 15
    Define Views ......................................................................................................................................... 16
    Define Screen Layout Views ................................................................................................................ 16
    Define Screen Layout Stages ................................................................................................................. 17
    Define Screen Layout Stages ................................................................................................................ 17
    Define Screens Sequences .................................................................................................................... 18
    Define Events ......................................................................................................................................... 18
    Define Tables ......................................................................................................................................... 19
    Usage View ............................................................................................................................................. 19
    Define Fixtures/Fittings Characteristics for Usage View Objects ......................................................... 19
    Suppressing Leading Zeros in Object Keys ............................................................................................ 20
    Define Number Range for Business Entity .......................................................................................... 21
    Define Regional Locations .................................................................................................................... 21
    Define Layer .......................................................................................................................................... 22
    Define District Locations ...................................................................................................................... 22
    Define Transport Connection ................................................................................................................ 22
    Define Maintenance Areas ..................................................................................................................... 23
    Define Default Unit of Measurement per Company Code ..................................................................... 23
    Define Number Range for Building ..................................................................................................... 23
    Define Building Condition ..................................................................................................................... 24
    Define Building Types .......................................................................................................................... 24
    Define Main Usage Types ..................................................................................................................... 24
    Define Number Range for Property ..................................................................................................... 25
    Define Municipality key ......................................................................................................................... 25
    Define Location Qualities ...................................................................................................................... 25
    Define Property Ground Types ............................................................................................................. 25
Master Data Architecture in REFX

Master data in REFX is divided into two views in which user can process real estate objects:

- **Architectural View**: This is an informative view which is used to integrate with external designing software like CAD and also define the space measurements which then flows to the Usage View. The architectural view represents the actual architectural framework, of a real estate object, taking account of all the chronological changes relevant to its usage. It is possible to define architectural information on rooms or spaces or fixed units without creating a corresponding rental object for each room or space.

- **Usage view**: This view takes care of all the settings for which the actual postings will happen in SAP.

Architectural View if defined has to be defined before usage view. It is advisable to implement Architectural view in the following:

- If detailed information about the architectural structure of the real estate in the system is to be maintained in the system.
- The usage of the objects changes frequently. In this case, the architectural view remains constant and new usage objects are created as needed.
- Graphical systems (CAD etc.) need to be linked to the real estate system.

The additional master data objects are available for service charge settlement:

- Participation group
- Settlement unit

The additional master data objects are available for the adjustment of conditions:

- Comparative group of apartments
- Adjustment measure

The additional master data objects are available for the real estate search:

- RE search request
- Offered object
- Contract offer

The additional master data object is available for third-party management:

- Mandate
Examples of Usage and Architectural View:

The Master Data in SAP REFX is defined in a hierarchical manner. Each object at the lower level is linked to a corresponding object of higher level. The hierarchy is maintained as below:
Assignments between Architectural and Usage Views:

Existing usage objects can be linked to existing architectural objects or vice versa. This assignment can be either partial or complete. Also usage objects can be created with reference from existing architectural objects. The advantage of this assignment is that user can partially or completely adopt the measurements of the assigned object. In that case the measurements can be automatically or manually updated.

The assignment can be made in following ways:

- On an existing usage object (on the Architecture tab page)
- On an existing architectural object (on the Usage tab page)

In both cases, the assignment can be made in master data processing on the specified tab page by choosing with the quick info text Assign.

To remove the assignment, user has to select the object and choose with the quick info text Undo Assignment.

- When creating a new usage object (with one exception: rental objects)
- Using occupancy planning: Here user can assign multiple architectural or usage objects, or just plan them.

Rules for the Assignment

The following rules are to be kept in mind when assigning objects:

- While linking objects in the usage and architectural views, user has to always start with the highest-level object of the usage hierarchy (business entity) and when removing a link it has to be done from the lowest level hierarchy first.
- On the usage side, user is only allowed to assign usage objects to an architectural hierarchy within the same time period if the highest-level usage object is already assigned to the architectural hierarchy.
- The usage objects, business entity, building and land, can only be assigned to one architectural object in a given time period (1:1 assignment). Multiple assignments are only possible in different company codes.

The usage and architectural views are connected to each other in a one to one relationship as given below:
Pre-Requisites to configuring Master Management

- To enable use of RE-FX, company code and controlling area need to be configured beforehand.
- To enable use of RE-FX, the following configurations are required to be set-up at the enterprise level:
  a. Activation of the Financial Extension (Application Indicator EA-FIN) Within the SAP R/3 Enterprise Extension Set
  b. Activation of the BTE Application (RE). This is essential to ensure Business transactions events (BTE) related to other modules.
  c. Activation of the Real Estate Extension

```
Display View “Activate Real Estate Extension”: Details

- Financial Extension (EA-FIN) Active
- BTE Application (RE) Active
- Real Estate Extension Active
```

- To enable use of RE-FX, the following configurations are required to be set-up at the company code level:

```
Display View “Company-Code-Dependent Settings”: Det

- Company Code: A000
- Accounting System: FI
- Uniqueness of Object Assignment:
  - Functional Location: Multiple
  - Asset: Multiple
  - WBS: Multiple
  - Items: Multiple

- Default Units of Measurement:
  - Area Unit: FT²
  - Volume Unit: FT³
  - Unit of Length: FT

- Rental Accounting:
  - Company Code Cash: Item Summary: Active
  - Item Summary: Active

- Zero Tax Indicators:
  - Input Tax Type 0%
  - Input Tax Group 0%
  - Output Tax Type 0%
  - Output Tax Group 0%

- Defaults:
```

- R3-FI has to be activated as the Financial Accounting System.
- Uniqueness of Object Assignment
  It states that whether uniqueness of object is to be maintained or not.
  - Functional Location Multiple –By checking, multiple real estate objects can be set in the same time in the same period for a Functional Location.
  - Asset Assignment- By checking, multiple real estate objects can be set in the same time in the same period for the assets.
  - WBS Multiple- By checking, multiple real estate objects can be set in the same time in the same period for the WBS.
  - Order Assignment- By checking, multiple real estate object can be set in the same time in the same period for the order.
  - Asset Mandatory –By checking, it is mandatory to assign the Fixed Asset to the Real Estate Object.
1. Default units of measurement
   - Area Unit – It specifies the unit of measurement for the area per company code as a default value on the business entity.
   - Volume Unit – It specifies the unit of measurement for the volume per company code as a default value on the business entity.
   - Unit of Length – It specifies the unit of measurement for the length per company code as a default value on the business entity.

2. Under Rental Accounting
   - Company Code Opts – If this indicator is set, it means that option rates are to be determined.
   - Residual Item – It specifies when there is an incoming payment and that does not clear the entire open item, then how will that be treated.
   - If this indicator is set then the remaining amount becomes a residual item that the system treats as a new receivable (open item).
   - Fill Assignment – If this indicator is set the assignment in document line item field is automatically filled.
   - Item Summarization-If this indicator is set then there will be summarization of line items.
   - Tax Line Item Summarization- If this indicator is activated then there will be summarization of the tax line items based on certain specified criteria like Underlying Tax Code, Tax Jurisdictions.

To enable use of RE-FX, the following configuration is required to be set-up also:

- Activation of Real Estate Management

![Change View “Activate components/control indicators”](image)

- Also, along with the configurations given above the necessary configurations for Master Data and contract management needs to be completed before configurations for Service Charge Settlement can be done.
Configurations in Master Data Management in RE-FX

The Flexible real estate module comes under the accounting part in SAP and can be accessed in easy access and SPRO as given in screenshots below:

Master Data Management configurations are available in SPRO under:

**IMG Path:** IMG ➔ Flexible Real Estate Management ➔ Master Data
Master Data Basic Settings

Before the Architectural view is configured the measurement types have to be defined for architectural, usage and contracts. It can be done in the following part of SPRO settings:

The activities to be performed are as given below:

Define Measurement Types

**IMG Path:** IMG ➔ Master Data ➔ Basic Settings ➔ Measurements ➔ Define Measurement Types

**Purpose:** Measurements are used to record measurable traits of real estate objects. The measurement type indicates the type of characteristic that is being measured. There is a special indicator that identifies area measurements.
In the screenshot below the example is given containing the details for Gross Area.

**Define Total Measurement Types**

**IMG Path:** IMG ➔ Master Data ➔ Basic Settings ➔ Measurements ➔ Define Total Measurements

**Purpose:** Here user can specify how summarized measurements are derived from other measurements.

**Define Derivable Measurements Types**

**IMG Path:** IMG ➔ Master Data ➔ Basic Settings ➔ Measurements ➔ Define Derivable Measurements

**Purpose:** The user can define how the measurement amounts of a rental object (for example, when a rental space is extracted) should be derived from other measurement amounts. The derived value can be changed when the rental object is processed. As long as no manual changes are made, the value for the derived measurement type is updated automatically each time the basis measurement is changed. It is possible to derive measurement amounts for the following rental object types:

- All rental object types from the same object or from subordinate/super ordinate architectural objects.
- For rental spaces from a super ordinate pooled space
Define Tenancy Laws

**IMG Path:** IMG ➔ Master Data ➔ Basic Settings ➔ Tenancy Law

**Purpose:** Here user can specify which a tenancy law has to be maintained in RE-FX. User can specify for the business entity, the contract and the settlement unit which tenancy law covers the relevant object.

![Tenancy Law Used: Overview](image)

Architectural View Configurations

Create Architectural Object Types

**IMG Path:** IMG ➔ Master Data ➔ Architectural View ➔ Architectural Object Type ➔ Create Architectural Object Types

**Purpose:** Here user can define the allowed architectural object types. By defining architectural object types, user needs to define the different, distinct architectural levels which have to be in the system and their relationship to each other.

![Object Types of Architecture: Overview](image)

**Note:** The same attributes exist in the architectural view as in the usage view, which enables user to derive the usage view from the architectural view, if required. For this to be possible, user has to assign the master data of business entities, properties, and buildings in the usage view to the corresponding architectural object types.
Assign Icons to Architectural Object Types

**IMG Path:** IMG ➔ Master Data ➔ Architectural View ➔ Architectural Object Type ➔ Assign Icons to Architectural Object Types

**Purpose:** Here the icons associated with the architectural object types are defined to assist in distinguishing the different objects.

<table>
<thead>
<tr>
<th>Architectural Object Type</th>
<th>IconName</th>
<th>IconText</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building Complex</td>
<td>ICON_PLANT</td>
<td>Plant</td>
</tr>
<tr>
<td>Connection object</td>
<td>ICON_CONNECTION_OBJECT</td>
<td></td>
</tr>
<tr>
<td>Door</td>
<td>ICON_DOOR_RECTANGLE</td>
<td>Door rectangle</td>
</tr>
<tr>
<td>Panel</td>
<td>ICON_DOOR_RECTANGLE</td>
<td>Door rectangle</td>
</tr>
<tr>
<td>Floor</td>
<td>ICON_DOOR_RECTANGLE</td>
<td>Door rectangle</td>
</tr>
<tr>
<td>Part of Building</td>
<td>ICON_DOOR_RECTANGLE</td>
<td>Door rectangle</td>
</tr>
<tr>
<td>Room</td>
<td>ICON_DOOR_RECTANGLE</td>
<td>Door rectangle</td>
</tr>
</tbody>
</table>

Define Allowed Object Type Hierarchy

**IMG Path:** IMG ➔ Master Data ➔ Architectural View ➔ Architectural Object Type ➔ Define Allowed Object Type Hierarchy

**Purpose:** In this step, user needs to define which architectural object types can be assigned as higher-level object types (parent object types) within the hierarchy, per architectural object type.

Specify Rule for Determining Object ID

**IMG Path:** IMG ➔ Master Data ➔ Architectural View ➔ Architectural Object Type ➔ Specify Rule for Determining Object ID

**Purpose:** Here user has to set up the rules to be used for generating a system-wide, unique architectural object ID from the architectural object code (AOID code). The settings depend on the object type. The AOID is assigned hierarchically which means that a new architectural object ID contains the architectural object ID of the object above it in the hierarchy. The architectural object code of the new object is added to this architectural object ID. This code can be separated by a separator.
Functions per Architectural Object Type

**IMG Path:** IMG → Master Data → Architectural View → Architectural Object Type → Functions per Architectural Object Type

**Purpose:** In this step, users can specify the function for architectural objects, per architectural object type. The function makes it possible to classify architectural objects. For example, type of room or building can be defined using this function.

### Change View "Function per Architectural Object Type": Overview

<table>
<thead>
<tr>
<th>Architectural Object Type</th>
<th>Architectural View</th>
<th>Function</th>
<th>Object Name</th>
<th>Object Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office</td>
<td>Office</td>
<td>Office</td>
<td>Office block</td>
<td>Office block</td>
</tr>
<tr>
<td>Building</td>
<td>Building</td>
<td>Building</td>
<td>Residential building</td>
<td>Residential building</td>
</tr>
<tr>
<td>Building</td>
<td>Building</td>
<td>Building</td>
<td>Factory building</td>
<td>Factory building</td>
</tr>
<tr>
<td>Building</td>
<td>Building</td>
<td>Building</td>
<td>Shopping Mall</td>
<td>Shopping Mall</td>
</tr>
<tr>
<td>Building</td>
<td>Building</td>
<td>Building</td>
<td>Mixed Office/Residential</td>
<td>Mixed Office/Residential</td>
</tr>
<tr>
<td>Building</td>
<td>Building</td>
<td>Building</td>
<td>Mixed Office/Residential</td>
<td>Mixed Office/Residential</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Mixed Office/Residential</td>
<td>Mixed Office/Residential</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Mixed Office/Residential</td>
<td>Mixed Office/Residential</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Parking space</td>
<td>Parking space</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Office</td>
<td>Office</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Living space</td>
<td>Living space</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Workshop</td>
<td>Workshop</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Retail Space</td>
<td>Retail Space</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Property</td>
<td>Warehouse</td>
<td>Warehouse</td>
</tr>
</tbody>
</table>

Measurement Types per Architectural Object Type

**IMG Path:** IMG → Master Data → Architectural View → Architectural Object Type → Measurement Types per Architectural Object Type

**Purpose:** Users can define exceptions here for individual architectural object types. However, the system ignores these exceptions if the No Exception indicator is set in the step mentioned above.

### New Entries: Overview of Added Entries

PM Integration

Settings per Architectural Object Type

**IMG Path:** IMG → Master Data → Architectural View → PM Integration → Make Settings per Architectural Object Type

**Purpose:** In this section, users specify for each architectural object type how functional locations are created. They can be

- Created automatically
- Created automatically and updated
- Not created automatically (no automatic integration with Plant Maintenance).
Define PM Notifications per Object Type

**IMG Path:** IMG → Master Data → Architectural View → PM Integration → Define PM Notifications per Object Type

**Purpose:** Functional locations can be assigned to Real Estate master data either manually or automatically (see PM Integration: Define Settings per Object Type. While processing master data, user can create notifications for these functional locations. Here user specifies what type of PM notification user can create for each object type.

Define Field Status Groups

**MENU Path:** IMG → Master Data → Architectural View → Dialog → Screen Layout → Field Groups → Field Groups

**Purpose:** Allows the client to customize the fields that are displayed and the associated actions required for each.

### Define Field Status Groups

**MENU Path:** IMG → Master Data → Architectural View → Dialog → Screen Layout → Field Groups → Field Status

**Purpose:** Allows the user to customize the fields that are required to be displayed.

---

**Change View "Field Groups": Overview**

**Change View "Field Grouping Activity": Overview**
Define Views

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Field Groups ➔ Field Status per Architectural Object Type

**Purpose:** Here on has to specify which field groups are grouped together into a view (part of a screen, technically a sub-screen). User should group together the field groups that necessarily belong together during a check.

### Change View "Field Status of Architectural Objects per Object Type": 0

<table>
<thead>
<tr>
<th>Architectural Object Type</th>
<th>Name of KO Type</th>
<th>Field Status Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>OTH</td>
<td>Category</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BSCB</td>
<td>Building Complex</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BCCU</td>
<td>Building</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BCPP</td>
<td>Property</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BCPP</td>
<td>Floor</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BCPP</td>
<td>Part of Building</td>
<td>Object originates from SAP ➔</td>
</tr>
<tr>
<td>BCPP</td>
<td>Part of Property</td>
<td>Object originates from SAP ➔</td>
</tr>
</tbody>
</table>

Define Screen Layout Views

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Views

**Purpose:** Here user has to specify which views are grouped together into sections

### Change View "Views": Overview
Define Screen Layout Stages

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Stages

**Purpose:** Here user has to specify which views are grouped together into sections.

Change View "Sections": Overview

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>KE000</td>
<td>Initial Screen</td>
<td>Initial Screen</td>
</tr>
<tr>
<td>KE001</td>
<td>Header Data</td>
<td>Header Data</td>
</tr>
<tr>
<td>KE002</td>
<td>Architectural Object</td>
<td>Architectural Object</td>
</tr>
<tr>
<td>KE003</td>
<td>Additional Data</td>
<td>Additional Data</td>
</tr>
<tr>
<td>KE004</td>
<td>Location</td>
<td>Location</td>
</tr>
<tr>
<td>KE006</td>
<td>Building Law</td>
<td>Building Law</td>
</tr>
<tr>
<td>KE007</td>
<td>Permitted Usage</td>
<td>Permitted Usage</td>
</tr>
<tr>
<td>KE008</td>
<td>Actual Usage</td>
<td>Actual Usage</td>
</tr>
<tr>
<td>KE009</td>
<td>Property Quality</td>
<td>Property Quality</td>
</tr>
<tr>
<td>KE011</td>
<td>Floors</td>
<td>Floors</td>
</tr>
<tr>
<td>KE012</td>
<td>Building Type/Condition</td>
<td>Building Type/Condition</td>
</tr>
<tr>
<td>KE013</td>
<td>Dates for New Construction</td>
<td>Dates for New Construction</td>
</tr>
<tr>
<td>KE014</td>
<td>Further Dates</td>
<td>Further Dates</td>
</tr>
<tr>
<td>KE015</td>
<td>Authorization Group</td>
<td>Authorization Group</td>
</tr>
<tr>
<td>KE070</td>
<td>Status Overview</td>
<td>Status Overview</td>
</tr>
<tr>
<td>KE079</td>
<td>Identification</td>
<td>Identification</td>
</tr>
<tr>
<td>KE080</td>
<td>Number Assignment</td>
<td>Number Assignment</td>
</tr>
<tr>
<td>KE090</td>
<td>Measurements</td>
<td>Measurements</td>
</tr>
<tr>
<td>KE091</td>
<td>Partners</td>
<td>Partners</td>
</tr>
<tr>
<td>KE092</td>
<td>Address</td>
<td>Address</td>
</tr>
<tr>
<td>KE093</td>
<td>Object Assignment</td>
<td>Object Assignment</td>
</tr>
<tr>
<td>KE094</td>
<td>Usage</td>
<td>Usage</td>
</tr>
<tr>
<td>KE095</td>
<td>Usage Period</td>
<td>Usage Period</td>
</tr>
</tbody>
</table>

Define Screen Layout Stages

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Screens

**Purpose:** Here user has to specify which views are grouped together into sections (framed areas in screens).

Change View "Screens": Overview

<table>
<thead>
<tr>
<th>Screen</th>
<th>Description</th>
<th>Screen Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>KEA001</td>
<td>Initial Screen</td>
<td>Initial Screen</td>
</tr>
<tr>
<td>KEA002</td>
<td>General Data</td>
<td>General Data</td>
</tr>
<tr>
<td>KEA003</td>
<td>Number Assignment</td>
<td>Number Assignment</td>
</tr>
<tr>
<td>KEA004</td>
<td>Additional Data</td>
<td>Additional Data</td>
</tr>
<tr>
<td>KEA005</td>
<td>Property</td>
<td>Property</td>
</tr>
<tr>
<td>KEA006</td>
<td>Building</td>
<td>Building</td>
</tr>
<tr>
<td>KEA007</td>
<td>Dates</td>
<td>Dates</td>
</tr>
<tr>
<td>KEA008</td>
<td>Measurements</td>
<td>Measurements</td>
</tr>
<tr>
<td>KEA009</td>
<td>Partners</td>
<td>Partners</td>
</tr>
<tr>
<td>KEA010</td>
<td>Object Assignment</td>
<td>Object Assignment</td>
</tr>
<tr>
<td>KEA011</td>
<td>Usage</td>
<td>Usage</td>
</tr>
<tr>
<td>KEA012</td>
<td>Recomputation</td>
<td>Recomputation</td>
</tr>
<tr>
<td>KEA013</td>
<td>Overviews (List)</td>
<td>Overviews</td>
</tr>
</tbody>
</table>
Define Screens Sequences

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Screen Sequences

**Purpose:** Here user has to specify which tab pages appear in the dialog, and which sections make up these tab pages.

![Change View "Screen sequences": Overview](image1)

Define Events

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Screen Sequences

**Purpose:** Here user has to specify which tab pages appear in the dialog, and which sections make up these tab pages.

![Display View "Events": Overview](image2)
Define Tables

**MENU Path:** IMG ➔ Master Data ➔ Architectural View ➔ Dialog ➔ Screen Layout ➔ Tables

**Purpose:** Here user has to specify which tab pages appear in the dialog, and which sections make up these tab pages.

![Change View "Tables": Overview](image)

<table>
<thead>
<tr>
<th>Table Name</th>
<th>Tab Logic</th>
<th>Read Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>V30AUD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V30AWEAS</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V30AEX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V30ARD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V30FREEL</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Usage View

Define Fixtures/Fittings Characteristics for Usage View Objects

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ General Settings for Multiple Object Types of the Usage View ➔ Define Fixtures/Fittings Characteristics for Buildings and Rental Object

![IMG Path](image)

**Purpose:** The fixtures and fittings characteristics are to be available when processing the rental object and building. The fixtures and fittings characteristics that user defines can be assigned to a representative list of rents. For fixtures and fittings characteristics that are not relevant for the representative list of rents, user can define a structure using the Specify Structure of Fixtures and Fittings Characteristics Independent of RLR IMG activity. For rental objects and buildings for which a representative list of rents is defined, the structure of fixtures and fittings characteristics is determined using the representative list of rents structure. If a representative list of rents is specified for a building or rental object, then in the processing dialog user can switch to representative-list-of-rents-independent display to use the structure defined here.
Suppressing Leading Zeros in Object Keys

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ General Settings for Multiple Object Types of the Usage View ➔ Suppress Leading Zeros in Object Keys

**Purpose:** The indicator for object types has to be set for which; user want the system to suppress leading zeros.

- **Input:**
  If user set the indicator for input, a purely numerical key is always saved technically in the database with leading zeros. Therefore, the system saves the key of a business entity for which user have entered the number 1 as 0000001.

- **Output:**
  If user set the indicator for output then the system does not display saved leading zeros for purely technical keys in the appropriate field in the database. For example, the system displays a business entity that has the number 00000007 in the database as 7. The list is still sorted in the numerical sequence.
Define Number Range for Business Entity

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Business Entity ➔ Number Range for Business Entity

**Purpose:** Here the user can specify how number assignment is handled for usage objects. The specification applies uniformly for the company code.

- For external number assignment, the user can specify the number range that is available when the user creates the usage object.
- For internal number assignment, the system counts upward sequentially starting from the number shown in the Number level field.

For buildings, properties, and rental objects, the system assigns the number per business entity when internal number assignment is used. This number is unique within the business entity. The next assigned number for these objects is therefore not identical with the number that is shown here in Customizing.

![Display Number Range Intervals](image)

Define Regional Locations

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Business Entity ➔ Regional Locations

**Purpose:** Regional location is used to denote the geographic region of operation. Here the user can specify the regional locations for the real estate properties.

![Change View "Regional Locations": Overview](image)
Define Layer

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Business Entity ➔ Layer

**Purpose:** Create the necessary locations of business entities with the amount of detail user need, and enter a name for the location.

![Image of Define Layer](image-url)

Define District Locations

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Business Entity ➔ District Locations

**Purpose:** Create the district locations of business entities in the amount of detail user need, and enter descriptions for them.

![Image of Define District Locations](image-url)

Define Transport Connection

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Business Entity ➔ Transport Connection

**Purpose:** Transport connections allow the maintenance of public transport availability. The user can define the list in this setting.

![Image of Define Transport Connection](image-url)
Define Maintenance Areas

**IMG Path:** IMG → Master Data → Usage View → Business Entity → Maintenance Areas

**Purpose:** The user can create the necessary maintenance areas for business entities in the amount of detail the requirements are there. The areas can be assigned names.

Define Default Unit of Measurement per Company Code

**IMG Path:** IMG → Master Data → Usage View → Business Entity → Default Unit of Measurement per Company Code

**Purpose:** User can define the default unit of measurement per company code in this setting.

Define Number Range for Building

**IMG Path:** IMG → Master Data → Usage View → Building → Number Range for Building

**Purpose:** Here user can specify how number assignment is handled for this usage object. The specification applies uniformly for the company code. Note that the system only takes the setting for interval "01" into account.

For external number assignment, user can specify the number range that is available when user creates the usage object. For internal number assignment, the system counts upward sequentially start from the number shown in the Number level field. For buildings, properties and rental objects, the system assigns the number per business entity when internal number assignment is used. This number is unique within the business entity. The next assigned number for these objects is therefore not identical with the number that is shown here in Customizing.

Display Number Range Intervals
Define Building Condition

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Building ➔ Building Condition

**Purpose:** The SAP building condition field is used to hold the facility classification. User can specify the descriptions for the conditions of buildings. The characteristic is for information only.

![Change View "Building Condition": Overview](image)

Define Building Types

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Building ➔ Building Type

**Purpose:** The SAP building type field is used to hold the facility classification. User can define the facility classification in this setting.

![Change View "Type of object": Overview](image)

Define Main Usage Types

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Building ➔ Main Usage Types

**Purpose:** Here user specifies the main usage type of the building. This attribute is of a purely documentary nature.

![Change View "Main usage types (properties, buildings)": Overview](image)
Define Number Range for Property

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Property ➔ Number Range for Property

**Purpose:** Here user can specify how number assignment is handled for usage object property. The specification applies uniformly for the company code.

---

Define Municipality key

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Property ➔ Municipality Key

**Purpose:** The municipality key fields are used to hold the MSA fields; MSA, county and state. The check values and initial field values can be loaded in via data conversion.

---

Define Location Qualities

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Property ➔ Location Qualities

**Purpose:** To define the quality of the property location the below settings can be used.

---

Define Property Ground Types

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Property ➔ Property Ground Types

**Purpose:** This setting can be used to define the property ground type.
Define Overall Condition of Property

**IMG Path:** IMG → Master Data → Usage View → Property → Overall Condition of Property

**Purpose:** The below maintained setting is used to indicate if the land (property) is covered or uncovered.

![Change View Overall condition of Property](image)

Define usage Types Acc. To Usage Plan

**IMG Path:** IMG → Master Data → Usage View → Property → Usage type according to Usage Plan

**Purpose:** This setting is made to indicate if the land is to be used for commercial, mixed building, park or residential building purpose.

![Change View Usage Types acc. to Development plan](image)

Define usage Types Acc. To Heritable Building Types

**IMG Path:** IMG → Master Data → Usage View → Property → Heritable Building Right Types

**Purpose:** This setting can be made to indicate if the land is to be used for heritable building.

![Change View Heritable Building Right](image)

Define Number Range and other basic configurations for Rental Object

**IMG Path:** IMG → Master Data → Usage View → Rental Object → Number Range for Rental Objects

**Purpose:** This setting is made to define the number assignment for rental objects. The specification applies uniformly for the company code.

![Display Number Range Intervals](image)
Define Usage Types for Rental Object

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Usage Types ➔ Usage Types

**Purpose:** In this section, user needs to specify the external usage types for rental objects and assign internal usage type to them. The usage type specifies the following:

- Which screen sequence is used for master data maintenance of the rental object
- Which rental object types (rental unit or pooled space/rental space) are allowed
- Which condition types are allowed for the rental object (by assigning a condition group per usage type)
- Which option rate method is defaulted
- Which adjustment rule is defaulted for a condition type
- Whether or not a rental object can participate in service charge settlement

Define usage Type per Rental Object

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Usage Types ➔ Usage Type per Rental Object Type

**Purpose:** In this section, user has to specify which usage types can be used exclusively for which rental object types.
Define Usage Type for Pooled Space

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Usage Types ➔ Usage Types Allowed for Rental Spaces per Pooled Space

**Purpose:** User has to assign multiple usage types for rental spaces that are extracted from pooled spaces. User assigns these to the usage type of the pooled space. In the standard system, rental spaces have the same usage type as the pooled space they belong to. This means that when the usage type of the pooled space is Office space, for example, the rental spaces user has to extract from it are also office space. However, user might need different types of offices at the rental space level (single office, common office, and so on).

### Change View “External Usage Types”: Overview

<table>
<thead>
<tr>
<th>No.</th>
<th>Usage type of RU</th>
<th>LIT Shortname</th>
<th>Cat.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Privately owned accommodation</td>
<td>Priv-ace</td>
<td>Non-commercial</td>
</tr>
<tr>
<td>2</td>
<td>Public authority owned accommodation</td>
<td>Pub-auth-ace</td>
<td>Non-commercial</td>
</tr>
<tr>
<td>3</td>
<td>Medical practice</td>
<td>Medical practice</td>
<td>Commercial</td>
</tr>
<tr>
<td>4</td>
<td>Store</td>
<td>Store</td>
<td>Commercial</td>
</tr>
<tr>
<td>5</td>
<td>Office</td>
<td>Office</td>
<td>Commercial</td>
</tr>
<tr>
<td>6</td>
<td>Warehouse</td>
<td>Warehouse</td>
<td>Commercial</td>
</tr>
<tr>
<td>7</td>
<td>Advertising space</td>
<td>Advertising space</td>
<td>Commercial</td>
</tr>
<tr>
<td>8</td>
<td>Vending machine space</td>
<td>Vending machine space</td>
<td>Commercial</td>
</tr>
<tr>
<td>9</td>
<td>Garage (commercial)</td>
<td>Garage (comm.)</td>
<td>Commercial</td>
</tr>
<tr>
<td>10</td>
<td>Garage (private)</td>
<td>Garage (priv.)</td>
<td>Commercial</td>
</tr>
<tr>
<td>11</td>
<td>Parking space</td>
<td>Parking space</td>
<td>Non-commercial</td>
</tr>
<tr>
<td>12</td>
<td>Garage (mixed use)</td>
<td>Garage (mixed use)</td>
<td>Commercial</td>
</tr>
<tr>
<td>13</td>
<td>Terminal</td>
<td>Terminal</td>
<td>Commercial</td>
</tr>
<tr>
<td>14</td>
<td>Terminal - Check-in</td>
<td>Terminal - Check-in</td>
<td>Commercial</td>
</tr>
<tr>
<td>15</td>
<td>Terminal - Lounge</td>
<td>Terminal - Lounge</td>
<td>Commercial</td>
</tr>
<tr>
<td>16</td>
<td>Terminal - Trading stall</td>
<td>Terminal - Trading stall</td>
<td>Commercial</td>
</tr>
</tbody>
</table>

Define Floor

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Attributes ➔ Floor Descriptions

**Purpose:** Provides floor descriptions. User can maintain the floor descriptions in the list below.

### Change View “Floors”: Overview

<table>
<thead>
<tr>
<th>No.</th>
<th>Floor description</th>
<th>Store</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Do not use: initialization</td>
<td>Initial</td>
</tr>
<tr>
<td>2</td>
<td>1st floor</td>
<td>1.0</td>
</tr>
<tr>
<td>3</td>
<td>2nd floor</td>
<td>2.0</td>
</tr>
<tr>
<td>4</td>
<td>3rd floor</td>
<td>3.0</td>
</tr>
<tr>
<td>5</td>
<td>4th floor</td>
<td>4.0</td>
</tr>
<tr>
<td>6</td>
<td>5th floor</td>
<td>5.0</td>
</tr>
<tr>
<td>7</td>
<td>6th floor</td>
<td>6.0</td>
</tr>
<tr>
<td>8</td>
<td>7th floor</td>
<td>7.0</td>
</tr>
<tr>
<td>9</td>
<td>8th floor</td>
<td>8.0</td>
</tr>
<tr>
<td>10</td>
<td>9th floor</td>
<td>9.0</td>
</tr>
<tr>
<td>11</td>
<td>10th floor</td>
<td>10.0</td>
</tr>
<tr>
<td>12</td>
<td>11th floor</td>
<td>11.0</td>
</tr>
</tbody>
</table>
Define Occupancy Obligations

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Attributes ➔ Occupancy Obligations for Accommodation Entitlement Certificate

**Purpose:** In this section, user defines which occupancy obligations a rental unit can have. The occupancy obligation specifies under which conditions a rental unit may be let. The occupancy obligation has to match the accommodation entitlement certificate specified for the applicant, that is, the application/rental request contains a list of the occupancy obligations for which the applicant owns a certificate.

![Change View "Occupancy obligation": Overview](image)

Define Reasons for different rent increase

**IMG Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Attributes ➔ Reasons for different rent increase

**Purpose:** In this step user defines reasons for alternative rent increases, which can be defined as attribute of the rental unit.

![Change View "Percentage rate increase differences": Overview](image)

Define Reasons for different rent increase

**MENU Path:** IMG ➔ Master Data ➔ Usage View ➔ Rental Object ➔ Attributes ➔ Account Determination Values

**Purpose:** In addition to account symbols, user can also define account determination values. User enters them in posting rules on the contract or rental object, and they control account determination for automatic postings.

![Change View "Account Determination Values": Overview](image)
Define Vacancy Reasons

**IMG Path:** IMG → Master Data → Usage View → Rental Object → Vacancy → Define Vacancy Reasons

**Purpose:** in this setting the user has to define the possible reasons why a rental object is vacant.

![Image of Reasons for Vacancy](image)

### Define Vacancy Reasons based on Vacancy Event

**IMG Path:** IMG → Master Data → Usage View → Rental Object → Vacancy → Determine Vacancy Reason Based on Vacancy Event

**Purpose:** The vacancy reason in the master data of a rental object explains the reason that the rental object is not occupied. User can enter the vacancy reason manually on the rental object.

However, the vacancy is usually caused by changes in the assigned occupancy contract. User can specify which changes to the occupancy contract result in which vacancy reasons on the rental object. User can still manually change a vacancy reason that was set automatically.

![Image of Default Vacancy Reason for Vacancy Events](image)

### Define Vacancy Reasons based on Notice period

**IMG Path:** IMG → Master Data → Usage View → Rental Object → Vacancy → Determine Vacancy Reason Based on Notice Reason

**Purpose:** When notice is given on a rental object, a notice reason has to be entered. For each notice reason, user has to specify which vacancy reason is set on the rental object when this notice reason is used.

![Image of Notice Reasons](image)
References

help.sap.com

For more information, visit the Enterprise Resource Planning homepage.
Disclaimer and Liability Notice

This document may discuss sample coding or other information that does not include SAP official interfaces and therefore is not supported by SAP. Changes made based on this information are not supported and can be overwritten during an upgrade.

SAP will not be held liable for any damages caused by using or misusing the information, code or methods suggested in this document, and anyone using these methods does so at his/her own risk.

SAP offers no guarantees and assumes no responsibility or liability of any type with respect to the content of this technical article or code sample, including any liability resulting from incompatibility between the content within this document and the materials and services offered by SAP. You agree that you will not hold, or seek to hold, SAP responsible or liable with respect to the content of this document.