Skip to Content
BW (SAP Business Warehouse)

FAQ - Business Explorer Suite: Platform Questions - General Platform Questions


Which BW 3.5 front-end versions can I use on top of NetWeaver BI 7.0?

  • You can use SAP GUI 6.20 with the latest BW 3.5 front-end patch to work with an SAP NetWeaver 7.0 System (only BW 3.5 front-end functionality). However 6.20 GUI is already out of standard maintenance.
  • You can also use SAP GUI 6.40 Comp 4 or higher and BW 3.5 front-end ('BW Add-in') (only BW 3.5 front-end functionality).
  • SAP NetWeaver 7.0 BI front-end is installed separately ('BI Add-in' on the installation CD).

For more information, please see SAP Notes 889314 and 147519.

Where can I get a good overview on the system landscape requirements for BEx Web in NetWeaver BI 7.0?

For more information, see the presentation SAP NetWeaver 7.0 BEx Web System Landscapes.

Where can I get a good overview of SAP NetWeaver 7.0 BI hardware & software requirements?

For more information, see SAP Note 893348.

What memory configuration do my front-end clients require to run SAP NetWeaver 7.0 Business Explorer?

For Windows XP, you should have a minimum of 384MB (recommendation: 512MB). For more information, see SAP Note 893348.

How can I find information about the possible platform and database combinations to install SAP NetWeaver BI for my customers?

Study the Platform Availability Matrix '/pam' in SAP Service Marketplace and choose NetWeaver 7.0 from the navigation tree to get current information about database and platform combinations.

Which Web Browsers are supported by SAP NetWeaver 7.0 BEx Web?

For BEx Web, we support Microsoft Internet Explorer as of version 6.x. As of SAP NetWeaver BI 7.0 SP7, we support Firefox as well.

For information about which Web browsers SAP NetWeaver supports, see the SAP NetWeaver Product Availability Matrix on SAP Service Marketplace.

For more information about browser support for NetWeaver, see SAP Note 893348.

Where can I find more information on the Federated Portal Concept?

Please check the following site: Content Sharing in SAP NetWeaver Portal.

Are there any known issues with the use of Firefox Browser with regards to BEx Web?

Yes, BEx Web only works if you switch off the 'Tabbed Browsing' Feature in Firefox. This issue is related to a bug in Mozilla Firefox. Every Firefox relase so far has this bug. SAP cannot provide a solution for this and has addressed the issue to the open source community. For details see SAP Note 1029680.

Which versions of Microsoft Windows & Office are supported by SAP NetWeaver 7.0 BI Business Explorer (BEx)?

  • BEx in SAP NetWeaver 7.0 supports MS Office 2003 and Office XP, SP2 (this includes Excel 2002) based on GUI 6.40.
  • BEx in SAP NetWeaver 7.0 supports MS Office 2003 based on Windows 2000/3, XP and on Windows Vista (since BI 7.0 ADDON FOR SAP GUI 7.10 Patch 1) for GUI 7.10.
  • BEx in SAP NetWeaver 7.0 supports MS Office 2007 based on Windows 2000/3, XP and on Windows Vista (since BI 7.0 ADDON FOR SAP GUI 7.10 Patch 1) for GUI 7.10.
  • BEx in SAP NetWeaver 7.0 supports MS Office XP (Excel 2002) based on Windows 2000/3, XP and on Windows Vista (as of BI 7.0 ADDON FOR SAP GUI 7.10 Patch 3) for GUI 7.10.

There is:

  • No support for NW 7.0 BEx Tools on MS Office 97
  • No support for NW 7.0 BEx Tools for Office 2007 in combination with GUI 6.40
  • No support for NW 7.0 BEx Tools for Vista in combination with GUI 6.40

For more information, see SAP Note 103174 and 1013140.

For the compatibility matrix click here.

For the Product Availability Matrix, click here.

For information regrading BEx 3.x & Vista please refer to note 1040856.

I am planning to use SAP NetWeaver 7.0. Which BEx frontend and SAP GUI should I use?

BI in SAP NetWeaver 7.0  requires SAP GUI 6.40 and Business Explorer. The Business Explorer is available in two different versions:

  • BW Add-On for Business Explorer (SAP BW 3.x)
  • BI Add-On for Business Explorer (SAP NetWeaver 7.0)

Only the Business Explorer for SAP NetWeaver 7.0  supports the new features (like BEx Report Designer). BEx Tools for SAP NetWeaver 7.0  are not downward-compatible but could coexist with BEx Tools for SAP BW 3.x side-by-side on one client PC.

Does the Business Explorer (BEx) Suite support any other platform but Microsoft Windows?

BEx components such as the Web Application Designer and the BEx Analyzer only support Microsoft Office on Microsoft Windows. However, end users can access the BEx Web Analyzer using a Web browser. They can also access SAP NetWeaver BI queries and Web applications using Web browsers running on multiple platforms.

How can I get the new SAP NetWeaver 7.0  BI front end?

The new SAP NetWeaver 7.0  BI front end is shipped automatically with the SAP NetWeaver 7.0  software shipments. Additionally, customers can order and install SAP NetWeaver 7.0  BI front end from the following CDs (can be ordered or downloaded from the SAP Service Marketplace):

SAP GUI 6.40 Compilation 4 or higher (includes both SAP GUI 6.40 and SAP NetWeaver 7.0  BI front end).

Is an upgrade to SAP GUI 6.40 for all my PC clients required to use SAP NetWeaver BI 7.0?

Yes. SAP NetWeaver 7.0  BI front end requires SAP GUI 6.40.

What options are available to upgrade my SAP 3.x BEx front end to SAP NetWeaver BI 7.0?

Install the BI add-on from the SAP GUI Compilation 4 (which includes SAP GUI 6.40 and SAP NetWeaver 7.0 BI front end Patch 0) and apply the latest patches.

Is SAP NetWeaver BI 7.0  BEx downward-compatible with previous SAP BW releases?

Yes. SAP NetWeaver 7.0  BI front end is downward-compatible to SAP BW 2.x, SAP BW 3.x, and SAP BW 3.50 systems because the previous version of the BEx tools are also installed.

The use of new SAP NetWeaver 7.0  BI functions is only possible with SAP NetWeaver 7.0  BEx tools. These SAP NetWeaver 7.0 BEx tools cannot be used in SAP BW 2.x, SAP BW 3.x, and SAP BW 3.50 systems.

How are front-end patches delivered for SAP NetWeaver 7.0 BI?

SAP BW front end-patches can be downloaded in the Software Distribution Center ->Download ->Support Packages and Patches ->Entry by Application Group ->SAP NetWeaver ->SAP NETWEAVER ->SAP NETWEAVER 2004s ->Entry by Component ->Business Explorer. You can choose between a GUI- and a GUI-less BEx Variant. For details please check note 1013139.

Is there a link between SAP BW 3.x front-end patches and SAP NetWeaver 7.0 BI front-end patches? Which SAP BW 3.x front-end patches and SAP NetWeaver 7.0 BI front-end patches contain the same corrections?

The front-end patches for SAP NetWeaver 7.0  BI front end and SAP BW 3.5 front end are delivered separately. They can be installed independently from each other. Therefore, there is no link between SAP BW 3.x front-end patches and SAP NetWeaver 7.0  BI front-end patches.

For dependencies between SAP NetWeaver 7.0  BI ABAP support packages and SAP NetWeaver 7.0  BI front-end patches, see SAP Note 879787.

Is there any dependency between SAP NetWeaver BI back-end support packages and front-end packages?

There are cases where SAP NetWeaver BI back-end functions are directly linked to SAP NetWeaver BI front-end functions. Such dependencies are documented in SAP Note 889315.

How long will SAP NetWeaver 7.0 BEx front end be supported?

SAP NetWeaver 7.0  BEx front end will be supported as long as SAP NetWeaver 7.0  is supported (Mainstream maintenance until March 2013. Extended maintenance until March 2016).

How long is SAP GUI 6.40 supported?

For more information, see SAP Note 147519.

Where can I find further front-end compatibility information?

For more information about front-end compatibilities, see BEx Compatibility of MS Operating Systems and Office Products.

Do I need additional licenses for the new BEx Web Printing solution?

No. Adobe Document Service technology is used. This is integrated into the SAP NetWeaver Application Server and included in the SAP NetWeaver licensing.

Where can I get preliminary sizing information on the SAP NetWeaver 7.0 BI Java stack?

SAP Note 927530 gives you rough sizing information on the Java stack, which is necessary for SAP NetWeaver BI stand-alone. Take this note into account until the official Quick Sizer for the BI Java stack is released.

If I want to use the 3.5 BEx tools on top of the SAP NetWeaver 7.0 BI server, where do I obtain them?

As of FEP 2 (of SAP NetWeaver BI 7.0 ), the BW 3.5 front-end tools are no longer included in the front-end patches. If you continue to use the old front-end tools, apply the corresponding front-end patches from the SAP NetWeaver 2004 stack (see also SAP Note 879787).

If you both toolsets, be sure to apply both SAP NetWeaver 2004 and SAP NetWeaver 7.0  front-end patches.

Former Member

No comments