Skip to Content

ANN: SAP GUI for Java 7.40 rev 4 available for download

Hi all,

SAP GUI for Java 7.40 rev 4 is now available for download.


Enhancements and New Features

  • Support for New OS Versions:
    • Fedora 22
    • Windows 10
  • Localization: Texts in dialogs coming from the Java runtime like confirmation and options dialogs are now translated the supported languages.
  • Modal Dialogs:
    • Sometimes the buttons in the toolbar of modal dialogs do not fit into the modal dialog with the size set by the backend. As a result buttons are cut off. Now the width of the dialog is increased to no longer truncate the toolbar content (except in those cases, where changing the dialog size would cause side effects).
  • Table Control:
    • It is now possible to open a context menu on the title and header area.

  Bugfixes

  • Rendering:
    • The usage of a faster drawing API of Java introduced in 7.40 rev 3 has caused some artefacts in various environments depending on the OS resp. Linux distribution, graphics card and driver. A workaround has been implemented without falling back to the slower performance of previous releases.
  • Enhanced Search:
    • While using the enhanced search, it could happen that the same text typed before was filled into another input field as well.
  • Signature Design:
    • Highlighted text in some places was hard to read because of using a wrong foreground color when a scheme other then the default was used.
  • TextEdit Control:
    • The sequence of ABAP calls SET_TEXT_AS_R3TABLE, GET_TEXT_AS_R3TABLE and again SET_TEXT_AS_R3TABLE in DEFINE code for the control CL_GUI_TEXTEDIT resulted in displaying an empty text.
  • Tree Control:
    • In a special situation, an exception has caused the control to no longer repaint and react to user input.
  • Blue Crystal:
    • Checkmark icons in menues have not been displayed.
    • Menu separators have been missing.


For details please refer to the manual (chapter "6.2 Release Notes and System Requirements" and "2. Installation") of the PlatinManual and SAP note 2059424.

Please use Java 8 Update 40 or newer, because some known issues related to the Html control component have been addressed.

Planning information

SAP GUI for Java 7.30 is no longer supported. Therefore please upgrade to SAP GUI for Java 7.40.

For migrating your landscape configuration, please refer to the SAP UI Landscape Configuration Guide.

Best regards

Rolf-Martin Wörsinger

P.S. For feedback and questions, please post a new thread.

In case you want to report an issue, preferably create a support message on component BC-FES-JAV.

No comments