Skip to Content

Preflight Checklist for Installing Lumira Server

Lumira Server 1.22

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 85)

1.0 SP8 (Rev 84)

1.0 SP8 (Rev 83)

1.0 SP8 (Rev 82)

Support for test and evaluation:

1.0 SP9 (Rev 91)

1.0 SP9 (Rev 90)

Yes
SAP HANA ClientSame as SAP HANAYes
SAP UAFL1.301Yes

SAP HANA Lifecycle Manager

(Optional, used with SAP SAL AFL)

1.0 SP7 (Latest patch recommended)

Yes

SAP SAL AFL

(NOT recommended.  Only for upgrade scenarios where UAFL is not an option.)

Note: UAFL and SAL AFL cannot co-exist.

Below revision should match that of HANA:

1.0 Rev 85 (Patch 0+)

1.0 Rev 84 (Patch 0+)

1.0 Rev 83 (Patch 1+)

1.0 Rev 82 (Patch 2+)

Yes
SAP Lumira Server1.22

No

SAP HOST AGENT

(Optional, used with SAP HANA Lifecycle Manager in command line install mode)

**

Latest version recommendedNo

Other HANA components (Optional)

***

Lumira Server 1.21

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 85)

1.0 SP8 (Rev 84)

1.0 SP8 (Rev 83)

1.0 SP8 (Rev 82)

Yes
SAP HANA Client (Recommended)Same as SAP HANAYes
SAP UAFL (Recommended)1.300Yes
SAP HANA Lifecycle Manager (Optional)1.0 SP7 (Latest patch recommended)

Yes

SAP SAL AFL (Alternative to UAFL)

Below revision should match that of HANA:

1.0 Rev 85 (Patch 0+)

1.0 Rev 84 (Patch 0+)

1.0 Rev 83 (Patch 1+)

1.0 Rev 82 (Patch 2+)

Yes
SAP Lumira Server1.21

No

SAP HOST AGENT (Optional)

**

Latest version recommendedNo

Other HANA components (Optional)

***

Lumira Server 1.20

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 84)

1.0 SP8 (Rev 83)

1.0 SP8 (Rev 82)

Yes
SAP HANA Lifecycle Manager1.0 SP7 (Latest patch recommended)

Yes

SAP SAL AFL

Below revision should match that of HANA:

1.0 Rev 84 (Patch 0+)

1.0 Rev 83 (Patch 1+)

1.0 Rev 82 (Patch 2+)

Yes
SAP Lumira Server1.20

No

SAP HOST AGENT

**

Latest version recommendedNo

Other HANA components

***

Lumira Server 1.19

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 82)

Yes
SAP HANA Lifecycle Manager1.0 SP7 (Latest patch recommended)

Yes

SAP SAL AFL1.0 Rev 82 (Patch 2+)

Yes
SAP Lumira Server1.19

No

SAP HOST AGENT

**

Latest version recommendedNo

Other HANA components

***

Lumira Server 1.18

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 82)

1.0 SP8 (Rev 81)

Yes
SAP HANA Lifecycle Manager1.0 SP7 (Latest patch recommended)

Yes

SAP SAL AFL

1.0 Rev 82 (Patch 0+) for HANA 1.0 SP8 (Rev 82)

1.0 Rev 81 (Patch 2+) for HANA 1.0 SP8 (Rev 81)

Yes
SAP Lumira Server1.18

No

SAP HOST AGENT

**

Latest version recommendedNo

SAP UI5

1.20.6Yes

Other HANA components

***

Lumira Server 1.17

Product / ComponentVersionDownload Path in SAP Service MarketplaceRequire File Extraction
SAP HANA StudioSame as SAP HANA

Yes

SAP HANA

(with XS Engine)

1.0 SP8 (Rev 80)

*

Yes
SAP HANA Lifecycle Manager1.0 SP7 (Patch 8 +)

Yes

SAP SAL AFL1.0 Rev 80 (Patch 1+)

Yes
SAP Lumira Server1.17

No

SAP HOST AGENT

**

Latest version recommendedNo

Other HANA components

***

* SAP HANA is also available from the path below (in .EXE and .RAR format), which contains the SAP HANA database server as well as many other software products/components including SAP HANA Lifecycle Manager and SAP HANA Studio.  However, it doesn't include SAP SAL AFL or SAP Lumira Server.


** SAP HOST AGENT is only required for certain scenarios (e.g. incrementally installing a SAP HANA Lifecycle Manager when an existing HANA database server is installed through the hdbsetup/hdbinst scripts and there's no existing SAP HOST AGENT on the system).

*** For upgrade installation from old versions of HANA, other newer versions of HANA components (e.g. SAP AFL) may also be required if those HANA components are installed on the old version of HANA.

Appendix: Check If a Product or Component Has Been Installed

If a SAP HANA Lifecycle Manager is available, use it to check installed product and component versions:

  • In SAP HANA Studio, right click the SID, then choose -> Lifecycle Management -> Platform Lifecycle Management -> SAP HANA lifecycle manager.
  • Click 'View Installed Products and Software Components'.

If a SAP HANA Lifecycle Manager is not available or doesn't work for you, use below methods:

Product / ComponentTo check if the product/component has been installed
SAP HANA Studio
  • To check the version, go to ->Help->About

SAP HANA
  • To check the version of HANA, run under account <SID>adm:

'/usr/sap/<SID>/HDB00/HDB version'

  • To check if there is a XS engine, visit:

http://<myhanaserver>:8000/sap/hana/xs/admin/

SAP HANA Lifecycle Manager
  • Run 'cat /hana/shared/<SID>/HLM/sapmanifest.mf'

SAP SAL AFL
  • Run 'ls -la /usr/sap/<SID>/HDB00/exe/plugins'

SAP HOST AGENT
  • Run './sapcontrol -nr 00 -function CheckHostAgent'

SAP Lumira Server
SAP UI5
  • Run 'select * from _sys_repo.delivery_units' in Hana Studio SQL console
SAP UAFL
  • In HANA Studio, right click on the instance, then select "Configuration and Monitoring" -> "Open Administration".  "SAP_AFL_SDK_UAL" should be listed besides "Installed Plug-ins".  Clicking on "Installed Plug-ins" should also reveal the version details.


Note: The above examples assume that the SID is 'QA1', the instance # is '00', and all components are on default install paths.  The <SID>, instance #, and paths in the commands might need to be adjusted to suit different environments.

Tags:
Former Member