Skip to Content
SAP NetWeaver Application Server

OCS package does not match the current software component vector

Tags:

While installing an ADD-ON or performing a SP Update, one often comes across the situation when:-

1.       1. One of more prerequisites haven’t been met properly

2.       2. There is equivalence level mismatch between source and target SP levels

Due to either of the above situations, you may come across –

ERROR: OCS package does not match the current software component vector

Error Encountered during Phase: SUM PREP_EXTENSION/ADDON_QCALC, PREP_EXTENSION/EHP_INCLUSION

SOLUTION:

For Case 1: Ensure that all the prerequisites are met and then repeat the phase.

For Case 2:  In case of a equivalence level mismatch between source and target SP levels, kindly cross check

the valid equivalence levels are met.  For more details, kindly refer

http://scn.sap.com/docs/DOC-49207

However, despite ensuring that equivalence level are fine, the issue persists.

In such cases, one needs to include the ACP (Attribute Change Package) for the component

into the underlying system (or generated stack xml file).

Despite the ACP file being included in STACK XML file, this error might still popup.

The reason for this is: The concerned ACP File is deleted (status - ‘D’) from ‘EPS/in’ directory.

SOLUTION:

     a.       Download the ACP file (.SAR) from SAP SMP and manually add it to EPS/in

     b.       Go to SPAM/SAINT --> Utilities --> Reload Package Attribute

     c.       Continue with the process.