Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

ORA-01031: insufficient privileges

Hi to all experts,

Whenever I run redo log backup in DB13, i will get the error message as below:

BR0002I BRARCHIVE 6.40 (15)

BR0006I Start of offline redo log processing: adyhdcwk.svd 2008-07-04 14.44.06

BR0280I BRARCHIVE time stamp: 2008-07-04 14.44.06

BR0301E SQL error -1031 at location BrInitOraCreate-2

ORA-01031: insufficient privileges

BR0303E Determination of RDBMS version failed

BR0007I End of offline redo log processing: adyhdcwk.svd 2008-07-04 14.44.06

BR0280I BRARCHIVE time stamp: 2008-07-04 14.44.06

BR0005I BRARCHIVE terminated with errors

Does anyone can help me?

Thanks a lot.

BR,

Nancy

replied

Hi Nancy,

I believe that your privileges in Oracle was set correctly as I can observed from previous statement.

It might be due to permission of BR* executable file in exe directory which caused failed to call oracle via CCMS Agent (DB13).

Could you please check the following permission accordingly?

-rwsr-srw- 1 oraid1 dba 3203221 Jul 4 16:33 brarchive

-rwsr-srw- 1 oraid1 dba 3298276 Jul 4 16:33 brbackup

[https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/oss_notes/sdn_oss_bc_db/form/handler%7B5f4150503d3030323030363832353030303030303031393732265f4556454e543d444953504c4159265f4e4e554d3d373736353035%7D|https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/oss_notes/sdn_oss_bc_db/form/handler%7B5f4150503d3030323030363832353030303030303031393732265f4556454e543d444953504c4159265f4e4e554d3d373736353035%7D]

Please apply the following solution if there was mismatch of the exe file

su - root

cd /usr/sap/<SAPSID>/SYS/exe/run

chgrp dba brbackup brarchive

chmod 6756 brbackup brarchive

*The authorization **6 should prevent just anyone being able to start an offline backup, which could disrupt the availability of the SAP system. At the same time, make sure that the user <sapsid>adm can still overwrite the tools (during an upgrade for example).

The system must have the following: BRTools 6.40 Patch-Level 32 or higher.*

Please let me know if any concern.

Hope this would help.

BR,

Terry

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question