Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

CONNECT failed with sql error '1017'

Hello,

I have installed ECC 6.0 and getting below error in R3trans -x :

Oracle database is started.

isrqserver:prqadm 5> R3trans -x

This is R3trans version 6.14 (release 700 - 10.09.07 - 09:57:00).

unicode enabled version

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'PRQ'"

R3trans finished (0012).

********

4 ETW000 R3trans version 6.14 (release 700 - 10.09.07 - 09:57:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 10.06.2008 - 12:54:22

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -x

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Tue Jun 10 12:54:22 2008 87 0.000087

4 ETW000 [dev trc ,00000] db_con_init called 20 0.000107

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 48 0.000155

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/PRQ/SYS/exe/run/dboraslib.o' ...

4 ETW000 52 0.000207

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/PRQ/SYS/exe/run/dboraslib.o), hdl 0

4 ETW000 4600 0.004807

4 ETW000 [dev trc ,00000] Library '/usr/sap/PRQ/SYS/exe/run/dboraslib.o' loaded

4 ETW000 30 0.004837

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/PRQ/SYS/exe/run/dboraslib.o

4 ETW000 35 0.004872

4 ETW000 [dev trc ,00000] Version of '/usr/sap/PRQ/SYS/exe/run/dboraslib.o' is "700.08", patchlevel (0.115)

4 ETW000 292 0.005164

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/PRQ/SYS/exe/run/dboraslib.o

4 ETW000 34 0.005198

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/PRQ/SYS/exe/run/dboraslib.o

4 ETW000 55 0.005253

4 ETW000 [dev trc ,00000] New connection 0 created 24 0.005277

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 2

55, con_opt = 255, occ = NO

4 ETW000 40 0.005317

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 43 0.005360

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 31 0.005391

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 25

5, con_opt = 255, occ = NO

4 ETW000 37 0.005428

4 ETW000 [dev trc ,00000] Got LIBPATH=/usr/lib:/lib:/usr/sap/PRQ/SYS/exe/run:/oracle/client/10x_64/instantclient from environment

4 ETW000 387 0.005815

4 ETW000 [dev trc ,00000] Oracle Client Version: '10.2.0.2.0' 54 0.005869

4 ETW000 [dev trc ,00000] -->oci_initialize (con_hdl=0) 21 0.005890

4 ETW000 [dev trc ,00000] Client NLS settings: AMERICAN_AMERICA.UTF8 1765 0.007655

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPSR3's password 23 0.007678

4 ETW000 [dev trc ,00000] Connecting as /@PRQ on connection 0 (nls_hdl 0) ... (dbsl 700 250407)

4 ETW000 32 0.007710

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 37 0.007747

4 ETW000 [dev trc ,00000] 0 UTF8 1 0x110fabc00 0x110fc4078 0x110fc3928

4 ETW000 44 0.007791

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 28 0.007819

4 ETW000 [dev trc ,00000] Allocating server context handle 21 0.007840

4 ETW000 [dev trc ,00000] Attaching to DB Server PRQ (con_hdl=0,svchp=0x110fc7218,srvhp=0x110fc7438)

4 ETW000 65 0.007905

4 ETW000 [dev trc ,00000] Assigning server context 0x110fc7438 to service context 0x110fc7218

4 ETW000 40409 0.048314

4 ETW000 [dev trc ,00000] Allocating user session handle 33 0.048347

4 ETW000 [dev trc ,00000] Starting user session (con_hdl=0,svchp=0x110fc7218,srvhp=0x110fc7438,usrhp=0x110fb39e0)

4 ETW000 41 0.048388

4 ETW000 [dev trc ,00000] Assigning user session 0x110fb39e0 to service context 0x110fc7218

4 ETW000 8566 0.056954

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_MODULE (:A0, :A1); END;

4 ETW000 53 0.057007

4 ETW000 [dev trc ,00000] BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO (:A0); END;

4 ETW000 83 0.057090

4 ETW000 [dev trc ,00000] Now '/@PRQ' is connected (con_hdl 0, nls_hdl 0).

4 ETW000 638 0.057728

4 ETW000 [dev trc ,00000] ALTER SESSION SET NLS_SORT = BINARY

4 ETW000 39 0.057767

4 ETW000 [dev trc ,00000] SELECT USERID, PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)

4 ETW000 283 0.058050

4 ETW000 [dev trc ,00000] Got SAPSR3's password from OPS$-user 506 0.058556

4 ETW000 [dev trc ,00000] Disconnecting from connection 0 ... 21 0.058577

4 ETW000 [dev trc ,00000] Rolling back transaction ... 33 0.058610

4 ETW000 [dev trc ,00000] Closing user session (con_hdl=0,svchp=0x110fc7218,usrhp=0x110fb39e0)

4 ETW000 130 0.058740

4 ETW000 [dev trc ,00000] Now I'm disconnected from ORACLE 416 0.059156

4 ETW000 [dev trc ,00000] Connecting as SAPSR3/<pwd>@PRQ on connection 0 (nls_hdl 0) ... (dbsl 700 250407)

4 ETW000 36 0.059192

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 35 0.059227

4 ETW000 [dev trc ,00000] 0 UTF8 1 0x110fabc00 0x110fc4078 0x110fc3928

4 ETW000 35 0.059262

4 ETW000 [dev trc ,00000] Assigning username to user session 0x110fb39e0 20 0.059282

4 ETW000 [dev trc ,00000] Assigning password to user session 0x110fb39e0 23 0.059305

4 ETW000 [dev trc ,00000] Starting user session (con_hdl=0,svchp=0x110fc7218,srvhp=0x110fc7438,usrhp=0x110fb39e0)

4 ETW000 47 0.059352

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCISessionBegin' failed with rc=1017

4 ETW000 1661 0.061013

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '1017'

4 ETW000 33 0.061046

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 1017 19 0.061065

4 ETW000 [dblink ,00431] ***LOG BY2=>sql error 1017 performing CON [dblink#5 @ 431]

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'PRQ'"

*************************

Pls help

Regards,

Ankita.

replied

Hello Ankita,

First to say that the OPS$ user seems to be properly configured as it connects without problems and it is able to read the SAPUSER table to get the password for the SAP user:

> 4 ETW000 dev trc ,00000 Got SAPSR3's password from OPS$-user 506 0.058556

but using this password fails.

Reason: The password for this user has been changed using ORACLE tools.

That is wrong, if you do so then you get this problem.

If you want to change the password for the SAP user then you must use SAP tools (BRCONNECT):

brconnect -u system/<syst_pwd> -f chpass -o sap<sid> -p <new_sap_pwd>

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question