Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

OPatch failed with error code 74

- What can I do to fix this error when applying an Oracle patch for 10.2.0..2 on HP-UX B11.11 64 Bits.

- I get this error when applying all patches.

This is the screen shot.

dr3dvqa:orau3d 103> cd /oracle/stage/102_64/patches/5063279; opatch apply -force

Invoking OPatch 10.2.0.2.5

Oracle Interim Patch Installer version 10.2.0.2.5

Copyright (c) 2007, Oracle Corporation. All rights reserved.

Oracle Home : /oracle/U3D/102_64

Central Inventory : /oracle/oraInventoryU3D

from : /var/opt/oracle/oraInst.loc

OPatch version : 10.2.0.2.5

OUI version : 10.2.0.2.0

OUI location : /oracle/U3D/102_64/oui

Log file location : /oracle/U3D/102_64/cfgtoollogs/opatch/opatch2008-03-04_16-08-50PM.log

ApplySession applying interim patch '5063279' to OH '/oracle/U3D/102_64'

Interim patch 5063279 is a superset of the patch(es) [ 5063279 ] in OH /oracle/U3D/102_64

OPatch will rollback the subset patches and apply the given patch.

Running prerequisite checks...

Prerequisite check "CheckRollbackable" on auto-rollback patches failed.

The details are:

Patch 5063279:

Archive Action: Source file "/oracle/U3D/102_64/.patch_storage/5063279_Nov_28_2006_04_15_32/files/lib/libserver10.a/kdibl.o" does not exist.

'oracle.rdbms, 10.2.0.2.0': Cannot update file '/oracle/U3D/102_64/lib/libserver10.a' with '/kdibl.o'

ApplySession failed during prerequisite checks: Prerequisite check "CheckRollbackable" on auto-rollback patches failed.

System intact, OPatch will not attempt to restore the system

-


The following warnings have occurred during OPatch execution:

1) OUI-67078:Interim patch 5063279 is a superset of the patch(es) [ 5063279 ] in OH /oracle/U3D/102_64

-


OPatch failed with error code 74

Former Member
replied

you best bet:

uninstall Oracle completely. delete all traces of it, then install Oracle 10.2.0.1, patch it to 10.2.0.2 and install all additional needed patches.

I know this will take a lot of time, but deleting the patch_storage directly screwed up your oracle patch installation and my solution is the cleanest way of fixing it.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question