Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

NetWeaver 04s: JSP and Servlet versions

Hi Experts,

I need to know if a Web application requiring JSP 2.0 and Servlet 2.4, which runs fine under Apache Tomcat 5.5.x, can be deployed on "SAP NetWeaver 04s".

I'm asking this because I'm having difficulties in finding the exact J2EE version supported by NetWeaver 04s (and therefore the supported JSP and Servlet versions).

Thanks in advance


Hi Aldo,

First, welcome to SDN!

SAP NetWeaver 7.0 (formerly known as NetWeaver 04s) is J2EE 1.3 compatible. JSP 2.0 and Servlet 2.4 are part of J2EE 1.4. However, you can run your web app on [original link is broken] [original link is broken] which is fully Java EE 5 compatible and also supports all previous J2EE versions.


-- Vladimir

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question