Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error by installing SolMan 4.0 on Wind x64/Oracle - Phase ABAP Inport

Hello,

I'm trying to install Solution Manager on a 2GB Virtual Machine with Windows 2003 x64 and Oracle 10.2.0.2. The installation stops by the ABAP Import:

The Log File SAPAPPL2.log ends with:

(DB) INFO: MOB_DEVCFG created #20151127222241

(IMP) INFO: import of MOB_DEVCFG completed (96 rows) #20151127222241

(DB) INFO: MOB_DEVCFG~0 created #20151127222241

(DB) INFO: MOB_DEVPFE created #20151127222241

(IMP) INFO: import of MOB_DEVPFE completed (50 rows) #20151127222241

DbSl Trace: Error 604 in exec_immediate() from oci_execute_stmt(), orpc=0

DbSl Trace: ORA-604 occurred when executing SQL stmt (parse error offset=0)

(DB) ERROR: DDL statement failed
 ( ALTER INDEX "MOB_DEVPFE~0" LOGGING )
 DbSlExecute: rc = 99
  (SQL error 604)
  error message returned by DbSl:
ORA-00604: error occurred at recursive SQL level 3
ORA-04031: unable to allocate 4136 bytes of shared memory ("shared pool","select i.obj#,i.ts#,i.file#,...","Typecheck","seg:kggfaAllocSeg")
(DB) INFO: disconnected from DB

C:usrsapSM0SYSexeucNTAMD64R3load.exe: job finished with 1 error(s)
C:usrsapSM0SYSexeucNTAMD64R3load.exe: END OF LOG: 20151127222242

I tried to decrease the parallel processes from 3 to 1 and I increased the variable shared_pool_size in the file init.ora from 67MB (proposed by the installer) to 350MB, but I get the same error.

Any idea?

Thanks and best wishes,

Tommaso

Former Member
Former Member replied

Hi,

As you already stated.

You don't have enough memory in the Oracle shared pool due to:

1) The shared pool may be fragmented

2) You really don't have enough space

You may be able to get pass this specific error by manually flushing the pool and then retrying the sapinst phase.

sqlplus / as sysdba

alter system flush shared_pool;

If that doesn't work you can generally increase your shared_pool on the fly:

1) decrease your db buffer cache

alter system set db_cache_size = new_sizem (new_sizem would be 500m for 500 mb)

2) alter system set shared_pool_size - new_sizem;

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question