Archived discussions are read-only. Learn more about SAP Q&A

Error: java.lang.NoClassDefFoundError: com/sap/mw/jco/JCO$Exception

hi, all,

Now I'm facing a problem that the J2ee Server node could not start.

The system is a double stack on SunOS while R3 runs fine.

Looking into std_server0.out, I found the following error msg:

Core service com.sap.security.core.ume.service failed. J2EE Engine cannot be s

tarted.

java.lang.NoClassDefFoundError: com/sap/mw/jco/JCO$Exception

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:219)

at com.sap.security.core.persistence.datasource.imp.r3persistence.R3JC

oProxy.getInstance(R3JCoProxy.java:81)

at com.sap.security.core.persistence.datasource.imp.R3PersistenceBase.

doInitRfc(R3PersistenceBase.java:684)

at com.sap.security.core.persistence.datasource.imp.R3Persistence.loca

lInitialization(R3Persistence.java:277)

at com.sap.security.core.persistence.datasource.imp.R3PersistenceBase.

init(R3PersistenceBase.java:424)

at com.sap.security.core.persistence.imp.PrincipalDatabagFactoryInstan

ce.<init>(PrincipalDatabagFactoryInstance.java:357)

at com.sap.security.core.persistence.imp.PrincipalDatabagFactory.newIn

stance(PrincipalDatabagFactory.java:156)

at com.sap.security.core.persistence.imp.PrincipalDatabagFactory.getIn

stance(PrincipalDatabagFactory.java:109)

at com.sap.security.core.persistence.imp.PrincipalDatabagFactory.getIn

stance(PrincipalDatabagFactory.java:56)

at com.sap.security.core.InternalUMFactory.initializeUME(InternalUMFac

tory.java:270)

at com.sap.security.core.server.ume.service.UMEServiceFrame.start(UMES

erviceFrame.java:295)

at com.sap.engine.frame.ApplicationFrameAdaptor.start(ApplicationFrame

Adaptor.java:31)

at com.sap.engine.core.service630.container.ServiceRunner.startApplica

tionServiceFrame(ServiceRunner.java:214)

at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceR

unner.java:144)

at com.sap.engine.frame.core.thread.Task.run(Task.java:64)

at com.sap.engine.core.thread.impl5.SingleThread.execute(SingleThread.

java:79)

at com.sap.engine.core.thread.impl5.SingleThread.run(SingleThread.java

:105)

Could anyone pls tell me what is going on there and how shall I get the j2ee server

run again?

Any help is highly appreciated, thanks!

best regards,

Zhichao

  • SAP Employee

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question