Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Edit Problem after changing and transporting a table view

Hallo Experts,

I hope you can help me.

I changed a Z-table in the Data Dictionary. For this table there exists an Tableview.

After I added three new fields I generate a new tableview:

Utilities -> table maintenance generator

Change -> create maintenance screen -> ok

after this I optimized the layout of the screen.

On our Enviromentsystem my Tableview works perfect.

I can make changes in the table.

Then I transported the new tableview to our testsystem.

There I started the sm30 "Maintain table view" and tried to change table entries.

After a click on "Maintain" the following Message appears:

TK 730 Changes to Repository or cross-client Customizing are not permitted.

The strangest thing is, that before my transport, it worked, I could change table entries.

There were no changes on the userrights.

And I can change a similar table on the testsystem.

I compared the properties of both tables. But I could not find a difference.

Have anybody an idea where the error can be?

Former Member
Not what you were looking for? View more on this topic or Ask a question