Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAPXPG Problems

Hi Experts,

OS: Linux RH4AS (x86_64)

SAP SRM 5.0, DB - Oracle

My jobs in DB13 currently are failing with the following error:

SXPG_COMMAND_EXECUTE failed for BRCONNECT - Reason: x_error

I am using a distributed environment with a standalone DB on one server and the CI on another server. I do <b>NOT</b> have a standalone gateway on the DB server and am trying to connect using remote calls. I have set the parameter gw/remsh to ssh.

What Works:

ssh between both servers have been setup and I can successfully test this from the OS level.

The <sid>adm user is setup on both servers with the same shell and permissions and I can access the DB server through ssh and run brtools functions.

The SAPDBHOST has been specified with the DB Server.

I have created an entry in SM69 for ssh and tested with SM49 successfully. Eg: If I pass the parameter ls -l, it returns with the list of files present.

/usr/bin/ssh -q srmdtst01 ls -al -


/usr/bin/ssh -q srmdtst01 sapxpg ls -al -- Does NOT work.

What Does NOT Work:

SAPXPG when run with the above entry in SM69 returns nothing, which according to note 446172 is supposed to mean that everything is all right. But RFC SAPXPG_DBDEST_<DBSERVER> also fails the connection test. I've got Activation type in the RFC set to "Start on Explicit Host" and have even provided the full path to sapxpg on the DB Server. The RFC connection test fails with a "timeout during allocate".

What should I set the "start type of External Program" to in the RFC? Its currently set to Default Gateway Value but I've tried all the other options and it still fails.

Any other ideas on why sapxpg fails to start?


Chengappa Ballachanda

Former Member
Former Member replied

Problem was that the server name was not fully qualified in the ssh known hosts file. This caused a "host key verification" failure causing the RFC to fail.



2 View this answer in context
Not what you were looking for? View more on this topic or Ask a question