Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

TREX 7.0 - SAP RFC Connection cannot register TREX_XXX_XXXXX Program ID

Hello All

In SAP ECC running in Windows, I test the RFC connection created by TREXAdmin using the SM59 RFC Test Connection.

It gives the error the PROGRAM ID TREX_XXX_XXXXXXXX cannot register in the SAP GW - that communicates with a TREX Server process TREXRfcServer.exe.

I verify that for some reason the TREXRfcServer process is not running at the TREX Server machine.

Everytime I stop/start the TREX service, it does not go up, although it has been configured and worked before.

I've done already a restart to the machine and the situation stills the same.

I've checked the RFCServer.ini and the TREXDeamon.ini and even set the TREX_XXXX_XXXXXX Program ID in a section of this file with the right parameters to check if by stop/start the TREX service it goes UP, but it doesn't worked...

I think now, it is a problem in the SAP GW but it is also related with the TREX RFC Server process.

I tried to register the PROGRAM ID in the SAP GW (Trex_XXXX_XXXXXXXX) on the machine that uses this GW, however I think because the process TREXRfcServer.exe is not running, that's why the command rfcexec this process fails.

In my case when trying to register, it do not finnishes and I've to End the Process in the Task Mgr of the Windows Server.

I run the ..TREX..EXEpython and it gives errors on the HTTP service which I think is not use for the RFC connections to the ECC system.

Does someone is experiencing the same issue or know a solution to this problem ?

Do someone know if I have to install the TREX 7.0 again with this kind of behaviour ?

Kind Regards

Sílvia C.

Former Member
Not what you were looking for? View more on this topic or Ask a question