Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Remove ns1: namespace prefix in HTTP adapter

Dear Experts,

I'm facing the following issue, using the plain HTTP receiver adapter:

when I'm sending out my XML message, the "usual" ns1: namespace prefixes are added to the message.

It goes out like this:

<?xml version="1.0" encoding="UTF-8"?>

<ns1:INQUIRY xmlns:ns1="">






And it should be like this:

<?xml version="1.0" encoding="UTF-8"?>

<INQUIRY xmlns:ns1="">






In previous forum-threads, there are several proposed solutions:

1. using the XMLAnonymizerBean

It doesn't work here, because in plain HTTP I cannot call up any module processor (it doesn't go through the AE)

2. using XSLT to remove the complete namespace

It is not good, because I have to keep the namesapce, but without the ns1 prefixes

So, the question to you is: how to delete only(!) the ns1 prefixes, keeping the original namespace in the message.

Any comments are welcome!

Best regards,

Andras Kovacs


> - Use SOAP adapter instead of plain HTTP: it worked

> quite well and I could remove the prefix with the

> XMLAnonymizer Bean!

> Here you mentioned that it can called up in "no SOAP

> mode". Do you mean here check in the "don't use SOAP

> envelope" checkbox or is it something more?

Yes, that is right. I was not aware how this check box is called.



0 View this answer in context

Helpful Answer

Not what you were looking for? View more on this topic or Ask a question