Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem Executing Oracle Stored Procedure

I have a Oracle Stored procedure with one input parameter and no out parametres.

The procedure contains a cursor which is fetching data obtained after joining 3 tables and i am inserting the data from cursor into some table. the stored procedure is not outputting anything.

When i execute the procedure in Query template like this

<b>execute myproc('xyz')</b>

it flashed the

following error

<b>"A SQL Error has occurred on query, ORA-00900: invalid SQL statement" </b>

as suggested in earlier thread i used FixedQueryWithOutput mode but the same error. I also used Command and Fixed modes but it flashed the same error.

But when i execute the procedure in SQL*Plus it works fine.

Somebody please help me out with this.



please call the procedure like this

CALL Stored_Proc_Name('[Param.1]','[Param.2]',:x)

here Param.1 and param.2 are input for the procedure and x is the output param



0 View this answer in context

Helpful Answer

Not what you were looking for? View more on this topic or Ask a question