Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Implicit Enhancement for Data Declaration

Hello all,

I want to add one more field at the data declaration level.

I am following below steps :

1) I went to report and clicked on 'Enhance' button.

2) Then I went to Edit->Enhance Operations->Show Implicit Enhancement Options

3) Then I went to the Data Declaration section and right clicked and choose 'Enhancement Implementation'->Create.

4) Then I declared my variable.

5) When I checked the syntax, it gave me error.

Below is the piece of code.


data: begin of austab occurs 100,

ikone TYPE c,

lgtyp like lagp-lgtyp,

lgpla like lagp-lgpla,

kreuz type c, "ind. to be invented

kzpmi type c, "ind. Plus Minus Initial

idatu like lagp-idatu,

werks like lqua-werks,

matnr like lqua-matnr,

charg like lqua-charg,

flg_aktiv type c, "ind.

nidat like lagp-idatu, "New Inventory date

ttext(25) type c, "Textfield

sperr type c, "ind. blocked due to transfer

kzmmq type c, "ind. bin with several quants

iverz(1) type c,

linno like sy-linno,

pagno like sy-pagno,

lqnum like lqua-lqnum, "new

lgnum like lqua-lgnum, "new

plpos like lqua-plpos, "new

""""""""*""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""$"$\SE:(7 ) Struct. AUSTAB, End S

$$-Start: (7 )----



abcin type abcin,


$$-End: (7 )----


end of austab.


The error I am getting is "Comma without preceding colon (after ABCIN ?).

Please help me out in solving this .



Not what you were looking for? View more on this topic or Ask a question