Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Strange JCO error when running Web Dynpro App

I am developing a new WebDynpro application to be deployed on our SAP

Portal interfacing with a SAP R/3 backend. The application uses

multiple JCo destinations (two for each model) all of which were

configured according the SAP guides (userid/password for metadata and

ticket for model data). The tests work fine for all connections.

However, we get HTTP 500 errors when executing the application. The

main message is : "com.sap.mw.jco.JCO$Exception: (101)

RFC_ERROR_PROGRAM: 'password' missing".

I have not been able to find anything to help and SAP themselves have yet to provide us an explanation.

- I was able to run the application fine in dev and it worked with this error occasionally appeared but now it always appears.

- Our portal is 2004s SP 10

- All of the JCOs are configured properly as per SAP instructions

- modeldata use SSO with user configured in R/3

- metadata use userid/password

- Another prototype Web Dynpro application has the same error.

- All of the Web Dynpro models are Adaptave RFC.

Any ideas would be greatly appreciated.

Former Member
Not what you were looking for? View more on this topic or Ask a question