Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

testing database connection error during XI installation phase,urgent!!!

Dear expert,

windows server 2003 enterprise edition, Oracle 10g, PI 7.1 (netweaver 2004s sr2)

when the XI installation is at phase 19 of 95, the error is occurs at testing database connection.

here is sapinst.log:

INFO 2007-10-09 16:08:00

Copied file 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/inifile.xml' to 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/inifile.2.xml'.

INFO 2007-10-09 16:08:00

Copied file 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/inifile.xml' to 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/inifile.3.xml'.

INFO 2007-10-09 16:08:11

Execute step

Component W2K_ServicePack_Check|ind|ind|ind|ind

Preprocess of component |NW_Onehost|ind|ind|ind|ind|0|0|NW_First_Steps|ind|ind|ind|ind|0|0|W2K_ServicePack_Check|ind|ind|ind|ind|2|0.

INFO 2007-10-09 16:08:34

Copied file 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/keydb.xml' to 'C:/Program Files/sapinst_instdir/NW04S/SYSTEM/ORA/CENTRAL/AS/keydb.2.xml'.

INFO 2007-10-09 16:08:34

Execute step testDatabaseConnection of component |NW_Onehost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_CreateDBandLoad|ind|ind|ind|ind|10|0|NW_ABAP_Import_Dialog|ind|ind|ind|ind|5|0|NW_ABAP_Import|ind|ind|ind|ind|0|0.

INFO 2007-10-09 16:08:39

Switched to user: xi0adm.

INFO 2007-10-09 16:08:39

Creating file C:\Program Files\sapinst_instdir\NW04S\SYSTEM\ORA\CENTRAL\AS\R3load.exe.log.

INFO 2007-10-09 16:08:39

Switched to user: xi0adm.

INFO 2007-10-09 16:08:39

Working directory changed to C:\Program Files\sapinst_instdir\NW04S\SYSTEM\ORA\CENTRAL\AS.

INFO 2007-10-09 16:08:39

Output of E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe -testconnect is written to the logfile R3load.exe.log.

WARNING 2007-10-09 16:08:43

Execution of the command "E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe -testconnect" finished with return code 2. Output:

sapparam: sapargv( argc, argv) has not been called.

sapparam(1c): No Profile used.

sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: START OF LOG: 20071009160839

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: sccsid @(#) $Id: //bas/700_REL/src/R3ld/R3load/R3ldmain.c#8 $ SAP

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: version R7.00/V1.4 [UNICODE]

Compiled Sep 1 2006 00:38:35

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe -testconnect

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

(DB) ERROR: db_connect rc = 256

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

(DB) ERROR: DbSlErrorMsg rc = 99

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: job finished with 1 error(s)

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: END OF LOG: 20071009160843

ERROR 2007-10-09 16:08:43

CJS-30023 Process call 'E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe -testconnect' exits with error code 2. For details see log file(s) R3load.exe.log.

ERROR 2007-10-09 16:08:43

FCO-00011 The step testDatabaseConnection with step key |NW_Onehost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_CreateDBandLoad|ind|ind|ind|ind|10|0|NW_ABAP_Import_Dialog|ind|ind|ind|ind|5|0|NW_ABAP_Import|ind|ind|ind|ind|0|0|testDatabaseConnection was executed with status ERROR .

And here is r3load.exe.log:

sapparam: sapargv( argc, argv) has not been called.

sapparam(1c): No Profile used.

sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: START OF LOG: 20071009150726

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: sccsid @(#) $Id: //bas/700_REL/src/R3ld/R3load/R3ldmain.c#8 $ SAP

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: version R7.00/V1.4 [UNICODE]

Compiled Sep 1 2006 00:38:35

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe -testconnect

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

(DB) ERROR: db_connect rc = 256

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12541

DbSl Trace: CONNECT failed with sql error '12541'

(DB) ERROR: DbSlErrorMsg rc = 99

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: job finished with 1 error(s)

E:\usr\sap\XI0\SYS\exe\uc\NTI386\R3load.exe: END OF LOG: 20071009150731

Appriciate for your help!!!

Many Thanks!

Former Member
Not what you were looking for? View more on this topic or Ask a question