Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Visual Administrator problem in 6.40 SP22 problem

Hello,

I was not sure in which forum exactly to ask, so if the post is not for here, please let me know.

We have some problems using VA in 6.40 installation SP22 (SP_REL CW37).

After the logon only the cluster nodes can be seen but without anything else inside them.

In the logs there is the following exception (this is part of it):

java.rmi.RemoteException: Error while getting cluster node subtree of

:name=ClusterNodeRepresentative,j2eeType=com.sap.e

ngine.services.adminadapter.impl.ClusterNodeRepresentative

,SAP_J2EEClusterNode=46786850,SAP_J2EECluster=""; nested excep

tion is:

javax.management.ReflectionException: Cannot invoke getter or

setter (getClusterNodeMBeanSubTree) as operation u

nless jmx.invoke.getters property is set

at com.sap.engine.services.adminadapter.impl.ConvenienceEngineAd

ministratorImpl.getClusterNodeSubTree(Convenienc

eEngineAdministratorImpl.java:258)

at com.sap.engine.services.adminadapter.impl.ConvenienceEngineAd

ministratorImplp4_Skel.dispatch(ConvenienceEngin

eAdministratorImplp4_Skel.java:99)

at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(Disp

atchImpl.java:319)

...

First (because of our previous experience) I thought that the problem was with the JDK version (it was 1.5 sth...) (actually the JMX implementation in it), but after we tried with 1.4.2 the problem still exists.

Maybe there is a problem with this SP? I don't have a clue.

Thanks,

Dimitar

Former Member
Not what you were looking for? View more on this topic or Ask a question