Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

brbackup fails with error 23 after running 2 hours

Hello,

we are facing a strange problem with brbackup.

The backup (online/offline) always fails after running 2 hours with message "EXIT STATUS 23: socket read failed"

It isn't depending on special datafiles, just on the runtime. Dividing the backup in several streams to get a less runtime solved the problem for a while. But the database became larger and since some days the 2 hours runtime were reached again - and the backups are failing.

File backups for these servers were completed successfully, in spite of their runtime, which is mostly more than 2 hours. It just concerns brbackup.

We are using Veritas Netbackup 5.1 MP4.

I already set the debug level to highest value, but the logs are containing the error message without a hint on the cause...

I also tried increazing all possible client timeout settings in the Netbackup configuration but this just had the effect to keep the already failed brbackup session in status running in the Netbackup monitor until the time out had been reached.

There are also some other servers in the same backup cell, running SAP backups by brbackup which were completed successfully. I compaired their Netbackup installation/configuration and found no difference (except client name and SID of course).

Now I wonder, if there is any possibility for timeout entries in the SAP configuration or SAP gateway, which is responsible for such backup aborts...

I am afraid to be "no SAP guru" - so I hope to find some help here...

Many thanks in advance!!!!

ml

Former Member
Not what you were looking for? View more on this topic or Ask a question