Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Generic extractor and an append structure

Hi all,

this system is driving me crazy. So, that's something worked in former times..

I created an generic extractor on VEKP. I have not restricted to any selection criteria or hide any field. The system generated the extractor and everything is fine. THEN I created an append on the generic extractor and put different fields inside the append. I want (and this works) to fill this different field via user exit for extraction. All field in the append are having the prefix ZZ, all field are characteristic and there is no inconsistency in the append. I activated the append.

AND NOW - none of the fields of the append is available in RSA6 to hide or none hide or do anything. They are not available. By checking with SE11 on the generated structure - all field including the append are there.

We are on ECC 5.0 with PI 2004.1 for 5.0 SP 10.

Can anyone help. As i told you, this worked in former times (with SAP 4.6C with PI 2004.1 or lower).

Regards

OJ

Former Member
Not what you were looking for? View more on this topic or Ask a question