Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SOAP Fault uncompleted

Hello experts,

I'm having a problem in a RFC->SOAP synchronous scenario. Using XPI Inspector I managed to the the SOAP Fault message the target system is returning:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

    <soapenv:Body xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" wsu:Id="id-1580306328">

        <soapenv:Fault>

            <faultcode>errorcode</faultcode>

            <faultstring>message</faultstring>

            <detail>

                <Attributes>

                    <field1>value1</field1>

                    <field2>value2</field2>

                    <field3>value3</field3>

                </Attributes>

            </detail>

        </soapenv:Fault>

    </soapenv:Body>

</soapenv:Envelope>

Unfortunately what I get in SXMB_MONI and in the Message Maping is not the previous message, but a partial message of the message:

<?xml version="1.0"?>

<Attributes>

                    <field1>value1</field1>

                    <field2>value2</field2>

                    <field3>value3</field3>

</Attributes>

I have tried the parameters XMBWS.NoSOAPIgnoreStatusCode and noSOAPMakeSysErrFromResponseFault but it didn't work.

Any ideas how can I get the full message?

Regards,

Tags:
Former Member replied

Hi

The soap adapter will retrieve the fault message from detail tag.

<soapenv:Fault>

            <faultcode>errorcode</faultcode>

            <faultstring>message</faultstring>

           <detail>

                <Attributes>

                    <field1>value1</field1>

                    <field2>value2</field2>

                    <field3>value3</field3>

                </Attributes>

            </detail>

        </soapenv:Fault>

If you want complete soap message then enable Do Not Use SOAP Envelope in the soap receiver channel.

Check question 7 in this sap note 856597 - FAQ: XI 3.0 / PI 7.0/7.1/7.3 SOAP Adapter


Response:

HTTP/1.1 500 Internal Server Error

Content-Type: text/xml; charset="utf-8"

<SOAP:Envelope

  xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

  <SOAP:Body>

    <SOAP:Fault>

      <faultcode>SOAP:Server</faultcode>

      <faultstring>Server Error</faultstring>

      <detail>

        <e:myfaultdetails xmlns:e="Some-URI">

          <message>My application didn't work</message>

          <errorcode>1001</errorcode>

        </e:myfaultdetails>

      </detail>

    </SOAP:Fault>

  </SOAP:Body>

</SOAP:Envelope>


will result in an application error message with fault payload


<e:myfaultdetails xmlns:e="Some-URI">

  <message>My application didn't work</message>

  <errorcode>1001</errorcode>

</e:myfaultdetails>


Regards,

Praveen.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question