Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

livecache cannot be started

Hello experts,

I cannot start livecache (7.7.07.50 on Linux) due to following errors:

dbmcli on LCD>db_online

ERR

-24994,ERR_RTE: Runtime environment error

20090,Check knldiag! Kernel exited with '1' before reaching ADMIN state

The database is in state "offline", but resources were found: pid file

found but

startup message from kernel:Core dump suppressed

dbmcli on LCD>show state

OK

No root pointer in mapping table

'RTECons_MemoryDumpMapping' instance could not be created

Failed to map memory dump files


I have tried to clear pids from below files (by mv LCD LCD.old) and then start.

/sapdb/data/pid/LCD

/sapdb/data/ppid/LCD


Cleared shared memory by:


/sapdb/LCD/db/pgm/dbmshm CHECK /var/lib/sdb/dbm/ipc LCD

/sapdb/LCD/db/pgm/dbmshm DELETE /var/lib/sdb/dbm/ipc LCD

I have also tried to delete folder /sapdb/data/wrk/LCD/rtedump_dir and

checked SAPNote 1283278.


Attached is knlmsg log.


Thank you for any advice.


Ivana



knlmsg.txt.zip (1214 B)
Tags:
Former Member
Former Member replied

Hi James,

based on SAP Notes I found out there was different number of data volumes and log volumes present on the server than in configuration. Command param_getvolsall showed 13 data volumes and 1 log volume but there were 21 data volumes and 2 log volumes on server. It means that by restore_param i "took away" data volumes from number 14. I reverted it as I described above.

I have opened OSS message to SAP and they solved the issue. The cause was that parameters MirroredLogVolumeName002 and LogVolumeName002 were identical. So I set parameter MirroredLogVolumeName002  to different path than LogVolumeName002.

Thanks a lot for help!

Ivana

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question