Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

import contacts in System Configurator (Import and export jobs in SP8 - SP9)

Hello, everyone!
In our system, we use a small PowerShell script to export users from AD to .csv and then to a text file.
Before we upgraded to SP8 everything worked flawlessly.
The process is as follows:
The script exports all users of a particular group and all subgroups and load them in a.ssv-файл. Along the way, reading these values ​​as the name, last name, number, email, etc. and assigning some skills and other values, depending on whether a user is a subgroup.
Then, from the .csv-file all transferred to a text file.
Next, job same hourly import all data from a text file in the System Configurator.
This Job loads all users into a single group of Contact Center, and then throws by subgroups.


Before updating all worked flawlessly in the SP7. But after we upgraded to SP8 and subsequent updates to SP9 began to appear such mistakes:
NullPointerException: null
The pattern has not been established for this error. The error appears in a random string. But usually always in line 3 and 4 and further to the random.
If you take the file and edit it manually, for example by removing half of the rows and columns - nothing changes.
If you remove all the lines, and leave one or two users - they are imported without problems. And it may be that those lines that did not want to be imported from a complete file.
In all of this, there is also a second script that loads the members of the other group, which dismissed employees are placed. The principle is the same script. It creates a text file, but it has all the columns except for the column empty delete. These officers are marked for deletion, and that file is imported without any errors.


Attaching example of a tex-file

Contact-Center.txt has the issue to import

Import's Result.txt - is an aerror result of importig that Contact-Center.txt file

Contact-Center-Delete.txt has no such errors and imports correctly

P.S. In the test environment, the issue is the same.

Tags:
Former Member
Not what you were looking for? View more on this topic or Ask a question