Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Using OpenUI5 with eclipse impossible?

Hi everyone,

currently I'm using the SAPUI5 plugin for eclipse which also delivers the open UI5 sources for local development / testing.

Is there any way of switching to an OpenUI5 version for local eclipse development instead?

I know, that I could just use the HANA CDN version of OpenUI5 in my bootstrap, but since I have some caching problems with my local tomcat (sometimes changed files are not served in their latest version) I use to disable browser caching in the chrome dev tools. So reloading everything from a remote server on every page refresh in the browser would drive me nuts.

Any suggestions?

Tags:
replied

>>, but since I have some caching problems with my local tomcat (sometimes changed files are not served in their latest version) I use to disable browser caching in the chrome dev tools.

why dont use app cache??

just download openui5, extract it to your tomcat's webapps and reference like

<script id='sap-ui-bootstrap' type='text/javascript'
   src="/openui5_PATH/resources/sap-ui-core.js"

...

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question