Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SOAP adapter with SSL hangs

We're trying to consume a webservice. It's one with SSL.

There's also an acceptance version and this works like a charm in BODS.

We copied the webservice-c folder and made the adjustments according to this http://scn.sap.com/thread/3589313.

This is the wsdl we are trying to use. Creating the datastore and importing the functions is no problem. We are using BODS version 14.2.3.618:

https://service2.loyaltyinabox.com/facade/nsx/ManagementAndControl/1.2/WSDL/Service.wsdl

From the same machine we can do a succesfull call to this webservice with SOAP UI. In the call a security token is provided. The only other security is the certificate, which is in place on the bods server and which is referenced to in the axis2.xml

We also ran the job from the command line and this is where it stops/hangs:

[Tue Oct 27 17:30:51 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler AddressingOutHandler within the phase MessageOut

[Tue Oct 27 17:30:51 2015] [info] Starting addressing out handler

[Tue Oct 27 17:30:51 2015] [debug] ..\..\src\modules\mod_addr\addr_out_handler.c(133) No action present. Stop processing addressing

[Tue Oct 27 17:30:51 2015] [debug] ..\..\src\core\transport\http\sender\http_transport_sender.c(246) ctx_epr:https://service2.loyaltyinabox.com/facade/NSX/ManagementAndControl/1.2/Service.svc

[Tue Oct 27 17:30:51 2015] [debug] ..\..\src\core\transport\http\sender\http_transport_sender.c(805) using axis2 native http sender.

[Tue Oct 27 17:30:51 2015] [debug] ..\..\src\core\transport\http\sender\http_sender.c(416) msg_ctx_id:urn:uuid:4f368906-fe60-4cfc-b76a-9e56c6a7f8b6

The other wsdl (acceptance) does not stop there:

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler AddressingOutHandler within the phase MessageOut

[Tue Oct 27 14:01:14 2015] [info] Starting addressing out handler

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\modules\mod_addr\addr_out_handler.c(133) No action present. Stop processing addressing

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\transport\http\sender\http_transport_sender.c(246) ctx_epr:http://acc2.luntronics.com/facade/NSX/ManagementAndControl/1.2/Service.svc

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\transport\http\sender\http_transport_sender.c(805) using axis2 native http sender.

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\transport\http\sender\http_sender.c(416) msg_ctx_id:urn:uuid:f38b4219-e28b-4f7d-a699-de3330c256db

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\transport\http\sender\http_transport_sender.c(822) OP name axutil_qname_get_localpart = http://www.w3.org/2004/08/wsdl/out-in

[Tue Oct 27 14:01:14 2015] [debug] ..\..\axiom\src\soap\soap_builder.c(930) Identified soap version is soap11

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler request_uri_based_dispatcher within the phase Transport

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler AddressingInHandler within the phase Transport

[Tue Oct 27 14:01:14 2015] [info] Starting addressing in handler

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler addressing_based_dispatcher within the phase Transport

[Tue Oct 27 14:01:14 2015] [debug] ..\..\src\core\engine\phase.c(210) Invoke the handler LoggingInHandler within the phase PreDispatch

[Tue Oct 27 14:01:14 2015] [info] Starting logging in handler .........

In fiddler we see that a tunnel is created but that's all. The client (BODS) does not call the webservice.

Any ideas?

Former Member
Not what you were looking for? View more on this topic or Ask a question