Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Central Hub Deployment Service Registration

Hi everyone,

We have installed a seperate Hub System now to implement the Hub Development Scenario with Development in Backend. In backend I have created a Gateway alias to my new Gateway Server. In Gateway Server i have created connection to the backend. Now i have try the following:

Going to Backend tcode SEGW create a small Odata-Service and make the service Registration. Under folder Servicemanagement i can see my created alias. I make right click Register than i have to make a remote login to my Gateway Server after that a message appears that i will be redirected to a system. And now a remote login to my backend appears. If I login in nothing happens. Does somebody know whats the problem here?

Second option:

I my Gateway Server I go to tcode /iwfnd/maint_service click on add Service and enter under systemalias my backend system. Now i can see my created services from backend. If I choose want i can activate that service and call it over the Gateway. So that works fine.

So is it the right way to first register a service in backend completly and than go to Gateway and register this service there again?

I thought i will create my odata with DPC and MPC Classes and than i click register Service and it gets registered at gateway.

Thanks for your Help.

Tags:
Former Member
replied

Max,

There is only one registration of the service. Additional, alternative option was given in SEGW, which will connect to Hub and register the service in HUB. This option as given so that you do not have to login to two servers for development and registration. IMO it is better to register in HUB using the /IWFND/MAINT_SERVICE and just ignore the service registration option available in SEGW as it is too confusing.

Regards

Krishna

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question