Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

FormattedAddress XML error when calling Query Accounts Webservice

Hi,

i try to get back the address uuid from a specific customer by webservice in an HCI DS project.

I use GetCustomerbyIdentification -> Inbound Service Interface (public)

As long as im setting CustomerTransmissionRequestCode to '2' (complete node) and AddressInformationTransmissionRequestcode to '4' (exclude node) the job returns the Account UUID without any error. But i didn't get the Address UUID with this RequestReturn Setup. See Attached Response in Pic 2

When I try to set AddressInformationTransmissionRequestcode  also to '2' or even '1' (complete node) i always get the following error in View-design-data viewer and also on task run:

2015-10-27 20:30:01       (E)(8676:8692)     XML-240108      |Session __JOB_DSoD_JIT_QueryAccountsToSQL_1445977783239_176|Data flow __DF_DSoD_JIT_VIEWDATA_1445977783239_176_1|Transform FindbyIdentification-Function1

                                                               An element named <FormattedAddress> present in the XML data input does not exist in the XML format used to set up this XML

                                                               source in data flow <__DF_DSoD_JIT_VIEWDATA_1445977783239_176_1>. Validate your XML data.

2015-10-27 20:30:01       (E)(8676:8692)     XML-240307      |Session __JOB_DSoD_JIT_QueryAccountsToSQL_1445977783239_176|Data flow __DF_DSoD_JIT_VIEWDATA_1445977783239_176_1|Transform FindbyIdentification-Function1

                                                               XML parser failed: See previously displayed error message.

2015-10-27 20:30:11       (E)(8676:8780)     XML-240307      |Session __JOB_DSoD_JIT_QueryAccountsToSQL_1445977783239_176|Data flow __DF_DSoD_JIT_VIEWDATA_1445977783239_176_1|Transform FindbyIdentification-Function1

                                                               XML parser failed: See previously displayed error message.

The FormattedAddress node already exists in the wdsl response schema. See picture 1.

I don't know what causes the error or have another idea to get the address UUID.

Thank you,

Rene

2.png (84944 B)
1.png (52492 B)
Tags:
Not what you were looking for? View more on this topic or Ask a question