Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

MOpz: Target Constellation Product System Erroneously Changed

Here's one I haven't seen before. I'm preparing to apply support packs to my ERP ABAP system landscape, and in the Confirm Major Target step (step 2.2) of Maintenance Optimizer the tool tells me that it is going to change the Product System to Technical System assignments so my DEV Product System will be assigned to each of DEV, QAS, and PRD Technical Systems. By this I mean something like the following:

Initial Constellation

Technical SystemProduct System
DEVDEV
QASQAS
PRDPRD

So far so good, that is what my landscape looks like in LMDB. But, here it gets weird:

Target Constellation

Technical SystemProduct System
DEVDEV
QASDEV
PRDDEV

Why would MOpz do that? So, naturally, I went back to LMDB and carefully reviewed the product system and technical system definitions, and they all look correct. Indeed, the Initial Constellation is correct in MOpz. So why does the tool want to reassign things like this? Obviously I won't let this move forward like this, so I'm going to restart the maintenance transaction with just the one system (DEV), as for this support package application I don't even need a stack.xml (it will be done with SPAM, not SUM), I just need my files approved for download. But, I worry about the implications of this for an upgrade in the same landscape we have coming up in a few months, where obviously I will need to use SUM.

This isn't our first time at this particular rodeo, as we've been using MOpz for this landscape for years. However, SolMan did recently "force" me to update Note 1969109 (SAP Solution Manager 7.1 SP12 - Basic functions) to the latest version (from version 15 to version 22), along with attendant many "prerequisite" Notes updated, so I wonder if something in all of that broke things.

This is for Solution Manager 7.1 sp12, and as mentioned with v22 of the "Basic Functions" Note for sp12. The target landscape is ERP 6.04 / NW 7.01 and I'm updating from sps13 to sps17, though that is probably irrelevant to this issue.

Cheers,

Matt

Tags:

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question