Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

wdeploy problem with deploy to tomcat server on windows

Hi community members!

I have little question related to wdeploy.

I've used it few times already in the past. I've always had little issues, but finally it always worked. Unfortunately in last two days i can't figure out what is the problem.

I was never sure while using this which path's to provide - destination or source server (we have full installation on one server, but as web application other server is used, which has only tomcat installed, and not from SAP installator but from apache tomcat website).

I use wdeploy gui like i always did. Also web application was few months ago successfully deployed to other server. Now we want to add another web server. All servers are using windows.

I'll describe what i choose while trying to set up wdeploy.

I have checked option Deploy all available SAP BunsinessObjects Web Applicatoins to the server.

I've chosen Tomcat 7.0 as Web Application Server type

Server Instance: destinationHostName (tried also IP)

Service Name: destinationTomcatServiceName (service is disabled, but tried also with enabled)

I've checked Tomcat installed as a Windows Service

as Server Domain Root Directory i've provided: <destination server tomcat path>\tomcat\tomcat-7.0.65\

Then I click 'options' and i provide:

Wdeploy work directory: <sap installation path on source server>\wdeploy\workdir

Web applications source tree location: <sap installation path on source server>\warfiles\webapps

then i click apply and afterwards, when i click 'run' i get:

Error occured during the action deployall

()

Deployment log files are located at:

<log path>

and in those logs i get lots of lines, but none of them tells exactly what the problem was. Its like:

tomcat7.xml:76: Error: The application server is not detected using supplied path.(DEP00301)

and in other log file:

AppSourceDir = O:/SAP BusinessObjects/SAP BusinessObjects Enterprise XI 4.0/warfiles/webapps/AdminTools

Error: The application server is not detected using supplied path.(DEP00301) O:/tomcat/tomcat-7.0.65/

can anyone help?

Former Member
replied

Hi,

Just copy the files from different server will not work.

You needs to copy Warfiles & Wdeploy folders from the source system to new and you needs to use wdeploy GUI to deploy the files at new server.For this you needs to follow all steps which are mentioned in the pervious link.


Amit

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question