Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

URGENT! Personas 2.0 SP3: ME51N: copy data failed in dynamic fields of Tabs of icon "Item"

Hi Personas experts,

I am making a personas app using me51n where I need to copy the user's input data from our own UI table into SAPGUI me51n table.

Example, there are two rows in the table with different account assignment:

row 1: Account Assignment (V), I need to copy a number into the field "Cost Center" of Tab "Account Assignment"

row 2: Account Assignment (Y), I need to copy a number into the field "Order" of Tab "Account Assignment"

If I use two buttons with each to do one data copy, and I manually press the butons one after the other, it will be OK.

But if I put two button actions into one button, I will get an error "control not found".

The reason seems to be that after "select another tab" in script, there needs a time delay to allow the backend to refresh the UI to add dynamic fields. My script is trying to copy data to the dynamic field before it appears on the UI.

I tried to add "Refresh Screen" in between the scripts, but it deos not solve the issue. Also I tried to rearrange the order of script actions so that there can be a time slot after select a new tab, but it is not working either.

Can SAP personas experts help on this? How do we control the script to wait for the new dynamic fields appear before copying data to it. It is a headach issue doing Personas app for the tcodes which involves dynamically rendered UI based on teh backend data changes.

We need urgent help tosolve this issue asap! Thanks a lot!

Dong Zhu

Tags:
Former Member
Former Member replied

We turned to use Personas 3.0, this issue is not valid anymore.

Br,

Dong

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question