Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Administrator password is locked

Hello,

I was tryuin to login to NWA with admin credentials and it seemed like a glitch... at first the system asked to update a password. Password update was unsuccessful by some reason. Now Administrator password is locked due to number of unsuccessful login attempts...

Can someone help me to unlock/change password?

I found a very nice topic here: How to reset Netweaver Administrator password (Sherry Yu - ISV Engineering, Oracle Corp) but this approach doesn't work and I don't know why. I am unable to change a property... the are not clickable (like manual said)... see picture attached #1.

After that I tried to change property through setting a new value (see picture attached #2). The property changed, but after I tried to save changes by pressing 'Save' button (see picture attached #3) I got the error message:

ERROR: Can't edit property 'ume.superadmin.password'.

INFO: Change service properties for ZATPL_AIO/com.sap.security.core.ume.service completed.

After engine restart it didn't work.

Can you help me to sort this out as I need to make it work.

System: Windows 2008R2, NW7.31 AS Java on MaxDB.

3.jpg (109781 B)
2.jpg (104919 B)
1.jpg (268958 B)
Former Member
Former Member replied

Hello Yuksel,

Thank you for the links, but, as it turned out, the resolution of this problem is a bit different.

I found out that in release 7.31 and newer ones it is impossible to change/set properties in Config Tool directly. Instead, Properyt sheets must be used... It is not easy to find something in the tree structure, but the next guide can be used (published with courtesy of www.teknobasis.com):

Start the config tool (via config.bat or config.sh) in <drive>\usr\sap\<SID>\J<Sys No>\j2ee\configtool

configtool path

Once it is open, switch to configuration editor mode.

display configuration

On the Display Configuration tab page. Choose:

Cluster_config    System custom_global cfg services com.sap.security.core.ume.service Propertysheet properties

configuration path
configuration path final

You can either double click the icon or click on the edit button located at the toolbar. A warning message will appear to ensure that the server and the dispatcher nodes are shut down. If you have done so, proceed to click Yes

edit mode

From the menu, look for parameter ume.superadmin.activated and ume.superadmin.password and you can change the value by double clicking the parameter

ume parameter

From here you can change the parameter ume.superadmin.activated to true to activate the user sap* (once you’ve enabled this feature, other user will not be able to logon to the portal). You can enable it by inserting the new value to true custom-value field and click the Apply Custom button.

ume superadmin activated

Same goes with ume.superadmin.password, insert the password for sap* in custom-value field and click Apply custom.

ume superadmin password

Once you have made the changes you need to restart the Application Server via MMC in order to take effect.

portal logon page

That's it!

Do not forget to revert changes, as you will be unable to login with different user.

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question