Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SLES12 / MaxDB - problems with patch via SDBSETUP

Hi all,

I've just installed NW702 on SLES 12 with MaxDB 7.9.08.23

Now I want to update the MaxDB to 7.9.08.34 with SDBSETUP via GUI (I know i can use the command line, but not for the global listener).

When I start SDBSETUP I get some Errors:

1) libpangox-1.0.so.0: cannot open shared object file...

Solution:

- ln -sf libpangoxft-1.0.so.0.3600.3 libpangox-1.0.so.0 (in /usr/lib and /usr/lib64)

2) libpng.so.3: cannot open shared object file...

Solution:

- Installation of libpng12 (64bit and 32bit) with yast

- ln -sf libpng12.so.0.50.0 libpng.so (in /usr/lib and /usr/lib64)

- ln -sf libpng12.so.0.50.0 libpng.so.3 (in /usr/lib and /usr/lib64)

(This problem I had in SLES11, too)

3) libjpeg.so.62: cannot open shared object file...

Solution:

- Installation of libjpeg62 (64bit and 32bit) with yast

4) libtiff.so.3: cannot open shared object file...

Solution:

- ln -sf libtiff.so.5.2.2 libtiff.so (in /usr/lib and /usr/lib64)

- ln -sf libtiff.so.5.2.2 libtiff.so.3 (in /usr/lib and /usr/lib64)

Now it is running, but with many grafical errors. For example no radio buttons will be shown.

In the terminal where I startet it, there are errors:

--------------------------------------------------------------

** (-e:4919): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Adwaita/gtk-2.0/Check-Radio/option-checked.png: Failed to load image '/usr/share/themes/Adwaita/gtk-2.0/Check-Radio/option-checked.png': Fatal error in PNG image file: bad parameters to zlib

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

** (-e:4919): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Adwaita/gtk-2.0/Check-Radio/option-unchecked.png: Failed to load image '/usr/share/themes/Adwaita/gtk-2.0/Check-Radio/option-unchecked.png': Fatal error in PNG image file: bad parameters to zlib

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

** (-e:4919): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Adwaita/gtk-2.0/Buttons/button-default.png: Failed to load image '/usr/share/themes/Adwaita/gtk-2.0/Buttons/button-default.png': Fatal error in PNG image file: bad parameters to zlib

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(-e:4919): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

** (-e:4919): WARNING **: Invalid borders specified for theme pixmap:

        /usr/share/themes/Adwaita/gtk-2.0/Buttons/button-default.png,

borders don't fit within the image

--------------------------------------------------------------

Any idea?

I've already installed GTK2 but it doesn't help.

Regards

Thomas

Tags:
Not what you were looking for? View more on this topic or Ask a question